Глава 2 Исследования перед взломом

— Возьмите, например, меня, — сказал Михаил Александрович, — тонкая игра. Человек-собака. Шизофренический брел, осложненный маниакально-депрессивным психозом, и притом, заметьте, Берлага, сумеречное состояние души. Вы думаете, мне это легко далось? Я работал над источниками. Вы читали книгу профессора Блейера?

— Н-нет, — ответил Берлага голосом вице-короля, с которою сорвали орден Полвязки и разжаловали в деншики.

— Вы не читали Блейера? Позвольте, по каким же материалам вы готовились?

И. Ильф, Е. Петров. Золотой теленок.

Любой серьезный взлом требует некоторых подготовительных исследований, которые должен произвести хакер перед тем, как усесться за компьютер. Грамотному “взломщику” необходимо владеть определенным объемом информации.

Чтобы заняться хакерством, вам, естественно, следует обладать кое-какими сведениями о компьютерах и телекоммуникациях (на уровне идей), но для реального взлома нужен, в первую очередь, телефонный номер, или какой-либо другой путь получения доступа к “вражескому” компьютеру. И в том, и в другом случае понадобится предварительное исследование. При первом обращении к компьютеру вам также придется исследовать возможные способы взлома и выбрать подходящий. И, наконец, вы будете производить исследования уже после того, как получите доступ к вожделенной системе, дабы извлечь как можно больше пользы из открывшихся перед вами возможностей. Последние рассматриваются в разделе под названием “Что делать, когда вы оказались внутри”. А сейчас давайте обсудим, что же следует сделать, прежде чем начать военные действия.

ВЫБОР цели

Под “прицеливанием” я подразумеваю процесс, в ходе которого хакер решает, что именно из существующего программного обеспечения стоит попытаться “ломануть”. Эта тема по многим причинам может показаться тривиальной, но, тем не менее, она заслуживает обсуждения.

Предположим, что вы новичок в этом деле. Допустим, вы получили — путем каких-то собственных исследований, или же по воле случая — некую информацию, которая, как вам кажется, может помочь проникнуть в определенную систему. Например, через нелегальные компьютерные каналы вы раздобыли телефонный номер большой правительственной базы данных со сведениями о шпионаже. Само собой, может показаться разумным просто набрать этот номер, чтобы убедиться, верны ли ваши сведения. С другой стороны, лучше сначала исследовать “дичь” и проверить, стоит ли она затраченного времени и денег за телефонный счет, а также оправдывает ли она связанный с взломом риск. Поишите данный номер в перекрестном телефонном каталоге данного региона. Такие каталоги можно найти во многих библиотеках. Это книги, как правило, выпушенные без лицензии телефонной компании, содержат список имен и адресов с номерами телефонов. В отличие от обычных телефонных книг, в перекрестных каталогах имя отыскивается по номеру, а не наоборот. Если вам не удастся найти такой каталог, позвоните оператору АТС и ангельским голосом осведомитесь, кому принадлежит данный номер. Естественно, что предпочтительнее самому просмотреть каталог, не выходя на контакт с сотрудниками телефонной компании (лишние свидетели). Если номер общедоступен, то это, скорее всего, вообще не компьютерная линия, и его можно оставить в покое. Вам может показаться бессмысленным тратить время на поиск номера, вместо того чтобы просто его набрать, но не забывайте: прежде чем трогать “дичь”, следует накопить как можно больше информации о ней. Если номер действительно принадлежит сверхсекретной базе данных, будьте готовы к тому, что ваш звонок могут отследить; во всяком случае, он вызовет подозрение.

Новички обычно жаждут совершить свой первый большой взлом, и по горячности совершают опрометчивые поступки. Возможно, у вас еще не было опыта по изменению данных телефонной компании, или звонков с автомата, или каких-то иных способов замаскировать свой вызов. Новичок, набирающий секретный номер после предварительных исследований, вероятно, тоже глупо рискует, но он все же продвинулся на несколько ступеней выше по профессиональной хакерской лестнице, чем салага, который звонит вообще без всякой подготовки — это непростительная глупость.

Итак, когда цель избрана, вам не обязательно приступать немедля к вашему первому большому начинанию. Может оказаться более предпочтительным выждать, пока у вас не наберется достаточно опыта, чтобы выполнить все как надо. Если вам стало кое-что известно о “дичи”, и больше это неведомо никому, лучше всего помалкивать, пока вы не произвели взлом. Если вы станете действовать, руководствуясь своими знаниями, и попытка провалится, шансы на повторную попытку будут близки к нулю, поскольку администраторы системы тоже не будут сидеть сложа руки. Запомните следующее: выше головы не прыгнешь. Прежде чем нырять с аквалангом за покоящимся на дне сокровищем, научитесь сначала держаться на воде, иначе утонете и это будет скучно и бездарно, как сказал один человек.

“Прицеливание” включает в себя также исследования другого рода. Что, если у вас в руках действительно оказался некий заманчивый секрет, позволяющий куда-то проникнуть? Вероятно, сперва следует подумать о наилучшем способе проникновения в эту систему. Например, если искомая система входит в Интернет, вам придется измыслить способ войти в сеть под чужим именем. Но имейте в виду, что на вашу “дичь” может положить глаз и другой охотник. Так что возможности вести подготовку годами у вас нет. Что же, хакерство — это такая штука, где побеждает наиболее энергичный.

Если вы числитесь в колледже, либо живете рядом с колледжем, и ваш компьютер зарегистрирован в Интернете, вам не составит труда войти в сеть под собственным именем, и уже оттуда пытаться соединиться с другими системами. Но это не только легко, а еще и чудовищно глупо! Только законченные идиоты совершают взлом, входя в сеть под собственным именем. Не успеете вы просмотреть те немногие директории, что открыты вашему минимальному уровню доступа, как вам уже придется искать способ маскировки для совершения дальнейших действий. Повторяю еще раз: вам придется искать способ входа под другим именем, и уже потом решаться на что-то большее.

Взлом компьютерных систем высшего порядка делится на две части: частный взлом и общественный. Имеется в виду, что сначала вы маскируетесь под какое-то частное лицо, а затем ищете способ замаскировать вашего липового пользователя под зарегистрированного пользователя взламываемой системы. Можно потратить уйму сил, денег и времени на попытки проникнуть в систему, которая в результате окажется бесполезной. Допустим, вы избрали мишенью компьютер на родном факультете, возымев желание превратить свою ступень F в ступень А. Вам может показаться, что вам достаточно прикинуться деканом или кем-либо еще из факультетского начальства, но во многих случаях это оказывается вовсе не так. Начальство факультета, как правило, не пользуется компьютерами, содержащими сведения о присвоенных ступенях, если только декан сам не ведет какой-либо курс. Значит, вам придется переключиться на профессора, или, скорее всего, на его ассистента. Именно они вводят в компьютер оценки. В результате вы начнете доискиваться, каковы могут быть пароли профессора и его ассистента. Затем встанет вопрос о компьютере. Какой компьютер вы будете пытаться “взломать”? Преподаватели, особенно те из них, что ведут математику или курсы компьютерных дисциплин, обычно сообщают студентам адрес своего компьютера, чтобы вы могли общаться с ними по электронной почте. Но это не поможет вам подняться на ступень выше. Для этих функций наверняка предназначен какой-нибудь закрытый административный компьютер — его-то вам и следует взламывать. Может показаться само собой разумеющимся, что наивысшим уровнем компьютерного доступа обладает ректор университета. Но так ли это на самом деле? Действуйте наверняка — займитесь профессорами.

Один из моих преподавателей английского языка неоднократно упоминал в аудитории персонажа одного сериала, и несколько раз упоминал о вещах, которые могли бы иметь отношение к данной передаче (использовал те же фразы, что употреблял в сериале персонаж). Естественно, попытки проникнуть в сеть за счет этого типа следовало бы начать, исходя из словечек персонажа, если учесть тот факт, что преподаватель английского вряд ли может осознавать всю ценность паролей с бессмысленным содержанием.

Но следует ли В ДЕЙСТВИТЕЛЬНОСТИ избирать своей мишенью ТАКОГО преподавателя? Если бы я завалил его предмет, и захотел порыться в его данных, чтобы повысить свою ступень, герой сериала вряд ли помог бы; насколько мне удавалось заметить, контроль над присуждением уровней, как правило, ведется ассистентами, а не профессорами! Потому-то для достижения избранной цели и необходима предварительная разведка.

Если вы знаете, чего хотели бы достигнуть, произведите вначале необходимые исследования, чтобы выяснить: те ли ЛЮДИ, которых вы избрали для достижения своей цели, сидят за клавиатурой нужного вам компьютера. Потенциальные мишени зачастую можно вычислить, читая свободно публикуемые открытые документы. Они рассчитаны на “этичное использование” системы и часто дают возможность заглянуть в “защищенные” от постороннего взгляда разделы. Например, мне удалось прочесть маленький отрывок из устаревшего доклада о мерах по безопасности. Данное положение, по-видимому, относилось к списку мер, которые следовало принять для улучшения зашиты компьютерной сети. Но к тому времени, как я прочел эту заметку, меры уже были приняты, а вот мысли о том, что зашита действительно необходима, давно успели улетучиться из головы автора доклада, и информация оказалась общедоступной. Вот что гласит это положение:

Сеть 19 должна быть полностью изолирована от персональных компьютеров и широкополосных сетей с помошью шлюзов. Входы на все терминальные серверы подлежат защите в обязательном порядке. Персональные компьютеры следует снабдить соответствующим программным обеспечением для ведения наблюдений за сетью с целью обнаружения неправильного и,или неэтичного ее использования.

Посмотрите, какое море информации можно извлечь из данного отрывка. Имея на руках эти рекомендации по усилению зашиты, нам не составит труда обнаружить то самое программное обеспечение, которое выполняет функции по защите. Тогда мы увидим, что могут делать эти программы и чего не могут; мы сможем отыскать в них ошибки или слабые места и использовать эти ошибки. На худой конец мы всегда в состоянии изобрести другие способы обойти эти программы — ведь на плечах у нас голова, а не котел, верно? Но наибольший интерес представляет (и имеет самое непосредственное отношение к нашему разговору о “прицеливании”) упоминание о “Сети 19”. Что это за “Сеть 19”? Наверняка нечто такое, что администрация хотела бы спрятать подальше от посторонних глаз. А раз так, то, похоже, перед нами достойная цель для взлома. Если такая заметка попадется на глаза хакеру, он, несомненно, изберет Сеть 19 своим объектом.

Это пример" случайно обнаруженной информации, которую можно с успехом использовать. Но помните — я прочитывал ВСЕ общедоступные документы ради ОДНОЙ-ЕДИНСТВЕННОЙ задачи — я хотел совершить взлом. То, что вышеупомянутая информация попала мне в руки, было чистой воды ВЕЗЕНИЕМ, но поиск-то я вел НАПРАВЛЕННЫЙ.

По сути дела, оперативные исследования такого рода — просматривание каждого дюйма имеющейся в вашем распоряжении системы, прежде чем заняться поиском менее доступных объектов — тоже является “прицеливанием”. Если вашей целью является определенная секретная компьютерная система, просмотрите все схожие с ней доступные системы, перед тем, как заняться той, что вас интересует. Запас карман не тянет. Такой просмотр может привести к полезным намекам, типа упоминания о Сети 19; по крайней мере, вы ознакомитесь с различными сторонами системы — “дичи”.

Вот что следует искать, “прощупывая” доступную систему, прежде чем заняться менее доступной: каким образом в ней осуществляется ввод и вывод; имеются ли в ней лазейки, и как система реагирует на них; каков формат ее команд (буквенный, управляющая последовательность), и какие типы команд пригодны к использованию; что это за компьютер и какое “железо” в нем находится. Конечно, существуют еще некоторые веши, которые вы будете искать, вроде информации о интерфейсе или о том, сколько времени занимает выполнение тех или иных команд. Эти сведения пригодятся позднее, ибо, когда дойдет до дела, то есть до взлома, вам не захочется тратить многие часы, пытаясь найти нужную команду или элементарно выйти из системы.

“Прицеливание” может показаться не только скучным, но и раздражающим занятием. В конце концов, ученый может анализировать радугу, используя специальные научные термины, объясняющие, что же она собой представляет, какой она формы, и почему цвета в ней располагаются именно так, а не иначе. Но вместе с тем, это сложное описание радуги не будет иметь ничего общего с самой радугой. Анализ не затрагивает красоту радуги. Технический жаргон не включает в себя поэтических эпитетов, которые мы привыкли ассоциировать с радугой. Вы можете привести те же доводы, объясняя, чем “прицеливание”, подготовка и планирование попыток взлома отличаются от удовольствия, доставляемого самим взломом. Если вас наняли для взлома, вам придется выполнить работу, иначе вам не заплатят за нее. Но, с другой стороны, зачем нам мучиться, занимаясь такой ерундой, как скрупулезный сбор предварительной информации? Вы правы! Вы абсолютно правы! Совершенно необязательно принимать те предложения, о которых я говорю. Нет настоятельной необходимости как следует поразмыслить, что же вы собираетесь делать, прежде чем браться за дело. Это всего-навсего мое мнение, что следует иметь понятие о таких вещах. Что решившись на нарушение закона, надо по крайней мере знать, как это делается,

“Прицеливание” к определенным компьютерам, которые, как вы уверены, содержат нужную вам информацию, и к людям, обладающим определенными уровнями доступа и возможностями — все это похоже на научное описание радуги и не приносит ничего, кроме разочарования. Но в дальнейшем, если вы действительно хотите продвигаться вперед, если вы хотите совершать взломы ради развлечения и извлекать все больше удовольствия из каждой новой попытки, я бы все же посоветовал вам заняться этими скучными вещами. Они помогут избавиться от долгих бесплодных поисков и однообразных попыток совершить взлом с помощью грубой силы, а также избежать неприятностей.

Итак, разрабатывайте основной план действий. Удостоверьтесь, что выбранные вами цели годятся для данного случая. Тогда вы будете знать, что ваш взлом не обернется полным тупиков лабиринтом. Сам я придерживаюсь концепции “намерений”, или “целей”, но, если вы не частный сыщик и не ушлый журналист, то, возможно, захотите и будете рады проникнуть в любой оказавшийся под рукой компьютер с помощью любых подручных средств. Это тоже неплохо; многие хакеры настолько отдаются своему увлечению, что, даже если компьютерная система и не таит в себе ничего особенного, о чем они прекрасно знают, эти ребята все же взламывают ее, так как получают удовольствие от самого процесса взлома. Но ведь очевидно, что куда интереснее проникнуть в систему с какими-то секретами, нежели в такую, чье содержимое не представляет для вас никакой ценности. Стоит ли тратить многие месяцы, пытаясь пробраться в систему, содержащую статистические данные о частоте копуляций лабораторных крыс? (Впрочем, возможно, такие вещи представляют для вас интерес). Проявляйте осмотрительность при выборе целей. Проникновение в систему — только полдела; когда вы окажетесь внутри, вам будет гораздо интереснее.

сбор Информации

Прежде чем приступить к своим исследованиям, вам следует выяснить, какого рода информацию вы стремитесь получить. Существует три темы, о которых должен иметь представление хакер: телекоммуникации вообще, системы вообще и конкретные системы в частности. Вам следует обладать определенным уровнем знаний о компьютерах, модемах, телефонных сетях и о человеческой натуре. Я весьма надеюсь, что эта книга ознакомит вас с подобной полезной информацией. Если нет — а я с готовностью признаю, что данная книга не является чем-то вроде Вселенской Библии — отправляйтесь на поиски специальных библиотек и ищите там то, что вас интересует. Возможно, вам и не требуется никаких особенных знаний. Но вам наверняка захочется ознакомиться с последними достижениями технологии, равно как и с теми организациями, чьи компьютеры вы собираетесь “взламывать”. Даже если вы считаете, что знаете все, что только можно знать, совсем не помешает убедиться: в самом ли деле вы являетесь знатоком своего дела — особенно, если речь идет о таких стремительно меняющихся вещах, как аппаратное обеспечение, программное обеспечение и телекоммуникации.

Ступайте в близлежащую библиотеку. Найдите полки с книгами по компьютерам, полки с книгами по уголовному праву и полки с книгами по управлению бизнесом. Там вы обнаружите “легальные” книги о хакерстве и компьютерных преступлениях. Изредка следует просматривать также книги по телекоммуникациям. Если вы хотите получить понятие о различных ситуациях, в которые вы можете попасть, значит, вам понадобятся книги об информационных службах, интерактивных базах данных, компьютерных преступлениях, операционных системах, BBS и обо всем, что имеет отношение к действиям, производимым с компьютером и модемом. Поищите в каталоге карточки со словами “телекоммуникации”, “зашита”, “компьютеры”, “хакерство”, “телефонные системы”, “модемы”, и т. п. Не забудьте и о справочниках — там содержится много полезных материалов. Хакер-ству лучше всего обучаться в деле, но в технической литературе тоже можно найти немало хороших приемов и хитростей. Кстати, вы знаете, кто публикует больше всех в мире книг? Правительство Соединенных Штатов. Если ваша библиотека является государственной, прочтите все правительственные публикации на интересующую вас тему. Из них вы сможете почерпнуть немало полезной информации.

Я вовсе не хочу сказать, что вам следует прочесть каждую книгу в библиотеке, и уж конечно, не имею в виду, что все это надо прочесть до того, как вы начнете ваши первые хакерские опыты. Я просто довожу до вашего сведения следующее: зачастую люди не представляют себе, сколь богатую информацию можно почерпнуть из вполне доступных источников, не прибегая ни к каким взломам. К тому же, читая книги, вы узнаете о том, как выглядят компьютерные системы изнутри. Вы ознакомитесь с различными необходимыми командами, форматами имен и паролей, которые используются в различных системах. Вдобавок, зачастую в таких книгах спокойно можно найти списки доступных номеров — позвонив по ним, вы сможете проверить различные системы либо получить информацию по этим системам. Все эти сведения пригодятся вам и помогут двигаться вперед.

Придя в библиотеку, загляните в отдел периодики и возьмите там несколько компьютерных журналов и газет. Предпочтение следует отдать тем, которые вы обычно не читаете, или таким, о которых вы вообще не слышали. Полезно бывает посылать в журнал заказы на интересующую вас информацию, а также заполнять карточки Службы Чтения для получения доступных сведений на эти темы. Просто диву даешься, какие компании порой отвечают на такие послания, и еще более удивительно, сколько зацепок для хакера содержит выдаваемая информация. Лично я вхожу в число постоянных адресатов нескольких компаний по компьютерной защите. Я знаю все, что мне необходимо, обо всех их программных продуктах, о новейших достижениях, о том, кто пользуется этими программами. Вооруженный такими сведениями, я могу прокладывать свой путь в обход продукции данных компаний. Зная, как они ловят хакеров, я знаю, как избежать поимки. С другой стороны, иногда более практичным оказывается выклянчивание у библиотекарей подаренных библиотеке книг. Многие библиотеки принимают в дар книги — для распродажи или чтобы пополнить собственные запасы. Большую часть этих книг составляют старые технические руководства различных компаний — по компьютерам, программному обеспечению и работе операционных систем. Библиотекари, имеющие дело с подаренными материалами, увидев такие веши, обычно выбрасывают их за ненадобностью. Постарайтесь подружиться с библиотекарем, и он, скорее всего, предпочтет отдавать такие вот “ненужные” издания вам, нежели выкидывать. V меня набралось множество ценных пособий, справочников, руководств по операционным системам и магнитных дисков подобного рода. Я могу похвастаться даже замечательной и вполне злободневной подборкой закрытых изданий AT&T. Порой найденные вами книги содержат заметки, нацарапанные на полях или на обложке. Моя любимая пометка такого сорта — телефонный номер и групповой идентификационный код доступа. Код доступа с тех пор устарел, но телефонный номер еще существует, так же как и гостевой пароль, который иногда удается обнаружить в подобных руководствах.

некоторые нестандартные методы исследований

Эти методы не столь уж необычны, поскольку в дело идет все, что может принести пользу в вашем отважном предприятии. Раздобыв идею нового способа получения большего количества сведений об интерактивной системе или о работающих в ней людях, постарайтесь опробовать ее на практике. В принципе, любые сведения могут оказаться полезными. Все, что вы обнаружите, поможет вам проникнуть либо в тот компьютер, который интересует вас на данный момент, либо в другой — когда-нибудь в будущем. К тому же, согласитесь, всегда приятно обнаружить закрытые данные или тайные секреты системы. Поделитесь своими открытиями с другими хакерами, а те в долгу не останутся — как пить дать отблагодарят вас, поведав что-нибудь этакое.

Существует пять нестандартных методов исследований: диалоговые руководства и модели программ;

копание в мусоре; анализ найденных дискет; изучение фотографий; “вынюхивание”. Помните — все эти методы исследований работают.

диалоговые обучающие руководства и модели программ

Руководства и модели программ часто используются для обучения работе с компьютерной системой. Эти программы имитируют компьютерные экраны, какими видел бы их пользователь в процессе реальной работы в сети. Руководства и модели отличаются от реальной работы тем, что сообщают пользователю о стандартных методах общения с системой и иногда даже показывают ему необходимые в работе специальные детали. Если пользователь не прошел курс обучения, ему обычно выдается сборник упражнений для работы с облегченной версией настоящей системы, причем, как правило, выдается вместе с богатым набором всевозможных шпаргалок.

Руководства и модели дают новым пользователям практический опыт общения с программным обеспечением, с которым им придется иметь дело, знакомят с его функциями и задачами. Такие программы весьма часто используются в учебных целях вместо реальной системы, или же как дополнение к ней. На то имеется несколько причин. Что, если система еще внедряется, или проходит стадию обновления? А может быть, новичка слишком накладно обучать на “живой” системе — мало ли что. Модели решают подобные проблемы, так как их можно инсталлировать на любой компьютер.

Агентства по временному найму могут использовать программное обеспечение какой-либо компании для подготовки своих работников, особенно, если компания выделяет данному агентству много рабочих мест. Или же постоянные сотрудники могут захотеть подучить возможность взять обучающий диск в библиотеке компании, чтобы попрактиковаться дома. Наконец, хорошая обучающая программа или модель дает уверенность в том, что все сотрудники получат одинаково точные инструкции, не пропускающие важных деталей, о которых может забыть рассказать инструктор-человек.

Как добраться до этих программ? Программы-модели можно получить в общественных, специализированных и даже научных библиотеках. Можно также заказать такую у производителя. Напишите производителю программного обеспечения, что мол вы собираетесь круто раскошелиться на его продукцию. Льстите, лгите, грейте в производителе чувство собственной сверхполноценности, а потом, будто бы невзначай, вверните: а нет ли, случаем, у господ хороших какой-нибудь “демонстрашки”? Дескать, я готов брать все оптом, а партнеры колеблются. Впрочем, если вы лицом подходящий и скользкий как угорь, а вдобавок терпеть не можете писать писем, то не исключено, что вам удастся даже добыть такую программу у дружески настроенного сотрудника компьютерного отдела компании (займитесь социальной инженерией! представьтесь менеджером или супервизором компании).

Модели и руководства — незаменимая вещь в хакерском деле; их польза очевидна. Они помогут вам изучить систему, и, вероятно, раскроют используемые по умолчанию имена точки входа; не исключено, что в них окажется даже описание недостатков системы.

Иногда приходится подключать все свое воображение, чтобы найти другие способы использования руководства. Как-то я сидел в одном офисе, ожидая назначенной встречи. Секретарша на минутку вышла,я подошел к ее столу и позаимствовал дискету, вложенную между страницами книги. Дискета содержала программу под названием ARRSIM (ARRangement SIMulator — модель программы по планированию и организации). Это оказалась действующая копия их рабочей программы, только с бессмысленными именами в базе данных. Программа предназначалась для обучения сотрудников планированию и организации встреч между клиентами и потенциальными поставщиками. Придя домой, я загрузил “демонстрашку” ARRSIM и начал свою игру. Сначала я попытался поменять адрес, на что компьютер ответил мне — “Supervisor Approval Required” (необходимо подтверждение от супервизора), и на экране замигал курсор. Тут явно был нужен пароль. Я попытался воспользоваться тем, что использовался при загрузке (он был написан на наклейке дискеты), но пароль не сработал. Я просканировал дискету с помощью одной веселой утилиты, но не нашел никакого подходящего текста (скрытого пароля). Мне всегда казалось, что изменение адреса — это нечто такое, чем приходится заниматься на каждом шагу. Так почему же, когда я попытался изменить адрес, у меня запросили пароль? Эту программу явно составлял один из тех параноиков, которые не в состоянии доверить девочке-оператору самостоятельно изменить имя или адрес. Итак, я позвонил в компанию (да-да, той самой знакомой секретарше) и после традиционного обмена сплетнями об общих знакомых (“Так Шейла стала бабушкой! У них мальчик или девочка?” — я слышал, как она обсуждала это событие с коллегой в тот день, когда я был в офисе), мне удалось вставить вопрос: — Джей, не знаешь ли ты, что надо набрать, когда на экране появляется “Supervisor App...” — О, это такая глупость! — она рассмеялась. — Просто кошмар. Набери “morris”.

Не знаю, на кой им это понадобилось. Всем уже осточертел этот “morris”. Я поблагодарил ее. А дальше было знаете что? Не угадали. “Morris” не сработал. Точнее, не сработал в качестве пароля для входа в руководство (да и ничто не сработало бы, вероятно). Но это был именно тот пароль, который использовался для входа в НАСТОЯЩУЮ систему. Очевидно, предполагалось, что загружаться с терминалов, расположенных в офисах, могут только супервизоры.

Копание в мусоре

Это вовсе не грязная работа, и ее совсем необязательно выполнять, но серьезные исследователи ею не брезгуют. Под “исследователями” я подразумеваю тех хакеров, которые проводят исследования компании или компьютера.

Для этого не нужно рыться в отбросах. В большинстве мест существуют отдельные контейнеры для бумаг. Некоторые из бумажек могут быть разорваны на клочки, но большинство остаются целыми. Лучше устраивать охоту за мусором в те дни, когда прочно установилась солнечная погода, чтобы объект ваших поисков оказался в приличном состоянии. Я обычно собираю найденную бумагу в пачки и складываю в специальные мешки. Придя домой, я просматриваю свои трофеи. Там можно найти закрытые телефонные каталоги, названия различных организаций и имена частных лиц, пособия для обучения, устаревшие файлы, письма, информацию о разработке проектов, а порой даже упоминание о компьютерной системе. Львиная доля этого мусора НЕ бесполезна, и вдобавок почти все эти бумажки жутко интересно читать. Даже обычная свалка, как правило, оказывается на редкость опрятным местом (почему-то). Роясь в мусорных контейнерах различных компаний, ведомств и других учреждений, я обнаружил: микрофильм, счета, целые коробки с деловыми объявлениями, книги, дохлую кошку (очень крупную), обломки всякого электронного хлама и еще много-много... ну, в общем, мусора. Конечно, большая часть всего этого не поможет совершить взлом, но содержащаяся там информация может пригодиться.

Порой удается многое узнать о том, как функционирует организация, роясь в ее отходах. Когда я в первый раз занялся этим делом, я вытащил один- единственный зеленый мешок с мусором из контейнера на задворках банка. Кстати, мешки с банковским мусором заклеены бумажкой, на которой написаны название банка, а также время и дата выброса мешка. Находящийся внутри мусор бывает двух видов. В мешках поменьше содержится мусор из всех частных отделений банка, в других — цитоплазма измятой бумаги и пробитых чеков, выметенных из-под стойки. Интерес представляют мешки из частных офисов. В тот первый раз один из банкиров оказался японцем — в дополнение к банковской всячине он выкинул японскую газету и обертку от японского леденца. Присутствовали также женщина, сидевшая на диете, стремящаяся свести концы с концами мать-одиночка и заместитель директора банка. Мусор самого директора банка был очень интересным. В нем обнаружились: сломанный замок от подвала, коробка с оранжевыми “сигнальными ключами”, несколько конвертов из-под ключей от подвала, листок бумаги с кодовой комбинацией от сейфа, нацарапанной на ней, словно улика из дешевенького детектива (12R-32L-14R, если вам интересно), и докладная “Отделу управления” от женщины из “Отдела автоматизации” вместе с дискетой. Из этого письма мне удалось узнать имя, адрес и номер комнаты отдела автоматизации банка. Я отправил им по почте разработанное с помощью социальной инженерии послание (см. главу о социальной инженерии), и в результате получил копию запрошенной дискеты и в придачу — некоторое количество полезной (для меня) информации.

Если вас застукают за взломом мусорного контейнера, лучше всего сказать, что вы “просто ищете пустые банки, которые можно сдать”. Нынче множество контор занимается приемом чего угодно, и такой ответ никого не удивит. Старая байка насчет “школы” или “социального проекта” тоже вполне сгодится: соврите, что вы проводите здесь исследования, готовя доклад об отходах государственных или частных предприятий.

Прежде чем впервые выйти из дома, отправляясь на поиски мусора, сделайте несколько телефонных звонков, дабы выяснить, какова на данный момент ситуация в этой области. Позвоните в департамент по твердым отходам и поинтересуйтесь, когда намечается сбор мусора на той свалке, которую вы хотите ограбить. Если сбор состоится в понедельник утром — хорошо, значит, вы сможете наведаться туда вечером в уик-энд, когда там никого не будет. Сделайте этот звонок до того, как садиться в машину, иначе вы рискуете совершить свой налет на следующий день после вывоза мусора. Что до выброшенных бумаг, то в случае, если снаружи нет специально предназначенных для этого контейнеров, вы можете зайти в в рабочее время в интересующую вас контору (если вас туда пустят) и взглянуть, насколько заполнены бумагой коробки внутри здания. Проводите такой осмотр в течение нескольких дней в разное время, и вы будете знать, когда они выбрасывают бумажный мусор. Когда их ящики наполнятся, ваша задача — этот мусор спереть.

Girk: снаряжение экспедиции

Конечно, можно сходу отправляться опустошать все мусорные контейнеры мира. Но я вас советую прежде как следует подготовиться к походу за мусором.

Вот те предметы, которые вам стоит включить в ваш GIRK— Garbaged Information Retrieval Kit (Снаряжение для Поиска Выброшенной Информации):

Резиновые перчатки. Любые, можно даже те, в которых вы моете посуду. Хотя большая часть того мусора, в котором вы будете рыться, является “чистой” — контейнеры с писчей бумагой — все равно неплохо надеть какие-нибудь тонкие перчатки. Их следует надевать и дома, когда вы будете сортировать принесенные мешки.

Лестница. Я не имею в виду настоящие стремянки, хотя кто вам мешает побродить по городу со стремянкой в свое удовольствие? Дело в том, что некоторые контейнеры с мусором весьма высоки или стоят вертикально, и слезать с них может оказаться трудновато. Отыщите себе какой-нибудь старый стул или скамейку, и положите в багажник машины — вдруг пригодится, особенно если придется лезть внутрь контейнера. Стул или скамейка должны быть старыми. Во-первых, чтобы не жалко было им пожертвовать в случае поспешного отступления. А во-вторых, чтобы могли сойти за выброшенный хлам, пока вы будете ворочаться в контейнере. Фонарик. Возьмите с собой кусок веревки, или брезентовую полосу, или еще что-то в том же духе, и соорудите нечто вроде ремешка с петлей. Петля должна быть достаточно широка, чтобы можно было легко надеть петлю с фонариком на руку и снять с руки. Мощный фонарь здорово пригодится вам в ночных вылазках, особенно внутри контейнера. Убедитесь, что батарейки в порядке. Мешки Для мусора. Лучше взять потемнее. Выбирайте для этой цели мешки черного, коричневого и тому подобных цветов. В конце концов, вы же не желаете, чтобы люди знали, что у вас там лежит. Если вы не приносите домой со свалки нетронутые мешки целиком, а просто вытаскиваете из мусора руководства, записки и т. д., захватите с собой мешок. Опытные люди берут с собой два мешка, один в другом, на случай, если один из мешков порвется. Подходящая одежда. Не стоит обследовать контейнеры с мусором в вашем воскресном наряде! Наденьте обувь, в которой вы сможете лазать и прыгать. Наденьте одежду, которая вам не помешает, лучше старую, которую не жалко испортить. Если у вас есть нечто типа форменной одежды, наденьте ее. Если вам известно, что обслуживающий персонал компании обычно носит бейсбольные кепки, или рубашки либо пиджаки определенного цвета, приложите все свои усилия, чтобы одеться похоже. Выбирайте темные тона, ничего ярко-розового, красного, желтого — они слишком привлекают внимание. Пустые банки из-под содовой. Некоторые хакеры сообщают сторожам или другим охранникам, что ищут алюминиевые банки на обмен. Можно заполнить один из ваших мешков на треть банками, или оставить снаружи контейнера открытый мешок с банками, чтобы прохожие могли сделать нужные вам выводы.

Однажды я поведал скучающему старику-сторожу следующую небылицу: — У нас в школе устроили соревнование по сдаче алюминиевых банок. За каждый фунт банок, что мы приносим, школа получает три доллара. Классу, который принесет больше всех, вручат приз. Наш класс пока на втором месте, но я стараюсь поднять его до первого! — Дедок ушел и вскоре вернулся с охапкой пустых банок и бутылок из-под пива. — А бутылки берете? — осведомился он.

Запомните: не надо носить в карманах лишних ве-шей, или надевать часы, которые случайно могут соскочить с запястья. Если вы не хотите, чтобы ваши деньги, бумажник, кредитные карточки, записные книжки и так далее поглотила ненасытная утроба мусорного контейнера, оставьте все это дома.

Перед выходом проверьте карманы. Убедитесь, что не имеете при себе предметов, могущих послужить для идентификации вашей личности, а также ничего такого, что можно потерять. Я могу припомнить, по меньшей мере, четыре сообщения, отправленных хакерами по частным BBS, с содержанием типа “Джиз! Только что вернулся с помойки CompuPhone; я забыл надеть свое кольцо, когда вылезал из контейнера! Завтра придется снова туда переться!” К с другой стороны, имеет смысл прихватить с собой дешевые часы или еще что-то, дорогостоящее на вид, но грошовое по сути. Тогда, если к вам приблизится какая-нибудь любопытствующая личность, у вас будет возможность вскочить со словами: “Вот они, эти несчастные часы! Я так изнал, что уборшик, этот пьяный мексиканский придурок, выкинул их вместе с мусором”. И еще один совет бывалого человека: вернувшись домой, примите душ!

анализ найденных дискет

Когда вы становитесь хакером, вам повсюду во множестве начинают попадаться дискеты. Одни из них — испорченные, покореженные, погнутые — выброшены из-за очевидной (кажущейся!) непригодности, другие — беспечно забыты в дисководе, под клавиатурой, под столом; дискеты также могут находиться на своих обычных местах — лежать на рабочих столах, в дискетницах, в библиотечных справочниках, в шкафах для хранения файлов. Конечно же вам захочется считать данные с этих дискет и запустить находящиеся на них программы. Я вовсе не предлагаю вам действительно красть дискеты, которые вы увидите в офисе или где-то еще, но возможно вам удастся незаметно взять одну из них на ночь или на несколько деньков, так, что пропажа не будет обнаружена. Если так — успехов вам!

Но, стоп! Прежде чем начать рассказ о том, как поступать с добытыми дискетами, давайте определимся с терминологией. В этой книге речь пойдет о дискетах для микроЭВМ, которые бывают двух видов:

5 1,4- и 3 1,2- дюймовые. Дискета состоит из двух частей. Снаружи находится квадратная пластиковая пластина — я предпочитаю называть ее конвертом, а внутри — круглый диск из мейлора. Конверт предназначен исключительно для зашиты тонкого и хрупкого диска, и может быть ужасно измят безо всякого вреда для находящихся на диске данных. У 3 1,2-дюймовых дискет есть маленькая металлическая или пластиковая двериа, которая отодвигается, открывая расположенный внутри диск. 5 1,4-дюймовки не имеют подобной зашиты, и их диски можно увидеть сквозь овальное отверстие.

ВНИМАНИЕ! Никогда не вставляйте дискету неизвестного происхождения, особенно физически поврежденную, в хороший дисковод. Аля изучения найденных или поврежденных дискет лучше одолжить дешевый подержанный дисковод, и использовать для анализа обнаруженных дискет только его. Помните, изучение плохих дискет может легко испортить ваш дисковод. Никогда не запускайте плохие, поврежденные или найденные дискеты на своем рабочем дисководе!

проверка

Анализ найденной дискеты начинается с того, что вы извлекаете ее из бумажного конверта, если таковой имеется, и рассматриваете с двух сторон, дабы обнаружить явные отметки, такие как царапины, пятна от кофе или моршинки. Все же удивительно, какие испытания способны вынести хрупкие дискеты. В начале восьмидесятых, когда на рынке впервые появились домашние компьютеры, отовсюду неслись предупреждения: “Не кладите дискеты рядом с магнитами, рядом с монитором, на принтер или возле телефона. Оберегайте дискеты от воздействия сильного электромагнитного поля. Не сгибайте их, держите только за наклейку...”. И т. д, и т. п. Конечно, с дискетами следует обращаться бережно, но со временем стало очевидным, что дискеты — это не столь хрупкие создания, как некогда считали. И уж конечно, пластик и тефлон, из которых они сделаны, достаточно дешевы, чтобы никто не постеснялся их выбрасывать.

Итак, если вы, роясь в отходах какой-нибудь компании, увидите помятую дискету — не побрезгуйте, прихватите ее с собой — возможно, на ней есть что-нибудь интересненькое.

Если дискета (5 1,4-дюймовая) не имеет видимых повреждений, но вы все же беспокоитесь по этому поводу (“не представляешь, в какой грязише я ее на-дыбал!”), осторожно возьмите конверт одной рукой, а другой поврашайте диск (используя отверстие в центре). Врашая диск, внимательно осмотрите его сквозь овальное окошечко. Затем переверните диск, и проделайте то же самое с другой стороной.

Если найденная дискета — “трехдюймовка”, то, производя эти манипуляции, пальцем отодвиньте дверцу и осмотрите диск с обеих сторон. Если у вас есть серьезные основания подозревать, что дискета загрязнена, или внутри находится какая-то пыль, тогда будьте осторожны — врашением можно поцарапать диск. Вместо этого сделайте следующее: пальцем сдвиньте диск к краю конверта, затем возьмите острые ножницы или нож и срежьте очень тоненькую полоску с противоположного края конверта (того, где наклейка), раскройте конверт, нажав на его края большим и остальными пальцами, и извлеките диск. Не стирайте с него грязь — ведь вы же не хотите повредить его. Постарайтесь сдуть грязь или пыль. Можно использовать фен, установив его на подачу холодного воздуха. Теперь загляните внутрь пластикового конверта. Вы обнаружите прокладку из белой ткани типа газовой. Если она загрязнена, выбросьте такой конверт. Возьмите другую дискету, с ненужными вам данными, вскройте конверт описанным выше способом, вытащите диск и замените его другим. Убедитесь, что предохранительное кольцо в центре, если таковое имеется, обращено к лицевой стороне.

В случае с “трехдюймовыми” дискетами отодвиньте двериу и осторожненько вскройте острым ножом пластиковый футляр. Не засовывайте нож в конверт, старайтесь обрабатывать края и уголки там, где соединяются обе половинки. Выташите гибкий диск. Постарайтесь сдуть с него пыль и грязь. Затем поместите диск в чистый конверт, склеив половины.

V “трехдюймовок” своя специфика. Чаше всего заедает двериу, либо она попросту отсутствует. Если дверца на месте, но с ней что-то не так, — попросту снимите ее с дискеты с помошью ножа или скальпеля — большинству трехдюймовых дисководов наличие или отсутствие дверцы безразлично — ведь ее единственным назначением является предохранение диска от пыли и грязи нашего суетного мира.

Дверца на “трехдюймовке” подпружинена. Иногда пружинки уже нет. В этом случае дверца будет свободно ходить взад-вперед. Если же пружинка имеется, то, освободив ее, уберите куда-нибудь от греха подальше. Если дверца на “трехдюймовке” на месте и с ней все в порядке, то тогда, за редкими исключениями, диск остается чистым. Однако, если диск “трехдюймовки” и в самом деле запылен или загрязнен (люди такие свиньи!) — дело плохо. В этом случае вам предстоит изнуряющая процедура высвобождения его из пластмассовой оболочки (лучше это очень осторожно делать лобзиком). После чего диск очищается и помешается в другой пластмассовый корпус, уже разъятый на две части. Поместив диск в корпус, аккуратно склейте обе части. Дайте клею высохнуть. Еще раз повторяю: это очень тонкая операция, требующая высокой технической и духовной подготовки. “Пятидюймовые” дискеты порой бывают помяты или изогнуты. Они пригодны к употреблению, но место изгиба может своротить головку вашего дисковода. Поврежденный же дисковод, в свою очередь, может непоправимо испортить хорошие дискеты, вставленные в него впоследствии. Итак — НИКОГДА не вставляйте помятые дискеты в хороший дисковод, а нормальные— в плохой, приобретенный вами для найденных дискет.

Если вы нашли среди мусора измятую дискету, постарайтесь сначала как можно тщательнее распрямить ее. Положите дискету на твердую гладкую ровную поверхность. Накройте несколькими листами бумаги и положите сверху тяжелую книгу в качестве пресса. НЕЛЬЗЯ выпрямлять погнутые дискеты, пытаясь изогнуть их в другую сторону. Если защитный конверт никакими силами не удается привести в приличное состояние, выньте находящийся внутри него диск и вставьте в хороший, ровный конверт, так, как описано выше.

Ну вот, дискета прошла санитарную обработку. Теперь можно попытаться ее прочитать на специально подготовленном для этих целей дисководе.

Не пытайтесь проделывать такие веши с дискетами, купленными в магазине! Срезав верхушку, сожмите конверт с двух сторон. Затем извлеките диск. Теперь вы можете подремонтировать диск, очистить его и вставить в новый конверт.

А теперь давайте рассмотрим другие случаи, когда диск поврежден, но еще годен к употреблению. Для простоты и наглядности будем иметь в виду пятидюймовые дискеты.

Если диск поврежден только с одной стороны, вы все же сможете считать данные с другой. Для этого существует два способа.

Первый способ заключается в использовании специальной восстанавливающей программы-“доктора” для частично читаемых дорожек, которая собирает вместе найденные данные. Такие программы, вроде утилиты DEBUG для DOS, позволяют вам побитно изменять данные на диске. Если вам удастся добыть старый односторонний дисковод, ваша задача несколько упростится: достаточно просто вставить в него дискету поврежденной стороной вверх, и прочесть данные. (В односторонних дискетах данные обычно считываются и записываются на нижнюю сторону дискеты, если держать ее наклейкой вверх).

Второй способ — использование косметического ремонта для маскировки поврежденной стороны. Например, вы нашли дискету с нестирающимися пятнами на одной из сторон диска, и ваш дисковод просто отказывается ее читать. Вот что надо сделать. Возьмите другую дискету, отформатируйте и вскройте конверт. Выньте диск из конверта и наклейте новый диск поверх испачканной стороны найденного с помощью клейкой ленты. Лента должна находиться между двумя дисками; лучше всего подойдет тонкая двусторонняя лента. Проверьте, точно ли совпадают края двух дисков. Поместите склеенные диски в чистый конверт, и увидите, что у вас получится!

Вы можете очень осторожно склеить порванный диск с помощью тонкой прозрачной ленты. Лента должна быть наклеена только с одной стороны. Собрав все данные, которые вам удастся, с одной стороны, можно переклеить ленту и обработать другую сторону. Естественно, как упоминалось выше, лента не должна находиться на той стороне, с которой считываются данные— она может перекосить и запачкать головку дисковода.

Если на первый взгляд диск вполне пригоден, но вы получаете “Read Error”, вероятно, на нем имеются физические повреждения на микроскопическом уровне. Это могут быть крошечные отверстия или царапины, настолько мелкие, что их нельзя увидеть невооруженным глазом. Вы можете обойти такие дефекты, проворачивая диск внутри чехла. Если повреждение занимает какую-то незначительную часть диска, возможно, дисковод пытается прочесть в первую очередь именно этот кусок. Если чуть повернуть диск влево или вправо, оказавшийся на месте поврежденного сегмент может быть нетронутым и, следовательно, пригодным для чтения. Продолжайте раз за разом понемногу вращать диск, пока не обнаружите такой кусочек. Если вам не удалось найти его, возможно, вас просто одурачили! Дискета может оказаться чистой, или она не подходит к вашему компьютеру. А может быть, она односторонняя и вы вставили ее не той стороной к головке дисковода.

Дискета, найденная в мусорном контейнере, может содержать корпоративные данные, запатентованное программное обеспечение, иногда даже руководство или “демонстрашку”, о которых говорилось ранее. Вы и представить себе не могли, что хакеры занимаются археологией, верно? Но именно так и обстоят дела — мы заглядываем в жизнь людей, чтобы узнать, о чем они думают, что представляет для них ценность, а что нет; мы учимся на их опыте. Извлеченная из мусора поврежденная дискета поведает вам такие веши, о существовании которых вы никогда и не подозревали. Я весьма рекомендую вам заняться этим делом — из-за его увлекательности, а также благодаря интеллектуальным наработкам, которые оно вам даст.

изучение ФОТОГРАФИЙ мониторов

Фотоснимки компьютерных экранов, которые можно увидеть в книгах, журналах, системной документации, профессиональных изданиях, равно как изображения на мониторах, появляющиеся в телевизионных программах, новостях и коммерческих передачах — все это может содержать ценную для хакера информацию.

На фотографиях может быть показан только экран (или монитор), либо весь компьютер целиком, включая клавиатуру, центральный процессор и аксессуары. Иногда в кадр попадает работающий компьютер в реальном окружении, а порой и сидящий за компьютером оператор.

Первая группа картинок с одним лишь экраном, т. е. непосредственно “скриншоты”, может показать вам, на что похоже содержимое некоей системы, в которую вы никогда не входили. По нему вы сможете догадаться, какой вид доступа используется в системе (если на экране набран пароль), каковы имя пользователя и вид пароля, какие данные доступны и т. д. И все это можно узнать из одних лишь иллюстраций.

В руководствах пользователя и других инструкциях тоже встречаются рисунки экранов с подобной информацией, включая входные коды, сообщения об ошибках и другие полезные мелочи.

Зная сообщения об ошибках и вид экрана, вы гораздо удачнее сможете прикинуться системным администратором или пользователем, когда захотите прибегнуть к уловкам социальной инженерии (о них будет рассказано ниже). Это особенно полезно, если система, о которой идет речь, закрыта для внешнего доступа. Примеры входа в систему подскажут вам стратегию применения грубой силы. Когда на фотографии или рисунке показано имя пользователя, оно может оказаться действительным. И даже если на экране вместо пароля виднеется ряд звездочек (*******), вы все же узнаете, какая длина пароля установлена в данном случае. Если на некоторых фотографиях в отдельных изданиях все указанные пароли заменены восемью звездочками, это хороший признак: значит, для входа в систему используется восьмизначный пароль, либо восемь знаков — максимально допустимая длина пароля. Стиль имени пользователя тоже имеет значение, и его обычно видно на картинке. Просматривая примеры пользовательских имен, можно узнать, требуются ли имена и фамилии, нужны ли заглавные буквы, или же в качестве имен пользователей используются аббревиатуры либо названия компаний и рабочих групп.

Бывают фотографии, где снят не один только экран. Часто можно увидеть клавиатуру, с которой работает пользователь, тип компьютера и прочее. На более обширном фото можно увидеть окружение компьютера. Находится ли он в кабинете, или это зал, где уймища народа вкалывают бок о бок? Что за книги стоят на полках? На картинке могут присутствовать интересные сообщения, приклеенные к стене, либо лежащие на столе. Если на изображении виден пользователь, носит ли он (или она) какие-нибудь опознавательные знаки? Есть ли на картинке семейные фотографии, или предметы, по которым легко определить хобби пользователя, например, бейсбольная бита или удочка? Помните, хакер пускает в дело любую доступную информацию.

Когда я упоминаю об окружении компьютера, я, конечно же, имею в виду лишь изображения компьютеров в их естественной среде — в противоположность искусственно с режиссированным рекламным фото, вроде рекламы с изображением Макинтоша, стоящего в типичной комнате тинэйджера. Фотографии компьютеров, которые стоит изучить, часто встречаются в газетных и журнальных статьях. Изучение таких вещей, как предметы семейной жизни, книги и увлечения типичного пользователя, а также его (или ее) одежды, может помочь при отыскании паролей.

Определенный тип компьютера предполагает определенные способы взлома с использованием известных ошибок или лазеек. Видимое окружение компьютера тоже даст “социальному инженеру” возможность проявить свое знание какого-то отдельно взятого кабинета или офиса внутри здания.

В дополнение к изображению полезные сведения может содержать также напечатанная информация об авторе фотографии. Можно обратиться непосредственно к нему самому, либо с помощью его имени определить конкретный город или организацию, а затем уже вычислить номера телефонов, средства доступа и, опять же, пароли.

Иногда собрать большее количество сведений об интересующей вас системе помогает сильное увеличительное стекло. Неплохо бывает также записывать на видеопленку как можно больше связанных с компьютерной темой телевизионных шоу — вы всегда будете иметь возможность просмотреть интересные куски в замедленном режиме. Остановка кадров с конкретными сценами помогает заглянуть в скрытую от посторонних глаз часть системы и собрать информацию о работающих с ней людях. Если сильные помехи на телевизоре мешают вам останавливать кадр, постарайтесь очистить видеоканал. Если это не помогает, возможно, дело в “забивающей” видеоизображение звуковой дорожке. Попробуйте ее убрать, оставив лишь изображение. Сделать это можно следующим образом: соедините вместе два видеомагнитофона, используя лишь кабель входа, выхода для видео, без звукового канала. Скопируйте нужный вам кусок ленты, и у вас будет только изображение. Посторонние фоновые шумы, громкая музыка или голос ведущего могут иногда создать подобную же проблему со звуком.

Вот иллюстрация к тому, чем полезна детективная работа с подобными фотографиями.

Хакер по прозвищу Красотка смотрела передачу о внутренней жизни полицейского участка по местному кабельному телевидению. Камера крупным планом показала экран компьютера, на котором можно было разглядеть три последние цифры номера телефона, соединенного с модемом. Остальную часть номера закрыли блики на экране. Красотка знала, что полицейский банк данных, о котором шла речь, размешен в одном из городков штата Мэриленд, поскольку об этом упомянул ведущий передачу офицер полиции. Некоторые коды доступа в банк данных можно было легко различить на экране или угадать, но не все. Несколько часов, проведенных в библиотеке, дали Красотке трехзначные наборы цифр, использующиеся в городке, о котором упоминал полицейский. Красотка проверила каждое из этих сочетаний, пока не обнаружила верный телефонный номер. (Поскольку она узнала последние три цифры из телевизионной передачи, для заполнения пропущенных ей оставалось только проверить каждое сочетание по десять раз.) Дозвонившись, она смогла воспользоваться известной ей входной информацией (необходимо было ввести номер полицейского участка, муниципалитета и штата) и “взломать” ту часть информации, которая была ей неизвестна (из передачи она знала, что требуется восьмизначный пароль).

Мораль: Красотка не зря потеряла время, пялясь в “ящик”.

Даже в широковещательных передачах настоящий хакер может обнаружить случайно проскользнувшую важную информацию. Те, кто смотрел соответствующую серию передач Геральдо Риверы (“Теперь об этом можно рассказать”) в конце 1991 года, помнят историю о группе хакеров, которые совершили взлом военного компьютера. В течение повествования камера несколько раз вплотную приближалась к монитору, на котором был виден электронный адрес того компьютера, что подвергся взлому. В передаче также сообщили, что хакеры вошли в систему под именем odquaylen, без какого бы то ни было пароля. Разумеется, после разразившейся шумихи, войти в систему, набрав odquaylen, было уже нельзя (я сам проверял), и все схожие способы получения доступа к системе отныне ликвидированы.

“вынюхивание”

Люди часто совершают экскурсии, как официальные, так и неофициальные. Экскурсия может представлять собой обычный маршрут для любопытных детишек и их родителей, а может быть организована специально для вас — достаточно сообщить, что вы журналист, желающий написать статью о компании.

Во время такой экскурсии вы соберете ценные сведения о компьютерных залах, а также о вашем экскурсоводе. Данная информация может помочь вам при отгадывании паролей. Обладая достаточной учтивостью, иногда удается уговорить самодовольного владельца компьютера продемонстрировать вам возможности его новоприобретенной игрушки. Эти данные совсем не повредят вам, когда, вернувшись вечером домой, вы начнете готовиться к взлому.

Как видите, даже простое созерцание компьютеров и экранных меню может оказаться полезным.

Есть одна хитрость, к которой я люблю прибегать, хотя и не слишком часто. Всем знаком феномен послесвечения. Если изображение остается на экране в течение определенного промежутка времени, оно как бы “выжигается” на дисплее. Это часто случается с меню. Мне приходилось бывать в общественных местах, где стояли старые терминалы. С них можно было прочесть или “взломать” множество функций, ранее доступных лишь персоналу. (Чтобы разглядеть все это, приходится изрядно повозиться с регулятором яркости). Иногда мне удавалось прочесть кое-что на экране компьютера, стоящего у прилавка — выжженные на дисплее строки еле заметно просвечивали сквозь вполне безобидное текущее изображение.

Многие предприятия, организации и институты имеют дело с тем, что называют специальными библиотеками. Они содержат информацию исключительно по одной конкретной отрасли, к которой принадлежит данное предприятие, но порой в них можно найти ценные сведения и о самом предприятии. Например, в библиотеке компании могут быть руководства по единственной в своем роде компьютерной системе, использующейся в данной компании. Часто встречаются ценные списки программ, доступных на мэйнфрэймах. В подобный список может входить примечание о применяющихся средствах зашиты, что позволит вам написать производителю этих средств и запросить подробности.

Полезно бывает производить “вынюхивание” вокруг зданий, проходящих реконструкцию, равно как и вокруг тех зданий, чьи обитатели переезжают на новое место. В подобных случаях двери зачастую открыты настежь, а компьютеры и различные пособия валяются под ногами. Однажды я зашел в помещение, временно покинутое хозяевами ввиду ремонта. Его коридоры были завалены грудами бумаг, столов и рабочих станций (шла покраска комнат). Я обнаружил массу паролей, приклеенных к клавиатурам на клейких записках, нацарапанных на блоттерах, прикрепленных к дну выдвижных ящиков. Просто поразительно, с какой беспечностью люди вот так разбрасывают повсюду свои секреты, и насколько часто это случается.

Бесцельно слоняясь по зданию одного факультета, я обзавелся справочными пособиями десятилетней давности. Эта макулатура принадлежала прекратившей свое существование группе пользователей. Почти ничего из этого нельзя было использовать для взлома, зато почти все было дико интересно читать. Обнаружил я эту кипу в пыльной коробке на верхней полке чулана. В том же здании я набрел на маленькую комнату; дверь ее была закрыта, а к двери прикреплены четыре таблички. Первая, с официальной гравировкой, гласила: “Компьютерный зал”. Остальные, угрожающего содержания, были написаны от руки или напечатаны на принтере: “Не оставляйте дверь открытой!”; “Посторонним вход запрещен!”; а последнее грозное предупреждение гласило: “Уходя, ВСЕГДА запирайте дверь!”. Нечего и говорить, что дверь оказалась незапертой. Внутри находилось большое и весьма информативное справочное руководство по оперативной системе и две персоналки, каждая с модемом. Обследовав жесткий диск одного из этих компьютеров, я обнаружил, что программа терминала была инсталлирована с файлом сценария на подключение (script), который содержал телефонные номера, пароли и другие процедуры входа.

Я это к чему? А к тому, ребятки, что при “вынюхиваний” всегда следует искать такие веши. Зарубите себе на носу, что для хакера файл сценария — это все равно что самородок для золотоискателя-одиночки.

“Вынюхивание” может подарить вам все те же дискеты с руководствами и демонстрационными программами, порой и поврежденные. Вдобавок оно придает приключенческий оттенок обычно пассивному искусству хакерства и дает возможность хоть ненадолго оторваться от утомительного вглядывания в экран. “Вынюхивание” обеспечивает необходимую нагрузку организму и спасает от гиподинамии.

Конечно, не обязательно производить “вынюхивание” перед взломом. Опять-таки подобные исследования можно проводить, вовсе не имея в виду предстоящий взлом. Просто... да о чем говорить! Это само по себе захватывающе интересно. Как и в случае моих путешествий по перевернутому вверх дном зданию и коридорам университета, тщательные исследования могут привести к весьма любопытной информации. Другими словами — не все хакеру за компьютером сидеть; иногда можно и повеселиться в свое удовольствие!

Назад


Глава 3. Пароли и контроль над доступом

ТОРЖЕСТВЕННЫЙ КОМПЛЕКТ

Незаменимое пособие для сочинения юбилейных статей, табельных фельетонов,

а также парадных стихотворений, од и тропарей Раздел 1. Словарь. Существительные.

1. Клики; 2. Трудящиеся; 3. Заря; 4. Жизнь; 5. Маяк; 6. Ошибки; 7. Стяг (флаг); 8. Ваал; 9. Молох; 10. Прислужник; 11. Час; 12. Враг; 13. Поступь;

14. Вал; 15. Пески; 16. Скок; 17. Конь; 18. Сердце; 19. Прошлое.

И. Ильф, Е. Петров. Золотой теленок

Для зашиты компьютерных установок на сегодняшний день имеются три основных класса контроля доступа. Это:

— контроль, основанный на знании (пароли);

— контроль, основанный на обладании (ключи);

—контроль, основанный на личных характеристиках (биометрические приборы).

В случае контроля, основанного на обладании, речь идет о предметах, принадлежащих пользователю, — физическом ключе, магнитной карте и т. д. Иногда используется металлическая пластинка причудливой формы, которую вставляют перед началом работы в шель распознавателя. “Ключом” может служить также идентификационный знак либо специальное письмо с подписью одного из высокопоставленных лиц компании.

Биометрические приборы анализируют специфические физические особенности пользователя (подпись, отпечатки пальцев или рисунок линий на ладони) и сравнивают их с теми, что наличествуют у них в памяти. Эти два вида компьютерной зашиты могут использоваться и для дистанционного управления доступом, хотя обычно к ним прибегают для ограничения доступа к тому месту, где находятся компьютеры, — компьютерному залу или отдельному кабинету.

Биометрические и физические ключи будут далее рассмотрены более подробно.

Первый вид контроля над доступом, наиболее распространенный, основан на обладании специфической информацией. Это означает, что правом доступа обладают лишь те лица, которые способны продемонстрировать свое знание определенного секрета, обычно пароля. Львиную долю работы хакера составляет именно поиск этого пароля. В этой главе и рассказывается обо всем, что вам необходимо знать о паролях: как они работают, где хранятся, и как их можно “взломать”.

пароли

Самый простой и дешевый путь зашиты любого типа компьютерной системы сводится к старому, испытанному способу: применению пароля. Даже те компьютеры, которые вовсе не нуждаются в средствах зашиты, зачастую снабжаются паролем просто потому, что пароль дает ощущение психологического комфорта и его использование не требует особенно много времени, сил и места в памяти. Более того, в системах, уже защищенных другими средствами — магнитными картами или иными программными методами, типа шифрования, нередко удваивают или утраивают заши-ту содержимого, прибегая к системе паролей. Таким

образом, практически все установки компьютеров включают в себя пароли того или иного вида.

Пароли, как правило, рассматриваются в качестве ключей для входа в систему, но они используются и для других целей: блокирование записи на дисковод, в командах на шифрование данных или на разархива-цию файлов — короче, во всех тех случаях, когда требуется твердая уверенность в том, что соответствующие действия будут производиться только законными владельцами или пользователями программного обеспечения.

Пароли подразделяются на семь основных групп:

— пароли, устанавливаемые пользователем;

— пароли, генерируемые системой;

— случайные коды доступа, генерируемые системой;

— полуслова;

— ключевые фразы;

— интерактивные последовательности типа “вопрос — ответ”;

— “строгие” пароли.

Если вы решились на взлом, вам, прежде всего, необходимо вычислить, какой из этих семи видов паролей используется в данной системе.

Первый является наиболее распространенным — обычно пользователи, движимые мелким тщеславием, просят придумать себе личный пароль.

Случайные пароли и коды, устанавливаемые системой, могут быть нескольких разновидностей. Системное программное обеспечение может применить полностью случайную последовательность символов — случайную вплоть до регистров, цифр, пунктуациии длины; или же в генерирующих процедурах могут быть использованы ограничения. Например, каждый код доступа согласуется с заранее подготовленным шаблоном (вроде oabc-12345-efghn, где буквы и цифры, на заданных позициях, генерируются случайным образом). Создаваемые компьютером пароли могут также случайным образом извлекаться из списка обычных или ничего не значащих слов, созданных авторами программы, которые образуют пароли вроде onah.foopn, или ocar- back-treen. Полуслова частично создаются пользователем, а частично — каким-либо случайным процессом. Это значит, что если даже пользователь придумает легко угадываемый пароль, например, “секрет”, компьютер дополнит его какой-нибудь неразберихой, образовав более сложный пароль типа “секрет,5гh11”.

Ключевые фразы хороши тем, что они длинные и их трудно угадать, зато легко запомнить. Фразы могут быть осмысленными, типа “we were troubled by that”, или не иметь смысла — “fished up our nose”. Ключевые фразы применяются в тех организациях, где менеджер слегка помешан на защите. Следует заметить, что в программировании постепенно намечается тенденция к переходу на более широкое применение ключевых фраз.

К концепции ключевых фраз близка концепция кодового акронима, который эксперты по защите оценивают как короткую, но идеально безопасную форму пароля. В акрониме пользователь берет легко запоминающееся предложение, фразу, строчку из стихотворения и т. п., и использует первые буквы каждого слова в качестве пароля. Например, акронимами двух приведенных выше фраз являются “wwtbt” и “fuon”. Как видите, подобные нововведения в теории паролей значительно затрудняют занятия электронным шпионажем.

Шестой тип паролей — интерактивные последовательности “вопрос — ответ”, предлагают пользователю ответить на несколько вопросов, как правило, личного плана: “Девичья фамилия вашей супруги?”, “Ваш любимый цвет?”, и т. д. В компьютере хранятся ответы на множество таких вопросов. При входе пользователя в систему компьютер сравнивает полученные ответы с “правильными”. Сеансы вопросов и ответов могут оказаться лакомым кусочком для хакера, который хорошо знаком с пользователем, под чьим именем он пытается войти в систему. Системы с использованием вопросов — ответов склонны к тому же прерывать работу пользователя каждые десять минут, предлагая отвечать на вопросы, дабы подтвердить его право пользоваться системой. Это очень раздражает, особенно если пользователь погружен в интересную игру. Ныне такие пароли почти не используются. Когда их придумали, идея казалась неплохой, но раздражающий фактор прерывания привел к тому, что данный метод практически исчез из обихода.

“Строгие” пароли обычно используются совместно с каким-нибудь внешним электронным или механическим устройством - “цербером”. В этом случае компьютер обычно с простодушным коварством предлагает несколько вариантов приглашений, а бе-долага-пользователь должен дать на них подходящие ответы. Этот вид паролей часто встречается в системах с одноразовыми кодами, а также в параноидаль-ных организациях.

Одноразовые коды — это пароли, которые срабатывают только один раз. К ним иногда прибегают, создавая временную копию для гостей, чтобы продемонстрировать потенциальным клиентам возможности системы. Они также порой применяются при первом вхождении пользователя в систему. Во время первого сеанса пользователь вводит свой собственный пароль и в дальнейшем входит в систему лишь через него. Одноразовые коды могут также применяться в системе, когда действительный пользователь входит в нее в первый раз; затем пользователю следует поменять свой пароль на более секретный персональный код. В случаях, когда системой пользуется группа людей, но при этом нельзя нарушать секретность, прибегают к списку одноразовых кодов. Тот или иной пользователь вводит код, соотвествуюший времени, дате или дню недели. Может быть, вам повезет и вы найдете такой список в одном из своих походов за мусором. Коды, конечно, вам уже не пригодятся, но зато вы уразумеете принцип зашиты данной системы.

пороли, устанавливаемые пользователем

Большинство паролей относятся к типу “выбери сам”. Большинство современных программ запрашивают не слишком короткий пароль, чтобы систему было “труднее взломать”. Обычно пароль содержит не менее четырех-пяти букв. Существуют также и другие меры, призванные не позволить пользователю создать неудачный пароль. Например, система может настаивать на том, чтобы пароль включал в себя строчные и заглавные буквы вперемешку с цифрами; заведомо очевидные пароли, например, “компьютер”, ею отвергаются. В разных операционных системах существует немало программ, которые просматривают файлы, содержащие пароли, анализируют пароли пользователей и определяют, насколько они секретны. Неподходящие пароли заменяются. Вам необходимо досконально познакомиться с такими программами. Тогда вы будете иметь представление о том, какая из этих программ используется в избранной вами системе, и какие пароли данная программа не пропускает.

Не считая гениев и безнадежных тупиц, все люди, когда надо принимать быстрые решения, мыслят и действуют примерно одинаково. Людям требуется время, чтобы начать мыслить творчески. Начальные предположения и первые умозаключения в определенных группах людей оказываются одинаковыми. Когда человек впервые загружает компьютер, и тот запрашивает у него пароль, этот пароль окажется вариантом одной из общих и актуальных для всех тем — особенно если у пользователя не хватает времени или он находится в незнакомом месте. Представьте себе состояние человека, когда его просят придумать собственный секретный пароль. Возможно, каждая минута промедления оборачивается все новыми центами и долларами, либо его окружает группа технических работников, которые обучают этого человека работе с системой. Как бы то ни было, стоит запросу появиться на экране, и человека посещает мысль о том, что надо немедленно что-то предпринимать. Люди выдают первое, что приходит им в голову. А в голову приходит то, что они видят или слышат в данный момент, либо то, что собираются сделать сразу же после загрузки. Пароли создаются впопыхах, а последующая замена такого пароля на более надежный происходит достаточно редко. Таким образом, многие пароли извлекаются из мыслей, которые плавают на поверхности сознания — мыслей о работе, семье, возможных событиях, имуществе, оборудовании, увлечениях и интересах. Если вам удастся угадать или узнать одну из подобных характеристик полноправного системного пользователя, вероятность того, что вы угадаете верный пароль, значительно возрастет.

Возьмите каталоги компаний, занимающихся изготовлением наклеек-постеров, юмористических фотографий и прочей ерунды, которой пестрят стены офисов. Сколько раз вам уже приходилось видеть растиражированную фразу “Вам необязательно быть кретином, чтобы работать здесь... Но стать им не помешает!”. Могу дать гарантию, что словечко “кретин” с этого плаката используется в качестве пароля ежедневно.

Не забывайте также о возрасте и образе жизни среднестатистического пользователя, под которого вы собираетесь маскироваться, чтобы войти и совершить взлом. В офисе какой-либо солидной корпорации, скорее всего, не приклеят постер с обнаженной натурой, но вот в студенческом городке это вполне возможно — там стоит опробовать пароли типа “playmate”, “victoria”, “body” или “month”.

Самый простой способ раздобыть пароль — самому войти в систему в качестве пользователя, или подсказать пароль пользователю, входящему в систему впервые. Можно разыграть перед новичком роль компьютерного гуру — рассказать ему об основах этого дела, обойдя молчанием аспект секретности, и постараться узнать их пароль при вводе. Новичок либо громко скажет вслух только что придуманный пароль, или же вы увидите, как загорятся его глаза при виде настенного календаря с заголовком: “surfboard”. (Порой они говорят: “Господи, какой бы пароль посекретнее придумать? О, знаю...”, и вслух сообщают вам свой пароль, набирая его на клавиатуре.)

Вышесказанное — приятная случайность. Обычно, особенно если к вашему появлению пароль уже введен, приходится изрядно повозиться, прибегая к методам тупого перебора, наблюдениям, социальному либо техническому методам узнавания пароля.

Пароли в большинстве своем являются литературными словами типа “subway”, “chocolate” и т. п. В самом деле, можете ли вы представить себе новичка, сидящего за компьютером и старательно вводящего в качестве пароля нечто вроде “fMm6Pe”? Ну, конечно же, нет! Правила правописания для паролей не применяются: при создании паролей разрешается использовать имена собственные, равно как и слова с орфографическими ошибками, аббревиатуры, бессмыслицы и иностранные термины. Так, любитель посмотреть по телевизору Star Trek может создать пароль “enterprize” вместо корректного “Enterprise”. Возможно, он (или она) не знаком с правописанием, а может, ему так просто больше нравится, — неважно. Важно, чтобы вы знали: слова с ошибками — полноправные обитатели мира паролей. Можно найти букву “k” на месте “с” — “koka kola”, “х” вместо “ks” в “thanx” и другие фонетические заменители.

Некоторые хакеры просматривают каждое слово в английском языке, пока не найдут что-нибудь, работающее в качестве пароля. Если пароль, который они ищут, действительно обычное слово, но неправильно написанное, можно потерять кучу времени. Поиск паролей с помощью одной лишь тупого перебора слов, со словарем, нередко превращается в безрадостное и бесполезное занятие. Многие слова часто встречаются среди паролей. В то же время иные слова почти никогда не используются в качестве паролей. Разве найдется человек, способный ввести в качестве пароля наречие? Такие слова следует опробовать в последнюю очередь. Пароли, как правило, относятся либо к существительным, либо к глаголам (обычно общеупотребительным), а иногда — к прилагательным. Среди паролей популярны имена и прозвища друзей и подружек; вы узнаете их, проведя предварительные исследования.

Кроме литературных слов попадаются также имена родственников, домашних животных, названия улиц, спортивных команд и продуктов питания; важные даты и номера, такие, как номера страховок, дни рождения и другие памятные даты и т. д.

Встречаются также бессмысленные наборы знаков клавиатуры, (“jkjkjkjk”, “7u7u7u”, “QWER”, “ccccccc”, “0987654321”, “asdfgh” или “AZSXDC”.) Такие пароли обычно представляют собой простые наборы повторяющихся или расположенных рядом символов клавиатуры и т. п. Иногда кажется, что клавиатурные пароли совершенно невозможно разгадать, и в то же время в них присутствует своя логика — если знаешь, что происходит на другом конце телефонной линии. Например, сочетание “05AF” может показаться странным для выдуманного второпях пароля, но если вам известно, что данный компьютер снабжен специальной шестнадцатеричной малой клавиатурой, все сразу становится ясно.

Малая шестнадцатеричная клавиатура используется некоторыми программистами для ускорения ввода символов в шестнадцатеричном коде. Эта клавиатура — хорошая иллюстрация к принципу, которым пользуются находчивые хакеры: то, что вы видите на вашей стороне линии, может отличаться от того, что происходит на той.

Вот несколько реальных системных паролей, с которыми я сталкивался: “abcdf”, “qwerty”, “12345”, “хххххх”, “ороророрр”.Если минимальная длина пароля должна составлять шесть символов, не думайте, что клавиатурные пароли намного превысят эту длину. С другой стороны, нельзя же опробовать все сочетания клавиш: их бесконечно много. Но в любом случае отгадывание клавиатурных паролей скрасит вам часы отдыха.

ПОИСК ВОЗМОЖНОГО ПАРОЛЯ

Одним из пособий, которыми я пользовался при написании этой книги, являлось неофициальное руководство по популярному платному информационному сервису. На протяжении всей книги автор постоянно упоминала о своей любимой кошечке, о своей любви к мягким филадельфийским “pretzels”, о своей любимой футбольной команде, о своем муже, детях и недавно проснувшемся интересе к компьютерам. Подобные ссылки на ее личные пристрастия появлялись не только в тексте книги, они присутствовали даже в иллюстрациях к действию команды “Find”, в примерах сообщений и писем.

Имя автора, разумеется, я знал. Я знал также, что она входит в число пользователей одной системы, и знал, каков ее образ жизни. Вычислить ее системный код оказалось невероятно просто, а перебрав десятка два паролей я смог войти в систему, маскируясь под нее. После этого она, по моему совету, изменила свой пароль.

И этот пример вовсе не исключение! Мы с вами ежедневно читаем газетные статьи, журналы и книги, в которых авторы сообщают читателям свои компьютерные адреса, чтобы читатели могли им написать.

Вчера я слушал радиопередачу, в которой ведущий выдал свой адрес в CompuServe всем радиослушателям, которым не удалось дозвониться ему на радио! Мы имеем достаточно информации о многих из этих авторов, чтобы наши догадки насчет их паролей были обоснованы. Даже в случаях, когда автор книги не распространяется насчет своей личной жизни, об этом обычно можно узнать, прочитав статью “Об авторе”.

Большую часть компьютерных книг пишут профессора колледжей; нетрудно узнать, в каком колледже они преподают, и у вас появится ниточка, ведущая к паролю.

Если в приведенных примерах программ попадается бейсбольный жаргон, это также может послужить вам подсказкой.

Я хочу, чтобы вы имели в виду — все вышесказанное приведено здесь исключительно в информативных целях. Эти заметки сделаны лишь для того, чтобы указать на некоторые очевидные недостатки существующей компьютерной безопасности. И выбросите из головы любые глупые идеи насчет взлома моих паролей!

Еще одна хитрость — просмотр выпусков “Кто есть кто”. Чуть ли не все промышленные отрасли ежегодно издают альманахи “Кто есть кто”. Большинство этих изданий выпускаются просто в угоду тщеславию:

люди тратят свои деньги, чтобы о них что-то напечатали. Эти альманахи содержат немало полезных данных. Если этого вам недостаточно, напечатайте свой собственный псевдоофиииальный образец анкеты “Кто есть кто” и пошлите по электронной почте нужным вам сотрудникам компании. Проверьте, соответствует ли форма анкеты той, что принята у них в компании; пообещайте, что данные сотрудники будут включены в книгу бесплатно и также бесплатно получат по одной копии книги. Это повысит вероятность того, что их анкеты будут заполнены, а вы получите ценную информацию, которая поможет вам вычислить их пароли.

Вот еще одна уловка — обзавестись друзьями из числа сотрудников компании. Позвоните в их офис и потолкуйте с секретаршей или с каким-либо другим лицом, которому всегда известны все слухи. Скажите, что вы из нового журнала, специализирующегося на достижениях в области бизнеса. Попросите сообщить вам имена людей, возглавляющих основные отделы, дабы вы могли послать им бесплатный талон на ознакомительную подписку. Затем поговорите с секретарями начальников этих отделов. Пусть они заполнят анкеты “маркетинговых исследований”, возможно, за некоторое вознаграждение — бесплатную подписку, рекламные часы с радио и т. п.

Обычные рыночные анкеты для подписчиков торгового журнала включают вопросы об образовании, присвоенных степенях, производственных достижениях, членство в профсоюзных ассоциациях, военную службу, размер оклада и длительность работы в компании. По мере продолжения вашей беседы начинайте задавать вопросы об их хобби и занятиях в свободное от работы время, любимых видах спорта; узнайте имена их родственников и их домашние адреса. Все эти вопросы вполне может задать исследователь в области рынка, а ответы на них могут дать вам ключи к паролям. Можно сделать проще: позвоните и скажите, что вы являетесь помощником редактора в журнале о торговле и занимаетесь поиском интересных людей, работающих в данной отрасли. — Нет ли у вас кого-нибудь, кто совершил бы нечто совершенно потрясающее, или хотя бы имеет какие-то необычные хобби? — Ответ может оказаться отрицательным. Но не отчаивайтесь: может, у кого-нибудь есть какой-либо специфический талант? Музыкальный, например? Продолжайте в том же духе — в конце концов, вы на что-нибудь наткнетесь и сможете использовать приведенные выше методы, чтобы собрать о данной личности как можно больше сведений.

Узнавание чьих-то личных пристрастий называется созданием личностного профиля (у хакеров — “парольного профиля”). Эта техника применяется тогда, когда хакер хочет получить информацию о конкретном человеке, чьи компьютеры он собирается взломать. Если вы хотите собрать интересующую вас информацию о главном боссе какой-либо корпорации, вам следует поискать его (или ее) интервью для прессы, узнать, каковы его (или ее) пристрастия, и действовать, исходя из полученной информации.

Одну из популярных уловок упоминает в своей “Настольной книге” хакер Хьюго Корнуолл. Она основана на том факте, что зачастую главному лицу организации программное обеспечение преподносится на блюдечке в уже готовом виде — с введенным паролем, — чтобы, упаси Боже, начальство не перенапрягло мозги. Естественно, такой пароль легко угадать, исходя из личных интересов босса, — ведь пароль-то готовился желающими выслужиться подхалимами именно для него. — Вы говорили, мистер Ларсен любит порыбачить? Так введите в качестве пароля слово “рыба”.)

Давайте предположим, что хобби или увлечения избранного вами лица уже известны. Как действовать дальше? Для начала можно пойти в библиотеку и взять там все имеющиеся в наличии книги по данному предмету. Затем создайте банк слов, взятых из словарей и каталогов. Людям нравятся большие и, как им кажется, сложные слова или названия из сферы их обожаемых хобби: им кажется, что эти слова больше никому и в голову не придут. Так, студенты-литературоведы используют в качестве паролей имена вроде “Еврипид”; в целом же студенты тяготеют к мешанине из длинных технических терминов. Создав списки слов, начинайте их пробовать вводить к качестве пароля. Если не одно из них не подойдет, можно переходить к другому типу пароля. Аоктор необязательно придумает пароль “перикард”. Жизнь человека многопланова, а профессиональная деятельность составляет лишь одну из ее сторон.

изучение паролеи

Если вы считаете, что все эти разговоры насчет легко отгадываемых паролей — пустая болтовня, поразмыслите хорошенько. Я потратил немало времени на формальное и неформальное изучение данного предмета, прежде чем выяснил, насколько в действительности безопасны создаваемые пользователями пароли. Вот результат одного из подобных экспериментов. Среди 3829 паролей оказалось: 15 обычных ASCII-символов, 72 двузначных пароля, 464 трехзначных, 477 четырехзначных, 706 пятизначных (все они состояли либо из одних строчных, либо из одних прописных букв) и 605 шестизначных (все из строчных букв).

Вывод: то, что хакеры могут просто сидеть и отгадывать пароли — ФАКТ, а не ФИКЦИЯ. Это не только возможно, но зачастую и нетрудно.

Другой пример того, насколько легко взламываются пароли — “червь”, который прополз по всему Интернету в 1988 году, “завалив” большую часть сети. У “червя” было два способа размножения, один из которых базировался на взломе пользовательских паролей. Сначала “червь” пробовал типичные пароли, такие, как имя для входа в систему, имя или фамилию пользователя, и тому подобные варианты. Если ни один из них не подходил, “червь” прибегал к помощи словаря, состоявшего из 432 общеупотребительных паролей. И, наконец, если оба этих метода не срабатывали, “червь” обращался к словарю системы UNIX и пробовал каждое слово, пока не находил верное. Результаты показали, что этот метод работал безупречно. Кстати, если вы окажетесь в системе UNIX, и вам понадобится грубая сила для получения более высокого уровня доступа, системный словарь может здорово помочь. Он находится в поддиректории “,usr.dict,”. Файл называется “words”. Вы также можете переписать этот файл на дискету или скопировать его на другой компьютер, если вам нужен открытый словарный текст для использования на других машинах.

Одно из достоинств (и недостатков) словаря UNIX заключается в том, что содержащиеся там слова не совсем соответствуют общеупотребительному словарю английского языка. В системном словаре превалируют научные термины, что отвечает целям, ради которых был создан данный словарь.

ограничения для паролей

Большинство операционных систем создавалось не для сверхсекретных задач. Разумеется, в системах разделенного времени вся секретность заключается в основанных на паролях бюджетах. Впрочем, как мы уже заметили, многие пароли крайне легко отгадать.

Ограничения операционной системы UNIX для паролей ограничиваются тем, что пароли должны состоять не менее чем из пяти строчных символов, либо из четырех, при условии, что по крайней мере один из этих символов является прописной буквой или управляющим кодом. Впрочем, если пользователь настаивает на введении более короткого пароля, невзирая на предупреждения о ненадежности, система все же допустит его пароль. Системные операторы знают о том, что большинство паролей не отвечают требованиям секретности. Поэтому многие из них инсталлируют специальные программы, которые запрещают создание слишком “легких” паролей. Пароль должен отвечать определенным требованиям, как то:

а) быть определенной длины;

б) включать в себя как прописные, так и строчные буквы;

в) включать в себя одну и более цифр;

г) включать в себя один нецифровой и неалфавитный символ.

Одно или несколько из этих правил должны соблюдаться.

Программа может также протестировать пароль пользователя, применив список известных ей “плохих” паролей, которые не допускаются к использованию. Запрет на однобуквенные или простые буквенные пароли, конечно, создает определенные трудности при отгадывании, но не слишком большие. Однажды я пытался отгадать пароль некоего человека; мне казалось, что его пароль должен быть “рореуе” (“пучеглаз”), поскольку у него была обширная коллекция классических юмористических книг и в основном его интересовал именно этот комикс. Системное программное обеспечение предлагало вводить в качестве пароля смесь из прописных и строчных букв (кстати, это также дает полезную информацию о том, что система отличает строчные буквы от прописных). Я попробовал ввести следующее: Рореуе PoPeYe popeyE PopEye popEYE рорЕуЕореуЕ PopEYE РоРеуе, а затем ввел инверсную форму каждого из этих сочетаний, превращая PopeyE в pOPEYe (на случай, если пользователь считал заглавные буквы нормой для компьютерной клавиатуры, а строчные — исключением). Казалось маловероятным, что этот любитель комиксов придумал нечто из ряда вон выходящее — ввел прописные буквы посреди слова или расставил их бессистемно. (Да и кто из нас, будучи в здравом рассудке, поступит так, если его попросят ввести заглавные буквы в пароль?) В конце концов его пароль оказался “OliveOyl”. При первой загрузке пользователя система может попросить его ввести в пароль не заглавные буквы, а числа. И опять же, вряд ли Простой Пользователь станет разбивать слово числами, да и числа введет не длиннее, чем одно-двухзначные. Ведь пользователь обычно рассматривает пароль как слово. И о необходимости включения в него чисел он подумает в последнюю очередь. Таким образом, обычно встречаются пароли следующего вида: пароль#, пар#оль, #пароль. Числа, как правило, берутся легко запоминающиеся, либо те, которые удобно набирать, вроде О или 1. Числа от 1 до 31 встречаются наиболее часто, равно как и числа с повторяющимися цифрами или заканчивающиеся нулями или девятками — 888, 500, 1999 и т. п. Можно ожидать, что автор пароля поставит цифру “1” на место буквы “I” (строчная “L”), если пароль содержит данную букву. Компьютерные фанатики также имеют милую манеру заменять букву “О” нулем, если требуется ввести какую-либо цифру. Если вы подозреваете, что пароль содержит цифры “1 ” или “О”, вместо букв, то попробуйте набрать вместо “cool” или “computer” следующее: “cOOl” или “cOmputer”.

пароли, создаваемые компьютером: подделка и анализ паролей, генегигуемых машиной

Многие из паролей, которые создает сам компьютер, порождены не без участия генератора случайных чисел. Взгляните, например, на приведенный ниже отрывок из сегмента воображаемой программы:

5 Randomize Timer

100 For i = 1 to 6

110 Char=lnt(Rnd*91)

120 If Char < 65 Then Goto 110

130 Password = Password + Chr$(Char)

140 Next i

200 Print "Ваш новый пароль: "; Password

В данном случае шесть прописных букв выбираются независимо друг от друга и соединяются, образуя пароль. Буквы выбираются по случайному числу между 65 и 90 — в соответствии с ASCII-кодом для заглавных букв. Случайность выбранных кодов ASCII основана на использовании функции Rnd, возвращающей псевдослучайные числа, базирующиеся на показаниях компьютерного таймера. В принципе, для генерации случайных чисел может быть использовано все, что угодно — главное было бы аппаратное обеспечение. Во всех основных языках программирования имеется встроенная или библиотечная функция, возвращающая псевдослучайное число: либо в интервале от нуля до единицы, как в приведенном выше примере на языке Бейсик, либо в диапазоне, задаваемом программистом.

Впрочем, можно полностью избавиться от фактора случайности, а просто присваивать каждому новому пользователю один и тот же пароль, например — “EVbDCI8”. Но это я шучу. Проблема в том, что подобное вряд ли ускользнет от внимания системных администраторов. Более логичный способ — заставить программу генерировать похожий на случайный пароль, основанный на некоторой информации о пользователе, которую можно почерпнуть из легко доступных источников (дата рождения, номер Социальной Безопасности и т. д.). После этого вы просто вставляете эти данные в копию программы на вашем домашнем компьютере и создаете новый пользовательский пароль.

Один неплохой шифровочный алгоритм работает следующим образом: берутся синусы ASCII-кодов первых шести или восьми букв имени пользователя, затем берутся две предпоследние цифры из синусов, изменяются до подходящего размера, и соединяются в соответствующие ASCII-кодам буквы, формируя “слово”. Таким образом, вы получаете похожий на случайный пароль, который изготавливается практически вручную. Если имя пользователя состоит менее чем из шести букв, оставшееся место можно заполнить условными символами.

В данном примере имя пользователя превращается в ничего не значащий пароль в соответствии с методом, приведенным в тексте. На первый взгляд получившийся пароль кажется случайным и безопасным, но хакер может его разгадать, прибегнув к общедоступной информации о пользователе (здесь это фамилия пользователя).

Это достаточно простой пример; в жизни вам придется в соответствии с требованиями вводить в пароль строчные и прописные буквы, укорачивать его или удлинять, либо вставлять в пароль цифры, если понадобится. Такое внедрение пароля может оказать вам услугу, если вы занимаетесь системой электронных сообщений или объявлений: пользователям могут так понравиться их новые безопасные пароли (а разве “rueavz” не кажется безопасным паролем?), что они начинают пользоваться ими и в других местах.

Еще одна возможность, также предполагающая, что вы можете изменить генератор паролей незаметно — заменить начальное число генератора случайных чисел постоянной величиной (наберите в начале программы: 5 Randomize 0, тем самым заставив программу производить одни и те же серии случайных чисел при каждом запуске (до тех пор, пока компьютер включен и программа не возвращена в первоначальное состояние). Однако это довольно рискованно, и может привести к нежелательным побочным эффектам. Один из методов устранения недостатков генераторов псевдослучайных чисел был разработан одним из создателей UNIX, Денисом М. Ричи, и издан в 1986 году в информационном бюллетене о средствах зашиты под заголовком “On the Security of UNIX” (“О защите в системе UNIX”). Для повышения безопасности вычислительных установок администраторы решили создать безопасные, генерируемые компьютером пароли. Каждый пароль должен был представлять собой восьмизначную строку из строчных букв и цифр. Число таких паролей равняется 2,821,109,900,000. Как сказано у Ричи, у PDP-11,70 уйдет 112 лет на отгадывание этих паролей, перебирая их один за другим. Но один хакер знал, что генератор случайных чисел располагает лишь 32,768 начальными числами, значит, количество возможных результатов сокращается именно до этой величины. Представляете, этот негодяй создал генератор, проверил каждую из этих строк одну за другой и обнаружил все генерируемые системой пароли, потратив на это всего около, одной минуты машинного времени. Действительно, не жалко потратить шестьдесят секунд и немного попрограммировать ради того, чтобы получить доступ во все бюджеты системы!

Если вы не сможете ввести код для машинной генерации паролей, вам, наверно, удастся проанализировать их уже после создания. Для этого вам потребуется как минимум один пароль, а лучше два или более, из созданных системой. Если вы располагаете легальным входом в систему, один пароль у вас уже есть. Если вы взламываете локальную BBS, или еще какую-либо из тех систем, где возможны многочисленные анонимные входы, попробуйте перезагрузиться несколько раз и собрать несколько новых паролей под разными именами. Можно приобрести соответствующее программное обеспечение для работы с BBS или программу генерации паролей и работать с ними, собирая различные пароли.

Однажды я набрел на “свеженькую” BBS. Поразмыслив, я вошел в качестве нового пользователя и не обнаружил там ничего интересного — программа заводского супервизора для местных агентов, чтобы те могли заказывать товары по описи. Для входа я использовал вымышленные имя и адрес: Roger Eichner, 13 Stem Court, North Coast, WA 64203. Система дала мне пароль oroghner24. Я был изумлен! Ведь программа явно попросту взяла первые три буквы моего имени, последние четыре буквы фамилии и добавила в конце номер! Но так ли это? Я загрузился еще раз, как новый пользователь под другим именем. На этот раз видимой взаимосвязи между паролем и именем, казалось, не было. Теперь я уже не просто изумился, но и смутился! Неужели тот, первый, пароль был просто случайностью? А второй? Может быть, это так запрограммировано, чтобы в качестве паролей только иногда использовались части имени пользователя? ^ Тогда я вошел в третий раз, и опять как новый пользователь. И снова пароль никак не был связан с именем, которое я ввел. Теперь я уже почти окончательно убедил себя в том, что первый пароль был всего лишь невероятным совпадением. Я послал системному оператору сообщение, чтобы тот уничтожил бюджеты тех трех новых пользователей (приложив к посланию их имена с адресами, чтобы он не подумал, что я шучу), и больше не входил в эту систему в течение нескольких недель. Несмотря на то, что последние два пароля никак не были связаны ни с введенными мной личными данными, ни друг с другом, я думал, что, возможно, я что-то пропустил в тот первый раз, и некоторые символы одного пароля повторились в следующем. Могли ли эти символы иметь отношение к скорости передачи моей информации в бодах, к типу компьютера, или какому-то другому параметру, который оставался бы неизменным от одной загрузки к другой? А не могла ли случайность паролей заключаться в том, какие данные программа избирала для создания паролей? В первом случае эти данные были взяты из моего имени, и один из элементов (связь которого с моими данными я не смог распознать) повторился в третьем пароле. Я вновь вошел в систему под тем же именем, адресом, с теми же терминальными характеристиками и т. д., что и в первый раз. К своему огорчению, я получил не созданный компьютером пароль, а следующее сообщение: “Уважаемый пользователь. Мы сожалеем, что вам придется пройти через это еще раз, но за последние несколько дней у нас возникли некоторые проблемы. Я вынужден просить вас удовольствоваться предоставленным вам низким уровнем доступа до тех пор, пока у меня не появится возможность предоставить вам ваши права в полном объеме. Прошу обратить внимание на следующее: в ответ на запрос системы о пароле не вводите тот же самый пароль, который был введен раньше. Создайте новый пароль, полностью отличный от предыдущего. В случае возникновения затруднений обращайтесь за разъяснениями к системному администратору.

StRaPmAsTeR = = = wl1 LIE = = => (системный оператор).

Введите пароль = =>?”

“Разъяснение” гласило, что некий (относительно недавний) пользователь сей BBS, чей псевдоним был Мистер Шутник, ввел в действие “свойство” программного обеспечения данной BBS, создававшее несекретные пароли. В предыдущем году система “вышла из строя, что явилось результатом действий мистера Шутника”. Причина или вид поломки подробно не описывались, вероятно, потому, что постоянные пользователи системы уже и так знали эту историю. Как бы то ни было, теперь вы понимаете, каким образом можно получить неплохую информацию, изучая “случайные” пароли. Даже если на первый взгляд вы не можете найти ни одного осмысленного набора символов, это не означает, что его нет вообще. Может присутствовать лишь намек на такой набор, или хотя бы ошибка или странность, которую вам удастся обнаружить.

Например, в первой версии одной программы BBS — настолько жуткой, что через месяц полетела клавиатура — генератор случайных паролей никогда не создавал пароли, в которых присутствовала бы буква А или цифра 0. Знание этой особенности может оказать некоторую услугу: для семизначного пароля типа WXYZ123, где WXYZ — строчные либо прописные буквы, а 123 — цифры, существует только 284,765,630 возможных комбинаций букв и цифр, вместо 456,976,000 — разница в 172,210,630 паролей! Программное обеспечение кишмя кишело ошибками, многие из которых прославились как наихудшие ошибки за всю историю программирования.

неслучайные пароли, генерируемые машиной

Под конец давайте обсудим неслучайные машинные пароли. Пользователи часто подключаются к системе еще до окончания оформления регистрации, пользуясь временным паролем. Временный пароль может представлять собой какую-то уже известную пользователю информацию, например, номер карточки социального страхования, дату рождения, либо другие личные данные. Предполагается, что потом пользователи заменяют такие мало секретные пароли на более безопасные, но пока им специально не покажут, как это делается, или не посоветуют так поступить, пользователи вряд ли произведут замену.

Вот один некомпьютерный пример, наглядно демонстрирующий эту человеческую слабость. В апреле 1992 года студенты университета в Нью-Ажерси получили послание с информацией о новом классе регистрационных процедур. В послании утверждалось, что код персонального доступа (Personal Access Code — РАС), предназначенный для подтверждения личной регистрации, состоит из первых четырех цифр даты рождения данного человека (месяц и день), вводимых вместе с девятой цифрой студенческого номера (а по необходимости — номера Социальной безопасности). В первую очередь меня поразил тот факт, что они сообщили студентам, что их сверхсекретный РАС на самом деле — их день рождения. Такое сообщение сводит на нет все меры по безопасности, которые они пытаются внедрить. Действительно, неужели так уж трудно узнать чью-то дату рождения? Но РАС является только частью пароля, а другая часть — студенческий ID. Узнать чей-то ID — проще простого. ID можно легально, или почти легально, узнать в студенческих оздоровительных центрах, прочесть на досках объявлений в компьютерных залах, в идентификационных картах, в списках имеющих право на общежитие — да где угодно! Послание также гласило, что те, кого беспокоит проблема безопасности, могут подойти в регистрационный офис, чтобы изменить свой РАС. Как вы понимаете, никому и в голову не придет куда-то тащиться и что-то менять, коли можно обойтись и без этого. К тому же, замена первых четырех цифр вряд ли сможет отпугнуть опытного хакера. Чтобы отследить изменение пароля, потребуется 10 000 минус одна попыток. Не говоря уже о тех 366 возможных паролях, которые можно перебрать до того, как эта “озабоченная безопасностью” личность сменит свой код. Десять тысяч чисел — это, разумеется, немало, но перебрать их все вполне возможно. Автоматический номеронабиратель способен проделать это примерно за семь минут, если количество попыток ввода кодов на один звонок будет неограниченным. В любом случае, я привел эту историю для того, чтобы проиллюстрировать одну истину: пользователь и пальцем не пошевелит, чтобы изменить коды доступа, если его не заставить.

И, даже если они это сделают, мало что изменится. На что же тогда мы, хакеры? Давайте теперь вернемся к нашему разговору о неслучайных паролях, которые генерирует компьютер; вернее, о тех, которые устанавливает программист или администратор, выбирая их из компьютерных файлов данных.

Компьютер выбирает пароли каждый раз, когда требуется ввести большое количество паролей сразу. В течение первой недели семестра в колледже для студентов, занимающихся в компьютерных классах, создаются тысячи входов. По большей части эти входы-бюджеты устанавливаются с пользовательским именем, соответствующим усеченной или уменьшительной форме настоящего имени пользователя, а пароли представляют собой либо номер карточки социального страхования (НКСС), либо студенческий ID. Итак, если вы решили подвергнуть взлому компьютерную систему колледжа, приступайте к делу в самом начале семестра — пока пользователи не заменили свои пароли на более секретные. НКСС можно отгадать методом прямого перебора.

НКСС (или другие идентификационные номера) также можно получить социальными методами (см. главу о социальной инженерии), или с помощью других хитростей. Я присутствовал на уроке в одном колледже, когда инструктор раздал всем листки бумаги, попросив студентов написать на них свое имя и идентификационный номер. Затем листочки передавались ассистенту преподавателя, который вводил информацию в компьютер, создавая входы-бюджеты в системе. Если вам случится попасть на подобный урок, постарайтесь сесть на заднюю парту, чтобы никто не мог заметить, как вы копируете личные данные других людей. Имена и НКСС нетрудно увидеть в списках посещающих занятия, в классных расписаниях; они обычно содержат сведения об имени и НКСС каждого учащегося. Если расписание не висит на видном месте, это не означает, что его нет. Придумайте какой-либо способ хотя бы мельком взглянуть на него. Например, скажите, что в прошлый раз ваше имя неправильно записали и вы хотите проверить, исправлено ли оно. Профессора обожают рассуждать о промахах образовательной бюрократической системы. Сыграйте на этой слабости!

После нескольких шумных судебных разбирательств был сделан вывод, что указание номера социальной безопасности в совокупности с именем человека в общедоступных средствах неконституционно, так как является вторжением в частную жизнь. С тех пор НКСС все реже и реже используются для идентификации, уступая место устанавливающемуся организациями ID. В этом случае приходится больше полагаться на метод перебора, чтобы получить доступ к массиву личных идентификационных номеров.

Предварительные пользовательские пароли не всегда представляют собой идентификационные номера. Если между администратором системы и пользователем установлена какая-либо иная связь, кроме компьютерной, в качестве временных паролей могут быть назначены другие слова (они изменяются при подсоединении пользователя к системе). Возможен общий пароль для новых пользователей, который дается всем бюджетам и который обычно нетрудно взломать. Но пароль может оказаться также весьма трудным для отгадывания и безопасным — вроде длинной строки случайных символов. Иногда приходится перехватывать электронную почту нового пользователя в поисках конверта с присвоенным этому пользователю паролем. программы - тоже люди

Иногда на компьютерных системах устанавливаются программы, имеющие свои собственные пользовательские имена и пароли, точно такие же, как и у любого другого пользователя системы. Если вы входите в систему под именем этой программы, программа начинает выполняться. Эти программы могут представлять собой руководства по сетям, информационные системы, базы данных, системы сообщений или какие-либо программные приложения. Некоторые системы имеют также входы с простыми командами в качестве пользовательского имени, такими как “time”, “date” или “who” (эта команда сообщает о том, кто загрузился в систему). Это позволяет людям выполнять некоторые часто использующиеся функции, минуя хлопотный процесс входа в защищенную систему. Зачастую эти командные входы вообще не имеют паролей, что кажется идиотизмом, поскольку некоторым из них даны права доступа суперпользователя. Не исключено, что вам удастся войти в одну из этих программ-пользователей с помощью комбинации имя, пароль, состоящей из следующих слов:

guest, demo, help, info, tutorial, tut, menu, data, base, intro, anonymous, database, visit, welcome, hello.

Так, например, “visit” или “visitor” может быть именем пользователя, a “tut” — паролем. Существует также возможность входа под именами “calendar”, “cal”, “sched”, “schedule”, “who.is”, “ftp”, “who”, “Ipq”, “archiv” и другими схожими именами команд. На многие системы устанавливаются программы общего пользования или даже общедоступные. Доступ

можно получить, загрузившись под именем “info”, как предложено выше, или другими способами.

Вымышленный университет Вакка Ду может предложить войти в команду под именами: “wdu”, “wdu info”, “chellowdo”, “wdunews”, “wdumail”, “wel-comewdu”, или какой-то иной вариацией аббревиатуры университета.

Если вы избрали этот путь, вас прежде всего следует поздравить с успешным взломом; но что дальше? Если вы заинтересованы в получении более высокого уровня доступа или в выходе из программы, вас ожидает множество трудностей. В следующем разделе предлагаются способы загрузки в обход рамок того или иного уровня доступа.

методы перебора

Они обычно задают немало работы вашему компьютеру. Они просты, но занимают много времени, и заключаются во введении одного пароля за другим до тех пор, пока наконец, может быть, один из них не сработает, к вашему счастью. Или до тех пор, пока у вас не лопнет терпение, и вы не обратите свои взоры к лучшим методам.

К методам перебора хакер обычно прибегает в начале и в конце своих попыток взломать систему. В первый раз он делает это, наполовину подчиняясь велению чувства. Как хорошо было бы угадать пароль сразу же, или хотя бы после семидесяти пяти или ста попыток! В случае неудачи хакер некоторое время использует другие, более изощренные способы. Если же ни один из них ни к чему не приводит, он вновь возвращается к перебору, стремясь достичь цели. В конце концов метол перебора обязательно срабатывает. Слово “обязательно” как раз и притягивает хакеров, а уточнение “в конце концов” сводит их с ума.

Эти методы требуют очень много времени, и почти ничего больше. Время уходит на исследования, испытания и ошибки, а также написание специальных программ для “бомбардировки” системы паролями.

Метод перебора — не самый элегантный способ взлома, но так как в конце концов он все же себя оправдывает, каждый хакер рано или поздно прибегает к нему в той или иной ситуации. Вы можете оказаться в такой ситуации, когда вам ничего не известно о пользователях конкретной системы; обычные имена и пароли не срабатывают, а уловки не действуют. В таких случаях вам придется прибегнуть к самому “лобовому” приему: написанию небольшой программки, которая станет периодически вступать в диалог с компьютерной системой и вводить новую комбинацию имя, пароль, до тех пор, пока какая-либо комбинация не сработает. Это может продолжаться бесконечно.

Некоторые хакеры используют словарный файл из своих текстовых процессоров или с информационных панелей. Идея неплоха, но только при правильном использовании. Следует отредактировать словарный файл так, чтобы тот включал в себя общеупотребительные названия, имена, все буквы алфавита, имена музыкантов и президентов, марки машин, числа, псевдонимы знаменитостей и тому подобный материал для наиболее употребительных паролей. Избавьтесь от слов вроде “perspectives” (“перспективы”)— они слишком вычурны для пароля. Если вы хотите ускорить процесс своей работы, придерживайтесь тех же принципов и в отношении числовых паролей. Если вы живете в Нью-Йорке, следует начать свою атаку с нью-йоркских НКСС.

Существует много способов сократить число потенциальных паролей, которые вам необходимо проверить. Военные используют автоматическую систему TACACS для проверки законности пользования компьютерами их сети. Коды доступа TACACS выглядят как строки, состоящие из буквенно-цифровых символов — но эти строки никогда не содержат цифр О и 1, а также букв Q и Z. Основой для такого решения послужила теория о том, что когда пользователь читает свой код доступа на кодовой карте, он легко может спутать единицы, нули, Q и Z с другими цифрами и буквами.

Когда вы отредактируете свой словарь, оставив в нем только те пароли, которые кажутся вам наиболее подходящими, или определите, какие коды наиболее вероятны в данном случае, напишите маленькую программу на любом известном вам языке, чтобы та вступала в диалог с модемом, и раз по разу вводила слова, одно за другим, делая все новые и новые попытки. И еще. И еще... Такую программу нетрудно написать, но если у вас нет подобного опыта, вы можете найти множество похожих программ на BBS.

Вот что следует учитывать при написании программы. Сколько раз компьютерная система позволит вам вводить неверное имя, пароль, пока не отсоединит вас? Три? Восемь? Если она даст вам всего лишь три попытки, а потом распрощается, убедитесь, что ваша программа выдала именно три комбинации имя, пароль, прежде чем снова набрать номер. Дистанционные компьютеры часто принимают введенные символы еще до того, как на экране появляется приглашение. Если так происходит с системой, в которую вы пытаетесь проникнуть, вам необходимо вставить в вашу программу цикл задержки, дабы быть уверенным в том, что пароли не будут введены до того, как на экране возникнет курсор.

Что же произойдет, когда ваша программа наконец сумеет отыскать подходящие имя и пароль? Когда программа работает, а вы сидите за компьютером, глядя на экран, вам надо как-то узнать о том, что метод грубой силы сработал. Иначе ваша программа продолжит выдавать пароли, а системные операторы, которые теперь уже почти наверняка заметили, что происходит, просто придут в ярость! Программа должна выдавать вам на экран приходящий из удаленного компьютера текст. Как только будет получено что-то дополнительное, кроме приглашений о вводе имени, пароля, пусть программа выведет эти данные на экран и подаст звуковой сигнал. Можно сделать и так, что программа введет команду выхода и выведет на экран найденную комбинацию, чтобы, проснувшись утром, вы сразу же увидели ее.

Если вам известно, что некий Joe User (абстрактный пользователь) работает на компанию X, можно создать программу для проверки всех комбинаций паролей с пользовательскими именами Joe, User, JUser и Joe User, исключив такие варианты как joe, JOE и joeuse. (Из ваших экспериментов и исследований вы будете иметь какое-то представление о том, какого формата должно быть имя данного пользователя, так что вам не придется перебирать слишком много вариантов). С другой стороны, если вы не знаете имени и фамилии ни одного из сотрудников компании, вам придется либо узнавать их (т. е. просматривать каталоги компании, ежегодные отчеты, газетные статьи, задавать вопросы по телефону, и т. д., и т. п.), либо подвергнуть проверке каждую комбинацию возможных имен. Если вам придется перебирать все имена, не забудьте о женских и иностранных именах. Можно прогуляться в библиотеку, чтобы выяснить, какие имена и фамилии наиболее популярны. Но не забудьте, что вам нужны не современные популярные имена, а те, что были популярными и распространенными двадцать-тридцать лет назад, когда родители давали их теперешним сотрудникам интересующей вас компании.

Разумеется, для проверки возможных паролей не обязательно писать специальную программу. Если у вас есть в запасе время и терпение, вы можете просто сесть за компьютер и сами вводить имена. Но учтите — это займет куда больше времени, чем нужно компьютеру для взлома с помощью метода перебора.

Должен заметить следующее: независимо от того, насколько тщательно вы подготовились, всегда проходит невероятно много времени, прежде чем метод перебора сработает. Поэтому ввод паролей следует ускорить, насколько возможно. Если вам приходится после каждых трех попыток заново устанавливать автоматическую связь с модемом, сначала убедитесь, что данная телефонная линия не обладает возможностями “Touch Tone”.

И еще: прежде чем приступать к атаке с помощью грубой силы, обзаведитесь модемом с самой высокой скоростью передачи, какой вам только удастся найти, даже если для этого придется одолжить его у друзей. Разница всего в несколько бодов значительно увеличивает скорость передачи. отражение атаки

Однажды, когда я был еще подростком, мы всей семьей отправились ужинать в ресторанчик “Попробуйте все”. На самом деле я решил принять участие в походе, чтобы выяснить, сколько же я смогу съесть, но к третьему заказу нас начали утомлять удлиняющиеся периоды ожидания при неуклонно уменьшающихся порциях. Мой отец объяснил это следующим образом:

“Видишь ли, они делают так, чтобы ты не смог съесть слишком много. Ждать еды приходится все дольше и дольше, а самой еды становится все меньше и меньше.” Не знаю, прав ли он был, но немного погодя мы и вправду решили, что не стоит ждать сорок минут, чтобы получить еще одну тарелку с едой.

Для отражения силовых атак специалисты используют тот же самый принцип, что и вышеупомянутый ресторан. Как я уже говорил, при достаточной настойчивости угадать легальную комбинацию имя-пароль, или открыть ее случайно — всего лишь дело времени. Отсюда следует, что предотвратить успешное завершение такой атаки можно, построив системные приглашения так, чтобы хакер устал и бросил свое дело, не доведя его до конца.

Наиболее распространенный способ зашиты — прерывание связи после нескольких неудачных попыток пользователя войти в систему. После этого компьютер может не давать разрешения на повторную связь в течение определенного промежутка времени. Недостаток этого способа в том, что он может причинить неудобство легальным пользователям — хотя уж лучше подождать несколько минут, чем войти в систему и обнаружить, что твои файлы испортил какой-то кракер.

Впервые услышав о социальной инженерии, большинство людей бывают слегка шокированы. Во всяком случае, я был шокирован. При слове “хакер” люди обычно представляют себе страждущего очкарика, который упорно и неустанно просиживает ночами за своим компьютером, в надежде наконец-то найти то самое единственное слово, которое откроет перед ним все технические секреты вселенной. Именно так и обстояли дела в недавнем прошлом, но потом это стало непрактичным. Конечно, грубые методы, вроде метода угадывания паролей путем перебора, представляют собой определенную ценность — ведь они являются основной частью арсенала любого хорошо экипированного хакера. Но пароль можно получить и другими путями; например, с помощью социальной инженерии.

“Социальная инженерия” — это попытка выведать у легального пользователя системы информацию, необходимую для прохождения защитного барьера данной системы. Этот метод еще называют “заболтать оператора”. Социальная инженерия (СИ) может принимать различные формы и обличья. Здесь я приведу некоторые из них. Как вам вскоре станет ясно, для каждого способа существует уйма хитрых уловок и приемов. Некоторые приемы я подвергну рассмотрению, остальные можете додумывать самостоятельно.

благородный метод

Хакеры, которым совесть не позволяет вызнавать пароли с помощью хитростей, все же могут безболезненно прибегать к одному из методов социальной инженерии — вежливо просить: “Ну, пожалуйста...” Лично до меня ни разу не доходила достоверная информация о том, что этот метод сработал, хотя поговаривают о хакерах, которым якобы удавалось узнать пароли, просто попросив об этом системных пользователей. По слухам, в подобных случаях системный оператор обычно получает по телефону или по электронной почте сообщение типа: “Я — хакер. Дайте мне пароль для нижнего уровня доступа, и я постараюсь использовать все свое мастерство, чтобы указать вам на недостатки вашей системы. Тогда вы сможете их исправить и уже не бояться злоумышленников - кракеров”.

Другая разновидность этого метода — позвонить кому-нибудь (кому угодно, хотя бы той же секретарше в офисе), и просто спросить:

— Ой, а что вы набираете по утрам на компьютере, прежде чем приступить к работе?

Может ли это сработать? Что ж, вам потребуется определенная доля везения, чтобы напасть на такого (или такую), кто сыт по горло собственной работой и не особо осведомлен насчет правил безопасности. Минусы этого приема заключаются в том, что обман не всегда удается, а неудача может в дальнейшем осложнить вашу задачу. Лучше призвать на помощь свою актерскую жилку и попробовать разыграть по телефону роль кретина.

хакер в роли неофита

В данном случае вы играете роль нового пользователя. Допустим, вы пытаетесь проникнуть в компьютерную систему какой-либо компании. На часах 8.55 утра. Вы звоните в их компьютерный отдел (из дома, или откуда-нибудь еще) и беседуете с неким сотрудником, представившись ему новым пользователем из другого отдела той же компании.

ЧЕЛОВЕК НА ДРУГОМ KOHЦE ПРОВОДА: Хэлло;

компьютерный отдел, Ажек Чиппер у телефона.

ВЫ: Хэлло, Ажек, это Гари Харрис из отдела исследований. Не могли бы вы помочь мне с одной проблемой?

ДЖЕК: Не исключено... А в чем дело?

ВЫ: Ну, я здесь пока один, и никак не могу начать работу. Может, подскажете, что надо сделать?

ДЖЕК: Разумеется. Компьютер перед вами? ВЫ: Да.

ДЖЕК: 0'кей. Включите красный тумблер на полу. Видите его?

ВЫ: Аа, о'кей. Я вижу... 0'кей.

ДЖЕК: На загрузку уйдет несколько минут.

ВЫ: На что?

ДЖЕК: Ну, на загрузку. Я имею в виду, через одну-две минуты компьютер будет готов к работе.

ВЫ: Остановилось. ДЖЕК: Что вы видите?

ВЫ: То же, что и всегда. Он и раньше все время доходил до этого места, а потом переставал работать. Что мне делать дальше?

ДЖЕК: А что вы обычно набираете?

ВЫ: Не знаю. Я здесь первый день, к тому же временно. Мне сказали, что кто-нибудь все мне объяснит!

ДЖЕК: Хорошо. Нажмите на “ВВОД”. ВЫ: “ВВОД”... Хорошо... Есть. ДЖЕК: Теперь наберите “TEMP”, пробел, “PUPPY” ВЫ: Хорошо... Ну, вот! ДЖЕК: Получилось?

ВЫ: Спасибо, Джек! И почему это у меня раньше не выходило!

Теперь давайте коротко обсудим вышеприведенный разговор. Приветствуйте своего собеседника в тех же выражениях, что употребил он сам. Это делается для того, чтобы компьютерщику было удобнее разговаривать с вами, а также, чтобы он понял, что вы не боитесь открыто сказать ему (или ей), как вас зовут и какую работу выполняете в компании. Если собеседник представится вам имяреком из компьютерного отдела, сообщите ему, что вы — из исследовательского отдела. Если у вас нет справочника компании, с которым можно свериться, вы не можете точно знать, какой термин употребляют сотрудники для названия своих отделений. Таким образом, лучше всего копировать термины того, кто находится на другом конце провода. Даже если вы сами скорее употребили бы термин “подразделение” вместо “отдел”, тот факт, что вы говорите на языке компании, заставит сотрудника компании отнестись к вам как к себе подобному. Просьба о помощи в том, что касается компьютеров, пробуждает в техниках чувство компьютерного благодушия. Добавьте также, что вам очень любопытно, что же могло случиться с его, компьютерщика, подопечной системой. Выражение “не могли бы вы” вызовет в нем некоторое раздражение — неужели вам неизвестно, как круто он умеет обращаться с компьютерами. Да он просто наизнанку вывернется, лишь бы показать вам все, на что он способен. Грамотным пользователям нравится демонстрировать свое умение (так же, как и вам, не так ли?), особенно техникам, чья работа как раз и заключается в том, чтобы помогать неосведомленным нормально работать. Не забудьте употребить слово “проблема”. Компьютерщики обожают решать проблемы. Стоит намекнуть, что проблемы возникли именно с его системой, и такой тип просто ума лишится: только успевай записывать пароли, которые из него посыпаются!

Помните, в начале я упомянул о времени разговора — 8.55? Не всегда удается позвонить до начала рабочего дня, но имеет смысл постараться сделать именно так. Это даст вам вескую причину для обращения к технику:

ведь вы могли прийти на работу первым, и вам не у кого больше спросить. Но техники редко приходят на работу раньше всех, и такая уловка не всегда срабатывает. Следовательно, вы можете позвонить в конце рабочего дня. Тогда можно сказать, что все остальные в офисе уже выключили свои компьютеры и отправились по домам, а вот вы никак не можете закончить работу. Когда вы уже заставили собеседника почувствовать себя суперменом, можете смело приступать к сути проблемы, соблюдая все же определенную осторожность, дабы ваши неловкие замечания насчет процедур ввода не спугнули жертву. Ведь когда вы устанавливаете связь с компьютерной системой из дома, все происходит совсем не так, как если бы вы обращались непосредственно к системе. Лучше всего избегать основных вопросов, обрисовав собеседнику суть возникших у вас затруднений. Вопрос “Не могли бы вы объяснить мне, в чем дело” относится к тому, что техник автоматически проделывает каждый день. Вместе с тем, важно попросить собеседника сделать что-то специфическое (например, попросить его рассказать о процедурах установки?), но не настолько специфическое, чтобы оказаться в его глазах подозрительно осведомленным. К примеру, если вы скажете просто: “Не могли бы вы мне помочь?”, он может решить заглянуть в ваш офис, чтобы выручить вас. Так как на самом деле в офисе вас нет, ваш собеседник, само собой, выйдет из игры — к вашему огорчению. Вы должны мысленно представлять себе все те действия, которые вас попросят проделать, поскольку в офисе вас нет. Неплохо иметь под рукой настоящий компьютер, чтобы ваш собеседник (или собеседница) могли услышать, как вы включаете его и что-то набираете на клавиатуре.

ДЖЕК: На загрузку уйдет несколько минут. ВЫ: На что?

Ваш вопрос показывает вашу полную безграмотность в отношении компьютеров. Но не следует перегибать палку, пытаясь доказать, что последние тридцать лет вы провели в пещере. Вопрос вроде “А что такое клавиатура?” может вызвать недоверие, но никак не сочувствие к вашей наивности. Не забудьте, что вы ведете беседу с определенной целью — выведать у собеседника информацию, поэтому постарайтесь не упустить нужный момент. Фраза “Остановилось” поколеблет уверенность техника в нормальной работе компьютера. Но прежде всего это поможет вам контролировать беседу, подводя ее к логическому завершению.

ДЖЕК: А что вы обычно набираете?

На этот вопрос можно дать ответ “Набираю свой пароль...”, но так недолго и ошибиться. Что, если компьютер, о котором идет речь, подключен только к локальной сети, и защищен не через пароль, а как-то по-другому? Вдруг речь идет всего лишь о приглашении DOS? В таком случае полезно изобразить из себя новичка. Обычно это неплохо срабатывает, разве что всем известно, что компания проводит массовые увольнения сотрудников или близка к банкротству.

Сообщение, что вы работаете временно, может пойти вам на пользу, а может и нет. Временные сотрудники обычно встречаются с местным супервизором, которому сдают отчеты и задают вопросы. Впрочем, техник может об этом и не знать; в любом случае, нетрудно сказать, что супервизор посоветовал вам обращаться за разъяснениями в компьютерный отдел.

ДЖЕК: Хорошо. Нажмите на “ВВОД.

ВЫ: “ВВОД”... Хорошо... Есть.

ДЖЕК: Теперь наберите “TEMP”, пробел, “PUPPY”

ВЫ: Хорошо... Ну, вот!

Ваше “Хорошо” показывает, что вы уже миллион раз проделывали то же самое, но все зря.

Горячо поблагодарите техника за помощь, еще раз дайте ему убедиться в том, что вы хотя и новичок, но все же полноправный сотрудник компании (сказав, что вы не знаете, почему у вас ничего не получалось).

Я привел этот пример, основываясь на сотнях разговоров, которые ведут с компьютерщиками настоящие пользователи, сталкиваясь с подобными проблемами. Меня самого пользователи не раз спрашивали, как произвести какие-то действия, никак не получавшиеся у них самих. Обычно все налаживается после перезагрузки. Как правило, после этого пользователь брюзжит: “Но я же делал то же самое! И ничего не работало!” Не говорите так с вашим техником, дабы не оставить о себе дурного впечатления — этот человек может вам еще пригодиться.

Вот еще один пример того, как хакер может сыграть роль полного простофили в области компьютеров, получив при этом нужную информацию. Когда в офисе инсталлируется новая компьютерная система, рядом с терминалами часто приклеивают телефонные номера технического отдела компании, чтобы пользователи могли связаться с техническим отделом компании и посоветоваться об обнаруженных недоделках в системе. Карточка (или просто бумажка с телефонным номером) может также быть приклеена к стене, специально отведенной для важных сообщений, или спрятана за столом клерка либо под его стойкой. Постарайтесь вывернуть шею и прочесть, что там написано (или попросите кого-нибудь, не обязательно же делать все тайком!).

Допустим, занимаясь неким отделом страховой компании, вы решили позвонить некоему компьютерщику Фрэнку Смиту. Наберите номер и произнесите следующее: “Привет, это Лорин из страховой компании (...) .У нас тут начала твориться какая-то ерунда с компьютерами, мне пришлось их выключить, и теперь я не знаю, что делать...”. И вам все расскажут.

хождение во власть

Если у вас не та ситуация, чтобы заставить техника почувствовать себя Господом Богом, возможно, настало время вам самим превращаться в божество. В военных структурах, разыграв роль офицера высокого ранга, можно вселить страх в сердце любого из тех, кто рангом пониже. Наберите номер и сообщите, что вы либо сам генерал, либо его личный секретарь. Вы оба (генерал и секретарь, или наоборот) просто вне себя от ярости, оттого что ваш компьютер не работает как следует. Вам необходимо знать, почему в компьютере отсутствует ваш пароль и бюджет. Не следует жаловаться или что-то объяснять — просто гневно настаивайте. И результаты не заставят себя ждать. В компании иногда полезно представиться генеральным директором или президентом, либо секретарем одного из вышеозначенных лиц, особенно если глава данной организации славится своим вспыльчивым характером. Никому не хочется, чтобы его уволили или понизили в должности. Гневный тон полезен потому, что человек, снявший трубку, сделает все, лишь бы только избавиться от вас. Впрочем, президентам, начальникам, военным чинам и т. д. необязательно гневаться. Просто сообщите имя того, за кого вы там себя захотите выдать, и вам поверят (кто же осмелится выдавать себя за генерала Такого-то?). Но если вы разыгрываете из себя большую шишку и при этом не гневаетесь, не забудьте произвести предварительные исследования, дабы знать, что представляет собой этот босс. Вот пример такого диалога:

ЧЕЛОВЕК НА ДРУГОМ KOHЦE ПРОВОДА: Добрый де...

ВЫ: “Говорит генерал Фроббс. Ваша бесцеремонность меня просто потрясает! Я отсутствовал в течение двух дней, а вернувшись, обнаружил, что меня нет в компьютере! Кто у вас отвечает за эти компьютеры? Что за наглость! Я настаиваю, чтобы мой бюджет был восстановлен! У меня там много важнейших документов!”

СОБЕСЕДНИК: А вы пробовали набрать “GROUP.1 ”, “SEC”? Это должно сработать.

ВЫ: К черту эти групповые коды! Верните мне мой личный бюджет! Что за наглость!

СОБЕСЕДНИК: К сожалению, я не смогу помочь вам с вашими личными кодами. Может быть, мне найти кого-нибудь, кто сумеет помочь вам?

Заметьте, в данном примере вам удается добыть комбинацию имя,пароль, которое дает вам хоть какое-то право доступа. Даже если ваш собеседник и не подумает искать генеральский пароль, у вас в руках уже есть доступ к системе, и не один, а несколько. Ведь если существует GROUP.1, то существует и GROUP.2, верно?

хакер в роли ПОМОЩНИКА

Этот вид разыгрывания роли подобен обратной социальной инженерии без диверсий. Вы делаете вид, что с компьютерами данной организации что-то случилось, а вы — техник, которого вызвали, чтобы устранить неполадку.

Допустим, вы хотите проникнуть в компьютеры, расположенные в офисе мэрии. Вы звоните секретарю мэра и сообщаете ей что-то вроде:

— Здравствуйте, это Джейк МакКоннел из отдела компьютерного обслуживания. Мы хотели бы знать, нет ли у вас проблем с компьютерной системой?

Естественно, хоть какие-то проблемы подобного рода у нее были — с компьютерами вечно возникают какие-то проблемы!

— Ну да! — отвечает секретарь. — Сначала случилось вот так, а потом — вот эдак...

— Именно! — говорите вы. — Вот это оно самое и есть! Вашей вины здесь нет — что-то произошло с компьютерами, и сейчас мы пытаемся установить причину неполадки. Когда вы включаете компьютер, что вы набираете на клавиатуре перед тем, как начать работу? Один из наших вчера пытался разобраться, что случилось, и решил, что, по-видимому, все дело именно в этом. Секретарь ничего не заподозрит — в конце концов, ведь вы же назвали свое имя. А если и нет, что плохого в том, что она скажет по телефону пароль?

Секретарь, равно как и любой другой малооплачиваемый, загруженный работой неквалифицированный пользователь, является слабым звеном в цепочке компьютерной безопасности. Секретари не разбираются в компьютерах, и разбираться в них не желают. Они знают лишь одно: что-то не так, а вы собираетесь навести порядок. Этот план весьма эффективен.

Часы пик

Не используйте данный план ранним утром, или в околообеденное время — в эти часы он может не сработать должным образом. Приступайте к нему тогда, когда рабочий день достигнет своей точки кипения.

Если вы можете свободно попасть туда, где расположены компьютеры с интересующей вас системой, — это может быть библиотека, стоматологический кабинет, банк или школа, — проведите некоторые исследования, чтобы выяснить, когда наступает наилучшее время для вашего звонка.

В одной из библиотек, куда я захаживал, каждый день около трех часов пополудни компьютерная система внезапно начинала работать вполовину обычной скорости. Это вело, в свою очередь, к значительным затруднениям в работе библиотекарей. Возможно, в три часа дня число пользователей достигало критического уровня, или же в это время информация была вынуждена идти по альтернативному маршруту к мэйнфрэйму, расположенному в колледже на другом конце города. И если бы я решил заняться социальной инженерией в библиотеке, я начал бы именно в это время, когда скапливалось большое количество проблем. Те посетители библиотеки, которые не знали об этой особенности местных компьютеров, звонили в компьютерный зал колледжа и спрашивали, что случилось. Как вы думаете, неужели им не было бы приятно в один прекрасный день получить звонок из “компьютерного зала” (т. е., от меня или от вас), и услышать предложение о помоши? Конечно же, они бы с радостью рассказали бы вам о своих процедурах входа, лишь бы компьютеры заработали быстрее!

Компьютеры обычно работают медленнее всего в середине рабочего дня, когда в сети находится наибольшее количество пользователей. Это особенно ощушается в университетах. Утром в систему загружается небольшое количество студентов и преподавателей, которые не отключаются в течение всего дня, независимо от того, работают они в системе, или нет. С другой стороны, многие системы начинают быстрее работать днем, так что предварительные исследования вам все-таки необходимы. Следует заранее знать о тенденциях к отклонениям скорости компьютеров там, где вы собираетесь заниматься социальной инженерией. Если' вам удастся обнаружить значительное отклонение скорости (как в той библиотеке), вы, естественно, захотите пустить в ход ваши способности в это самое время.

Это необязательно должны быть отклонения скорости компьютеров; если в определенный промежуток времени критически нарастает загруженность работой, уровень шума, число посетителей и т. п., такое время тоже хорошо подходит для социальной инженерии.

Чтобы обнаружить такие промежутки времени, посетите избранный вами офис несколько раз в течение дня, и посмотрите, когда сотрудники заняты больше всего. Если это библиотека, или туристическое агентство, сходите туда или сделайте несколько телефонных звонков. Спросите о чем-либо, и, если они испытывают некоторые затруднения при поиске нужной информации на компьютере, перезвоните туда уже как сотрудник компьютерного отдела.

Офисы обычно бывают перегружены после одного-двух нерабочих дней, так что имеет смысл начинать в понедельник. Но сотрудники не должны быть настолько заняты, чтобы вообще не отвечать на телефонные звонки.

Конечно, метод социальной инженерии годится для любой системы. Но бывает гораздо проще надуть юную кассиршу в банке, нежели администратора системы в местном колледже. Социальная инженерия с успехом использовалась для получения доступа к корпоративным сетям, научным, правительственным и другим системам. Это мощное оружие, но, прибегая к нему, надо быть хорошим актером.

дгугие советы

Если это возможно, вначале проведите исследования. Постарайтесь узнать как можно больше о часах пик и о том, какого рода проблемы возникают при использовании данной системы. Если вашей целью является, например, библиотека, разузнайте, кто из сотрудников совсем не разбирается в компьютерах. Попытайтесь поговорить с ними по телефону. Убедитесь в том, что вы верно называете себя — такой-то из компьютерного отдела (или подразделения, или сектора; используйте терминологию собеседника). Придумайте заурядное, часто встречающееся имя и такую же фамилию. Если вам не удастся получить входную информацию с первого раза, попытайтесь еще раз — в другое время, в другой день. Но не звоните два раза одному и тому же человеку.

Однажды мой друг, Билл, позвонил на фирму по распространению электронного оборудования и случайно услышал, как женщина, принимавшая его заказ, пожаловалась на то, что компьютеры отказали и ей приходится все делать от руки, в то время как в других частях здания все было в порядке. Повесив трубку, Билл тут же снова позвонил туда, попав к другому оператору. Представившись Биллом Робинсо-

ном из компьютерного отдела, он посоветовал оператору включить неработающие компьютеры и набрать на клавиатуре “всю ту ерунду, что вы обычно набираете после включения”. Биллу удалось выведать у нее всю необходимую информацию. Когда оператор закончила “загрузку” (безрезультатно, разумеется), Билл со вздохом произнес: “Ну что ж, дело хуже, чем я предполагал. Пойду еще покопаюсь. Спасибо за по-мошь.” Таким образом, Билл узнал, как войти в компьютерную систему “Shark Radio Supplies”, и вдобавок завел там знакомство, которое могло пригодиться ему при дальнейших исследованиях.

примеры СИТУАЦИЙ, ВОЗНИКАЮЩИХ ПРИ СОЦИАЛЬНОЙ инженерии

Занимаясь социальной инженерией, вы нередко будете попадать впросак, особенно вначале. Ведь вы будете разговаривать с секретарями и другими членами компании, которые отлично знакомы с реалиями своей “конторы” и вполне способны заметить обман. Вам станут задавать вопросы, на которые вам будет непросто ответить немедленно. Вот несколько примеров такого рода.

СЕКРЕТАРЬ В ПРИЕМНОЙ: Так вы Чарльз Грин? Но в нашем компьютерном отделе нет никакого Грина.

ВАШ ОТВЕТ: Я работаю здесь всего несколько дней.

СЕКРЕТАРЬ: Интересно, почему же это я не видела вашей фотографии на доске объявлений о найме новых сотрудников?

ВАШ ОТВЕТ: Вы правы. Она... как ее там... еще не успела приклеить мою фотографию. Может быть, после обеда...

СЕКРЕТАРЬ: То есть как это — она? Этим всегда занимается Джек.

ВАШ ОТВЕТ: Ах да, правильно, Джек!

СЕКРЕТАРЬ: Я ничем не смогу вам помочь, пока вы не сообщите ваш идентификационный код сотрудника.

ВАШ ОТВЕТ: О, у меня его нет. Я здесь временно. Заменяю сотрудницу, ушедшую в декретный отпуск.

СЕКРЕТАРЬ: Просто прочтите код на вашем идентификационном значке.

ВАШ ОТВЕТ: У меня еще нет значка... тут произошла какая-то путаница, и супервизор сказал, что я, наверное, получу его завтра. Вы же знаете, у них там вечно какая-то ерунда происхо...

СЕКРЕТАРЬ: Кто ваш супервизор?

ВАШ ОТВЕТ: N. Вы знаете что-нибудь о нем (о ней)? (Если вы провели предварительные исследования, вы должны знать ответ на этот вопрос. Если ответа вы не знаете, а компания большая, вы можете выдумать общеупотребительное имя или прибегнуть к старой уловке: “Хм... Кажется, на 'Ш'—Шиндлер? Шиффер?”)

А вот другая ситуация:

СЕКРЕТАРЬ: Но у меня нет компьютера!

ВАШ ОТВЕТ: Простите, я, должно быть, ошибся. Могу я поговорить с N.? (N. — имя босса).

Если вам удастся незаметно собрать новости и слухи, циркулирующие в компании, используйте данную информацию в беседе, если, конечно, собеседник настроен дружелюбно. Это еще один способ завоевать доверие.

ВЫ: Кстати, вы не знаете, нет ли у N. сына в Лиге малышей? У моего сына есть друг по имени...

Но не забудьте — такие вопросы лучше задавать до того, как вы начнете расспрашивать о процедурах входа.

РАЗНООБРАЗНЫЕ советы по социальной ИНЖЕНЕРИИ

Вот еще несколько советов для обеспечения успешных занятий социальной инженерией.

Обращайте внимание на то, как собеседник реагирует на ваши вопросы. Если вы разговариваете с секретарем, или другим сотрудником, занимающим одну из нижних ступеней на лестнице зарплаты, он (или она) может не захотеть болтать с вами о компьютерах, если его (или ее) контролируют, либо если звонки прослушиваются боссом.

Зайдите в какое-либо доступное вам место с подключенными терминалами, и взгляните на стену, туда, где терминал подключается к телефонному щитку. Найдите на щитке четыре цифры и спишите их (это четыре последних цифры телефонной линии, к которой подключен терминал). Остальные три цифры можно узнать по соответствующему каталогу. Затем в течение нескольких дней набирайте этот номер по несколько раз в день, дабы убедиться, что линия всегда занята. При занятиях социальной инженерией такие “взятые напрокат” телефонные номера следует держать под рукой, чтобы давать тем людям, которые захотят вам перезвонить. Как правило, это операторы систем, которые подозревают в вас хакера и хотят убедиться, что вы без опаски можете дать им информацию о себе. Давать такие номера лучше, чем выдумывать, поскольку если телефон будет просто занят, это даст людям хоть какую-то уверенность в вашей честности. Уже одно то, что вы даете им свой номер, может рассеять их подозрения.

Когда человек дает вам свой пароль, ему надо мягко возразить: “А вы уверены, что вы действительно используете именно это?” У секретарей может быть два пароля: один — их собственный, который дает им доступ к групповому бюджету нижнего уровня, а другой — пароль более высокого уровня, принадлежащий боссу (секретарь знает этот пароль, так как секретари действительно знают об организации все). Разоблачающим тоном расспрашивая кого-либо о сообщенном вам пароле, вы можете заставить человека пойти на попятную, если он решил дать вам неверный пароль, и таким образом от вас отделаться. У него создастся впечатление, что вы и так знаете верный пароль, и хотите уличить его во лжи. Если при упоминании пароля более высокого уровня собеседник приходит в замешательство, скажите: “Неужели вам до сих пор не повысили уровень доступа? Только что куплена новая система, которая может работать в пятьдесят раз быстрее. Все ее так хвалят...”. Затем быстро перемените тему разговора.

Прежде чем сделать звонок, обзаведитесь соответствующей звуковой дорожкой, которая будет звучать на заднем плане. Перед этим наведайтесь в компанию и запишите их обычный рабочий звуковой фон. Дайте прослушать пленку по телефону своему другу, и сами тоже прослушайте ее по телефону, чтобы определить нужную громкость звучания. Но помните, что если вы решили сыграть “нового пользователя, пришедшего на работу раньше всех”, пленка с записью болтовни и печатающего принтера вам не пригодится!

Беседуя с людьми, даже по телефону, старайтесь все время улыбаться; ведите разговор дружелюбно и непринужденно. Если собеседник снимает трубку со словами вроде: “Здравствуйте, это корпорация ..., Лу-лу у телефона”, скажите: “Привет, Лулу! Это...”, и начинайте вашу проникновенную речь. Теперь Лулу будет тщетно вспоминать, не встречались ли вы раньше, и, если вы продолжите беседу с ней в том же духе, она потихоньку начнет воспринимать вас как друга.

Можно почерпнуть какие-то идеи из пособий по подражению голосам. Линия, по которой поступил ваш звонок, тоже может повлиять на ваш успех. Во многих компаниях телефон сортирует звонки на внешние и внутренние. Если вы притворяетесь, будто звоните по внутренней линии, ваш звонок должен отразить это. Позвоните в другой отдел той же компании, скажите им, что ошиблись номером, и попросите соединить вас с нужным вам отделом. Например:

СОБЕСЕДНИК: Отдел рекламы. Чем могу быть полезен?

ВЫ: Извините, я, кажется, неверно набрал номер. Не могли бы вы соединить меня с 4358?

Теперь ваш звонок автоматически становится внутренним, а у вас появляется какой-никакой авторитет (а может быть, на телефоне даже зажигается специальный внутренний сигнал). Еще один способ смоделировать внутренний телефонный звонок — набрать не тот номер, что указан в каталоге, а другой, отличающийся от указанного на одну цифру. Почти любая организация с собственной телефонной линией обычно располагает блоком телефонных номеров. Так, если в каталоге указан номер 123-4567, попытайтесь набрать 123-4568, и т. д. Такие звонки, если они проходят, могут создать впечатление, что звонит кто-то из своих — посторонний набрал бы номер из каталога.

Следует учесть, что, если вы пытаетесь добраться до одного из начальников корпорации, вы можете так и не пройти дальше его секретарей и других подчиненных. Неплохо бывает позвонить в офис того же или более высокого уровня, что избранный вами, и попросить секретаря соединить вас с искомым. К примеру, я собираюсь опробовать свои методы социальной инженерии на мистере Палука — менеджере среднего уровня, занимающегося обувным отделом. Но мне никак не удается поговорить с ним лично. Тогда я звоню мистеру Колту, менеджеру того же или более высокого уровня, и прошу его секретаря соединить меня с мистером Колтом лично. Секретарь спрашивает, по какому поводу я хотел бы поговорить с Колтом, и я отвечаю: “Обувь!” Но мистер Колт занимается не обувью, а резинками для трусов. Поэтому секретарь отвечает: “Об этом вам следует поговорить с мистером Палука; соединить вас с ним?” И она передаст ваш звонок секретарю мистера Палука, которому вы скажете: “Здравствуйте. Это такой-то. В офисе мистера Колта посоветовали мне поговорить с мистером Палука насчет обуви.” Это уже рекомендация, исходящая от другого сотрудника компании. Теперь вам станет проще добраться до мистера Палука.

другие Роли

Основной частью социальной инженерии является получение групповых или личных паролей путем разыгрывания роли по придуманному вами сценарию в надежде на то, что ваш собеседник подыграет вам. Но целью социальной инженерии необязательно являются пароли, и переговоры могут вестись не по телефону, а лично, либо по электронной почте. Личные переговоры требуют сильных нервов и незаурядного актерского мастерства, электронная почта больше подходит для тех, кто испытывает трудности с СИ (социальной инженерией) по телефону.

непосредственная инженерия

Любое исполнение какой-либо роли является формой социальной инженерии. Это может быть перевоплощение во вполне конкретную личность (например, президента компании, который желает знать, почему не работает его пароль), или же абстрактную (техник имярек, который звонит, чтобы узнать, не возникло ли каких-нибудь проблем с компьютерами). При этом, как правило, используется телефон — во-первых, потому, что он дает возможность хакеру вести переговоры с удаленными пунктами, не выходя из дома, а во-вторых, телефон создает защитный барьер между хакером и его собеседником. Если беседа идет не так, как планировалось, можно повесить трубку; но если вы теряете контроль над разговором, который ведете лицом к лицу, вам нелегко будет выпутаться из этой ситуации.

Для практических занятий непосредственной социальной инженерией (т. е. лицом к лицу) существует одно неплохое правило: всегда надевать приличный костюм, который хорошо на вас смотрится. Вы должны выглядеть так, словно только что вышли из модного ателье. На худой конец, наденьте рубашку и галстук. Для женщин подойдет любая одежда в деловом стиле.

Многие методы СИ, которые срабатывают по телефону, не годятся для личной беседы. Вы не сможете притвориться, что звоните из офиса, сидя рядом с компьютером. Поэтому информация, полученная таким образом, будет минимальной, либо малоценной. Возможно, у вас появится больше вспомогательных сведений, чем необходимой на данный момент информации. Делая вид, что ищете работу в фирме, совершая экскурсию, или даже просто проникая в здание и бродя по нему в одиночестве, можно получить много полезной информации о взаимоотношениях сотрудников. Чтобы проникнуть в компанию, хакеры также часто притворяются ремонтниками, малярами и другими рабочими. Сыграть роль охранника—тоже неплохая выдумка. Прототипом непосредственного “социального инженера” можно взять социолога, который делает опрос. Вы стоите у входа в здание с ручкой и анкетой, и просите проходящих мимо людей заполнить для вас одну ячейку. “Социолога” интересуют имена сотрудников, их жен и мужей, их хобби, домашние животные и их клички, и тому подобная информация. Придя домой, попробуйте ввести всю эту информацию в качестве паролей. Вы можете возразить, что за заполнение анкеты полагается какой-нибудь приз. Что ж, анкеты могут, к примеру, разыгрываться в лотерее, а выигравшие получат билеты на какое-нибудь местное шоу или бесплатный визит в близлежащий ресторан. (Примечание: не приставайте к людям с анкетами по утрам, когда они спешат на работу).

Заниматься социальной инженерией можно по электронной почте или с помощью других видов контакта с пользователями. Например, если вам не хочется целый день торчать с авторучкой у входа в здание, вы можете просто оставить бланки анкет рядом с письменным ящиком или указать на них адрес электронной почты, по которому их следует переслать. Но много ответов не ждите.

Другие уловки эпистолярной инженерии принимают вид рекламы. Наклейте в компьютерном зале объявление о найме добровольцев для работы над специальным проектом. “Требуются системные менеджеры с опытом работы!” Попросите желающих заполнить почтовые карточки с именем, адресом, желательным паролем, и, возможно, типом компьютера, с которым клиент предпочитает иметь дело. Создавая такую рекламу, вам захочется сказать себе “Т-с-с-с! Это слишком явная ложь!”. Но вы не поверите, сколько людей попадается на эту удочку. Напишите, чтобы они посылали свои почтовые карточки по адресу вроде: “Университет X, отдел компьютерной техники, кабинет Роджера Хэмма”, далее укажите свой адрес. Но если вы живете в тридцати милях от настоящего университета — забудьте об этом.

Однажды двое манхэттенских хакеров заметили, что в одном из журналов после рекламы популярной информационной системы с данными об играх осталось свободное место. Они набрали в библиотеках как можно больше журналов с этой рекламой и вставили в пустой промежуток, напечатав на принтере, следующее сообщение: “Региональные резиденты Манхэттена! Звоните (телефонный номер). Свободное членство в течение шести месяцев!” Затем журналы были возвращены в библиотеку. Когда люди звонили по указанному номеру, им включали следующую запись: “Добро пожаловать в программу свободного шестимесячного участия в сети X! Послушайте, какие потрясающие веши можно проделывать в нашей сети!..” После этого один из хакеров задавал звонившему несколько вопросов: “Где вы услышали о нашей программе?”, “Не присоединялись ли вы ранее к сети X?”, “Какими еще платными BBS или компьютерными сетями вы пользуетесь?”, “Под каким именем вы хотели бы входить в сеть X?”, “А каков будет ваш секретный пароль?”, “А вы уверены, что сможете запомнить такой пароль? Может быть, выберете другой?”. Действуя по этой схеме, они получили десяток имен для входа в компьютеры, и парочку паролей. Если вы живете в небольшом городке, такого улова у вас не наберется, но попробовать все равно стоит.

Можно также вклеить напечатанную карточку с рекламой прямо в журнал или поместить рекламу на BBS. Подобная же уловка заключается в распространении вашего номера в качестве локального переключателя звонков. Это может весьма пригодиться, если в ваших краях пока отсутствует связь Telenet или Tymnet. При загрузке пользователи увидят обычный открывающийся экран, хотя на самом деле это будет ваша модель программы. Занимаясь хакерством, вы, видимо, узнали адреса различных сетей, и сможете программно смоделировать любой подходящий входной экран. В противном случае отвечайте сообщениями вроде: “Линия занята” либо “Не удается установить связь”. В этой ситуации важным бывает правильно установить таймерные задержки, соответствующие обычным задержкам в сети.

После “соединения” с компьютером или сетью моделирующая программа продолжает работать: она запрашивает у пользователя имя и пароль, а затем “вылетает” из-за помех на линии или какой-либо другой неприятности. Если пользователь пытается тут же вызвать ее снова, можно сделать для него сообщение, что, дескать, пути передачи данных подвергаются перепроверке, или любую подобную чепуху.

Требование информации

А теперь давайте вернемся к чистой социальной инженерии, проводимой по электронной почте... Не ленитесь просматривать все компьютерные газеты и журналы, даже самые никудышные, в поисках информации о недостатках программных продуктов и лазеек в их безопасности. Журналистский кодекс чести вообще-то запрещает публикацию опасных секретов, так что точного описания ошибок в обеспечении безопасности систем вы не найдете. Вам будут попадаться заметки типа: “Вчера были пойманы четыре хакера, нашедшие лазейку в программе Х на машине Y военной базы Z”. Или: “Компания Y опубликовала предупреждение о недостатках выпушенного ею элемента Z, который создавался для зашиты системы от проникновения в нее нелегальных пользователей...” Вы можете сделать следующее: отпечатайте некое псевдоофициальное заявление и отправьте его по электронной почте той самой компании, а ответ не заставит себя ждать. Содержание может быть приблизительно таким:

Уважаемый м-р Абель Джонс! До меня дошли сведения о серьезных недостатках вашей продукции, а именно элемента Z. Я веду свои дела, полагаясь на то, что наши данные находятся в полной безопасности благодаря элементу Z.

Увидев, как мы обманывались в течение шести лет, я хотел бы получить от вас следующее: подробное описание изъянов, делающих ненадежным использование элемента Z, либо компенсацию за шестилетнюю эксплуатацию двенадцати непригодных элементов Z, что составит 14 000 $.

Жду вашего скорейшего ответа.

Заявление может также быть выполнено в духе “давайте поработаем вместе, чтобы улучшить этот мир”:

Уважаемый м-р Абель Джонс!

Я был весьма огорчен, увидев в номере “Computer Magazine” за пятницу информацию о дефектах, обнаруженных в вашем элементе Z.

На моем предприятии используется двенадцать таких устройств, и мне бы очень не хотелось потерять наши данные из-за их непригодности. Пожалуйста, вышлите в заклеенном конверте объяснение данной проблемы, чтобы мои техники могли устранить неполадки как можно скорее. Спасибо за помошь.

Искренне ваш...

Одно из этих посланий написано угрожающим тоном, другое — нет. С одной стороны, вам не хочется, чтобы ваше письмо посчитали липовым. С другой — данная компания наверняка получит множество писем подобного содержания, большинство которых будут отнюдь не подделками. Чтобы у вас не возникло проблем, напечатайте письмо на качественной бумаге, с настоящим или выдуманным бланком наверху.

Для пущего эффекта напечатайте адрес на конверте, а вместо того, чтобы наклеивать марку, пропустите конверт через почтовый счетчик. Можно дополнительно вложить визитку собственного сочинения — их можно недорого заказать. Если компания отказывается помогать вам без подтверждения сделанной у них покупки, — что ж, вы ничего не теряете. Вы всегда можете попытаться подвергнуть социальной инженерии техников данной компании, дабы выведать у них секреты безопасности. Вдобавок существует много ассоциаций и организаций по компьютерной безопасности, которым известны подробности допущенных ошибок. Можно попытаться узнать детали, написав в тот журнал, который напечатал статью об “элементе Z”. Постарайтесь встретиться с автором этой статьи. Журналистов и газетчиков обычно на удивление просто поймать по телефону, но заполучить их для разговора — это другое дело!

послание свыше

Уважаемый пользователь! Я вынужден сообщить вам неприятную новость. Являясь директором PinkyLink, самой крупной информационной службы Америки, работающей в режиме онлайн, я был шокирован, узнав о том, что шестого июля сего года имело место незаконное хищение нескольких файлов с именами пользователей. После нелегального копирования оригиналы были уничтожены. Одна из записей содержала, помимо всего прочего, закрытые личные данные небольшого количества наших клиентов. Хотя, к счастью, вашего имени не оказалось на похищенных файлах, все же определенная опасность для вас существует. На данный момент мы не можем сказать, содержались ли в похищенных файлах данные о каких-либо пользователях с программистским уровнем доступа, или нет. Таким образом, мы предлагаем вам заполнить приложенную анкету и незамедлительно выслать обратно по почте конверте. Мы берем на себя все ваши почтовые издержки. Оплаченный конверт с нашим адресом прилагается.

Заполнив анкету, верните ее, пожалуйста, как можно скорее. При получении мы создадим вам новый секретный ID.

Спасибо за поддержку.

В качестве компенсации за причиненные неудобства мы вычтем 75% из вашего счета за август.

Имя ______________________

Адрес ______________________

Индекс

Рабочий телефон Домашний телефон Старый (непригодный) пароль Новый (измененный) пароль

PinkyLink, самая большая информационная служба Америки, гарантирует, что вновь присланные личные данные будут введены не позднее 19-го сентября сего года. Конфиденциальность гарантируется до и после означенного срока. Просьба сохранить для себя копию или оригинал данного сообщения.

Представьте себе абстрактного пользователя, получающего по электронной почте такое вот послание. Выглядит послание настоящим, имеет logo и бланк соответствующей службы, пришло в запечатанном конверте. Но поверит ли пользователь, что послание сие ему действительно отправила служба PinkyLink? Складывается совершенно абсурдная ситуация! Любая настоящая компьютерная служба, у которой возникли

проблемы с паролями, станет осуществлять обновление всех паролей в режиме онлайн. Ведь это самый простой и дешевый способ обновить сотни или даже тысячи файлов с пользовательской информацией. Тем не менее, глядя на письмо, получивший его пользователь осознает, что он сам не находится в непосредственной опасности, в отличие от тех несчастных, чьи пароли были украдены; ему не придется получать по электронной почте громадные счета за кого-то, кто нелегально подключится к его, пользователя, бюджету. А как насчет упомянутых в конце 75%? Узнав про них, пользователь ответит на письмо в два раза быстрее. Он почувствует себя обязанным не только вновь сделать свой бюджет безопасным, но и обязанным перед базой данных: если уж они так любезно предупреждают его об опасности, да еще и платят, надо же хоть чем-то их отблагодарить. А оплаченный конверт с обратным адресом! Конечно, PinkyLink, скорее всего, меняет пароли пользователей и в режиме онлайн, но упоминать об этом в письме вовсе необязательно. Помните, что в посланиях подобного рода стиль имеет большее значение, нежели содержание. Прежде чем отправлять подобное письмо, потрудитесь взглянуть на экземпляры настоящей корреспонденции PinkyLink, чтобы получить представление о том, какую бумагу, шрифт и т. д. лучше использовать. На эту удочку обычно попадается довольно много народа, особенно если ваши адресаты — абсолютные новички. Позднее мы еще поговорим о том, как можно с пользой понаблюдать за BBS.

неприятности в раю

Ведя переговоры с крупной корпорацией, или заставляя людей посылать вам по электронной почте

свои пароли, вы можете нарваться на крупные неприятности. Почтовое министерство расценивает подобную деятельность как почтовое мошенничество, даже если вы всего-навсего собирались пошутить. Я привел здесь эти идеи лишь для того, чтобы стимулировать ваше воображению, вовсе не собираясь провоцировать вас на незаконные действия.

При занятиях социальной инженерией существует множество причин, по которым ваш собеседник может отказаться снабдить вас секретными данными. Он может:

• быть предупрежден об утечках информации;

• знать о тактике социальной инженерии;

• не поверить, что вы тот, за кого себя выдаете;

• знать, что вы не тот, за кого себя выдаете;

• не иметь причин помогать вам, и дать вам неверную или вводяшую в заблуждение информацию;

• доложить о вас менеджеру по безопасности. По любой из перечисленных причин человек, у которого вы пытаетесь выудить данные, может не суметь или не захотеть сообщить вам пароли и другую нужную вам информацию. А вы сами, прочитав все вышесказанное, стали бы выбалтывать секретные сведения неизвестному по телефону? Вот в чем проблема. Каково же ее решение?

обратная социалогия инженерия

Обратная социальная инженерия (или просто ОСИ, или даже ОИ) является довольно рискованным предприятием с переменной эффективностью и пригодностью в различных ситуациях. Впрочем, результаты, которые дает ОСИ, бывают настолько потрясающими, —

а порой столь же забавными — что данный способ ярко выделяется среди остальных методов взлома зашиты систем. Дело в том, что, хотя социальная инженерия представляет собой признанный и проверенный метод получения нужной информации, она имеет свои недостатки. Не бывает совершенных систем, и список в конце предыдущей главы наглядно показывает, что социальная инженерия срабатывает не всегда. ОСИ по многим критериям предпочтительнее СИ. Впрочем, применять обратную СИ можно лишь в некоторых ситуациях, после длительной подготовки и предварительных исследований. Вдобавок, настоящая обратная инженерия может с успехом применяться только самыми хитроумными (и легкими на подъем) хакерами. Не думайте, что эта техника станет вашим основным методом сразу, как только вы начнете знакомиться с миром компьютерных правонарушений. Обратная СИ в своих наиболее совершенных проявлениях требует информации, которой вы пока не располагаете, и уловок, с которыми вы пока что не знакомы. Вот сравнительный список, показывающий некоторые “за” и “против” обоих методов.

Социальная инженерия: вы совершаете звонок, зависите от собеседника.

Обратная социальная инженерия: собеседник совершает звонок и находится в зависимости от вас.

Социальная инженерия: вы чувствуете себя в долгу перед ним, либо он может поверить в это и повести себя соответственно.

Обратная социальная инженерия: принимая вашу помошь и советы, он отблагодарит вас, если в будущем вам понадобится помошь.

Социальная инженерия: вы нуждаетесь в его помощи.

Другой способ заключается в постепенном замедлении времени ответа на каждую новую попытку входа. Начинающий хакер может обнаружить, что ответ от удаленного компьютера приходит к нему через тридцать секунд... затем через минуту... затем через две... Периоды ожидания начинают увеличиваться только после трех или четырех неудачных попыток входа. Компьютер говорит сам себе: “Черт возьми, ни один нормальный пользователь не смог бы ошибиться столько раз. Наверно, это хакер!”

Еще одна хитрость — ложное приглашение ко входу в систему. После определенного количества неудачных попыток входа система продолжает запрашивать входную информацию, но каждый раз возвращает сообщение об ошибке, независимо от того, верна данная информация, или нет.

Отсюда следует мораль: при написании программы для взлома паролей не забудьте о выводе результатов на экран по мере продвижения. Не следует запускать программу на всю ночь и ложиться спать, не убедившись сперва, что в данном случае не имеют места подобные меры безопасности. Ведь проснувшись утром, вы можете обнаружить, что время ответа компьютера на ваши попытки входа составляет сорок минут. Или же программа безуспешно переберет все возможные комбинации, отвечая на ложные приглашения.

заключение

Значительная часть данной главы повествует о различных “вероятных” паролях, которые перебираются по ходу грамотной силовой атаки перебором.

Наиболее часто встречающиеся пароли можно перечислять ао бесконечности — имена домашних питомцев, исторические даты, названия книг — не говоря уже о том, что все они могут быть написаны с пропущенными гласными, задом наперед и в виде различных анаграмм. Порой и думать не приходится о со-крашении числа возможных паролей до нескольких, так как ваше “сокращенное” число окажется таким же бесконечным, как и то, которое вы пытались сократить. Кроме того, пароль может быть “легким” для угадывания и в то же время достаточно тайным, чтобы отбить у вас охоту его отгадывать. Пароль “Смит” не является особенно тайным, равно как и пароль “Ажонс”, но пароль “Смит@°Джонс” вполне отвечает требованиям секретности.

Сторонним наблюдателям кажется, что угадывание паролей как раз и является основным занятием хакеров, но на самом деле это лишь начальный этап взлома.

“Атаки перебором” лучше всего удаются компьютерам и к ним лучше всего прибегать тогда, когда для получения права доступа необходим компьютер (в качестве примера можно привести Роберта Морриса с его компьютерным “червем”).

Дело в том, что хакерское дело целиком зависит от знаний и мастерства. Метод перебора имеет мало общего и с тем, и с другим. Но никто не посмотрит сверху вниз на хакера, который грамотно проводит силовые атаки, особенно если у него есть на то веские причины. Но не надейтесь, что электронный мозг сделает за вас всю грязную работу: используйте лучше творческие возможности своего собственного мозга. О них-то и пойдет речь в следующей главе.


Глава 4. Социальная инженерия

Обратная социальная инженерия: Он нуждается в вашей помоши.

Социальная инженерия: ваша жертва обычно остается в недоумении.

Обратная социальная инженерия: все проблемы устраняются, вопросов не остается.

Социальная инженерия: вы почти не контролируете ситуацию.

Обратная социальная инженерия: вы полностью контролируете направление и предмет беседы.

Социальная инженерия: подготовительной работы практически не требуется.

Обратная социальная инженерия: тщательное предварительное планирование; требуется предварительное получение доступа к месту действия.

Социальная инженерия: может применяться где угодно.

Обратная социальная инженерия: применяется только в определенных условиях.

Социальная инженерия в основном исходит из предпосылки, что вы — самозванец, притворяетесь, что у вас возникли затруднения и вам требуется помошь другого оператора. А вот обратная ситуация: проблемы возникают у легального пользователя системы, и он (или она) просит вас, хакера, о помоши. Помогая пользователю разрешить возникшие проблемы, хакер без особенных усилий может узнать рабочие имена и пароли. Атака с помощью ОСИ состоит из трех частей:

• диверсия;

• реклама;

• помошь.

Диверсия — это первый краткий контакт с определенным компьютером, во время которого хакер создает какую-либо неполадку, требующую устранения.

Реклама — информирование пользователя о том, что вы разбираетесь в вопросах из области компьютеров.

Помошь — общение с пользователем, в процессе которого вы решаете проблемы пользователя, а тот, сам того не ведая, решает ваши.

Прежде чем я начну объяснять, как применять этот метод и что он может дать, вам следует уяснить для себя, почему лучше, когда пользователь обращается к вам за помошью, а не наоборот. Давайте рассмотрим по пунктам список недостатков социальной инженерии, приведенный в предыдущей главе, чтобы показать, как обратная социальная инженерия преодолевает эти препятствия.

преодоление недостатков социальной инженерии

Пользователь может быть предупрежден об утечках информации или знать о тактике СИ

Пытаясь подвергнуть социальной инженерии того, кто о ней знает, особенно квалифицированных программистов и других хакеров, вы вряд ли многого добьетесь. Даже если собеседник не знает о СИ как таковой, он (или она) может достаточно серьезно относиться к предупреждениям “Храните в тайне свой пароль”, чтобы не купиться на вашу болтовню. Социальная инженерия рассчитана на наивных пользователей. Но ведь не все являются таковыми.

В случае ОСИ легальный пользователь обращается к вам за советом. Следовательно, он считает вас

человеком, которому можно доверять, — членом компании или ее доверенным лицом, то есть тем, кто уже и так знает все пароли и протоколы. Так что у него нет причин не давать вам такую информацию. У него даже мысли подобной не возникнет — ведь ему так или иначе придется, обратившись за помошью, выложить всю подноготную.

Следует отметить, что обратная социальная инженерия не является социальной инженерией. Она подходит к проблеме разговора с пользователем с другой стороны, и пользователь, знакомый с обычными ха-керскими уловками, вряд ли сможет ее раскусить. Более того, даже если ваша жертва достаточно умна, чтобы распознать ОСИ, этот человек будет настолько озабочен возникшей у него проблемой, что не заметит происходящего. Ему (или ей) нужна ваша помощь, чтобы устранить неполадку; он понимает, что, если он не договорится с вами, вы ему не поможете.

Пользователь может не поверить, или знать, что вы не тот, за кого себя выдаете

Уязвимое место социальной инженерии в том, что вы являетесь для собеседника темной лошадкой, поскольку он не знаком с вами лично. Кроме того, если человек на другом конце провода узнал о том, что вы не тот, за кого себя выдаете, возможно, воспользовался ID, или телефоном с определителем номера, то в этом случае, пароли могут и не появиться, как по волшебству, перед “таинственными техниками” и “растерянными пользователями” с “испорченными” модемами. НО! При обратной СИ у тех, кто знает волшебные слова, нет причин подозревать или обманывать вас — ведь это они обращаются к вам за советом. Это вы помогаете им в их несчастье. В самом деле, когда они звонят вам, вы вправе спросить, кто они, собственно, такие. Безопасность — прежде всего.

Пользователь не имеет причин помогать вам, или может дать неверную,ошибочную информацию

Что прежде всего заботит человека, которого вы подвергли социальной инженерии, независимо от того, помог он вам, или нет?

Если бы я, не покладая рук, трудился в какой-нибудь конторе, или был секретарем, я просто пришел бы в ярость, если бы посередине хлопотного дня какой-то идиот позвонил мне по телефону и попросил уделить ему несколько минут моего драгоценного времени и сообщить некую информацию, которую он, скорее всего, вообще не должен знать! Я мог бы просто брякнуть в трубку, что на ум взбредет, только бы отделаться. При обратной же инженерии вы знаете, что ваши собеседники нуждаются в вашей помощи. Даже самый великий гуру из числа знающих пользователей обратился бы к вам, зная, что вы сможете быстро и эффективно определить суть проблемы и разрешить ее, не тратя времени зря. Этот пользователь знает, что ключ к решению задачи находится у вас, и если он его получит, в следующий раз сможет справиться с такой проблемой самостоятельно.

Пользователь может сообщить о вашем звонке менеджеру по безопасности

Опытный пользователь мгновенно догадается, если вы попытаетесь подвергнуть его социальной инженерии. Он может пойти и рассказать остальным, что вы пытались выманить у него пароль. “Остальные” — коллеги, боссы, менеджеры по компьютерам, человек, роль которого вы пытались сыграть, охранники либо офицеры безопасности. Ни один из них не станет помогать вам в дальнейшем, даже если вас не поймают сразу или не сведут к нулю ваши шансы на взлом. Разоблачение, конечно, совсем не подарок. Но при обратной инженерии вы неизменно приобретаете друзей. Когда вы помогаете людям преодолеть какие-то затруднения, они радостно пустят слух о вашей любезности и отзывчивости — а это означает еще больше звонков и паролей.

Предшествующие разъяснения преследуют три цели. Я хочу, чтобы вы поняли, почему такое мощное средство, как классическая СИ, может случайно провалиться, и как ОСИ может избежать этих ошибок. Я утверждаю следующее: социальная инженерия не может больше оставаться главным оружием в арсенале современного хакера без предупреждения обычных пользователей. Обычные пользователи проявляют все большую осторожность и благоразумие, когда дело касается таких интимных вещей, как пароли и компьютерная безопасность. Обычные пользователи стали больше читать о том, как хакеры взламывают системы. Они посещают лекции по компьютерной безопасности, которые устраивают их компании, колледжи и местные полицейские подразделения. В системы стали включать предупреждения о недопустимости разглашения любой информации; об этом твердят их работодатели и их собственный рассудок. И я сам — даже я! — говорю им о том, что существуют злоумышленники, мечтающие испортить их файлы. Я весьма сомневаюсь в том, что наступит такое время, когда все компьютерные пользователи будут достаточно осведомлены, чтобы держать язык за зубами. Возможно, через несколько лег предприятия поставят на свои телефоны задержку времени и подключат их к голосовым мониторам. Тогда запрещенные к произнесению слова будут обнаруживаться и уничтожаться прежде, чем электроны, составляющие сигнал, покинут пределы находящихся внутри здания проводов. Даже если подобная вещь станет повсеместной, или если 95% людей, общающихся с компьютерами, захотят покончить с социальной инженерией, все же останутся пять процентов, останутся сотни других хакерских уловок, новых и старых, и останется Обратная Социальная Инженерия, помогающая хакеру в его нелегком деле.

диверсионные методы обратной социальной инженерии

Первый шаг ОСИ — создать неполадку в избранном вами компьютере или сделать так, чтобы пользователь не смог на нем работать. Обычно это означает создание такой неполадки на рабочей станции, терминале или компьютере, чтобы пользователь не мог войти в систему так, как положено. Неполадку должно быть трудно обнаружить, но легко исправить. Вот список из пяти общих идей, расположенных в порядке возрастания затрачиваемого на них времени и степени вашего знакомства с системой:

• Изменение какого-либо параметра, неизвестного новичкам или такого, о котором они не подумают. Например: устанавливаемые по умолчанию порты принтера, цвета экрана, макросы, скрытые коды принтера, периферийные технические установки. Установить файлы в режим “только для чтения”, или переименовать их, или сделать невидимыми в их директориях. Пример: если рабочий файл текстового процессора называется WP.EXE, переименуйте его в WP.$A$.

• Вмешательство в аппаратное обеспечение. Например: переключить цветной монитор в монохромный режим; поменять дисководы; отключить клавиатуру, выташить из компьютера предохранитель.

• Инсталлировать большие резидентные программы, занимающие уйму памяти. Пользователь не поймет, почему ему не удается запустить программу.

• Запустить модель программы, подобную модели операционной системы, которая станет выдавать кучу ужасных сообщений об ошибках.

ВНИМАНИЕ! Диверсия не должна причинять неустранимого вреда компьютеру или пользователю! НЕ УНИЧТОЖАЙТЕ файлы и директории: не исключено, что их будет невозможно восстановить впоследствии. НЕ ИНСТАЛЛИРУЙТЕ вирусы: они легко выходят из-под контроля. НЕ делайте изменений, благодаря которым операционная система откажется загружаться: когда пользователь позовет вас на подмогу, у него может не оказаться под рукой дискеты для загрузки DOS!

разрешение диверсии

Допустим, уловка сработала и вам позвонили. После того, как система загрузится и вы обнаружите, что неполадка никуда не делась, вы должны сообщить пользователю, что он (или она) должен делать, чтобы устранить возникшую проблему. Конечно, можно просто дать ему недвусмысленные инструкции вроде:

“Наберите команду “rename WP.$A$ to WP.EXE”...” Но если пользователь достаточно сведущ, он наверняка заметит подвох. Как же обойти это препятствие? Вам придется дать взволнованному пользователю такие рекомендации, которые успокоили бы его.

Если диверсия связана с аппаратным обеспечением, разместите на диске программное решение. Например:

“Войдите в директорию текстового процессора, наберите “SETUP” и нажмите Return. Теперь попытайтесь запустить программу еще раз”. В данном случае SETUP— это файл, который вы разместили на диске; он содержит инструкцию по переименованию, а также команду по самоуничтожению после выполнения.

Проблемы, связанные с аппаратным обеспечением, бывает трудно определить или объяснить по телефону, но, вообше-то, в ОСИ редко используется аппаратное обеспечение. Если на месте у вас окажется достаточно времени для создания физических неполадок на искомом компьютере, у вас должно хватить времени и на то, чтобы отобрать необходимую вам информацию.

рекламные методы оси

Существует пять основных рекламных методов, которые могут заставить ваших пользователей позвать на помощь именно вас:

• Замена пометок. Если вы увидите приклеенный рядом с компьютером или непосредственно на нем листочек бумаги с номером телефона компьютерного отдела, снимите его и приклейте взамен записку с вашим собственным номером (или номером какого-то другого телефона, возле которого вы сможете сидеть в ожидании звонка).

• Размещение объявления. Поместите на доске объявлений (обычной, а не электронной!) большое, яркое, солидное объявление с содержанием типа:

Служба Технической Помощи

У ВАС ВОЗНИКЛИ ПРОБЛЕМЫ С КОМПЬЮТЕРОМ? ЗВОНИТЕ НАМ БЕСПЛАТНО ПО НАШЕМУ НОВОМУ НОМЕРУ:

(123)ABC-WXYZ

Служба Технической Помощи

Не забудьте поместить название и адрес компании, в которую вы хотите проникнуть, где-нибудь в углу объявления — чтобы можно было подумать, что объявление имеет какое-то отношение к ней. Расклейте такие объявления повсюду, или просто разбросайте по рабочим столам, особенно рядом с теми компьютерами, на которых вы произвели свою диверсию.

• Социальная инженерия. Позвоните за день, или даже за несколько часов до совершения диверсии, и сообщите тому, кто подойдет к телефону, новый номер вызова помощи из компьютерного отдела (т. е. ваш номер). Попросите держать его под рукой, чтобы не искать, если понадобится. Спросите, является ли ваш собеседник единственным пользователем данного терминала; если ответ отрицательный, попросите сообщить о новом номере другим пользователям.

• Перекройка каталога. Достаньте внешний телефонный каталог компании и добавьте ваш номер в список, либо вырезав существующий номер технической помоши, вставив вместо него свой собственный, либо разборчиво напечатав свой номер в конце каталога.

•Диалоговая реклама. Непосредственно в процессе диверсии постарайтесь дополнительно разместить заметку на доске объявлений (на сей раз — электронной!) с вашим номером компьютерной помоши. Выдавать телефонный номер может и одна из процедур вашей диверсионной программы. Например, вы можете переименовать WP.EXE, затем создать модель текстового процессора, который станет врываться в операционную систему после нескольких нажатий клавиш, оставляя на экране искаженные цвета, символы, а также следующее сообщение:

<ВЕЕР!>

XERROR 3 — Consult fdox 90v.32a or call Jim at technical support @ (123) ABC-WXYZ

При создании рекламы убедитесь, что пользователю известно, что он звонит по внешнему номеру (чтобы он знал, что ему надо сперва выйти из РВХ компании). Поступайте так, пока вам не удастся обзавестись собственным кабинетом или внутренним телефоном (например, проникнув в кабинет, пока его хозяин в отпуске).

ПУСТАЯ трата времени?

Конечно, предварительное планирование и сама диверсия очень улекательны и занимательны. Но стоят ли они затраченных усилий? Почему бы не удовольствоваться более простой социальной инженерией и не беспокоиться о том, как к вам отнесется парень на другом конце провода?

Ну что ж, во-первых, это глупо. Особенно учитывая тот факт, что большинство людей в тех учреждениях, которые вы собираетесь взламывать, будут

весьма неплохо информированы о безопасности. Вам придется признать, по многим причинам, что они узнают, кто вы такой, еще до того, как вы раскроете рот. А если они узнают, кто вы такой, они не станут помогать вам.

Вот еще один фактор, имеющий отношение к сказанному выше: занимаясь обратной инженерией, вы приобретаете друга на искомом предприятии. Приступив к взлому вплотную, вы не узнаете, не сидит ли кто-то у вас на хвосте, пока не свяжетесь с теми, кто находится “внутри”. Если вы хорошо зарекомендовали себя какому-нибудь пользователю, вы сможете позвонить ему немного спустя после взлома и поинтересоваться: “Алло, вы помните меня? Я помог вам справиться с проблемой... Хотел спросить, не слышно ли у вас о чем-нибудь подобном, или еще о каких-то странностях с системой?”. Если ваш собеседник слышал о попытках проникновения в систему или сбоях в ее работе, он в первую очередь сообщит об этом вам. Можно попросить его передавать вам все слухи о “хакерах” и т. п. А если ваш взлом обнаружат и, например, разошлют всем работникам сообщения с просьбой сменить пароли, поскольку в систему проник хакер, ваш ничего не подозревающий приятель опять же позвонит вам и расскажет о случившемся. Благосклонность одного из сотрудников избранного вами объекта, право же, стоит тех первоначальных трудностей, которые могут у вас возникнуть при совершении диверсии.


Глава 5. Компьютеры общественного доступа

три разновидности

В этой главе пойдет речь о двух аспектах, связанных с компьютерами общественного доступа:

— Как добраться до скрытых от посторонних глаз разделов, и — об использовании компьютеров для сбора информации о пользователях этих компьютеров, которую вам не положено знать.

Сам я никогда не взламывал такие компьютеры — хотя у меня есть и возможности, и желание для этого. Хакеры взламывают потому, что их прельщает идея того, что у любого доступного компьютера есть секретная сторона, в которую можно “вломиться”. Такая сторона есть у всех компьютеров общественного доступа и хакер — именно тот, кто хочет до нее добраться.

Компьютеры и “глупые” терминалы общественного доступа — предмет вожделений любого, кто интересуется хакерством. Ааже если к такому компьютеру и не подсоединен модем, хакер может получить удовольствие, используя данный компьютер для сбора информации о легальных пользователях, работающих в режиме онлайн.

Теперь компьютеры общественного доступа можно найти во многих местах — в офисах, приемных, магазинах, музеях, залах для отдыха в аэропортах, в учебных заведениях, но чаше всего — в библиотеках, и речь в данной главе пойдет в основном о библиотечных компьютерах.

Компьютеры, предназначенные для использования широкой публикой, можно теперь увидеть в публичных библиотеках. Они делятся на три группы:

• компьютеры с базами данных и информацией на CD-ROM,

• терминалы общественного доступа, и

• универсальные микроЭВМ.

Давайте рассмотрим эти разновидности по очереди, и выясним, какую пользу из каждой может извлечь хакер.

компьютеры с базами данных и информацией на CD-ROM

Базы данных на CD-ROM, являются компьютеризированными листингами периодических статей, обновляющихся каждый месяц. Другие доступные базы данных посвящены бизнес-новостям, переписям и т. п. Некоторые библиотеки располагают энциклопедиями на CD-ROM, а во многих государственных книгохранилищах должны находиться базы данных со списками доступных государственных публикаций.

Кстати сказать, я видел библиотеки на компьютерах (как правило, “Macintosh”), оснащенных программами с дружелюбным пользовательским интерфейсом, которые обучают посетителей, как пользоваться библиотекой и дают другие полезные советы. Все эти компьютеры могут представлять интерес для хакера лишь постольку, поскольку в них содержится информация, так как машины не соединены друг с другом, не имеют модемов и доступа к телефонной сети. Они обычно предназначены исключительно для получения информации по одной конкретной теме.

Наконец — хотя это бывает редко, и может показаться несколько странным, — существуют компьютеры, используемые в качестве “журнала регистрации”. Когда люди входят в компьютерный зал, офис и т. п., они заносят в компьютер свои имя и идентификационный номер, а порой отвечают на несколько вопросов о себе.

В отличие от баз данных и обучающих программ, компьютеры с записями посетителей более полезны для хакера, но не намного. Например, можно воспользоваться компьютером, чтобы узнать, кто еще пользовался данным помещением. Данная информация может оказаться полезной, если помещение, о котором идет речь, — компьютерный зал. Возможно, вам удастся найти сведения об использовании компьютера определенными людьми, либо обнаружить общую тенденцию к уменьшению числа посетителей в определенное время дня, — и то, и другое, как мы увидим в дальнейшем, может пойти на пользу дела.

Если компьютер с программой записи регистрации посетителей не дает сведений о том, кто находился в данном месте прежде вас, попытайтесь вый-

ти в операционную систему и поискать файлы с подходящими данными. Этот способ будет рассматриваться ниже в разделе, посвященном универсальным микроЭВМ.

Доступ к компьютерам с базами данных и информацией на CD-ROM обычно бывает не очень-то нужен хакеру. Существуют, разумеется, и исключения из правила, так что вы ничего не потеряете, если при встрече с таким компьютером хорошенько исследуете его.

библиотечные терминалы общественного ДОСТУПА

В качестве электронных библиотечных каталогов чаше всего используются обычные “глупые” терминалы, хотя порой встречаются и IBM-совместимые. Они носят названия типа IRIS или GEAC. Эти системы позволяют посетителям библиотеки искать материалы (книги, журналы, видеопленки); узнавать текущее местонахождение этих материалов (На полке? Выдан на руки? Просрочен? Утерян?); заказывать материалы;

узнавать библиотечные новости и т. п. Зачастую, особенно в университетских библиотеках, терминалы бывают подключены к коммутируемым линиям связи.

Задача хакера состоит в следующем: он знает, что каждый библиотечный компьютер имеет свою скрытую сторону. Как добраться до нее?

Каждая библиотечная компьютерная система делится на две части — общедоступный каталог и вторая часть — для служебного пользования. Последняя включает в себя процедуры отпуска материалов, конфиденциальную информацию о посетителях, добавление или изменение файлов, закрытие библиотечных карточек и т. д. Эти закрытые для общего доступа функции, используемые только сотрудниками библиотеки, должны основываться на информации из той же самой базы данных, которая имеется на терминалах. Общедоступные функции являются одним из разделов всей библиотечной программы. Это значит, что программа, позволяющая посетителям запрашивать книги, — лишь часть большей программы, включающей в себя функции управления более высокого уровня.

Естественно, эти две составляющие разделены между собой, в противном случае кто угодно мог бы зайти в библиотеку и стереть все штрафы со своей библиотечной карточки, или записать на карточку своего недруга штраф в 100$ за утерянные материалы. Итак, каким же образом общедоступная часть системы отделена от закрытой? Угадайте-ка.

Точно, с помощью пароля.

На самом деле пароль представляет собой комбинацию из спрятанной команды меню и собственно пароля для подтверждения прав пользователя. Выйдите в главное или самое первое меню библиотечной системы и попробуйте ввести различные команды, вроде BYE, END, EXIT, X, XXX, SYS, SYSTEM, LATER и OFF. Такие системы обычно рассчитаны либо на трехбуквенные, либо на однобуквенные команды, но, конечно, форматы команд в различных системах могут варьироваться весьма широко, так что вам следует изменять свою тактику в соответствии с особенностями конкретной системы. Если что-то типа BYE сработает и вы выйдете из общедоступной части системы, вероятно, вас попросят ввести ваш пароль. Ну, да ведь вы же знаете, как раздобыть пароль! А может, у вас его и вовсе не спросят...

скрытые команды

Взламывая любой общественный терминал такого типа, всегда необходимо помнить, что он обычно располагает несколькими уровнями секретности для потенциальных пользователей системы. На каждом уровне в меню могут появляться и исчезать различные команды — впрочем, возможно, вам удастся задействовать их, используя неадекватность программы. Если в меню даны опции с первой по четвертую — попробуйте использовать пятую! И шестую... и нулевую. Всегда используйте Z, Q, X, другие “редкие” буквы, и вообще все, что, на ваш взгляд, может подействовать. Однократного введения перечисленных команд может оказаться недостаточно — иногда программа раз или два выдает сообщения об ошибке, а на третий неожиданно вылетает система, или же вы оказываетесь на “запретной территории”. Скорее всего, вы не найдете программы, настолько плохие, что они позволяли бы войти нелегальному пользователю, но вы удивитесь, как много ошибок проскальзывает мимо глаз авторов и проверяющих. Это особенно справедливо для первых версий программ.

Запомните еще одно: в библиотечном компьютере скрыто множество функций, о существовании которых вы и не подозревали.

Попробуйте такие веши, как CON, ILL, CHG, DIS и другие трехбуквенные (или N-буквенные, в зависимости от данного случая) комбинации. В некоторых системах все команды трехзначные, кроме одной — NEW USER, или RECALL, и т. п. В этом случае вы будете знать, что компьютер воспримет и команды, выходящие за рамки трех символов, значит, можно попробовать их ввести. Команды, которые я привел выше, являются аббревиатурами — CONversion, InterLibrary Loan, CHarGe, Discharge. Вы-то, наверно, считали, что ILL — это “ILLness”, или “I Love Lucy”. Но данная аббревиатура очень часто используется. Если вы пытаетесь проникнуть в систему, о которой вам ничего не известно, весьма вероятно, что в ней используются подобные коды и аббревиатуры. Проверьте это предположение.

Одна из систем Великобритании использует аббревиатуры LCO и LIN — Library Check Out и Library Inquiry. В силу некоторых законов о частной собственности, сотрудникам библиотеки не разрешен доступ к бюджетам посетителей, содержащим личную информацию — телефоны, адреса и книги, выданные на руки. Это создает для библиотекарей определенные трудности, поскольку они ОБЯЗАНЫ знать, как можно связаться с людьми, которые не желают возвращать книги и записи (к тому же им, естественно, необходимо знать, какие именно книги были взяты). Поэтому люди, написавшие систему для библиотеки, включили в нее команду, незаметную для ВСЕХ — даже сотрудников библиотеки. Нажатие “X” на экране с запросом о книгах дает доступ к модулю запросов посетителей.

Дело заключается в следующем: “глупые” терминалы часто содержат выходы к управляющим программам. Вы можете добраться до этих секретных областей, либо нажав команду выхода — “лазейка” — и введя пароль, либо использовав секретный пункт меню или командный оператор. Если в программе есть ошибка, она может дать вам такой доступ, даже если на вашем терминале его быть не должно, или если вы не ввели пароль.

Бывает полезно также выключить терминал, подождать секунд десять включить снова и посмотреть, что произойдет. Некоторые терминалы реагируют на различные комбинации клавиш Ctrl, Shift и Alt.

Проверьте функциональные клавиши и комбинации Ctrl и Shift с ними. Попробуйте ввести другие управляющие коды, вроде Escape, Ctrl-C, Ctrl-X, Ctrl-Q, Ctrl-G, Ctrl-Break и т. д. Никогда нельзя знать заранее, что произойдет, и произойдет ли вообще хоть что-то необычное. Но, может статься, вы будете приятно удивлены.

терминалы общественного ДОСТУПА в колледжах

Существует еще один вид терминалов общественного доступа, которые нетрудно найти в компьютерных классах любого колледжа. Они отличаются от библиотечных тем, что предназначены только для использования санкционированными пользователями, имеющими бюджеты и пароли в системе.

На таких терминалах тоже стоит попробовать различные функции и управляющие коды. Это, скорее всего, не поможет вам куда-либо проникнуть, но использование контрольных кодов часто дает доступ к параметрам меню или изменению цветов экрана.

Нажмите “?” или наберите HELP, чтобы увидеть, какие команды доступны для вас. Большинство колледжей использует информационные системы, которые иногда соединены с библиотечной системой, содержащей информацию о делах студентов, телефонных номерах, часах занятий, студенческие новости; такая система может также дать возможность соединиться

с информационными системами других колледжей.

В большинстве случаев вы сможете использовать TELNET или другие сетевые протоколы для установления связи с компьютерами чуть ли не всего мира. Но, более чем вероятно, сначала вам придется пройти процедуру загрузки в качестве легального пользователя. Этот раздел связан с некоторыми методами, которые хакеры применяют для получения паролей и ID с помощью терминалов общественного доступа, установленных в колледжах.

Вот вам история №1.

способ e-z

Компьютерный энтузиаст по имени Барри из Лас-Вегаса, что в штате Невада, нашел весьма легкий способ получения информации, не требующий никаких программистских навыков и специального оборудования.

В университете, где он учился, была компьютерная лаборатория, в центре которой стояли “Макинтоши”, а по стенам — терминалы. У него был бюджет в тамошней системе, но ему хотелось заняться более серьезным хакерством. Он знал, что, попытайся он заняться чем-нибудь таким, загрузившись под своим именем, — и его ждут большие неприятности. Ему был необходим другой бюджет, хотя бы самого низкого уровня, откуда он мог бы спокойно заниматься своим делом.

Терминалы этого университета работали так: доступные команды или меню располагались на экране перед подчеркиванием _____ соответствующей длины, в конце которой пользователь должен был занести то, что он выбрал. С помощью клавиш со стрелками можно было передвигаться по всему экрану и

печатать, но при нажатии Send подтверждался прием только тех символов, которые были напечатаны вместо этого подчеркивания.

Барри вошел в главное меню информационной системы. Стер весь текст с экрана и воспроизвел экран загрузки, использовавшийся для доступа к мэйнфрейму. В конце он сочинил подходящее приглашение...

ENTER NAME,PASS IN FORM nnnnnnnn,pppppppp____________

... и установил курсор в начало линии. Он включил Caps Lock и выключил все остальные терминалы. Затем Барри уселся за “Макинтош” рядом с подготовленным терминалом, и стал ждать.

Казалось, в тот день всем и каждому были нужны только “Макинтоши”. Ему пришлось ждать более часа, пока, наконец, какая-то женщина не подошла к терминалам. Как и надеялся Барри, она выбрала именно тот терминал, который он “зарядил”. Барри со своего места возле “Макинтоша” мог видеть все, что она вводит.

Как вам известно, при использовании настоящего экрана загрузки при вводе пароля компьютер заменяет его звездочками. Но дама, севшая за терминал, похоже, и не заметила ничего необычного в том, что вместо звездочек она вводит настоящие данные.

Нажав Send после пароля, она услышала обычный сигнал отсутствия подтверждения — ведь она нажала Send, не введя при этом ничего на том месте, которое должно было использоваться для команд, стертых Барри. Компьютер вернулся в главное меню информационной системы, и удивленная женщина, загрузившись еще раз, занялась своими делами.

Другой пользователь, севший рядом с ней вскоре после того, как она вошла в компьютерный зал, заметил: “Они сегодня весь день как-то странно работают”. Барри был изумлен — не приложив практически никаких усилий, он получил необходимые ему имя и пароль, и мог спокойно взламывать что угодно, не опасаясь, что его выследят! Вдобавок, результат его действий приняли за неполадки в системе.

Существует много вариантов вышеописанной тактики, меняющихся в зависимости от свойств командной системы, используемых терминалов, обстановки в помещении и т. д. Вам придется изменять свою стратегию соответственно ситуации.

Некоторые терминалы позволяют менять цвет экрана. Однажды я проделал с терминалом такую же штуку, как и Барри. Сначала я стер настоящий загрузочный экран и заменил его своей имитацией. Но имитация не была идентичной — на моем загрузочном экране я поместил подчеркивание на одну линию ниже, чем следовало.

Затем я подвел курсор к тому месту на экране, где надо было вводить команды (как раз под моим фальшивым подчеркиванием). С помощью функциональной клавиши изменения цвета я ввел символы того же цвета, что и фон экрана: “logon”. Черные буквы на черном фоне — только мне да компьютеру было известно, что там находятся эти символы.

После этого я переставил курсор в начало подчеркивания, снова с помощью функциональной клавиши изменил цвет текста на белый и сел в кресло неподалеку.

Долго ждать мне не пришлось. Минут через двадцать вошла группа людей, и один из них сел за “мой” терминал. Но, к сожалению, увидев экран, он подумал, что терминал уже занят, и собрался уходить. Я сказал ему: “Нет, здесь свободно”. И тогда он перезагрузил терминал и начал загрузку в совершенно иную систему!

Еще через несколько часов мне все-таки повезло. Я установил терминал снова и занял свою позицию в кресле, притворившись, что изучаю учебник по алгебре и началам анализа. Прошло много времени, прежде чем за терминал сел парень, который ввел свое имя и пароль (все это мне не составило труда прочесть) и нажал на ввод.

Но программа, естественно, не смогла понять, что он набирает, так как он ввел имя и пароль не на том месте. Компьютер распознал только спрятанный мною “logon”, соединился с главной машиной и запросил идентификацию пользователя. Парень, решив, что ошибся при вводе, снова ввел свои данные... Но я был уже далеко, ведь всю необходимую информацию я уже получил.

Такой способ годится только для систем, которые позволяют вводить всю входную информацию в одну линию.

Для имитации загрузочного экрана можно также использовать текстовый редактор. Если у вас нет бюджета в системе, а, соответственно, и доступа к текстовому редактору электронной почты, возможно, в общественной информационной системе, доступной вам, имеется раздел “Send Commands to Sysop” — “Послать команду к системному оператору”. Вероятно, вам все равно придется воспользоваться общественным редактором, дабы ваши злонамеренные деяния не засекли через ваш ID.

С помошью текстового редактора можно, например, написать такой вот текст:

>login Enter Name:

Enter Password:

В конце можно оставить хвостик нормального меню, списка команд, либо текста, который каждый обычно видит, включив терминал.

Разместите “Enter Name:” так, чтобы эта строка была последней, видимой на экране. Поместите курсор сразу после двоеточия, и выключите клавишу “Insert”, если таковая имеется.

Человек, севший за терминал, подумает, что кто-то набрал команду “login” еще до него. Он введет свое имя и нажмет “Enter”. Нажатие “ввода” прокрутит документ на одну строку вверх, так что станет похоже, будто компьютер запрашивает ввод пароля, который и будет введен пользователем к вашему вашему удовольствию, ведь вы сидите неподалеку, наблюдая за тем, как разворачиваются события.

У данного метода существуют свои недостатки (как, вообше-то, и у всех этих методов E-Z). Что, если человек, который сядет за компьютер первым, не станет входить в свой бюджет? А если он ошибется при вводе, что останется незамеченным до тех пор, пока он не нажмет на “ввод”? В обоих случаях вашу маленькую шалость могут обнаружить. Всегда существует возможность того, что кто-нибудь из тех, кто присматривает за компьютерным залом, выключит те терминалы, которые, по его мнению, зря простаивают, и вся ваша работа пойдет насмарку. К тому же, если вы проделываете такие веши с университетским терминалом, с которого можно получить доступ к множеству различных компьютеров, наверное, это будет не слишком-то разумно.

Данная уловка может не сработать по многим причинам, но на установку требуется немного времени, так что последующее, порой долгое, ожидание, может оправдать себя.

Если вы решитесь проделать такой трюк, помните следующие моменты: сделайте все, что только окажется в ваших силах, чтобы было легче читать с экрана на расстоянии. Включите клавишу “Caps Lock”, если понадобится. Увеличьте яркость экрана, если сможете. Слегка разверните монитор, чтобы вам не мешали отблески, когда вы станете смотреть под своим углом зрения. Если удастся, выберите шрифт покрупнее. Прежде чем выбрать место, откуда вы будете наблюдать, убедитесь, что сидяший за компьютером человек не закроет собой экран. Во избежание подозрений займите себя чем-нибудь на время ожидания, но смотрите, не увлекитесь, чтобы не упустить свою “дичь”.

подглядывание через плечо

Два вышеописанных метода являются слегка измененной разновидностью того, что называется “подглядыванием через плечо”. “Подглядывание через плечо” означает, что хакер просто подглядывает через плечо легального пользователя, пока тот загружается в компьютерную систему. Он смотрит на то, что пользователь набирает на клавиатуре, чтобы подглядеть пароль. Помните, что большинство загрузочных процедур не высвечивает пароль на экране, так что для получения какой-либо полезной информации вы должны смотреть именно на клавиатуру.

“Подглядывание через плечо” в чистом виде можно осуществить только при определенных обстоятельствах, например, если вы на законных основаниях помогаете пользователю при решении его проблемы, и для этого стоите за его спиной, в то время как пользователь показывает вам, что произошло. В большинстве случаев вы не сможете долго простоять за чьим-то плечом, не вызвав подозрений; значит, придется прибегнуть к дополнительным ухищрениям.

Можно воспользоваться зеркалом, расположенным в соответствующем месте — верхнем углу комнаты между стеной и потолком. Зеркальце должно быть достаточно небольшим, чтобы его можно было приклеить клейкой лентой, но и не настолько маленьким, чтобы нельзя было рассмотреть отражение на расстоянии.

Воры телефонных карточек иногда используют бинокль, чтобы разглядеть кодовые номера других людей, тем самым получив возможность бесплатно звонить на дальние расстояния. Вы можете поступить также для прочтения паролей, вводимых с клавиатуры. Может возникнуть необходимость придать клавиатуре определенное положение, чтобы вам лучше было видно, что вводит пользователь. Если у клавиатуры есть подставки, поставьте ее на них, прежде чем занять свой пост.

Вы можете вести свои наблюдения и снаружи, через окно. Но убедитесь сперва, что изнутри вас не видно. Если здание освещается снаружи, вас нетрудно будет заметить, даже когда стемнеет. ао того, как заняться взломом, проделайте кое-какую детективную работу: зайдите в компьютерный зал и посмотрите, можно ли оттуда разглядеть того, кто находится снаружи. Возможно, вам удастся частично, закрыть шторы или жалюзи, чтобы дополнительно загородиться от наблюдения. И, наконец, поразмыслите вот над чем. Может быть, мои советы вам и не пригодятся. В течение последних двух недель я ежедневно посещал компьютерные классы одного учебного заведения, и каждый раз обнаруживал хотя бы один терминал, включив который, я оказывался в чьем-то бюджете. Видимо, владельцы бюджетов не знали, что простое выключение терминала не означает выхода из бюджета. Иногда таких терминалов было даже несколько. Ну чем не рай для хакера!

использование БЕЙСИКа

Если у вас есть бюджет — или если вы, зайдя в компьютерную лабораторию, обнаружили, что кто-то загрузился и ушел — вы можете написать простую программу на БЕЙСИКе для имитации входных процедур, и оставить ее работать.

Не забудьте ввести в программу соответствующие временные задержки, так как обычно на регистрацию команд уходит несколько секунд, а также заставить программу печатать звездочки (точки, тире и т. п.) вместо пользовательского пароля.

Иногда еще до загрузки можно использовать такие команды, как получение информации о том, кто еще в данный момент находится в системе. Возможно, вам удастся запрограммировать ложные ответы на запросы пользователей, а возможно, и нет. Впрочем, программу необязательно делать слишком “навороченной”, так как большинство пользователей, вероятно, просто сядут за компьютер и загрузятся. Можно посидеть в компьютерном классе и понаблюдать, какие команды используются наиболее часто, чтобы на их основе запрограммировать имитации.

После того как пользователь введет имя и пароль, программа должна сохранять информацию и выходить из вашего бюджета. Если вы написали программу в чужом бюджете (вроде тех, уже загруженных, о которых я упоминал), то программе придется как-то переносить данные в ваш бюджет. (Методы тайного переноса данных обсуждаются в главе “Что делать, когда вы оказались внутри”.) Ведь, выйдя из бюджета, вы не сможете загрузиться снова. С другой стороны, ОС может позволить вам сохранить файл в вашей собственной директории, если вы дадите ей правильные коды доступа, или если вы сможете временно сделать свой бюджет менее защищенным, чтобы другие пользователи могли записывать данные в вашу директорию.

Важно помнить о хакерской безопасности — никогда не знаешь, следит пользователь за твоими действиями или нет. Значит, прежде, чем помешать в свою директорию файл со столь изменчивой информацией, как чужие пароли, будет разумным ее закодировать. Я использую простую кодировку: сохраняю каждый символ в виде 13 + ASCII-код, а каждое второе число является случайным. Значит, комбинацию имя, пароль, скажем, SMITHERS,RANGERS моя программа сохранит в виде: 96 90 86 97 85 82 95 96 , 95 78 91 84 82 95 96, со случайными числами между каждой цифрой.

Развитие этих идей вы найдете в следующей главе.

Аппаратные методы

Однажды я откопал на складе технического оборудования старый, ненужный терминал, и подключил его к своему портативному компьютеру. Около четырех утра я притащил все это в компьютерную лабораторию и заменил стоявший там терминал на свой, соединенный кабелем с портативным компьютером.

Портативный компьютер я спрятал под столом. Это был деревянный стол с выступающей крышкой. С помощью электрического скоросшивателя я сделал из старых джинсов с отрезанными штанинами мешок, который подвесил к внутренней стороне стола, и поместил туда портативный компьютер. Этот компьютер должен был сохранять на диске первые десять символов, которые появятся после строк “Username:” и “Password:”. Таким образом, компьютер действовал как следящее устройство, работая как посредник между терминалом и мэйнфрэймом. Работа шла успешно.

У меня возникли затруднения только тогда, когда через неделю я заменил терминал на тот, что был в компьютерном зале: какой-то парень решил, что я пытаюсь его стащить.

Бывали случаи, когда хакеры брали старые терминалы, снимали с них пластиковый чехол и помешали внутрь маленькие компьютеры! Сам я так не делал, поскольку в используемых мною терминалах было слишком мало места, но в определенных ситуациях это вполне возможно. Надо только убедиться, чтобы компьютер и идущие от него провода не перепутались с внешними выходными проводами “глупого” терминала. Когда хакеры прячут свои портативные компьютеры подобным образом, они обычно помешают свой компьютер в какой-нибудь пустой чехол от терминала.

универсальные МикроЭВМ

Ну вот, мы добрались до Компьютера Общественного Доступа третьего типа, который я включил в список несколькими страницами раньше — универсальной микроЭВМ. Здесь я поведу речь об IBM и машинах с MS-DOS, хотя среди общедоступных машин теперь можно все чаше увидеть и “Маки”. Конечно, приемы, о которых я расскажу, можно видоизменить в соответствии с любым компьютерным оборудованием.

Допустим, вы вызвали вашу местную библиотеку и хотите использовать тамошний компьютер для обработки текста, деловых нужд и т. п. Обычно эти машины не входят в сеть, хотя, если в библиотеке их несколько, они могут быть подсоединены к одному и тому же принтеру или другому периферийному устройству. В колледжах программы обработки текстов могут размешаться на диске, защищенном от записи, — на каком-либо мэйнфрэйме или микроЭВМ. Сейчас появились также конторы, куда люди могут прийти, чтобы заказать компьютерное время и набрать свои отчеты или доклады, а затем распечатать их на лазерном принтере. Подобные заведения вполне могут послужить на благо хакера.

прорыв

Первое, что можно заметить на этих микроЭВМ — это некое подобие системы меню. Хозяевам места, где находятся компьютеры, вовсе не хочется, чтобы какой-нибудь сопляк пришел и переформатировал их жесткие диски, или оставил после себя непристойные сообщения, поэтому против подобной деятельности используются определенные средства зашиты. Вообще-то выйти из программы меню—дело нехитрое, несмотря на то, что сама программа — хотя бы частично — предназначена для того, чтобы вы этого не делали.

Если компьютер уже включен и вы находитесь в главном меню, поглядите, нет ли на экране каких-нибудь знаков или команд, которых там быть не должно, вроде “Alt-X to Quit”. Попробуйте это набрать — сработает или нет? Можно выйти из меню и получить лишь сообщение: “Ошибка! Нажмите любую клавишу, чтобы вернуться в меню”. Произошло следующее: когда утром компьютер был впервые включен, система меню была вызвана файлом AUTOEXEC.BAT. Нажав Alt-X, вы возвращаетесь в командный процессор AUTOEXEC.BAT, и изучаете следующую строку ВАТ-файла. Просто нажмите Ctrl-С, чтобы выбраться оттуда.

Даже если на экране нет никаких указаний по поводу выхода из меню, можно попробовать различные функциональные клавиши — Ctrl-Break, Escape, а также различные комбинации Alt и Ctrl с С, Х и Q.

Часто системы меню предлагают ввести пароль, прежде чем разрешить вам выйти в ОС. Если именно так обстоят дела на том компьютере, который вы взламываете, обязательно попробуйте различные пароли — начните с пустых линий, названия здания или компании, и других явных слов, имеющих отношение к работе и бизнесу.

Компьютерные системы более всего уязвимы в тот момент, когда переходят от одной программы к другой. Поэтому стоит попробовать выбрать пункт меню и нажать Ctrl-C сразу же, как только сделаете выбор. Чтобы добиться лучших результатов, можно еще раз нажать Ctrl-C одновременно с Ctrl-Break.

Если ничего из вышеперечисленного не сработало, выключите компьютер, затем снова включите и посмотрите, не удастся ли с помощью Ctrl-C или Ctrl-Break выйти из начальных процедур AUTOEXEC.BAT.

Или можно подготовить дискету с готовой к загрузке программой. Если ни та, ни другая тактика не поможет, используйте систему меню для запуска различных указанных в ней программ и посмотрите, нет ли в одной из них выхода в операционную систему.

свобода - это свободное передвижение

Как только вам удастся выйти из системы меню, вы сможете исследовать компьютер.

Если вокруг вас бродит много сведущего в компьютерах народа, или кто-то заглядывает вам через плечо, или в помещении появилось начальство, можно вернуться в разрешенные области, чтобы вас не вышвырнули из здания, когда обнаружится, что вы пролезли в запретную зону.

Я рекомендую скопировать все, что вас интересует, на дискеты и взять их домой, чтобы спокойно просмотреть. Так взломщик уносит с собой весь сейф целиком, чтобы у себя вскрыть его с помощью газовой горелки.

Сначала скопируйте AUTOEXEC.BAT и систему меню, а также любые найденные директории, которые содержат файлы с расширениями ВАТ, DOC или ТХТ; разнообразные дисковые утилиты; все, что имеет хоть какое-то отношение к телекоммуникациям;

резидентные программы; понятные текстовые файлы.

В особенности, если компьютер подсоединен к локальной сети, на нем могут быть диски D:, F:, H:, L:, или любые другие диски, обозначенные последними буквами алфавита, которые вы обычно даже и не подумаете искать. Поищите спрятанные файлы и директории, и если найдете, скопируйте их тоже. Взгляните также, не были ли уничтожены какие-то файлы, и постарайтесь восстановить их, возможно, они окажутся нужны вам.

В зависимости от ситуации — типа компьютера, того, где он находится, других имеющих значение факторов вы можете что-то найти, а можете и ничего не найти. Чаше всего вся польза от взлома общественного компьютера заключается лишь в волнующем удовольствии преодоления компьютерной зашиты. Впрочем, зачастую компьютеры бывают настолько плохо защищены, что и удовольствие-то оказывается слабеньким.

Я часто находил многопользовательские утилиты, которые не видел никогда ранее, так что стоит совершать такие взломы просто ради того, чтобы посмотреть, не найдется ли чего-нибудь новенького в этом духе. Вы, возможно, даже почерпнете какие-либо новые программистские идеи — некоторые из найденных вами ВАТ- и INIT-файлов могут оказаться на редкость сложными.

Еще в системах часто бывает можно найти программы внутреннего использования — такие, как списки и базы данных сотрудников, или другие программы, недоступные для посторонних и предназначенные только для управляющих учреждением или библиотекой.

Если, исследуя компьютер, вы постоянно натыкаетесь на приглашения о вводе паролей, попытайтесь выяснить, где на диске хранится основной список паролей. Однажды я выбрался из общественной программы меню специализированной библиотеки, и, оглядевшись, обнаружил тщательно спрятанный файл под названием PASSWDS. Выведя его на экран, я с удивлением увидел список, состоящий из шести или около того имен пользователей, вместе с их паролями, адресами и другой личной информацией. Поначалу я, конечно, был вне себя от радости, но мне до сих пор невдомек, к чему там были эти имена. Я опробовал их во всех местных системах — безуспешно. Я попытался найти информацию об этих системных пользователях на главных компьютерах с помощью команды “finger” UNIX, но ничего не получилось. Казалось, люди из списка вообще не существовали, где бы я ни искал!.. Возможно, кто-то просто использовал этот файл в качестве теста, или “демонстрашки”, или в какой-нибудь частной компьютерной системе.., но зачем же его тогда так хорошо спрятали?

Иногда такие вот отвлекающие зацепки играют роль следов, которые никуда не ведут. Здесь все дело в том, чтобы выяснить, что же вам требуется. Хакер-ство часто заключается в интенсивных исследованиях, когда целью является установление гипотезы, вопроса, который требует ответа. Как только вы поставите такой вопрос (“Будет ли этот список паролей работать на Raamses 3?” “Есть ли у секретаря президента Moroll Corporation системный доступ?”), вы можете переходить на более высокий уровень исследований и пытаться ответить на него.

Снаряжение для взлома компьютеров общественного ДОСТУПА

Прежде чем отправляться в экспедицию на взлом общественных компьютеров, подготовьте и захватите с собой ваш PACK: Public-Accessible Computer (hacking)

Kit — снаряжение для взлома компьютеров общественного доступа. Это снаряжение должно включать в себя:

• много чистых, отформатированных дискет, как 3 1,2-, так и 5 1,4-дюймовых, чтобы можно было быстро скопировать защитные программы меню. Проверьте, подойдут ли эти дискеты по формату к тем дисководам, которые вы будете использовать.

• внешние программы, такие, как Norton Disk Doctor и другие утилиты. Не помешает захватить также любые специальные программы, которые вы напишете (вроде моделей меню, о которых пойдет речь в следующем разделе). Посредством общедоступных программ можно отключить внешний громкоговоритель. Это может оказаться полезным, если вы взламываете компьютер, который издает громкий подозрительный сигнал всякий раз, когда вводится неверный пароль.

• другие инструменты: лучше всего нож, хотя сойдет и небольшая отвертка. Очень часто, особенно на АРМах с CD-ROM, вы обнаружите замки или крышки, прикрывающие дисководы для ограничения доступа. Для взлома “Макинтошей” удобна большая, не погнутая канцелярская скрепка. Если вам надо срочно сматывать удочки, можно просунуть кончик скрепки в отверстие рядом с дисководом, и ваша дискета выскочит. Зачастую это оказывается самым быстрым способом извлечь дискету.

модели меню и другие уловки

Почти все универсальные компьютеры общественного доступа в целях зашиты и для простоты оснащены программой меню. Существуют три “многообещающие” программистские идеи, которые хакер может применить в данном случае:

• изменение меню,

• изменение программы меню, и

• создание собственной модели систем меню.

Программы меню снабжены опцией редактирования. Это позволяет людям, которые занимаются техническим обслуживанием компьютера, создавать категории меню, такие, как “Деловые программы”, “Текстовые редакторы” и т. п., а также добавлять и редактировать программы общественного доступа. Способ заставить меню работать на вас состоит в следующем: вы используете возможность редактирования, чтобы изменить или добавить опцию, которая должна отсылать пользователя в область, где требуется пароль. Между тем, на самом деле меню будет отсылать пользователя к программе, написанной вами и представляющей из себя модель окружения, знакомого пользователю. Ничего не подозревающий пользователь вводит свой пользовательский ID и пароль (который сохраняет ваша программа), после чего получает сообщение об ошибке и снова оказывается в меню. Затем вы можете отправляться в то место, где компьютер прячет пароли и идентификационные номера, и использовать их, как вам заблагорассудится.

Но здесь возникает вопрос: каким образом можно отредактировать меню?

Свойство редактирования меню может являться частью программы, такой, как INSTALL.EXE иди SETUP.EXE. Возможно, вам удастся произвести редактирование непосредственно из самой программы меню, путем нажатия функциональной клавиши или набора управляющего кода.

Проблемы возникают потому, что вообще-то не положено иметь возможность изменять установку меню на компьютерах общественного доступа. Свойство редактирования меню может быть удалено при установке меню, либо для подобных вещей может требоваться пароль.

Может быть, вам удастся заново инсталлировать программу, восстановив существующее меню и сделав в то же время свои собственные добавления (мы вскоре обсудим этот момент). Или же у вас будет возможность использовать тестовый редактор или программу-адоктор” для изменения того файла, в котором хранится информация меню. Если при попытках изменить файл вы начнете получать сообщения об ошибках, попробуйте использовать для “блокировки” файла команду ATTRIB. Для “разблокировки” достаточно набрать “attrib filename -r” (на машинах с MS-DOS). В соответствии с характером работы этих программ тому, кто занимается редактированием, необходимо обеспечить короткую фразу, которая выводилась бы на экран. Затем он должен выбрать файл, который будет использоваться при выборе этой фразы, возможно, задав путь на диске и другую информацию.

Предположим, вы решили “просочиться” в компьютерную систему университета. В качестве начальной цели вы избрали общественный компьютер с текстовым редактором, электронными таблицами и телекоммуникационными возможностями. Когда кто-либо садится за компьютер и выбирает пункт меню “Телекоммуникации”, его, или ее, либо соединяют с главным сервером, либо спрашивают, с каким компьютером он (или она) хотел бы соединиться. Затем устанавливается соединение.

Так все должно выглядеть снаружи. На самом же деле, когда пользователь набирает “Т” для выбора телекоммуникаций из меню, меню запускает программу, которую вы подсадили в систему — вместо того, чтобы действительно войти в сеть.

Программа, которую вы “подсовываете”, должна выглядеть так, как будто она делает все то, что обычно происходит, когда кто-то выбирает из меню пункт “Телекоммуникации”. Например, она может спросить, с каким компьютером хотел бы соединиться пользователь, а затем сделать вид, что устанавливает соединение с этим компьютером. После этого программа выдает приглашения к вводу имени и пароля, и записывает эти замечательные слова на дискету!

Затем можно заставить программу выдавать сообщение об ошибке и возвращать пользователя в главное меню, но это будет выглядеть подозрительно, и заставит ответственных за систему людей повнимательнее присмотреться к установкам своего компьютера.

Лучше, если ваша маленькая моделирующая программка будет вызываться из ВАТ-файла. При ее использовании следующим шагом в ВАТ-файле может быть реальное соединение с системой. Можно заставить ВАТ-файл вводить имя и пароль, введенные пользователем, ликвидировав, таким образом, все странности. Или же пусть он выдает стандартное сообщение “пароль неверен”, а уже потом соединяется с сетью.

В других случаях опция “Телекоммуникации” может отсылать пользователя к коммерческому терминальному пакету, вроде ProComm Plus или SmartCom. И в данной ситуации вам тоже не составит труда создать вашу собственную ложную версию одной из этих программ. Но тут подстерегает ловушка. Когда пользователь войдет в вашу фальшивую терминальную программу, он должен будет выбрать телефонный номер из списка и попытаться связаться с ним. Пользователь будет весьма смущен и у него сразу же возникнут подозрения, если динамик будет включен, но не издаст ни единого звука, сопутствующего соединению! (Не забывайте, что вам каким-то образом придется заставить вашу программу выходить на связь, чтобы потом вы могли смоделировать вызванную сеть. После этого пользователь введет пароль, думая, что действительно подсоединился к сети.)

Наиболее разумный способ разрешения этой дилеммы — сделать так, чтобы программа выдавала экзотическое сообщение об ошибке, типа:

Operating Error 2130: Line Noise Interference Shut off your speaker and try again.

Конечно, это сообщение должно как можно больше походить на другие сообщения об ошибках, те, что на самом деле выдает терминальная программа.

Когда пользователь выключит динамик, программа может симулировать соединение и выдать стандартный загрузочный экран соответствующей сети. И вот имя и пароль взяты и записаны на дискету, после чего выдается сообщение об ошибке и пользователь отсоединяется.

Возможно, вам придется заставить компьютер просто выдать на экран кучу бессмысленных случайных символов после того, как имя и пароль будут введены. Постарайтесь, чтобы эта мешанина выглядела достоверно — что-то вроде помех на линии, с которыми время от времени приходится сталкиваться каждому — но не казалась чрезмерной. Пользователю придется отключиться практически немедленно. Если же он этого не сделает, или попытается сделать что-то другое, на экране компьютера должно появляться стандартное сообщение: “Logged off. Good bye!” В этот момент компьютер может загрузить настоящую терминальную программу, так что будет казаться, что ничего особенного не произошло.

Как правило, на общественных компьютерах не бывает коммерческих терминальных пакетов, в основном потому, что если они есть, люди приходят и начинают звонить чуть ли не всему свету. Но они могут оказаться в офисах и конторах, значит, решив отправиться “на местность”, не забудьте прихватить с собой эти идеи.

А теперь давайте вернемся к программе меню.

Программа меню необязательно является коммерческой версией. Она может быть создана на месте, либо написана на интерпретируемом языке вроде Бэйсика. Она может представлять собой и обычный ВАТ-файл.

Если вы столкнулись с одним из вышеперечисленных случаев, вам удастся без особенных усилий изменить саму программу меню, либо создав подпрограммы, в которых будут храниться имена и пароли, либо добавив опцию телекоммуникаций, если таковая отсутствует.

Последний вариант уловки, связанной с меню — построение модели меню. Это означает, что, если вы окажетесь не в состоянии изменить уже существующее меню, вам придется написать программу, похожую на существующее меню, но с вашими дополнениями.

На воспроизведение программы меню у вас может уйти некоторое время. Если в меню используются всплывающие окна, вам придется написать подпрограммы для смены экрана, либо запрограммировать окна, которые открывались и закрывались бы частями. Вам следует внимательно разобраться с цветами экрана и специальными символами на экране, с тем, как настоящая программа обращается с ошибочными данными, и с другими тонкостями меню.

Хотя программирование может оказаться сложным, вам все же лучше использовать собственное меню, так как тогда вам будет легче прятать захваченные пароли и другие полезные веши, получение которых, вообще говоря, и является основной целью данного проекта.

Как СПРЯТАТЬ Вашу “КОРЗИНКУ С ПРЯНИКАМИ”

Все вышеописанные методы работы; с меню, равно как и многие технические приемы, описанные ранее, предполагают воспроизведение последовательности загрузки в сеть и захвата нажатий клавиш, в результате чего на диске сохраняется соответствующий файл. Здесь следует беспокоиться о двух вещах: о том, что ваш файл обнаружат, и о том, что ваш файл прочтут. Давайте посмотрим, как же нам предохранить себя от этих двух событий.

Дело в том, что, так как все происходит на общественных компьютерах, ваши драгоценные файлы может обнаружить кто угодно. В число “кого угодно” входят те, кто несет ответственность за обслуживание, те, кто налаживает конфигурацию компьютеров, другие хакеры, и просто любопытствующие личности со стороны. Файлы может обнаружить и сам компьютер.

Большинство общественных компьютеров, которые могут вам встретиться, оснащены чистящими подпрограммами. Еженедельно, ежемесячно, а порой и еженощно компьютеры стирают все свои старые файлы данных, дабы освободить место на диске для нового материала.

К большинству общественных компьютеров с текстовыми процессорами приложены записки с просьбой пользователям приносить свои собственные дискеты, чтобы сохранять на них свою работу, но обычно существует специальная пользовательская директория USERS, либо какое-то другое место, куда любой может записать свои файлы.

Чистящая программа используется для удаления из таких директорий старых файлов. Эта программа часто сканирует и остальную часть диска, уничтожая файлы, которые хранят пользователи в других директориях. На общественных компьютерах часто можно видеть десятки пустых директорий в разных местах;

как правило, эти директории имеют человеческие имена. Это частные директории, которые люди создают для себя в надежде, что другие пользователи не станут читать или уничтожать их файлы — при этом совершенно не понимая того, что их файлы все равно будут, уничтожены самим компьютером. Зачастую чистящая программа не соображает, что и саму директорию тоже следует уничтожить.

Прежде чем располагать на общественном компьютере вашу программу меню, или что-либо другое, необходимо провести некоторые эксперименты, чтобы посмотреть, какой системой очистки располагает данный компьютер — если таковая имеется вообще. Нет смысла тратить многие часы на разработку проекта только затем, чтобы его стерли вскоре после того, как он будет реализован на компьютере.

Если на компьютере действительно есть чистящая программа, вам надо скопировать ее вместе с прочими вещами в самом начале ваших исследований данного компьютера. Взгляните на программу; вероятно, найдется множество способов ее обезвредить. Возможно, чистящая программа снабжена файлом данных, который содержит информацию о том, какие директории следует просмотреть, что необходимо сделать, если обнаружатся просроченные файлы, дату, по истечении которой файл становится “старым”, и другие подобные переменные. Вероятно, вам удастся приспособить этот файл для своих нужд, изменив его таким образом, чтобы “чистильщик” обходил своим вниманием вашу специальную директорию или программу.

Если чистящая программа запускается на компьютере автоматически, в ходе исследований вам необходимо найти “спусковой крючок”, который ее запускает и заставляет уничтожать только определенные файлы. Например, чистящая программа может быть соединена с функцией окончания сеанса, так что до того, как компьютеры выключаются на ночь, диски подвергаются сканированию и нежелательные файлы перемешаются. Чистящая программа может также задействоваться в качестве части стартовой подпрограммы, либо регулярно осуществляемого технического сопровождения. В любом случае, внимательное исследование файлов в системе позволит установить порядок, которому они следуют. Как только вы найдете программу, отключающую “чистильщика”, вы сможете изменить свой собственный файл таким образом, чтобы он не уничтожался, а игнорировался. Чистящая программа часто представляет собой монстра “все — или ничего”, который стирает все на своем пути , пересекая жесткий диск. Между тем, существуют и более деликатные версии, которые просто стирают старые файлы. Обойти этих “джентльменов” можно, написав несложную программу. Вот пример ВАТ-файла MS-DOS, который изменяет дату вашей спрятанной “корзинки с пряниками” из примера (в котором текстовый файл обозначается “filename”) на более позднюю. Подсоедините этот ВАТ-файл в конце AUTOEXEC.BAT, либо поместите в подпрограммы системного сопровождения непосредственно перед запуском “чистильщика”. И тогда ваш файл никогда не сотрут.

©ECHO OFF

CTTY NUL

DATE <COMMAND1> TEMP

EDLIN TEMP <COMMAND2

DATE 12-31-1999

EDLIN FILENAME <COMMAND3

EDLIN COMMAND 1<COMMAND3

EDLIN COMMAND2<COMMAND3

EDLIN COMMAND3<COMMAND3

DATE <TEMP

DEL *.BAK

DEL TEMP.*

CTTYCON

Чтобы это работало, вам следует создать три вторичных файла. Здесь они носят названия “сот-mand1”, “command2” и “command3”, но вы можете придумать для них и более невинные прозвища. “Commandl” содержит только возврат каретки (Control-M). “Command3” — файл, содержащий только букву “е”. “Command2” несколько длиннее:

2d

1 rCurrent date is

1rSun

1rMon

IrTue

1rWed

1rThu

1rFri

IrSat

ВАТ-файл работает, используя команду “date” для изменения даты на 31 декабря 1999 года. EDLIN задействован для сохранения файла с паролями (то есть с вашими “пряниками”) и трех вторичных файлов под новой датой, в целях их зашиты. В конце дата возвращается в нормальное состояние. Имейте в виду, что MS-DOS может быть установлена на представление даты в различных форматах. Если компьютер, к которому вы “прицелились”, имеет необычные установки, вам придется изменять ВАТ-файл и “Command2”. Учтите также, что “temp” является распространенным именем файла. Лучше подышите для своей программы что-нибудь более экзотическое.

Файлы AUTOEXEC.BAT часто подвергаются изменениям, и ВАТ-файл, подобный приведенному в примере, скорее всего, будет замечен обслуживающим компьютер персоналом. Чтобы ваши программы остались тайной, вам, возможно, придется хранить этот и ему подобные ВАТ-файлы в отдельном файле на жестком диске, подальше от AUTOEXEC.BAT. В том месте файла AUTOEXEC, где будет задействован ваш “троянский” ВАТ-файл, вы можете использовать команду “call” системы DOS (“call BATCH.BAT” задействует вашу “лошадку” и, по окончании ее работы, вернет в файл AUTOEXEC.BAT). Ваш ВАТ-файл может быть соответствующим образом закамуфлирован, так, как это описано ниже, а в файле AUTOEXEC.BAT внимание техника сможет привлечь разве что одна-единственная ложная строка.

Не забудьте, что в некоторых операционных системах, таких как MS-DOS, можно использовать команду “ATTRIB”, чтобы сделать имена файлов невидимыми в списке директорий (a “attrib FILENAME +h снова делает их видимыми). Такое сокрытие имени файла не является действительно безопасным, так как существует множество способов, с помощью которых кто-либо может случайно или намеренно найти спрятанные файлы на жестком диске. Но такое удаление имени из директории, несомненно, значительно снижает риск случайного обнаружения ваших “троянских” файлов.

чего следует остерегаться

Я хочу перечислить несколько вещей, которых следует опасаться при применении подобной программы. Мои замечания будут касаться приведенной в примере программы, но они достаточно универсальны, чтобы распространяться на любую похожую программу, которую вы спрячете в системе.

Во-первых, убедитесь в присутствии EDLIN, равно как и DEBUG, TREE и других внешних команд DOS. Они не обязательно являются доступными на используемом вами компьютере, так что вы можете влипнуть, если ваши намерения откроются. При попытке скопировать эти файлы вы можете обнаружить, что директория DOS защищена от записи. В этом случае придется помешать необходимые команды в альтернативную директорию. Это может подставить их под “нож” чистящей программы. Если чистильщик действительно уничтожит эти внешние команды, вам придется придумывать, как разместить их на диске, в то же время обезопасив от “чистильщика”. Этот ВАТ-файл работает только для текстовых файлов — двоичные файлы EDLIN испортит.

Во-вторых, прежде чем действовать, убедитесь, что директория DOS находится в PATH. Это означает, что, для того, чтобы конкретный файл можно было использовать, он должен быть расположен либо в текущей директории, либо в директории, которая была определена (обычно с помощью AUTOEXEC.BAT) как место, где ОС ищет файлы для запуска. Конечно, это не проблема — просто добавьте оператор PATH или CD перед первой EDLIN — но такой момент вы можете просто-напросто проглядеть, особенно если вам приходится самостоятельно добавлять специальные команды в необычную или незнакомую директорию.

Проверьте также перед тем, как инсталлировать какие бы то ни было программы: хватит ли места на диске? Хватит ли памяти? Не пытается ли программа создать временный файл в закрытой директории? (Если это так, откройте temp в директории USERS, или в любой другой не защищенной от записи директории). Не существует ли уже файл с названием “temp”? А как насчет “Command!”, “Command2”, и “Commands”? Существуют иные пути использования этой програма-боты программы-“чистильщика”, она может запускаться каждый раз, когда вносятся изменения в файл с паролями. Правда, это отнимает несколько секунд, и этого времени может оказаться достаточно, чтобы ощутимо замедлить работу прикладной программы пользователя. Не забывайте, что предполагалось использование данной программы во взаимодействии с каким-нибудь “троянским конем”, который вы инсталлируете; “конь” и так замедлит работу компьютера, а уж задержка, вызванная взаимодействием двух программ, вряд ли останется незамеченной.

Чистящая программа может использовать и другие критерии при принятии решения о том, какие файлы убрать, а какие оставить. Вам придется использовать схожие приемы программирования, чтобы соответственно приспособить свою программу.

Если специальная чистящая программа отсутствует, значит, жесткий диск очищается вручную. Возможно, этому человеку и не хватит ума в поисках файлов заглянуть за пределы вышеупомянутой директории USERS, но безопаснее считать, что этот человек не глупее вас. Да и вообще, вам ведь неизвестно, кто еще, кроме вас, пользуется общественным компьютером, а значит, вам следует принять меры и спрятать свои драгоценные файлы с паролями подальше от чужих глаз. Вот несколько предложений на эту тему:

Измените атрибут “спрятанных файлов” так, что он не будет значиться в директории.

Поместите его в тайную или недоступную директорию. Проведите такой эксперимент. Поместите следующие команды в ВАТ-файл:

:START MKDIR DIR CD DIR GOTO START

а затем запустите его из корневой директории. После того, как будут созданы шестнадцать вложенных директорий с именем “dir”, вы получите сообщение об ошибке. Нажмите Control-C и посмотрите на дело рук своих. Вы обнаружите, что внутри самой внутренней директории невозможно больше создавать директории — существует заложенный в компьютер предел. Впрочем, вы можете использовать утилиту обслуживания диска, или ваши собственные вызовы системы, чтобы перенести в самую “глубокую” директорию дополнительные поддиректории. Эти пересаженные директории нельзя будет задействовать или посмотреть из процессора DOS. Если чистящая программа использует команду TREE для просмотра всех директорий, она даст сбой или зависнет, добравшись до ваших нелегально перенесенных директорий. Этого нельзя допускать: такое событие приведет к обнаружению ваших секретных файлов, спрятанных внутри этой директории. К тому же такой фокус предполагает, что вы достаточно владеете программированием, чтобы самостоятельно написать программы удаления-переноса. Ваш “троянский конь” должен уметь переносить файлы данных из защищенного места и обратно.

А вот уловка, для применения которой вы наверняка знакомы с DOS в достаточной степени: закамуфлировать файлы, которые вы хотите обезопасить, внутри директорий, где они находятся. НИКОГДА не используйте названия файлов типа SECRET.PSW или HACKER.HA! Проявите капельку воображения. Зайдите в директории прикладных программ и взгляните, нет ли там подходящих названий. Например, если вы видите, что в электронной таблице имеются файлы под именами AFGRAB1.0VL, AFGRAB2.0VL, AFGRAB3.0VL, назовите свои файлы AGRAB4.0VL b AFGRAB5.0VL Вот тогда на них вряд ли обратят внимание. Файлы можно также разбить, разместить по разным директориям, но не забудьте указать пути в ВАТ-файле, который их использует.

“Троянские кони” на компьютерах общественного доступа могут стать отличным способом медленного, но верного способа сбора необходимых вам паролей. Впрочем, весь ваш труд пойдет насмарку, если, придя на следующий день, вы обнаружите, что все ваши файлы стерты. Умейте обезопасить себя и результаты своих усилий.

Читая про все эти программистские уловки, имейте в виду - я вовсе не хочу сказать, что вы действительно должны сидеть за компьютером и в открытую редактировать меню, или рыться в файлах в поисках паролей. НИКОГДА так не делайте! Вначале всегда следует провести предварительные исследования компьютера так, как я уже описывал. Тогда на начальной стадии исследований вы уже скопируете все важные и необычные файлы, и в вашем распоряжении будет вся программа меню целиком. Дома, где вас никто не потревожит, вы сможете написать все необходимые для этого типа хакерской атаки программы. Затем, закончив программировать и редактировать, вы можете вернуться к общественному компьютеру и на этот раз незаметно инсталлировать в систему измененные вами версии тамошних программ. Таким образом, уменьшится количество времени, которое вы проведете в общественном месте, проделывая неизвестно что с чужим компьютером. Снижается также вероятность того, что вы допустите ошибку в ваших действиях.

Следует соблюдать особую осторожность в отношении компьютеров, которые предназначены для использования лишь в течение коротких промежутков времени. Регистраторы посетителей, как указывалось ранее, используются лишь в течение нескольких секунд, которые уходят на то, чтобы пользователь ввел свое имя и идентификационный номер. Если вы станете крутиться около такого компьютера добрых сорок минут, делая какие-то записи и вставляя дискеты, это будет выглядеть весьма подозрительным.

Вам следует опасаться не других пользователей: им нет до вас никакого дела, а если что не так, они все равно, вероятно, примут вас за одного из сотрудников. В зависимости от того, где вы находитесь, вы даже можете особенно не бояться и того, что вас поймают менеджеры офиса или лаборатории, компьютерный персонал и другие тому подобные “официальные лица”. Если дело происходит в компьютерной лаборатории в колледже, за которой присматривают один-два студента, они могут вами заинтересоваться, но не станут слишком любопытствовать, если вы не проводите у компьютеров больше времени, чем вам положено. Никогда не стоит сразу раскрывать свои карты и признаваться, что да, вы — хакер, и сшиваетесь здесь, собирая данные для использования в своих целях. Для большинства из тех, кто может вами заинтересоваться, окажется вполне достаточным объяснение вроде: “А, я просто хотел посмотреть, как у них устроен ВАТ-файл”, или другое приемлемое обоснование в том же духе.

Некоторые компьютеры являются общественными;

но гораздо больше компьютеров находятся в частном владении. О них-то и пойдет речь в следующей главе.


Глава 6. Хакерство на местности

Внизу на тарелочке лежал незнакомый город. Он был нарезан аккуратно, как торт. Разноцветные утренние пары носились над ним. Еле уловимый треск и легчайшее посвистывание послышалось спешившим. антилоповиам. Очевидно, это сопели граждане. Зубчатый лес подходил к городу. Дорога петлями падала с обрыва.

— Райская долина, — сказал Остап. — Такие города приятно грабить рано утром, когда еще не печет солнце. Меньше устаешь.

И. Ильф, Е. Петров. Золотой теленок.

Помимо использования общедоступных компьютеров, обсуждавшегося в предыдущей главе, у хакерства на местности существует и другая сторона:

взлом частных компьютеров.

Конечно, просто войти в штаб-квартиру какой-либо компании и сесть за компьютер — довольно рискованное предприятие. Но зато как волнительно пробраться в охраняемое здание и исследовать как само здание, так и расположенные там компьютеры!

Иногда хакерство на местности бывает необходимым. Компьютеры часто не подключают к внешним телефонным линиям. В некоторых секретных системах личность пользователя проверяют с помощью специальной аппаратуры. Для получения доступа к такой системе вам, вероятно, придется использовать специальный модем, или чип, и т. п. В этих случаях вы будете вынуждены заниматься взломом на месте. К тому же, обратная социальная инженерия также часто предполагает посещение искомого компьютера. Су-

шествует множество причин, по которым хакеру необходимо встретиться с компьютером “лицом к лицу”.

Зачастую сделать это не так трудно, как можно подумать. Иногда бывает проше проникнуть в большую организацию, нежели в офис небольшой страховой компании или маленького предприятия. Но куда бы вы не стремились попасть, вам почти наверняка придется иметь дело с охраной, следящими камерами и биометрическими приборами (см. ниже), значительно затрудняющими доступ к компьютерам.

внутренние системы телевизионного наблюдения

Такие охранные системы относительно дешевы и широко распространены. В них обычно используется черно-белое изображение.

Камеры могут быть спрятаны, но не обязательно. Иногда на видном месте помешают неподключенную камеру, тогда как настоящая находится в другом, обычно неожиданном, чтобы взломщик, прячась от фальшивой камеры, попадал в поле зрения действующей. Порой для вида устанавливают только фальшивые камеры, тогда как настоящие вообще отсутствуют. Если вы видите, что несколько камер остаются неподвижными, в то время как остальные поворачиваются туда-сюда, они либо сломаны, либо являются фальшивыми.

Некоторые камеры заключаются в защитную оболочку. Это может быть обычная металлическая коробка, или нечто более подходящее к конкретному случаю, например, подделка под дымоуловитель, микрофон, фигурная решетка и т. д.

Занимаясь взломом, будьте осторожны со скрытыми камерами, хотя необязательно специально их отыскивать. Ведь вы не хотите, чтобы камера засняла вас крупным планом и в полный рост. Лучше всего гордо шествовать по запретным местам, не обращая специального внимания на углы и потолок. Если с потолка что-то свисает, отведите взгляд.

Многие системы телевизионного наблюдения не отличаются особым качеством изображения. Но некоторые, наоборот, дают превосходное изображение всего, что попадает в поле зрения камер. Если камера замаскирована, это может несколько снизить ее эффективность. Спрятанные камеры, как правило, стационарны и сфокусированы на одной точке — входе, выходе, определенном месте в зале.

Камеры иногда помешают и снаружи, под крышей или за дверью. Они бывают защищены с помощью навесов, вентиляторов и т. д. По бокам их часто покрывает алюминиевая оболочка с отверстиями. Наружные камеры приспособлены и для ночных съемок, так что вас могут засечь еще до того, как вы попадете внутрь здания.

Если вам абсолютно необходимо нарушить границы чьих-либо частных владений, чтобы добраться до их компьютеров, постарайтесь сделать это ненастной ночью. Видимость тогда будет плохая, лицо вы прикроете зонтиком, и, если вам удастся выбраться беспрепятственно, вас не выследят слишком быстро.

биометрические системы

Контроль над компьютерным доступом, основанный на личных характеристиках, является самым надежным — если, конечно, прибор исправен. Эти приборы, называемые биометрическими системами, контролируют доступ к компьютерам, иди помещению, где стоят компьютеры, путем проверки уникальных физических характеристик пользователя - отпечатков пальцев или ладони, тембра голоса, подписи, формы ладони, рисунка сосудов глаза и т. д.

Биометрические системы дороги, но срабатывают зачастую даже хуже телевизионных систем, как это ни странно. Тембр голоса может измениться из-за болезни, рисунок ладони меняется благодаря царапинам на коже и даже на стекле, к которому человек прижимает ладонь, да и личная подпись может изменяться от случая к случаю. Приборы, основанные на распознавании формы ладони, могут отвергнуть легального пользователя из-за бинта на пальце. Рисунок, образованный находящимися в глазах кровеносными сосудами, тоже в большой степени зависит от физического состояния пользователя.

Узнав про все эти недочеты, вы можете представить себе, каково работать в помещении, где при входе какой-то прибор каждый раз изучает твои глаза, или где надо говорить неестественно громко, чтобы включить компьютер. Уже через несколько дней это порядком надоедает, не говоря уже о времени, которое теряется при подобных процедурах.

Хотя сотрудникам и приходится подчиняться правилам прохождения такого контроля — например, за их действиями наблюдает охранник, — они используют малейшую возможность, чтобы махнуть на эти правила рукой. Людям нравится демонстрировать свое дружелюбие, показывая, что они отнюдь не являются частью этой дурацкой бюрократической машины своего предприятия. Им нравится держать двери открытыми, даже для чужаков. Они не думают, что кто-то может намеренно воспользоваться этим и проникнуть в помещение. К тому же, проработав определенное время в подобном учреждении, люди начинают испытывать чувство, что все их человеческие черты сведены к отпечаткам их пальцев.

Итак, эти дорогостоящие системы нередко стоят отключенными. Порой сотрудники даже задерживаются в дверях, чтобы пропустить вас, даже если до этого не видели вас ни разу в жизни.

Таким образом, наиболее эффективный способ зашиты легальных пользователей часто отвергается самими же пользователями. Что ж, это неплохо — по крайней мере, для хакеров.

ПУТЬ есть всегда

Вдумайтесь только, какое громадное количество государственных институтов тратит деньги на то, чтобы наблюдать за нами и вторгаться в нашу жизнь! Если власть предержащие захотят что-то сделать, узнать или изменить, это обязательно будет узнано, изменено или сделано.

Когда мы начинаем думать об этом, нам начинает казаться, что государственные структуры нельзя ни разрушить, ни остановить... ни взломать, а если кто-нибудь посмеет даже подумать об этом, его непременно посадят в тюрьму.

Да ничего подобного!

Государственные службы действуют в строго ограниченных рамках своих знаний и своих обязанностей. ФБР — мошная организация, но в ней тоже хватает своих дураков.

Считается, что с помощью современного оборудования правительство может заглянуть в нашу частную жизнь, словно в файл README.DOC. Считается, что государственные компьютерные системы неприступны. Многие из них вообще изолированы от внешнего мира и ни один хакер не может взломать их, связавшись с их компьютерами по обычной телефонной сети. Наиболее секретные государственные сети соединены с помощью оптоволоконных кабелей, проложенных глубоко под землей, и если даже кто-то сможет докопаться до них, сразу же прозвучит сигнал тревоги.

Конечно, это серьезная зашита, особенно, если вдобавок вспомнить еще и о множестве паролей, кодов доступа и т. д., необходимых для прочтения секретных данных.

Но не забудьте, что любую, даже самую сложную систему всегда создают люди. А людям свойственно ошибаться. Если после множества долгих спокойных ночей спящие охранники вдруг услышат сигнал тревоги, они могут и не отреагировать на него, продолжая спокойно спать. А если они встанут, чтобы проверить сеть, а тревога окажется ложной? И вторая, и третья тоже? Старая история про мальчика, который пугал волками односельчан, всегда оказывается права, особенно в ненастную ночь.

Была бы система — способ взломать ее найдется всегда. Вот некоторые из этих способов.

Хакерство на местности:как сыграть свою роль

Хакерство на местности требует определенной доли актерских способностей. Вам следует вести себя

так, словно у вас имеется веская причина находиться именно здесь и совершать именно те действия, которое вы совершаете. Это не так уж трудно. Шествуйте по коридорам с гордо поднятой головой, улыбайтесь и здоровайтесь с людьми, идущими навстречу. (Я научился этому трюку в школе, когда хотел беспрепятственно сбежать с уроков.)

Изо всех сил старайтесь держать себя в руках. Приготовьте какую-нибудь правдоподобную историю яа случай, если вас остановят и начнут расспрашивать. Ведите разговор в обычном темпе, без дрожи в голосе, и не забудьте ввернуть какое-либо специфическое словечко, распространенное среди сотрудников данной организации.

следование по пятам

Этот метод делится на две разновидности: электронное следование — вход в компьютер под именем последнего пользователя, который имел дело с системой, и физическое — использование права доступа других людей для получения доступа к компьютерам или в помещение, где они стоят.

Один из способов пройти в помещение, где для входа требуется магнитная карта, — просто стоять у входа и ждать, пока какой-нибудь обладатель карты не откроет вам дверь. Многие офисы вообще бывают открытыми ночью и в выходные, чтобы туда могли попасть уборшики и те, кто собирается поработать сверхурочно. Я особенно люблю посещать такие учреждения по воскресеньям. Достаточно подождать, пока какой-нибудь “трудоголик” не зайдет в дверь, оставив ее открытой. На пути вам может не встретиться ни единого человека, даже из технического персонала.

Прежде чем заняться “следованием по пятам”, подготовьтесь, чтобы не возбуждать подозрений. Наденьте деловую одежду и возьмите дипломат.

Однажды я нанялся на временную работу в один из крупных банков. Всю неделю, которую я провел там, я попадал внутрь вообще без какой-либо карты, а позднее и вовсе обнаружил запертую на простой замок дверь, которая вела в то же самое помещение.

другие полезные УЛОВКИ и трюки

Многие хакеры подбираются к интересующим их компьютерам, прикидываясь сотрудниками технического персонала. Захватите с собой стремянку, ведро краски и сделайте вид, что заняты работой. Этот метод лучше использовать в больших компаниях, где вас не станут особенно расспрашивать.

Можно получить доступ во многие учреждения с помощью агентств по временному найму. Даже если в первый раз вам не удастся подобраться к компьютерам, вы сможете заглянуть туда вторично, не вызвав лишних вопросов, и беспрепятственно исследовать здание. Особенно хороши учреждения с одинаковыми проходными комнатами, похожие на поднос для льда — множество углов, за которыми можно спрятаться, много полезной информации, и ни одной запертой двери!

Имейте в виду, что на некоторых компьютерах используются нестандартные ключи ввода данных. Так, вместо клавиши “ввод” после команды нажимается клавиша F1, и т. п. Оставленные без присмотра компьютеры часто встречаются в аэропортах. Зайдите за стойку и взламывайте, пока вас не засекли.

Прежде чем закончить рассказ о взломе частных компьютеров, я хотел бы затронуть еще одну область, косвенно связанную с данной темой.

пассивное электронное считывание данных

Хотя многие рассматривают хакерство исключительно как своеобразный вид спорта, пассивная обработка данных похожа, скорее, на созерцание спортивных соревнований по телевизору, чем на занятия спортом. Это сбор данных путем наблюдений за процессом работы легального пользователя.

Подключение одного или нескольких мониторов к одному и тому же компьютеру для наблюдения за ними не является большим техническим открытием. Если у вас есть доступ к компьютеру, на котором работает интересующий вас пользователь, вы можете подключить к его задней панели RF-адаптер и незаметно протянуть провод к другому монитору или телевизору. Затем вам остается только сидеть и смотреть, что происходит на экране искомого компьютера. Вам не удастся узнать паролей, поскольку на экране они будут заменены звездочками, пробелами и т. п., но вы сможете почерпнуть немало другой информации. Этот способ хорошо применять в том случае, если у объекта взлома много зашифрованных файлов, к которым у вас нет ключа. У вас на” экране будет появляться то же самое, что и у него, и если он расшифрует свои файлы, вы получите возможность их прочесть.

Далеко не всегда удается сидеть рядом с вашей “мишенью” со своим собственным монитором и вести наблюдения. Возможно, вам придется подключить к RF транслятор и устроиться снаружи с приемником, подключенным, в свою очередь, к экрану.

Если вы подключите к своему монитору видеомагнитофон, то сможете получить запись действий вашей “мишени”. Может быть, вам даже удастся подключить видеомагнитофон прямо к компьютеру, на котором будет работать данный пользователь. Если вы поступите так, постарайтесь обеспечить себе возможность свободно включать и выключать видеомагнитофон, чтобы запись не шла, пока компьютер выключен. Если у пользователя есть определенный распорядок работы, можно просто запрограммировать магнитофон на запись в это время.

Вывод информации с экрана не обязательно должен идти на другой экран; если у вас нет такой возможности, вы можете сделать вывод и на буферное запоминающее устройство принтера. Позаботьтесь о том, чтобы скорость принтера была достаточно высокой, либо он имел большой буфер, иначе компьютер замедлит свою работу по непонятной для пользователя причине. Ну и, конечно же, принтер следует разместить подальше от компьютера, лучше всего в другой комнате или здании.

Такой вывод можно устроить, например, с помощью опции “печатать с клавиатуры”, которая имеется во многих текстовых процессорах и заставляет принтер работать как обычную печатную машинку. Вы можете подойти к компьютеру и задействовать эту опцию, когда ваша “мишень” выйдет из комнаты, чтобы выпить кофе. Тогда все, что пользователь будет печатать на клавиатуре (в рамках текстового процессора), будет идти на принтер.

Нажав “Shift-PrintScreen” на любом компьютере с DOS, вы включите режим печати с клавиатуры. Правда, если при этом принтер не готов к работе, система может зависнуть.

Можно также войти в сеть и с помощью программы подключить выход искомого компьютера к вашему собственному терминалу. Если у вас есть пароль данного пользователя, главная вычислительная машина будет вынуждена разрешить загрузиться одному и тому же пользователю как бы дважды. Дополнительное программирование потребуется, если компьютер откажется выводить данные пользователя на ваш экран или, наоборот, начнет принимать ваши.

Если у вас имеется другой пароль, с помощью несложных программ можно послать изображение с компьютера “мишени” на ваш экран, и наоборот (если вы захотите подкинуть ему модель программы). В системах UNIX вам придется соответствующим образом изменять уже существующие программы TALK или WRITE. Эти две программы устанавливают связь между двумя независимыми бюджетами. Задача хакера — переписать эти программы, устранив защитные предосторожности.

Еще один способ — воспользоваться специальными контролирующими программами, которые можно купить или даже написать самостоятельно. Менеджеры офисов, как правило, следят за своими секретарями, клерками и другими операторами, когда те пользуются защищенными программами. Другие программы записывают, какое программное обеспечение использовалось, как и в течение какого времени. Для подобных исследований совсем необязательно возвращаться к избранному вами компьютеру, чтобы посмотреть, какие нажатия клавиш были записаны;

можно сделать так, чтобы программа пересылала их вам по электронной почте.

Как видите, программы, записывающие нажатия клавиш, могут доставить вам необходимую информацию без всякого пароля, хотя этот метод потребует от вас некоторых усилий и большого количества времени.

Можно также подсоединиться к телефонной линии, заняться перехватом микроволновых передач или телефонным прослушиванием, если позволяет модем. Тогда вы сможете еще и услышать телефонные разговоры пользователя. Можно с успехом подключаться к принтеру, модему и т. д.

Установив компьютер и подключив его, пользователи очень редко заглядывают за свою машину или под нее, так что ваш адаптер или выходной кабель останется незамеченным в течение длительного времени.

расшифровка излучения

Если, работая на компьютере, вы одновременно включаете телевизор, то, наверное, заметили, что при включенном компьютере на некоторых телевизионных каналах начинаются помехи. Этому есть простое объяснение. Все составляющие части компьютера — провода, усилители, даже печатные платы, — работают как антенны, проводящие электромагнитное излучение. Компьютер не только принимает излучение, но и передает, иногда перенося его на некоторое расстояние от источника, а близлежащая электропроводка и металлические трубки могут впоследствии работать как антенны.

Все компьютеры работают на радиочастотах и представляют собой радиопередатчики. Когда телевидение принимает сигналы от компьютера, это происходит случайно; а теперь представьте себе, что кто-то решил целенаправленно принимать такую излучаемую информацию. Конечно же, это возможно, и такие случаи бывали. Недаром компьютеры с наиболее засекреченной информацией устанавливают в комнатах с непроницаемыми для излучения стенами.

Существует замечательный электронный прибор, называемый прибором Ван Эйка. Он принимает пресловутое излучение и преобразует его в изображение на телевизионном экране. Вам останется лишь подключить к телевизору видеомагнитофон, и вы получите документальную запись всего, что происходит на интересующем вас компьютере.

Ван эйк и бриттон

В 1985 году группа шведских ученых под руководством Вильяма (“Вима”) Ван Эйка представила статью под названием “Электромагнитное излучение видеодисплеев: утечка информации?”. В статье описывалось, как можно легко и недорого переделать обычный телевизор в прибор для приема и преобразования информации, идущей с любого цифрового устройства, особенно компьютера. С идеей подобного прибора выступал еще в 1979 году ученый Дон Бриттон, но тогда ее не восприняли должным образом.

Мы с вами уже говорили о том, что радиоприемник может принимать мешанину сигналов, исходящих от проводов, печатных плат и так далее. Это верно, но бывает очень трудно, а подчас и невозможно отделить различные сигналы друг от друга и расшифровать их. Вам вряд ли удастся определить, о чем же “думал” компьютер, пока систему сотрясали электромагнитные импульсы.

“Импульсы” — вот ключевое слово. Всем известно, что компьютеры способны преобразовывать длинные строки нулей и единиц во что угодно (например, в наши любимые компьютерные игры). На самом деле, разумеется, по проводам не бегают крошечные нули и единички. По ним просто течет электрический ток различного напряжения, который наше воображение представляет как нули и единички. Любой электрический прибор является источником излучения. Но только цифровой прибор, такой, как компьютер, испускает импульсы высокого и низкого уровня напряжения.

Изображение на экране компьютера состоит из множества крошечных точек, называемых пикселями. Каждый пиксель представляет собой капельку определенного вещества, которая зажигается (флуоресцирует) под воздействием энергии, и покрыта защитным слоем. Контролирующая схема управляет позицией электронной пушки, которая периодически простреливает электронами весь экран, на короткое время зажигая те пиксели, которые должны засветиться. Каждый раз, когда это происходит, мы получаем импульс электромагнитного излучения с высоким напряжением. Идея Ван Эйка и Бриттона заключается в том, что телевизионный приемник воспринимает эти всплески высокого напряжения, производимые монитором, и зажигают пиксели в соответствующих местах телевизионного экрана. Прибор Ван Эйка осуществляет эту функцию с помощью обыкновенного телевизионного приемника, продуцируя искусственный синхронизирующий сигнал. Два регулируемых осциллятора используются для создания вертикальной и горизонтальной синхронизации. Для качественного приема требуется постоянная перенастройка осцилляторов. Теоретически, это можно делать вручную, но мы живем в эпоху компьютеров: сигналы математически комбинируются и отправляются в логическую схему, которая проделывает всю работу автоматически.

Модель Ван Эйка основана на PAL-приемниках европейского стандарта, использующих напряжение того же стандарта, и включает в себя встроенный цифровой измеритель частот. Если вы обладаете познаниями в технике и захотите сделать такое устройство сами, оно обойдется вам в 10-15$.

Кроме осцилляторов и платы логического устройства, синхронизирующего сигналы, вам может понадобиться подключение прямой антенны для лучшей фокусировки. При использовании данных приборов необходимо точно настраивать свой приемник на точку комнаты, где можно отделить друг от друга множественные излучения... Это происходит из-за различий между компонентами, составляющими различные мониторы. Поймав однородные сигналы, нужные вам, старайтесь их придерживаться.

преимущества и недостатки

Прибор Ван Эйка действует на расстоянии около километра. Он дает возможность хакерам изучать компьютерные системы, ничего не изменяя и не разрушая. Но в тоже время этот прибор не дает возможности совершать взлом, но только наблюдать за тем, как работает пользователь. Пароли появляются на экране компьютера весьма редко, и вам не удастся самим просмотреть интересующую вас систему.

Традиционные методы хакерства — по телефонным сетям — позволяют преодолеть расстояние, гораздо большее, чем один километр. Об этом пойдет речь в следующем разделе.


Глава 7 Хакерство на дому

— Как приятно, — сказал Остап задумчиво, — работать с легальным миллионером в хорошо организованном буржуазном государстве со старинными капиталистическими традициями. Там миллионер — популярная фигура. Адрес его известен. Идешь к нему на прием и уже в передней отнимаешь деньги. Что может быть проше? Джентльмен в обществе джентльмена делает свой маленький бизнес. Только не надо стрелять в люстру, это лишнее! А у нас... боже, боже!.. У нас все скрыто. Все в подполье.

И. Ильф, Е. Петров. Золотой теленок.

Ну, вот, теперь мы добрались до самого главного (как многие считают). Вы включаете компьютер, через несколько мгновений он загружается; вы нажимаете несколько клавиш, набираете на клавиатуре телефонный номер, и после пары-тройки гудков раздается долгожданный сигнал соединения. Квитирование — это хорошо, но ведь вам нужно нечто большее.

Вы несколько раз нажимаете “ввод”, и у вас запрашивают имя. Вы вводите имя — разумеется, не свое, а кого-то другого. Затем ваши пальцы тихонько шепчут клавиатуре некий заветный секрет, и на экране появляется скатерть-самобранка.

Меню! Опции! Сколько возможностей! Файлы, которые можно прочесть и изучить; программы, которые можно запустить; игры, в которые можно поиграть. Вы пробегаете по директориям, заворожено наблюдая за их калейдоскопом. Так много всего, а еще можно соединиться с другими компьютерами, добраться до множества других засекреченных файлов! Вы улыбаетесь, потому что начали понимать:

каждый взлом, даже самый незначительный, приводит к новым взломам, новым компьютерам, новым исследованиям и находкам.

вернемся к реальности

Термин “хакерство на дому” не совсем точен. В наши дни большинство компьютерных взломщиков не занимаются взломами у себя дома, опасаясь запроса ID, следящих устройств, ловушек и федеральных агентов. Под “хакерством на дому” я подразумеваю феномен коммутируемых линий связи, благодаря которым можно установить связь с целым миром, не выходя из дома.

С кем Устанавливать СВЯЗЬ

С кем же конкретно вы можете устанавливать компьютерную связь? Вариантов очень много. Другие домашние компьютеры, мэйнфрэймы, мини-компьютеры, компьютеры компаний, государственных учреждений, клубов, — вы сможете связаться с любой организацией или частным лицом, имеющим компьютер и желание поддерживать компьютерную связь с другими.

Вам может также прийтись по душе вызов действующих в режиме онлайн баз данных и платных служб.

За удовольствие надо платить

Недавно один хакер по кличке “Бунтарь” жаловался мне, что всем его устраивает служба CompuServe, кроме одного — непомерно высокой платы за ее услуги. По этой же причине CompuServe часто переименовывают в CompuServe, заменяя заглавную S значком доллара. CompuServe не единственный торговец, предоставляющий пользователям оплачивать их громадные счета за рекламу. Существуют сотни служб, действующих в режиме онлайн, к которым вы можете присоединиться, или взломать, — что вам больше понравится.

Базы данных предоставляют для просмотра информацию на любую тему: новости, результаты переписи, рыночная информация, результаты правительственных исследований, научные и технические доклады, книги, личная информация, история и культура. Иногда я копался в них до поздней ночи в поисках какой-либо информации, необходимой для книги, или из простого любопытства. Вы можете войти в такую базу данных в любое время дня и ночи, и отыскать в ней то, что вам требуется. Конечно, это стоит немалых денег. За получение доступа к базе данных надо платить, а вдобавок существуют еще:

• Экранная плата за каждую порцию информации, появляющуюся на экране, либо плата за каждый запрос к базе данных.

• Почасовая плата в зависимости от времени, в течение которого вы были подключены к базе.

• Дополнительная плата за использование модема с более высокой скоростью передач (возможность получения большего количества информации за то же время).

• Плата за удаленные вызовы, в случае, если служба не имеет номера доступа в вашем регионе.

Многие хакеры не хотят оплачивать все возрастающие счета этих служб, в то же время, не желая прекращать пользоваться их услугами, в частности, потому, что извлекают оттуда много полезной специальной информации. Игры в режиме онлайн, электронная почта, телеконференции, электронные доски объявлений и многое другое делают платные службы привлекательными для хакеров. Их привлекает также множество способов избежать платы за предоставляемые услуги. В этой книге описаны многие из них.

Вам будет интересно узнать об уловке двух молодых кракеров из Нью-Джерси, бесплатно пользовавшихся услугами одной из подобных служб. Персональные компьютеры определенной марки продавались вместе с некоторыми программами, включая пробное членство в этой службе. Кракеры взломали систему одного из компьютерных магазинов, получив в свое распоряжение список покупателей, которые приобрели эти компьютеры. Многие покупатели являлись частными лицами или семьями, но среди них нашлось также немало магазинов и предприятий. Навестив эти предприятия, они пошарили по их конторам и задним комнатам. Само собой, на одной из книжных полок в дальнем углу лежал заклеенный конверт, который содержал руководство “Начало работы со StarBase On-line” и пробные коды доступа, прилагающиеся к компьютеру.

сети с пакетной коммутацией

Корпорации и государственные учреждения, в чьих компьютерах вам хотелось бы порыться, разбросаны по всей стране. Но при этом вам, разумеется, не хочется рыться в собственном кошельке, чтобы платить за все эти удаленные вызовы. Решение проблемы — сети общественных данных (Public Data Network — PDN).

PDN — это сеть, включающая в себя сотни компьютеров по всей стране. Вы вызываете ближайший к вам компьютер, и набираете адрес компьютерной системы, к которой вы хотели бы подключиться. Адрес обычно представляет собой что-то вроде телефонного номера. Если введенный адрес достоверен, на экране появляется окно загрузки требуемой системы. Теперь вы получаете возможность общаться с системой, как если бы связались с ней напрямую, тогда как на самом деле весь текст, что вы вводите, разбивается на куски (пакеты), которые могут сжиматься и кодироваться, и в таком виде идут по стране, от одного компьютера к другому, пока не достигнут точки назначения.

Одновременно по сети могут путешествовать сотни сообщений, в то время как тысячи пользователей взаимодействуют с множеством компьютеров сети. Такая пересылка сообщений называется пакетной коммутацией. Компьютеры, играющие роль промежуточных звеньев, носят название пакетных ассемблеров, дисассемблеров (PAD), поскольку они принимают приходящие пакеты данных, отделяют закодированный заголовок пакета, сообщающий компьютеру, куда направляется данный пакет, затем вновь добавляют к пакету информацию, уже о новом направлении, и пересылают дальше по маршруту.

Хакеры очень любят присоединяться к PDN. Находясь в сети, хакер может вводить наугад различные адреса. Через несколько минут у него оказывается широкий выбор входных приглашений, которые можно взломать, и все это по местному вызову.

Из наиболее известных PDN можно назвать Telenet и Tymnet; существуют также международные и иностранные сети с пакетной коммутацией. Вы всегда можете вызвать одну из этих служб, чтобы взять список сетей с пакетной коммутацией вашего региона.

другие сети

Из всех других сетей можно брать в расчет только Интернет.

Интернет — это международная сеть, состоящая, в свою очередь, из других сетей. В нее входят научные и правительственные сети, предприятия и организации всего мира, связанные между собой с помощью PDN. Члены Интернет обмениваются идеями, программами, технологиями, слухами и шарлатанскими рецептами.

До появления Интернет существовали APRANET — военная сеть, место которой заняла теперь MILNET (хорошо защищенная сеть военных баз Соединенных Штатов), и другие небольшие сети, также принадлежавшие армии США. Все вместе они образовали DDN — Defense Data Network (Сеть Оборонной Информации). Теперь DDN — всего лишь одна из многих сетей, образующих Интернет.

Существует также National Science Foundation Network (NSFNET) — Сеть Национальных Научных Исследований, которая включает в себя суперкомпьютерные центры и другие исследовательские организации, поддерживаемые NSF. CSNET — сеть, создан- ' ная для развития сотрудничества между организациями, выполняющими государственные компьютерные разработки. JANET — сеть Соединенного Королевства Великобритании, одна из многих национальных сетей, входящих в Интернет. Интернет — поистине глобальное сообщество.

Многие платные службы предполагают наличие доступа к Интернет. К Интернет присоединены компьютерные бюджеты многих университетов. На самом деле членство в Интернет дает возможность путешествовать по всему миру туда и обратно, не покидая своего уютного кресла.

Выше мы говорили об адресах сетей с пакетной коммутацией. Адрес в Интернет представляет собой серию кодовых слов, разделенных точками, и принадлежит одному конкретному компьютеру, одному из миллионов, составляющих Интернет. Вот пример типичного адреса Интернет: “danielk@cz.zowie4.uboulder.edu”. Можно догадаться, что на компьютерном факультете Боулдеровского университета стоит компьютер под названием zowie4, а на этом компьютере работает человек по имени Аэниел, фамилия которого начинается с буквы “К”. “Edu” — стандартное добавление в конце адресов учебных компьютеров. Идентификационные элементы могут также быть следующими:

СОМ — коммерческие организации;

MIL — военные организации;

GOV — правительственные;

ORG — некоммерческие учреждения; и

NET — административные компьютеры Интернет.

Адрес Интернет может заканчиваться двузначной аббревиатурой — сокращенным названием страны. Например:

AU — Австралия;

IL— Израиль;

US — Соединенные Штаты;

JР — Япония;

UK — Великобритания;

DE — Германия.

как достать кодовые номера

Чтобы связываться с компьютерами напрямую, вам понадобятся их телефонные номера. Часто можно позвонить в компанию и попросить оператора на коммутаторе соединить вас с компьютерным отделом и (или) с компьютерной линией. Если это не сработает, постарайтесь дозвониться до отдельных офисов фирмы, и спросите, не знают ли они, как получить доступ к компьютеру компании с их домашних компьютеров. Если они не знают телефонных номеров, возможно, на компьютере в их офисе имеется терминальная программа, где хранится телефонный номер.

Очень полезны телефонные книги. Во-первых, внутреннего типа: компании и другие организации составляют директории с добавочными телефонами сотрудников. Внутренние директории могут также представлять собой списки номеров различных отделов, а иногда даже домашние телефонные номера и адреса сотрудников. Их имена можно использовать, если вы захотите притвориться знакомым этих людей, когда будете им звонить. Но если эти номера присутствуют в телефонной директории, вам и не придется делать такие звонки

Другой источник полезных данных — директории выделенных линий передачи данных телефонных компаний.

Когда человек разговаривает по телефону, он не обращает внимания на то, что через определенные промежутки времени голос на другом конце провода становится невнятным, или громкость становится то чуть выше, то чуть пониже. Но при передаче данных между компьютерами шумовые помехи могут стать серьезной проблемой. Поэтому телефонные компании за определенную плату устанавливают в офисах специальные линии для облегчения прохождения потока данных между телекоммуникационными приборами, такими, как модемы. Если вам удастся раздобыть телефонную книгу с номерами этих линий, вы приобретете замечательную коллекцию телефонных номеров компьютеров (а также факсов). Многие хакеры находят такие каталоги, роясь в мусоре.

Третий способ использования телефонных книг — просмотреть все свободно публикуемые белые и желтые страницы. Крупные компании имеют много телефонных номеров, причем номер каждого офиса или отдела отличается от соседних номеров на одну цифру. Например, чтобы позвонить в какой-либо отдел компании X, следует набрать 390-WXYZ. Первые три цифры одинаковы для всех отделов, а последние четыре — свои для каждой телефонной линии. Вам остается только включить компьютер и создать текстовый файл со списком вариантов из этих последних четырех цифр, которые даны в телефонной книге компании. Затем отсортируйте список и проверьте каждый из вариантов, не присутствующих в данном списке.

В решении этой задачи может помочь перекрестный телефонный каталог. Перекрестные каталоги сортируются не по именам, а по номерам. Если вам известно, что первые три цифры телефонных номеров компании Х - 390, использование подобной книги даст вам еще больший список исключенных номеров. Таким образом, перебор вариантов потенциальных номеров сократится.

Программное обеспечение способно неоднократно набирать серии телефонных номеров, сообщая о подключенном модеме. Эти программы (их часто можно найти на хакерских и кракерских BBS), имеют много названий: “WarGames Dialers”, “autodialers” (автонаборы) и т. д. Если вам не удается найти такую программу, напишите ее сами — это нетрудно и отнимет у вас всего несколько часов.

Заимев автонабор, используйте его с большой осторожностью. Когда вы начнете делать столько вызовов в течение короткого времени и с таким упорством, служба безопасности телефонной компании поймет, что происходит. Я часто подумывал о том, что неплохо было бы соединить автонабор с компьютером телемаркета. Тогда все будет выглядеть вполне законно: если трубку поднимет человек, он услышит запись краткого сообщения; если включается модем, можно будет перезвонить.

СПОСОБЫ обеспечения безопасности кодовых номеров

Некоторые директора по безопасности оказываются в своеобразной ловушке. Они понимают всю важность коммутируемых линий прямого доступа, но они понимают также, что, если человек в любой момент может напрямую связаться с компьютером, безопасности конец.

Для разрешения этого противоречия ответственные за безопасность не разрешают прямого наборного доступа к компьютерам. Дозволяется лишь доступ к промежуточному устройству или к такому компьютеру, который защищает важные данные от потенциальных хакеров.

Например, можно вызвать компьютер, предназначенный исключительно для проверки права доступа. Если право подтверждается, пользователя переключают на линию, соединенную с действующим компьютером. Затем у него могут затребовать определить свой личный бюджет пользовательским именем и паролем. Пока пароль для первоначального компьютера остается в тайне и периодически изменяется, важные данные на действующем компьютере находятся в безопасности.

В тех штатах, где действует запрос ID (и даже в тех, где его нет), можно установить модем только для подтверждения установления связи с пользователем, делающим вызов с санкционированного телефонного номера. Системные администраторы располагают списком домашних телефонных номеров и номеров учреждений, принадлежащих легальным пользователям, и если компьютер “видит”, что звонок пришел с номера, которого нет в списке, связь немедленно прерывается. Связь будет прервана и в том случае, если вызывающий включил блокировку вызова, которая не позволяет идентификатору вызова прочесть номер его телефона.

Там, где идентификация вызова отсутствует или недоступна, может применяться метод обратного вызова. Если звонящий вводит правильную идентификационную информацию, главный компьютер отключается, и затем сам перезванивает по тому телефонному номеру, который хранится у него в памяти и соответствует введенной информации. Это обычный способ обратного вызова, но в некоторых случаях (например, в системе электронных досок объявлений RBBS-PC) он производится следующим образом: звонящий ждет, пока телефон сделает энное количество звонков, затем кладет трубку и перезванивает заново. Во второй раз BBS отвечает на звонок. Если ж после N звонков звонящий не кладет трубку, компьютер вообще проигнорирует вызов, таким образом, обеспечив безопасность. Итак, если вам доподлинно известно, что такой-то номер принадлежит компьютеру, но тот не отвечает, попробуйте повторить вызов несколько раз, каждый раз делая различное количество звонков, и тут же перезванивая.

Главный компьютер может также не соединять звонящего до тех пор, пока на кнопочном телефонном аппарате не будет набран определенный код. Так как данный код обычно создается терминальной программой вызывающего компьютера, он может быть очень длинным и сложным, чтобы его было трудно случайно угадать или взломать с помощью грубой силы.

Как видите, приведенные выше способы обеспечения безопасности значительно осложняют жизнь хакера. Конечно, можно с помощью социальной инженерии вытянуть информацию из легального пользователя системы, но часто хакер даже не подозревает о существовании таких суровых мер.

Можно время от времени прозванивать определенные телефонные номера, если у вас есть основания подозревать, что один из них принадлежит к компьютерной линии. Если один из номеров никогда не отвечает, сколько бы раз вы не звонили по нему, можно сделать предположение, что он подключен к элементу обратного вызова, или чему-то в этом духе. Если вы звоните, слышите, что на другом конце компьютер, но соединения не происходит, вероятно, компьютер “взглянул” на ваш телефонный номер и сделал вывод, что он недостоверен. (Или же вы пытаетесь установить связь с факсом.) Устройства типа идентификатора вызова, или те, что делают обратный вызов, особенно распространены в тех компьютерных системах, пользователи которых находятся внутри небольшого региона. Дистанционная система может также пытаться определять специальные тональные сигналы, закодированные в модуляции, — хотя линия и коммутируемая, для соединения может потребоваться специальное оборудование.

Иногда системные менеджеры доходят до того, что скрывают даже сам факт существования у них компьютера, подсоединенного к коммутируемой линии связи. Когда пользователь вызывает такой компьютер, специальное устройство отвечает на звонок. Вместо характерного звука, издаваемого модемом, пользователь слышит запись голоса, шум помех, или вообще ничего не слышит — пока вызывающий модем не пошлет удаленном системе специальный пароль. Конечно, такая уловка легко собьет с толку любой автонабор.

В общем, устройства, ограничивающие доступ к искомому компьютеру, представляют собой ни что иное, как очередной защитный барьер, который надо преодолеть. К счастью, большая часть компьютеров не оснащена подобным образом, и взломать их не труднее, чем разбить сваренное вкрутую яйцо.

подробное исследование сценария входа

Сценарий входа — это область удаленного компьютера, доступ к которой вы получаете, еще не определив себя как правомочного пользователя системы.

У большинства компьютеров сценарий входа ограничивается приглашением ввести имя пользователя и пароль. Некоторые сценарии более широки, и выдают общее командное приглашение, в ответ на которое вы можете набрать сколько угодно команд. Эти команды необязательно будут выполнены (возможно, сначала вам придется войти в систему), но они могут вам помочь.

Существует несколько общих команд, которые можно ввести в ответ на системное командное приглашение. Сначала попытайтесь ввести “help” или “?”, и посмотрите, не получится ли что-нибудь. Команды типа “users”, “show users” или “who” могут быть полезны тем, что вы увидите список пользователей системы и попытаетесь разгадать их пароли. Преимущества некоторых других команд могут проявляться не столь явно, а многие команды могут оказаться вообще бесполезными для хакера.

Большой плюс основных командных приглашений состоит в том, что к ним часто можно вернуться после того, как вам не удастся войти. Даже если вы уже ввели три неправильных комбинации имя, пароль, компьютер продолжает возвращать вас к командному приглашению, давая вам возможность сделать следующую попытку.

Если вы попали на основное командное приглашение и никакая помощь не доступна, постарайтесь сделать различные веши, обращая при этом внимание на сообщения об ошибках, которые вы получите. Попробуйте набрать команды прописными буквами, строчными и вперемешку. Взгляните на максимальную и минимальную длину команд. Посмотрите, какие символы будут распознаны. Все это поможет вам уменьшить область неизвестного, и определить необходимые действия. Если каждый раз, набрав “HELP”, вы получаете сообщение об ошибке “Line too long” (“Слишком длинная строка”), вы будете знать, что система, по всей вероятности, ожидает трехзначных команд. Это полезная информация.

Если вы набираете “CONNECT”, а система отвечает “The verb CONNE is not available”, значит, она воспринимает только первые пять символов вводимых команд. Если же система восприняла все введенные символы, вы сможете воспользоваться помощью. К примеру, набрав “HELP”, вы получите список команд, “HELP COMMAND NAME” — разъяснения по одной конкретной команде. Это общепринятая система помощи.

Давайте перейдем непосредственно к вводу пользовательского имени и пароля. Некоторые терминалы сообщают вам о неправильном вводе сразу же после ввода неверного имени, другие ждут, пока вы введете имя и пароль. Первый тип предпочтительнее, поскольку менее защищен и предполагает значительно большее число попыток взлома, чем второй. Так, IBM VM,370 обладала недостаточной зашитой именно в этом смысле, немедленно информируя вас о том, выдавая сообщение об ошибке при вводе пользовательского имени — “userid not in cp directory”. Одна из известных мне систем (Dynix) следует тому же принципу. Сначала она услужливо предлагает вам ввести “Nine digit ID code” — “Девятизначный идентификационный код” (Так-так, что же это такое? Возможно, номер социальной безопасности?), а затем, если ввод был верен, говорит: “Good morning Samantha. Now type your password” — “Доброе утро, Саманта. А теперь введите ваш пароль”. Данный конкретный компьютер позволяет легко взломать один из нескольких командных языков и перепрограммировать интерфейс на основе меню. Компьютеры также снабжены коммутируемыми портами. Взламывать Dynix — одно удовольствие.

Если вы взламываете компьютер второго типа (тот, что запрашивает имя и пароль перед тем, как сообщить, принята ли ваша загрузочная информация), заметьте время, которое потребуется ему на то, чтобы выдать приглашение для ввода пароля. Это поможет сделать заключение о том, верно ли введенное вами имя пользователя. Например, вы вводите имя “Jim”, и до появления приглашения о вводе пароля проходит столько-то времени. Затем попробуйте ввести имя “Zzzzzzz” — явно неверное имя, которое отсутствует в памяти компьютера. Если после ввода этого имени до появления приглашения ввести пароль неизменно проходит большее количество времени, чем после “Jim”, значит, “Jim” — верное имя, и вы можете продолжить угадывать пароль уже с этим именем. В системах с последовательным поиском компьютер дольше пытается отыскать в своих файлах неверно введенную информацию, нежели верную. В любом случае, исходные программы всегда являются доступными, особенно для файлов UNIX, и вы можете просмотреть их, чтобы увидеть изнутри, как работает режим входа.

Если вы понятия не имеете, какой тип пользовательского имени и,или пароля используется в данной системе, следует прибегнуть к такой же проверке, как и в случае с общим командным приглашением, чтобы путем проб и ошибок обнаружить, какие символы требуются в данном случае, и сколько.

Существует совершенно иной способ исследования режима входа — с помощью управляющих кодов. Нажатие определенных клавиш, или комбинаций клавиш, посылает коды на удаленный компьютер, который заставляет их работать иначе, чем обычно. Например, можно послать на удаленный компьютер ASCII-код, чтобы скомандовать ему прекратить чтение файла с паролями. Иногда удается даже быстро перенабирать введенный пароль, заставив компьютер поверить, что он обнаружил его в своем файле паролей, и разрешить вам войти в систему. Иногда нажатием Control-Z (команда конца файла) в нужное время можно тоже добиться странных результатов.

Обращайте внимание на все аббревиатуры, непонятные значки и т. п., появляющиеся на экране. В любой порядочной библиотеке имеется энциклопедия акронимов (а в любой непорядочной — эта книга). Очень часто можно вызвать сеть с коммутируемой передачей данных, ввести верный адрес, и увидеть на экране что-то вроде: “Welcome to VHMSD! Password?” (“Добро пожаловать в VHMSD! Ваш пароль?”). Вы проводите некоторые исследования и обнаруживаете, что VHMSD — это Viking Horn Manufactures of South Dakota, и совершить взлом становится относительно проще. Помните, что при взломе компьютера вы на самом деле “взламываете” тех людей, которые на нем работают. Таким образом, если вам удастся вычислить, кто же заказывает музыку, в вашем распоряжении окажется множество средств, в том числе те методы исследований, о которых я упоминал выше. Иначе вы будете лишь наносить случайные удары по компьютеру, имея в запасе только какую-то непонятную аббревиатуру.


Глава 8. Электронные доски объявлений

Прочтя в черноморской вечерке объявление: "Си. ПР. КОМ. В. УА. В. Н. М. ОА. ИН. ХОЛ.*, и мигом сообразив, что объявление это означает — 'Сдается прекрасная комната со всеми удобствами и видом на море одинокому интеллигентному холостяку", Остап натянул белые прохладные брюки и отправился по указанному в объявлении адресу.

И. Ильф, Е. Петров. Золотой теленок.

С электронных досок объявлений (BBS) начинается знакомство большинства людей с компьютерными телекоммуникациями. BBS — это программа, которую каждый может установить на своем компьютере. Она наблюдает за модемом, ожидая телефонного звонка. Если вызов идет от другого модема, происходит соединение двух компьютеров. После этого позвонивший человек может использовать компьютер, находящийся на другом конце линии, как если бы непосредственно сидел за этим компьютером. Программа BBS позволяет тому, кто произвел вызов, выбирать различные опции из меню, давая ему возможность посылать сообщения на терминалы других пользователей, читать сообщения, посылать и получать файлы, либо играть в игры на удаленном компьютере. В сущности, вызывающий пользователь управляет компьютером по телефонной линии. Впрочем, он может управлять лишь программой BBS. Данная программа отделяет вызывающего пользователя от самого компьютера (по крайней мере, пытается).

Часто BBS запускают на своих домашних компьютерах компьютерные любители, рассматривая их как способ получения информации в духе настоящих хакеров. Обычно для вызова и просмотра программы платы не требуется, но это остается на усмотрение того, кто запускает BBS — системного оператора. Школы, библиотеки, магазины, группы пользователей, церкви и другие организации также часто используют BBS — для распространения своей информации и поддержания связи между своими пользователями. Иногда электронные BBS устанавливают компании, чтобы клиенты могли заказывать их продукцию по электронной почте, получать информацию о новых видах продукции, или информировать компанию о проблемах, возникших при использовании их товаров либо услуг.

Электронную доску объявлений установил даже Конгресс США. Она была запушена в конце 1991 года на программном обеспечении RBBS конгрессменом Бобом Вайзом и его подкомитетом Палаты Государственных Операций по государственной информации, праву и сельскому хозяйству, дабы государственные сотрудники могли анонимно информировать инспекторов о непорядках на их рабочих местах.

Существуют частные BBS, телефонные номера которых доступны далеко не каждому. К примеру, ФБР имеет в своем распоряжении National Crime Information Center — NCIC (информационный центр по государственным преступлениям), используя BBS для поиска пропавших людей, тех, кто находится в розыске и присмотра за людьми, неоднократно преступавшими закон. Привилегированные предприятия, типа ресторанов “быстрой еды”, часто используют BBS для ежедневной загрузки описей или финансовых сведений в компьютер, расположенный в штаб-квартире их компании. Ну и, само собой, существуют также “общественные” BBS, которые хранят молчание, поскольку люди, использующие их, делают это в нелегальных целях.

Доступ к большинству BBS контролируется комбинацией имя, пароль. Когда вы вызываете BBS, вас просят ввести свое имя, либо NEW, если вы делаете вызов в первый раз. Если вы новый пользователь, вас спрашивают, хотите ли вы зарегистрироваться в системе; если ответ положительный, вам зададут несколько вопросов, поприветствуют в системе, возможно, сделают краткий обзор и ознакомят с принятыми правилами (“Просим не засорять сообщения... Нельзя вести обсуждение нелегальных действий, таких, как компьютерное хакерство, телефонное, краденые номера кредитных карточек, и т. д....”).

Затем вам, вероятно, дадут гостевой доступ к BBS, пока системный оператор не сможет проверить достоверность вашего запроса для допуска, а возможно, вас отключат и попросят перезвонить на следующий день. Конечно, такая процедура не всегда применяется, но системные операторы всегда хотят убедиться в том, что вы именно тот, за кого себя выдаете - вдруг вы зарегистрировались с фальшивым телефонным номером? Им хочется знать, достойны ли доверия те люди, которым они разрешают использовать свой компьютер.

Электронные доски объявлений, по многим причинам, очень важны для компьютерных энтузиастов и хакеров. Они дают нам возможность общаться (порой анонимно, или почти анонимно) с другими пользователями. Мы имеем возможность учиться у тех, кто более опытен в этом деле, и использовать BBS, чтобы помочь “новобранцам” армии компьютерщиков.

Естественно, существуют аморальные и нелегальные способы использования BBS, способы эксплуатирования самих систем и связанных с ними людей ради собственной выгоды, пути установления контактов с компьютерным андеграундом всего мира, в том числе и с хакерами.

кяк найти номера BBS

Как только вы найдете один номер BBS, вы автоматически получите в свое распоряжение буквально тысячи других. Системные операторы BBS не конкурируют друг с другом. Их мало волнует, используете ли вы только их систему, или же вызываете по очереди все существующие BBS. Таким образом, в любой BBS, которую вы вызовете, почти всегда можно найти список других BBS. Список может включать в себя все BBS страны, или только местные; в нем указаны названия BBS, телефонные номера, иногда имя системного оператора и специальные характеристики каждой системы. Каждая BBS также обычно располагает центром сообщений, или таким местом, где другие системные операторы могут рекламировать свои системы.

Итак, вызвав одну BBS, вы получите телефонные номера множества других. Вся проблема, особенно для новичков, заключается в том, чтобы найти первый номер.

Аля начала спросите у своих знакомых, имеющих у себя компьютер и модем, нет ли у них номеров BBS.

BBS есть у многих групп компьютерных пользователей, у библиотек, религиозных организаций, школ.

BBS часто располагают компании, выпускающие модемы и другое оборудование для телекоммуникаций, равно как и компании, выпускающие программное обеспечение. Если в пакете нет информации о BBS, можно позвонить в компанию и уточнить. Например, Hayes располагают общегосударственной 1-800? BBS, которую можно вызвать, чтобы получить информацию о продукции и списки BBS со всей страны. Ее номер 1-800-US-HAYES.

Номера BBS публикуются в компьютерных журналах. Существует много книг по телекоммуникациям, в приложениях некоторых из них даны списки BBS по всей стране. Списки даются также в некоторых компьютерных телефонных книгах. Вдобавок можно найти рекламу BBS на обычных досках объявлений или в ближайшем компьютерном магазине.

как найти хакерские доски объявлений

Настоящие хакерские BBS не занимаются саморекламой, но не волнуйтесь: как только вы станете опытным хакером, вы сразу же узнаете об их существовании, и там вас примут с распростертыми объятиями.

Существует много хакеров и тех, кто считает себя хакерами, которые открыто рекламируют свои BBS, посвященные именно тем сведениям, которые вам нужны. Их информация может оказаться интересной;

но может случиться и так, что, загрузившись в такую систему, вы не обнаружите там ничего, кроме перебранки каких-то безмозглых субъектов. Вы можете поспрашивать на открытых хакерских (криминальных) досках, не знают ли их участники о существовании каких-либо других хакерских досок объявлений (можно также просмотреть представленные там списки BBS), но, вероятно, вам не удастся просмотреть открытые криминальные доски, поскольку они часто разоряются. Так как они не содержат ничего, кроме общедоступной или бесполезной информации, но не стоит думать, что вы много теряете, избегая такие BBS.

Иногда можно найти электронную беседу, обладающую некоторой интеллектуальной ценностью. Включитесь в нее, и вскоре вы обнаружите, что вас принимают, как своего. Если вы найдете такую BBS, члены которой заявляют, что они хакеры, но их беседы не содержат в себе ничего предосудительного, можете не сомневаться, что там есть лазейки, за которыми прячутся “под-доски”, где и обсуждаются настоящие хакерские новости. Покажите себя полноценным членом подпольного сообщества, и через некоторое время системные операторы и ассистенты операторов примут вас в свою элиту. Чтобы вас признали хакером, надо обмениваться информацией. У вас должна быть хорошая информация, чтобы делиться ею.

Если вы вошли в респектабельную BBS, которая, как вы подозреваете, содержит секретный хакерский подраздел, время от времени при загрузке пробуйте вводить различные не установленные команды (не больше одной команды в сеанс входа, чтобы не возбуждать подозрений). Если одна из ваших команд сработала, и у вас спрашивают пароль, знайте — вы напали на след. Поговорите с системным оператором или с другими членами группы о вашем отношении к хакерству, и спросите, что они думают по этому поводу. Сдержанно сообщите о ваших хакерских достижениях. На них произведет впечатление уже сам факт того, что вы нашли секретный раздел, но не хотите волновать их, взламывая его. И вы, разумеется, не станете печатать публичное сообщение о том, что нашли их секретную лазейку, — можете не сомневаться, что вокруг слоняется множество других жаждущих получить секретный доступ. В частном порядке побеседуйте о вашей находке с системным оператором и ассистентом, по электронной почте или в режиме онлайн.

Если вы взломали хакерскую BBS, хотя ее пользователи не знакомы с вами, они не могут быть уверены в том, что ваши намерения честны. Если их побеспокоить, они примут меры, чтобы защититься. В беседе с оператором лучше упомянуть о том, что вы не собираетесь взламывать обнаруженную вами лазейку, чтобы дать им убедиться в том, что вы — такой же брат-хакер, а не полицейский.

установление связей

Многие BBS, в которые вы войдете, строго запрещают нелегальные действия. Никаких разговоров о хакерстве, распространения способов взлома, и уж конечно, никакой скользкой информации для новичков. Вам придется начинать со вступления в уже устоявшиеся, довольно нудные беседы.

Соблюдайте вежливость и постарайтесь приносить пользу. В беседе вставляйте комментарии к месту. Если среди ваших друзей есть опытный хакер, это даст вашим способностям такую рекламу, как ничто другое, — кроме, разве что, настойчивости, любознательности и удачи.

Вскоре у вас появится несколько излюбленных систем, которые вы будете вызывать регулярно, но время от времени вам следует расширять этот круг, пробуя все новые системы, которые вам попадутся, в конечном итоге добиваясь получения доступа в “компьютерный андеграунд”.

Конечно, единого и организованного андеграунда как такового не существует, но зато существуют отдельные группы хакеров и просто тех, кто интересуется техникой. Они держат в секрете свои беседы о нелегальной деятельности, так что обнаружить их будет нелегко. Доски объявлений, которые они используют для общения, часто прячут от новичков, a BBS с самыми интересными новостями вообще не обнародуют свои телефонные номера. Лучше всего просто продолжать поиски. Если вам начнет казаться, что некто на одной из досок объявлений может быть связан с нетрадиционными методами использования компьютеров, вы можете послать ему (или ей) тактичное частное сообщение, в котором спросите, не интересуется ли он подобными вещами, и если да, то не желает ли он обмениваться информацией? Но помните:

любое сообщение, которое вы посылаете на BBS, могут прочесть системные операторы и, возможно, другие системные менеджеры, находящиеся ниже в этой иерархии, так что будьте осмотрительны, если главные действующие лица настроены анти-хакерски.

Множество людей обладают компьютером и модемом, и вы столкнетесь с множеством различных людей на электронных досках объявлений. Если вы будете искать там, где надо, вы, несомненно, найдете среди них и компьютерных взломщиков. Значительно сложнее может оказаться заставить их принять вас за своего. Хакеры любят рисоваться, но обычно не любят объяснять, в чем заключаются их уловки. Вам

придется показывать им, что вы — умный, изобретательный, логичный человек, который может заниматься хакерством на том же уровне, что и они сами — а также делиться с ними информацией.

Бродя по чащобе электронных досок, постарайтесь не заблудиться, записывайте свой маршрут. Сделайте список различных BBS с примечаниями о том, какое программное обеспечение используется в каждой, и какие особенности у них имеются. В частности, отмечайте такие признаки, как возможности передачи файлов, существование списка BBS, пользовательские списки и входы.

характерные особенности BBS

BBS представляют собой нечто большее, нежели просто доски объявлений, и это верно — они больше, чем просто место для написания и чтения сообщений.

BBS с секторами передачи файлов дают возможность бесплатно посылать (upload) компьютерные программы и файлы на BBS, и бесплатно получать (download) файлы с компьютера BBS. Многие наиболее серьезные BBS считают передачу файлов пустой тратой времени и места на диске, но все же они часто встречаются, особенно у тех операторов, которые стараются угодить программным пиратам (или бутле-герам), имеющим дело с защищенным от копирования программным обеспечением.

Существуют различные виды списков пользователей и входов в BBS. Они варьируются от ответов пользователя на анкету до небольшого ознакомительного сообщения о пользователе, краткого описания

его пристрастий и интересов. Часто можно посмотреть журнал регистрации пользователей, в котором записано, кто загрузился в BBS непосредственно перед вами, в начале дня или даже раньше.

“Двери” используются для выхода из программы BBS. Когда вы выходите через дверь (выбрав соответствующую команду в меню), то оказываетесь в совершенно другой программе. Двери обычно используются для игр в режиме онлайн, но через них можно попасть в любую программу. Все зависит от того, какое программное обеспечение используется в данной BBS и от прихотей оператора.

Вот другие характерные особенности BBS:

• Стены граффити. На них пользователи могут помешать короткие записки, рекламу или шутки.

• E-mail (электронная почта). Позволяет пользователям посылать личные сообщения другим пользователям системы.

• Беседы. Позволяет вести разговор в режиме онлайн с системным оператором, если тот на месте.

• Библиотеки текстовых файлов. Содержат анекдоты, шутки, “Добро пожаловать на BBS”, полезную информацию, технические файлы и многое другое, что люди могут захотеть прочесть.

Начав использовать BBS, вы познакомитесь со многими вещами, которые обычно можно найти на BBS... а также со способами их использования в своих гнусных хакерских целях!

ЭКСПЛУАТАЦИЯ BBS

Когда-то давным-давно, если вы хотели взломать компьютерную систему, можно было легко воспользоваться ошибками в ее программном обеспечении, или устанавливаемыми по умолчанию паролями. Теперь дело обстоит несколько хуже. Все эти дефекты и пароли по умолчанию, в основном, отошли в прошлое.

Конечно, вы можете их использовать, если знаете, что делаете, — но, к несчастью, полагаясь на эти методы, вы почти наверняка зайдете в тупик. Вам следует использовать новый вид системных дефектов.

Если вы не страдаете соответствующей фобией, вы не станете бояться, что вас поразит молния, каждый раз, когда будете выходить из дома. Это не столь большая опасность, чтобы о ней беспокоиться. Но что, если в один прекрасный день вас действительно ударит молния? Разве это не изменит ваш взгляд на вещи?

Вот моя точка зрения: самым слабым звеном в любой системе обеспечения безопасности являются люди, которые должны проверять, не нарушена ли безопасность. Среднестатистического компьютерного пользователя не волнуют проблемы безопасности — да и зачем? У него нет никаких причин о ней беспокоиться. Его файлы не уничтожал ни один вирус, номера кредиток никто не крал, а бюджет никто не взламывал. Поистине слабое звено.

Как же использовать слабость этого звена? Типичный пользователь одновременно является типичным человеческим существом. Он немного увлекается компьютерами, но не является компьютерным фанатиком (таким, каким, наверно, являетесь вы). А человеку сложно запомнить пятьдесят разных паролей. Значит, он будет использовать один и тот же пароль для каждой компьютерной системы и BBS, в которых у него есть бюджет. Пользователь придумывает легко угадываемые пароли, а то и вообще обходится без керов. Посудите сами. Новичок скорее, чем опытный пользователь, выберет неудачный пароль. Новички (или люди, не интересующиеся компьютерами), как правило, постоянно выбирают очевидные пароли.

Итак, если вы узнали, какова область интересов какого-либо пользователя (особенно новичка), вам будет “легко” отгадать его (или ее) пароль. Если вам известно, что данный человек использует компьютер на работе или по месту учебы, то он, скорее всего, имеет один и тот же пароль для обеих систем.

Я не хочу сказать, что отгадывать пароли легко и просто. Это не так — вам понадобится терпение и немалое количество времени. Но существуют более быстрые, приятные — и более технические — способы проникновения в бюджет Джо Блоу на BBS, нежели метод грубой силы. Давайте их рассмотрим.

Как преодолеть ЗАЩИТУ BBS

Несмотря на то, что BBS используют средства компьютерной зашиты, существует по меньшей мере восемь факторов, которые делают их уязвимыми для находчивого хакера. Вот эти лазейки:

1. Знакомство хакера с удаленным аппаратным обеспечением.

2. Запуск BBS на домашнем компьютере.

3. Знакомство хакера с программным обеспечением BBS.

4. Знакомство хакера с людьми, имеющими отношение к BBS.

5. Разнородный состав людей, имеющих отношение к BBS.

Сектор передачи файлов

Осведомленность хакера о тех моментах, когда системный оператор наблюдает за системой, и когда нет.

8. Осведомленность хакера о шаблонах использования.

Каждая из этих лазеек дает хакеру немало возможностей взломать ту BBS, которая ему понравится. А если все вышеперечисленные факторы имеют место, для хакера становится невозможным НЕ добиться успеха при взломе данной BBS.

В отличие от остальных ситуаций, в которые попадает хакер, — например, первого сеанса связи с большим правительственным компьютером, — в данном случае вам будут известны практически все особенности избранной вами BBS. В меню BBS часто присутствует опция, которая позволяет посмотреть, какое оборудование используется для работы системы. Вы также сможете узнать тип программного обеспечения и завести знакомства, регулярно общаясь с пользователями и системными операторами. Все эти данные дадут вам громадное преимущество при написании и загрузке так называемых “троянских коней”, при поиске дефектов, которыми можно воспользоваться, и, естественно, при угадывании паролей.

Обычно при входе BBS сообщают, можно ли побеседовать с системным оператором. На самом деле нет никакой гарантии того, что оператор отсутствует на самом деле, когда система сообщает об этом, но сообщение “Sysop is IN” (“Оператор на месте”), по крайней мере, служит предупреждением, дабы вы соблюдали большую осторожность.

Даже если оператора действительно не окажется на месте, само программное обеспечение BBS может наблюдать за вами зорко, словно ястреб, распечатывая при этом каждое ваше действие или попытку взлома программы. К примеру, программное обеспечение электронной доски объявлений RBBS-PC дает возможность системному оператору вести постоянный вывод на печатающее устройство всех имен вызывающих систему пользователей, все изменения файлов и сообщения об ошибках, которые возникают при работе системы. Как будет видно из дальнейшего содержания этой главы, это может причинять различные неудобства, в зависимости от способа вашей атаки BBS.

ЗАПУСК BBS

Самый простой способ сбора паролей —дождаться, пока люди начнут сами раскрывать их вам. Именно так и случится, если вы запустите свою собственную BBS.

Быть системным оператором — значит очень много работать, а к тому же иметь собственный компьютер, модем, телефонную линию (линии) и, возможно, собственный принтер. Прекрасный набор для взломщика!

Вот три исходных мотива для совершения взлома локальных BBS: 1) любопытство и жажда острых ощущений; 2) возможность попрактиковаться, особенно не рискуя; и 3) возможность получения паролей, которые могут использоваться их обладателями и в других компьютерных системах. Если вы заведете собственную BBS, первые две мотивации исчезнут, как не бывало. Останется только третий повод— сбор паролей, притом, что для этого существуют и более эффективные методы. Впрочем...

Хакер, запускающий свою BBS, получает некоторые преимущества, независимо от того, желает ли он злоупотребить доверием, которое пользователи испытывают к системному оператору, или нет. Например, хакер может установить BBS специально для других хакеров, чтобы те могли ставить свои вопросы и обмениваться информацией. Если вы хотите поступить именно так, вам следует соблюдать предельную осторожность в своей рекламе и при приеме новых пользователей, чтобы быть уверенным в том, что вы не пропускаете на свою доску объявлений полицейских или враждебно настроенных хакеров. Я еще упомяну о правилах безопасности в конце данной главы, а теперь вернемся к нашей теме.

Запуск BBS — или, по крайней мере, установка ее в своей системе, даже если вы не собираетесь ее обнародовать — поможет вам узнать о работе BBS больше, нежели любой другой способ. На хакера всегда благотворно действует тот факт, что он знает, как работает система, от А до Я — это греет его душу. Вы можете попытаться также установить ограниченную BBS и практиковаться, взламывая ее с компьютера своего друга, или попросить других попытаться ее взломать (речь идет только о самых близких друзьях). Таким образом, вы узнаете, что можно и чего нельзя сделать с программным обеспечением вашей конкретной BBS, и поднаберетесь хакерского опыта. Вдобавок вы сможете предупредить других системных операторов о слабых местах их систем. Сам я никогда не запускал BBS — мне никогда не хотелось ни отдавать свой компьютер и телефонную линию, ни тратить свое время на электронную доску объявлений. Но я побывал ассистентом оператора нескольких BBS, со всеми операторскими полномочиями, и узнал немало хитростей, с помошью которых люди пытаются взломать эти системы.

ПОЛНОЧНЫЙ Маскарад

Однажды ночью, около 1.30, Treacherous Den BBS почтил своим визитом хакер. Хакер несколько раз пытался войти в систему, используя мое прозвище, The Knightmare. Системный оператор, мой друг DR dendryte, сидел, наблюдая его бесплодные усилия, пока, наконец, не нажал функциональную клавишу перехода в режим беседы. Ниже приведена запись последовавшего разговора, скопированная прямо с распечатки системного оператора, но с опушенными ненужными повторениями. (Мои собственные комментарии заключены вот в такие скобки.)

— Системный Оператор хочет начать Беседу!

— Это DR dendryte. Кто вы такой?

— Это Knightmair я Забыл свой пароль. Впусти меня.

(Теперь DR dendryte уже точно знал, что разговаривает с самозванцем. Ему было известно, что я никогда не вызываю так поздно ночью, и что я никогда в жизни не забыл бы свой пароль, учитывая тот факт, что я несколько лет пользовался одним и тем же паролем. Но DR dendryte все же решил продолжить игру.)

— Как же ты мог забыть свой пароль??!

— Не знаю, он как-то вылетел у меня из головы, наверное!

— Я не могу так вот просто раскрывать подобные пароли.

— И не надо........ты можешь просто впустить меня в систему.

— Если ты действительно The Knightmare, тогда скажи мне свое НАСТОЯЩЕЕ ИМЯ! Пауза, затем:

— Неужели ты не веришь своему лучшему другу и со-оператору? Давай же.....

— Я не могу тебе поверить!!!!! Никакой ты НЕ The Knightmare... (Здесь DR dendryte намекает на неграмотность хакера; DR dendryte знал, что в моих беседах онлайн я весьма щепетильно отношусь к правописанию.) Он никогда не делает таких дурацких орфографических ошибок, и с грамматикой у него тоже все в порядке, и... (Теперь они пытаются печатать одновременно. DR dendryte дает высказаться кракеру.)

— Это просто глупость! Я тебе больше не друг! Можешь стереть меня из BBS.

— Если ты и вправду тот, за кого себя выдаешь, давай перейдем на голос!

(Это значит, что DR dendryte просит хакера выключить свой модем и поднять телефонную трубку — перейти на голос.)

— Я не могу поверить, что ты не доверяешь мне.

— ПЕРЕЙДИ НА ГОЛОС.

— У меня в комнате нет телефона..

— Как это нет!? На книжной полке рядом с тобой!

— Он сломался.

—ХА!! Ты должен был сказать: “НА КАКОЙ полке?” V тебя в комнате НЕТ книжной полки! ХА-ХА- ХА-ХА-ХА-А. + + +

(Щелчок.)

На следующий день, когда DR dendryte поведал мне эту историю, я сказал: “Тебе стоило сказать ему:

„The “nightmare — это Я!" То-то он смутился бы!”

Подобное самозванство может сработать, но только в том случае, если вы достаточно близко знакомы с человеком, чью роль вы собираетесь сыграть. В данном случае хакер решил при входе в систему сыграть мою роль, правильно предположив, что в полночь я не могу находиться у системного оператора дома. Возможно, хакер также предполагал, что DR dendryte в это время будет спать.

Мне сдается, что подобная уловка скорее сработает на компьютере какой-нибудь большой корпорации, где никто не знает друг друга, а сотрудники могут и не питать такой любви к своей компьютерной системе, как системные операторы — к своим.

взлом по электронной почте

Treacherous Den BBS являлась лакомым куском для хакеров. Это была большая система, с множеством пользователей (многие из них сами были системными операторами других BBS), которая располагала десятками игр и цифровых порнографических картинок, которые можно было загрузить.

Эта система была списана с пиратской копии программного пакета одной популярной BBS, но DR dendryte так изменил его, что ему удалось официально зарегистрировать систему на свое имя. Как-то раз давний пользователь системы задал ему по телефону безобидный технический вопрос насчет BBS. DR dendryte попросил его подождать минутку у телефона, пока он поищет ответ в руководстве.

— О, вы купили его? — спросил пользователь, конечно, имея в виду программное обеспечение BBS.

— Ага, — ответствовал DR dendryte, имея в виду руководство, которое приобрел за четверть иены в букинистическом магазине.

DR dendryte ответил на вопрос, поговорил еще немного и повесил трубку. Он больше не вспоминал об этом разговоре, пока через месяц не получил по почте картонный конверт. Это был дискетный конверт с напечатанной на компьютере наклейкой обратного адреса, которая указывала, что данный адрес принадлежит компании, производящей программное обеспечение BBS. DR dendryte открыл конверт. Внутри оказалось письмо на его настоящее имя, подписанное автором программного обеспечения BBS, человеком, который также являлся основателем и владельцем компании. Письмо гласило:

Дорогой м-р А. Г.!

К... Software приняла новую политику обновления программного обеспечения. Все клиенты, приобретшие non-entertainment пакеты ао июля 1986 года, получают право на бесплатное ежегодное обновление.

Данная новая версия вашей программы полностью совместима с предыдущей. Для обновления необходимо лишь вставить прилагающуюся дискету и набрать START.

Благодарим Вас за покупку отличной продукции К... Software. Надеемся в будушем вновь увидеть Вас среди наших покупателей.

Искренне Ваш

(Подпись)

DR dendryte с первого взгляда не только понял, что это совершеннейшая липа, но и догадался, кто имел глупость послать ему такое письмо. Он сразу же сократил входной доступ того пользователя, с которым говорил тогда по телефону, до статуса однократного посетителя. Затем он написал записку ядовитого содержания и послал ему по электронной почте. Этот самый пользователь был единственным человеком, кроме меня, который знал о существовании руководства. Но я-то, разумеется, был в курсе, что DR dendryte не покупал программы, а руководство добыл иными путями. Пользователь же ошибочно решил, что, раз у системного оператора есть книга, значит, он купил BBS.

Изучив присланную по почте дискету, мы обнаружили, что она содержит восемь файлов.

Там был текстовый файл, где говорилось о “чудесных и волнующих мгновениях, которые вы испытаете, получив вашу обновленную версию L...BBS Software”. Еще там был файл инструкции под названием START, повторявший содержание того текстового файла. START должен был “обновить” старую версию программы на “новую”.

Еще на дискете присутствовали четыре файла, в точности совпадавшие с теми, что находились среди программного обеспечения настоящей BBS (явная попытка отвлечь наше внимание), а вот пятая программа не совсем совпадала с оригиналом! (Сравнить два файла можно с помощью команды MS-DOS “comp”, или используя соответствующие возможности Нортона или другой программы типа Нортона.) Наконец, на дискете был пустой файл под названием Т, который не нес никакой смысловой нагрузки.

Нам понадобился не один час, чтобы выяснить, для чего этот пользователь запрограммировал свою “новую” версию. Программы отличались двумя моментами.. Копия файла пользовательской информацией была создана, чтобы отправляться по электронной почте пользователю при первой загрузке; также была вставлена лазейка, которая должна была дать временный доступ в операционную систему любому, кто нажмет control-E, control-X, control-1, control-T, control-! в ответ на приглашение ввести имя пользователя.

Вам не удастся проделать подобный трюк, пока вы не получите доступ к исходной программе программного обеспечения, что, видимо, удалось сделать тому пользователю (если вы не хотите потом восстанавливать по кусочкам всю электронную доску объявлений).

Вот так была отбита еще одна атака этих назойливых хакеров!

разрушение BBS

На другой BBS, в которой я участвовал, системный оператор-каждый день, возвращаясь из школы домой, обнаруживал, что его система разрушена. Она просто зависала, и ее приходилось перезагружать. В конце концов, он узнал от кого-то, что в данной версии этой BBS имеется дефект. Комбинация “\х”, напечатанная в ответ на приглашение ввести пароль, приводила к останову всей системы. Ключевые узлы программного обеспечения BBS были написаны на легко изменяемом, понятном Бейсике. Для устранения данной проблемы я просто ввел строку после приглашения, которая должна была отсоединять любого, пытавшегося набрать ужасный “\х”.

Это подействовало. Я всегда удивлялся насчет этого “\х”. Как там могла оказаться такая вредоносная вещь? Я не могу представить себе программиста, намеренно вставившего ее, разве что он собирался досадить нелегальным пользователям своей программы. Возможно, это была какая-то лазейка, не сработавшая должным образом. Возможно, если бы я повнимательнее изучил программу, то понял бы, что это значит.

Вполне возможно также, что дефект был вставлен в программу тем человеком, который дал оператору копию программного обеспечения, или тем, который сделал первую пиратскую копию, или еще кем-либо из этой цепочки. Пиратское программное обеспечение так быстро распространяется по стране и по всему миру, что буквально тысячи людей могли бы добавить этот дефект с “\х” и распространять программу дальше в таком виде. Эй, у вас еще не появилось никаких идей по этому поводу? У меня они уже есть!

Можно либо написать собственную программу для BBS, или изменить уже существующую, добавив некоторые секретные свойства, такие как выход в DOS, или любую другую лазейку на ваше усмотрение. Можно добавить строку, которая будет обнаруживать при вводе наиболее сложные и необычные управляющие коды и присуждать таким пользователям наивысший уровень доступа к системе.

Метод, похожий на эту тактику, — написать или изменить терминальную программу, которую вы дадите пользователю. Когда она примет внутренний код во время соединения с вашей BBS, вы получите доступ к вызывающему компьютеру. Например, вызывая вашу BBS, пользователь запускает вашу специальную терминальную программу. BBS должна послать на модем вызывавшего пользователя код, который позволит вам разгуливать по жесткому диску данного пользователя. Чтобы сделать свое присутствие незаметным, лучше всего входить во время передачи какого-нибудь длинного файла или, если скорость передачи модема невысока, в перерывах между его работой. Пока вы исследуете диски удаленного пользователя, терминальная программа может продолжать делать вид, что принимает данные.

PRODIGY, графически ориентированной интерактивной службе онлайн, летом 1991 года было предъявлено обвинение в занятиях подобными вещами. Пользователи обнаруживали свои личные данные, спрятанные внутри программного обеспечения, которое использовалось для вызова PRODIGY. После жалоб пользователей на грубое нарушение их прав главный вице-президент PRODIGY выслал оскорбленным утилиту, предназначенную для удаления несущественных данных из терминального программного обеспечения службы. В сопроводительном письме он без тени раскаяния заявлял:

Как мы уже утверждали публично и сообщали онлайн, программное обеспечение PRODIGY не считывает, не собирает, а также не перелает компании службы PRODIGY никакую информацию либо данные, не имеющие прямого отношения к вашему использованию службы. Мы хотим заверить вас, что продолжим работу над обеспечением безопасности личных данных всех наших участников.

Может, они и не делают ничего такого — но вы-то ведь можете!

Несколько лет назад группа предприимчивых хакеров распространила доморощенную терминальную программу с дефектом для компьютеров Macintosh. Программа предлагала пользователям удобную опцию, позволяющую хранить пароли и другие процедуры входа на дискете, чтобы можно было не бояться их забыть. Информация хранилась в зашифрованной форме на спрятанной части дискеты. Через несколько занесенных туда паролей и телефонных номеров программа “портилась”. Хакеры надеялись, что пользователи отошлют дискеты обратно, и в результате у них окажется богатый выбор входной информации.

Но на деле все оказалось не так, как задумывалось. Это PRODIGY может отмахнуться от вопросов пользователей благодаря своему уникальному графическому интерфейсу. А пока вам не удалось разработать в своей терминальной программе нечто подобное, нечего и мечтать о том, что пользователи возьмут на себя труд инсталлировать и изучать вашу программу, в то время как они уже знакомы с одной или несколькими коммерческими пакетами. Примерно такая судьба и постигла эту группу хакеров. Вначале их терминальная программа вызвала большой интерес (они свободно распространяли ее), но ни у кого не возникло желания ее использовать. Проблема была в том, что хакеры отдали программу в руки опытных пользователей, которые уже были близко знакомы, по крайней мере, с одной коммерческой программой. Хакерский терминальный пакет никому не понадобился, и великая идея с треском провалилась.

Что касается той первой идеи — изменить BBS, включив в нее лазейки, — это действительно возможно. Всегда найдутся люди, желающие установить свою BBS, или те, кто хочет приобрести новое программное обеспечение. Проблема распространения здесь имеет меньшее значение, нежели проблема программирования — особенно учитывая тот факт, что вам придется не только вставлять программу для лазейки, но и, для достижения лучших результатов, придумать способ, как спрятать эту программу от любопытных глаз.

“Троянские кони”

Для хакера обычно не составляет большого труда начинить BBS какой-либо версией программы типа “троянский конь”. Хакер пишет программу, предназначенную для выполнения какой-нибудь интересной функции, например, запуска игры или вывода на экран привлекательных картинок. В программе спрятаны инструкции для прочтения файлов паролей BBS, или выполнения другой скрытой операции. Затем хакер подзагружает программу в BBS и — внимание, это важно! — надеется, что системный оператор запустит программу.

Для написания “троянского коня” вам понадобится достать копию программы BBS, чтобы точно знать, каковы будут ваши тайные инструкции. Иначе как же вы узнаете, в какие файлы следует заглядывать и в каком секторе диска находится нужная информация?

Какие действия, помимо секретных, могут выполнять “троянские кони”? Вот несколько предложений:

Можно тайно перепрограммировать саму BBS так, чтобы в ней оказалась лазейка. Если программа BBS написана на интерпретируемом языке, “троянский конь” может добавлять несколько строк, которые дадут вам операторский доступ при вводе определенного кодового слова. Именно так и произошло с популярной электронной доской объявлений Commodore 64, написанной на Бейсике.

Вы можете запрограммировать “троянскую лошадку” так, что она будет заглядывать в файл, содержащий пароли, и каким-либо образом пересылать содержащиеся в нем данные обратно к вам. Во многих BBS существует секция текстовых файлов. Можно сделать так, что ваша программа будет зашифровывать пароли, добираясь до них, а затем присоединять в конец одного из текстовых файлов. Затем вам останется только загрузиться, просмотреть файлы, взять закодированные пароли и расшифровать их. Другие люди, читая текстовые файлы в режиме онлайн, примут случайно расположенные на первый взгляд символы за помехи в линии передачи или безвредное искажение файла.

Другой способ отправить себе информацию о паролях состоит в использовании функции электронной почты BBS. Дабы избежать подозрений (системные операторы обожают читать электронную почту, которую пользователи посылают друг другу), вам следует, опять же, закодировать информацию и включить ее в какую-либо другую порцию электронной почты.

“Троянский конь” может содержать приближенную версию какой-либо ключевой части самой программы BBS. Затем “лошадка” извлекает искомый кусок и копирует его поверх легальной версии, записанной на диске.

как скрыть деятельность “Троянских коней”

Когда вы загружаете в систему программу, содержащую “троянского коня”, вам следует иметь в виду два момента:

• Вашу “лошадку” могут обнаружить в процессе ее работы.

• Ее могут обнаружить либо до, либо после прогона.

Давайте по очереди рассмотрим эти две проблемы.

во время работы

Рациональному хакеру легче избежать этой опасности, чем злонамеренному разрушителю системы. Дело в том, что, если Юнец Джо напишет программу, которая тайно переформатирует жесткий диск, в то время как лампочки жесткого диска будут непрерывно зажигаться, на экране должно происходить нечто, способное отвлечь внимание пользователя. Юнцу Джо следует с умом соорудить некий не интерактивный “тайм-киллер”, который будет развлекать пользователя на протяжении всего времени, которое понадобится для форматирования диска или для уничтожения файлов. Это может быть порнографическая картинка (возможно, дополненная цифровыми звуковыми эффектами: “О! О, детка! М-м-м...”), или цифровая музыкальная партитура; программа может также посылать графическое изображение на принтер. Между тем ваши быстродействующие “троянские кони” (“спринтеры”) будут в срочном порядке делать свое дело.

Никогда не допускайте вашу программу на жесткий диск (или любое периферийное устройство), если системный оператор не сможет увидеть причины для этого. В то время как “троянский конь” будет заниматься своим делом, на экране должно быть сообщение, дезинформирующее оператора о работе программы. Например, если “лошадка” спрятана в игре,

она должна посылать на экран сообщение вроде: “Сохранение вашего последнего счета...”, тогда как на самом деле программа будет копаться в пользовательских файлах доступа (или делать что-то еще, на ваше усмотрение). Не забудьте о том, что попутно программа действительно обязана сохранить новое количество очков пользователя, а общее время ее работы должно быть весьма кратким. Как только “троянский конь” закончит работу, программе следует стереть с экрана сообщение; это позволит убедиться в том, что работа программы с жестким диском не вызвала подозрений. Если будет возможность, сотрите сообщение с экрана посреди работы “троянского коня”, чтобы создать иллюзию очень малого времени обращения к жесткому диску.

Другой способ незаметно добраться до диска состоит в том, чтобы в начале работы программы выдать на экран нечто типа:

AutoCheck Virus Detection Program v1.3 ©opyright 1992 Paul Bradley Ascs.

Scanning file FILENAME.1 for viruses..... Scanning file FILENAME.2 for viruses...

А тем временем “троянский конь” будет “проверять” жесткий диск компьютера на пароли!

В качестве FILENAME.1, FILENAME.2 и т. д. можно вставить имена программ и файлов данных, которые были загружены вместе с приложением. Замечательным штрихом будет не мгновенное, а постепенное появление на экране скобок (...) после каждого обращения к жесткому диску, дабы создать впечатление, что программа действительно проверяет файлы на вирусы.

“Прикрыть” деятельность “троянского коня” (в соответствующих обстоятельствах) можно также с помощью сообщений типа: открытие файла данных, чтение данных, сохранение выбора перед выходом,

загрузка текста

Сообщения всегда должны соответствовать тому, что в действительности происходит в видимой части программы.

“Троянские кони”, выполняющие функции BBS (такие, как изменение паролей), должны, если возможно, делать это путем прямого доступа к диску, не используя программу BBS. Это позволит вам обойти любые защитные протоколы и распечатки подозрительных действий.

до и после

Системные операторы, администраторы систем и даже обычные пользователи стали теперь осторожнее относиться к пересылке файлов. Они, как минимум, опасаются вирусов, и изучают программы перед тем, как их использовать, более тщательно, чем когда бы то ни было раньше.

Это означает, что они будут проверять ваши подгруженные программы на вирусы с помощью сканера. Такая проверка практически неизбежна, но бояться нечего, так как существующие программы проверки на вирусы не смогут обнаружить вашего “троянского коня” ни в одном из законных файлов. Вам следует опасаться только того, что системный оператор или менеджер станет собственноручно изучать ваши подгруженные программы в поисках нецензурных слов или ошибок.

Как и в предыдущем случае, сознательным разрушителям и системным вандалам придется труднее, чем вам. У них есть текст, который им придется прятать внутри своих программ. Например, всем известен вирус, или логическая бомба, которая вопит “GOTCHA!!” (“Попался!”), когда записывается поверх таблицы размещения файлов. Существующие программы ищут в файлах именно подобные веши. Даже если у оператора не имеется соответствующей программы, но он достаточно наблюдателен, разрушительское “GOTCHA!!” будет замечено еще до того, как программа начнет работать.

Ваших “троянских коней” не придется прятать слишком тщательно. Весь текст в ваших программах будет состоять из текста, который так или иначе будет выведен на экран: текст, либо являющийся частью прикладной программы, либо текст, который исходит из программы, а на самом деле прикрывает деятельность “троянского коня”. К тому же в вашей программе не будут торчать, подобно ослиным ушам, команды типа “format с:”. Таким образом, ваша работа легче, чем у кракера, хотя далеко не является пустяком.

В вашей программе могут быть команды чтения, записи или изменения хранящихся в BBS личных файлов. Системный оператор не должен обнаружить ни таких команд, ни, тем более, имен файлов. Использовать для кодирования команд и имен шифр “на одну букву выше” нежелательно, так как существуют программы, которые сканируют файл и выводят на экран содержащийся в нем удобочитаемый текст. Если вы просто замените все буквы следующими по порядку (т.е. PASS превратится в QBTT, и т. п.), в программе все равно останется текст в закодированном виде, и

оператор может догадаться, что он означает. Лучше, если вы закодируете текст, используя цифры, символы или иностранные алфавиты.

Программа, в которую вы вставите “троянскую лошадку”, может являться не откомпилированным исходником или пакетным файлом. В этом случае, чтобы спрятать “троянских коней”, вам понадобится некоторая ловкость рук. НИКОГДА не загружайте пакетный файл просто так, в его первоначальном виде. Представьте себе состояние системного оператора, получившего от пользователя следующее:

cd BBS\USERS

open USERINFO.TXT

read USERINFO.TXT: User#44

set systemlevel 3 == systemlevel 99

close

exit

Это не настоящая программа. Я привел ее в качестве примера наглой попытки повышения уровня доступа, которая неминуемо привлечет внимание системного оператора.

Один из способов избежать этой проблемы — заставить ведущую прикладную программу создавать пакетные файлы и другие программы, которые для этого требуются. Пакетные команды запускаются как закодированная абракадабра в прикладной программе. Требуется подпрограмма, которая открывала бы текстовый файл, расшифровывала команды, наполняла ими файл, а затем делала свое дело. Создание и использование файла могут происходить в различные промежутки времени, чтобы не удлинять время нелегального доступа к диску.

В легко читаемых источниках “троянская лошадка” также не должна стоять в самом начале или в конце листинга. Засуньте ее поглубже в программу. Добавьте комментарии, способные отвлечь внимательного читателя. И помните, если ваша прикрывающая программа будет особенно умно сделанной, системному оператору может захотеться проанализировать ее, чтобы понять, как это вы добились столь выдающихся результатов! Это означает, что прикрывающая программа может оказаться объектом пристального внимания, и вашего “троянского коня” могут случайно обнаружить.

После использования “троянского коня” программа должна его уничтожить, т. е. последние несколько действий “троянского коня” должны стираться из программы.

Стереть прикладную программу, а вместе с ней и “троянского коня”, может и сам системный оператор. Это может оказаться сложным — заставить системного оператора стереть все загруженные вами файлы, не вызывая никаких подозрений. Способ заключается в следующем: прикладная программа должна являться чем-то уже имеющимся у оператора, или чем-то похожим на его версию, но похуже.

Вы можете даже просто послать системному оператору письмо по электронной почте, в котором сообщите, что обнаружили в программе потенциально опасную ошибку, а “в случае, если вы решите уничтожить ее, я вышлю вам исправленную версию”. Так можно поступать только в случае, если прикладная программа, которую вы послали, откомпилирована, иначе системный оператор сможет и сам устранить ошибку (уж он-то устранит!)

Встречаются операторы-параноики, которые пересылают все подгруженные файлы на другой компьютер, прежде чем запустить их. Могут также быть установлены иные, чем вы ожидали, директории, или сама BBS может загружать файлы не на жесткий диск, а на гибкий. Помните об этом, когда будете создавать свою программу, чтобы ваша “троянская лошадка” срабатывала лишь тогда, когда компьютер установлен так, как предполагалось. Таким образом, она будет запускаться, только получив доступ к файлам с паролями, или для чего вы там ее предназначите. Это необходимо также потому, что, если ваша прикладная программа окажется достаточно качественной, системный оператор сделает ее доступной для загрузки другими пользователями.

“сделай сам”: пять узелков на память

Мы с вами уже говорили о хакерских BBS. Что, если вы будете усердно искать подходящую BBS, чтобы приобретать знания и делиться информацией, но ваши поиски не увенчаются успехом? Вы можете создать собственную BBS, полностью отвечающую вашим потребностям. Раздобудьте подходящее программное обеспечение, соберите самых верных друзей — и установите собственную электронную доску объявлений! Запуск собственной системы означает, что отныне вам не придется особенно много работать на своем домашнем компьютере и использовать свою телефонную линию. Это не станет проблемой, если вы занимались исключительно хакерством, поскольку теперь ваши возможности значительно расширятся благодаря использованию лап-топов и т. п. Но вы, скорее всего, используете свой компьютер и в других целях: играете, набираете тексты, программируете, а также легально пользуетесь модемом. Не забывайте об этом, прежде чем загоритесь идеей создания собственной BBS.

Один из способов обойти данную проблему — а вместе с ней и многие другие проблемы, которые возникают при установке BBS — применить ваши хакерские способности и взломать какой-либо мэйнфрэйм, находящийся далеко от вашего дома, а затем использовать его для установки вашей электронной доски объявлений.

Где бы вы ни решили установить вашу систему, вам понадобится фальшивый фасад, чтобы система выглядела легальной, и обратная сторона, заключающая в себе закрытую область только для избранных хакеров. Приглашайте в этот круг только тех, кого вы знаете как разумных и достойных доверия хакеров, а остальную часть доски пусть использует, кто захочет.

Я видел, как создавались просто фантастические BBS, которые кончали весьма плачевно. И видел средненькие BBS, которые быстро зарекомендовали себя самым лучшим образом. Что до хакерских BBS, вам не придется испытать значительного взлета, поскольку хакерские BBS редко занимаются саморекламой — в конце концов, вы же не хотите, чтобы в вашу BBS входил кто попало. Но вам все же захочется привлечь и удержать новых пользователей — кто знает, вдруг они окажутся именно теми, кого вам хотелось бы в личном порядке пригласить в ваш секретный “уголок хакера”, к вашему взаимному удовольствию?

Стратегия привлечения и удержания новых пользователей заключается в том, чтобы установить, подключить и не выключать вашу BBS. Многие неопытные системные операторы, взволнованные перспективой запуска своей собственной системы, постоянно отключают свои BBS от линии и производят в них усовершенствования. Не делайте этого! Если кто-то захочет сделать вызов, и ваш компьютер не ответит, повторного вызова он уже не сделает.

Рекламируйте вашу BBS на других BBS, членов которых вы хотели бы видеть и у себя.

Пусть члены вашей BBS проводят разведку, пытаясь обнаружить подпольные хакерские BBS. Вы сможете приобрести полезную информацию для обмена, а может вам повезет и вы обнаружите хакера, достойного принятия в ваш клуб.

Прежде чем допустить незнакомого хакера в потайную область ваших хакерских “под-досок”, вы должны не раз и не два удостовериться в том, что он или она не является полицейским. Настоящие хакерские BBS устанавливают для новых членов настоящий обряд инициации, включающий рекомендации от уважаемых хакеров, полное раскрытие хакером личной информации, которую можно проверить, и автобиография с подробным описанием достижений и того, что хакер может дать группе. Не окажитесь в дураках! Убедитесь, что тот, кто называет себя хакером, не является на деле агентом ФБР — проверьте величину его кредита, данные телефонной компании и участие в других компьютерных системах. Вам следует призвать на помощь все свои хакерские способности, чтобы убедиться, что данная вам личная информация соответствует реальной личности. Это вовсе не паранойя, а здравый смысл. Очень многие хакеры были обмануты самозванцами. Безопаснее всего вообще не принимать в вашу BBS новых членов; но это не лучший выход, поскольку таким образом вы теряете громадное количество информации.

Можно весьма приятно провести время, изучая электронные доски. Это поможет вам отточить ваше умение и очень многому вас научит. BBS так бесконечно много, что хакер может обнаружить, что дни и ночи просиживает, соединяясь с ними, не испытывая удовольствия от настоящего взлома. Учитывая всю опасность занятий хакерством, это не самый худший вариант.

В следующей главе мы еще рассмотрим способы, с помощью которых хакер может уйти от закона. А теперь давайте вернемся к хакерству — все самое полезное и интересное впереди!


Глава 9. Что греховно, а что нет

— Балаганов, — представился рыжеволосый. — Шура Балаганов.

— О профессии не спрашиваю, — учтиво сказал Бешер, — но догадываюсь. Вероятно, что-нибудь интеллектуальное? Судимостей за этот гол много?

— Две, — свободно ответил Балаганов.

— Вот это нехорошо. Почему вы пролаете бессмертную душу? Человек не должен судиться. Это пошлое занятие. Я имею в виду кражи. Не говоря уже о том, что воровать грешно, — мама, вероятно, познакомила вас в детстве с такой доктриной, — это к тому же бесцельная трата сил и энергии.

И. Ильф, Е. Петров. Золотой теленок.

Я хочу поговорить о некоторых не хакерских методах разрешения хакерских проблем. Бывают случаи, когда по какой-то причине хакеру требуется совершить взлом за какой-то определенный короткий промежуток времени. В таких ситуациях обычные методы, занимающие много времени, не годятся, и тогда приходится прибегать к крайним мерам. По большей части речь идет о хакерстве как профессии, и я чувствую необходимость рассказать здесь об этом, поскольку в последнее время в мире хакеров стало модным работать “хакером по найму”.

хакерство по найму

Некоторые хакеры “перевоспитываются”, становясь консультантами по компьютерной безопасности в корпорациях и правительстве. Такие “перебежчики” подвергаются нападкам с двух сторон. Хакеры говорят: “Как вы смеете так поступать с нами!” (Возражение: “Настоящие хакеры не станут выдвигать

такие обвинения. Настоящий Хакер получает удовольствие, пытаясь перехитрить другого хакера и не дать ему пробить брешь в компьютерной защите”. Законопослушные граждане тоже недовольны:

“Раньше ему нельзя было доверять, почему же мы должны верить ему теперь?”, или: “Если вы знаете, как взломать систему, это еще не означает, что вы знаете, как защитить ее от взломщиков”. Это достаточно разумные доводы.

Если у вас есть желание заняться этим делом, знайте — вы не одиноки. Компании платили по 20 000$ и более хакерам, которые соглашались попытаться проникнуть в их компьютеры. “Команды тигров” (“Tiger teams”) — так называют группы хакеров, а порой и хакеров-одиночек, которых нанимают организации для проверки своей компьютерной зашиты на прочность. Если вы решили избрать этот путь, вам придется создать себе репутацию профессионала, которому можно доверять. Вы должны будете доказать, что вы компетентный хакер, но не следует давать понять, что в вас живет бунтарский дух.

Помните, что компьютеры подвергаются опасности не только со стороны кракеров. Существуют вирусы, неподходящие для компьютеров условия, растяпы-сотрудники и другие беды, способные отправить на дно самый непотопляемый корабль. Предупреждая владельцев компьютеров о возможных неприятностях, вы завоюете себе исключительное уважение и рекомендации для других нанимателей.

Что касается критики со стороны “защитников закона”, важно предлагать средства для ликвидации любых прорех в компьютерной защите, которые вы обнаружите в ходе своих исследований. Вы — хакер, а значит, знаете хакерский способ мышления. Вам известно, что у них на уме, известны их методы, следовательно, вы действительно имеете основания давать рекомендации по защите систем от вторжения. Объясните своему работодателю, почему для него очень важно следовать всем вашим советам. Сообщите, как вы проникли в систему, какие слабые места обнаружили, расскажите о потенциальных недостатках, которые могут повлечь за собой неприятности в будущем.

Подходящими клиентами могут стать также частные лица, которые обеспокоены неприкосновенностью информации, хранящейся в их базах данных. Хакеров нанимали для изменения телефонных номеров, поиска отсутствующих в каталогах номеров и адресов, перемещения файлов, просмотра лицензированных данных, изменения учебных уровней и т. д. Взлом компьютеров предприятий по договору с этими же предприятиями — абсолютно законное занятие, но, помогая людям проникать в файлы данных и даже изменять их, вы нарушаете закон. Отсюда следует, что выбирать тех, с кем вы будете иметь дело, и раскрывать им свои личные данные надо весьма осторожно.

Хакерство — это хобби. Если же за него вам начинают платить, перед вами встает вопрос: что, если вы не сумеете выполнить работу?

Конечно же, для Супер-Хакера вроде вас не бывает никаких преград; но порой поджимают сроки, или возникают непредвиденные трудности, и система, в начале выглядевшая такой хрупкой, вырастает в громадного непробиваемого монстра, преодолеть которого вы не в силах. Тогда-то и начинается игра не по правилам. Надеюсь, вам не придется прибегать к этим не хакерским методам. С другой стороны, если настал момент, когда вы должны выбирать — либо опустить руки, либо закончить работу с помощью нетрадиционных способов, лучше выбрать последнее, дабы не запятнать своей репутации.

Кроме того, к чему ограничивать себя чисто хакерской техникой, в то время как куча взломщиков не постесняется использовать эти нестандартные методы, захоти они проникнуть в систему? Если компания платит вам за то, чтобы вы остановили взломщиков, вам следует проверить, не сработают ли грубые приемы, широко распространенные среди жаждущих получить доступ к компьютеру не-хакеров. Более того, вы обязаны таким образом проверить на прочность систему, за безопасность которой вам платят.

ГРЯЗНЫЕ уловки

Я называю эти уловки грязными, поскольку такие веши присуши лишь грубым дилетантам. Эта “техника” — как раз для не хакеров. Скажу больше: такие веши присуши только тем, кто вообще не является компьютерным пользователем! Под “компьютерными пользователями” я подразумеваю тех, кто использует компьютеры потому, что им этого хочется, а не по необходимости.

Зачастую эти уловки используются для совершения грабежа или шпионажа — областей, которые имеют отношение к настоящему хакерству лишь постольку, поскольку имеют отношение к компьютерам. Настоящий хакер должен знать о существовании этих уловок, но прибегать к ним только в последнюю очередь, и только тогда, когда у него имеются серьезные причины для совершения взлома.

взятки

Возможно, не стоит давать взятку самому администратору системы, но, возможно, найдется некто рангом пониже, тоже обладающий “наивысшим доступом”, кто захочет за определенную плату одарить тем же доступом вас. Лучше использовать взятки для получения доступа к системе, чем подкупать человека, чтобы тот выполнил за вас компьютерную задачу. В конце концов, вы же не хотите втягивать его в свои дела; если вы занимаетесь шпионажем посредством компьютера, то вам меньше всего нужен сотрудник компании, знающий о ваших занятиях.

Используйте взятки либо для получения доступа к бюджету того, кому вы даете взятку, либо к только что созданному бюджету привилегированного пользователя. В последнем случае входите в систему только в отсутствие того, кому вы дали взятку, чтобы тот не захотел из любопытства посмотреть, чем вы занимаетесь.

плохое отношение

Это не совсем “грязная уловка”, но что-то вроде этого. Если вам удастся найти сотрудника, особенно программиста, который зол на компанию, а может, даже собирается увольняться, — считайте, что дело сделано. Используйте его или ее обиду на компанию против компании. Напомните ему, как нехорошо компания поступила с ним, что его работу не оценивали должным образом, постоянно отдавая предпочтение другим. Не вдаваясь в подробности, сообщите, что вы хотите помочь ему отомстить компании. Конечно, такие веши недостойны хакера, но если вам удастся привлечь на свою сторону оскорбленного сотрудника, он-то и понесет ответственность за ваши хакерские дела (да, временами я бываю жесток, знаю).

В любом случае, сотрудники, которые ищут лучшей доли, или те, кому опротивели их начальники, являются богатейшим источником закрытой информации, включая профессиональный жаргон компании, телефонные директории, процедуры и стратегию. И, разумеется, пароли.

Если вашей целью является система с наивысшей степенью зашиты, ваша последняя надежда — обзавестись другом, работающим в данной организации. Но бывший сотрудник будет рассержен тем, что его использовали. Если вы услышите о сотруднике, который собирается увольняться, или которого собираются уволить, — используйте эту возможность для сбора необходимых вам данных. Ведь компьютерные бюджеты будут существовать еще долго после того, как сотрудник покинет компанию. После того, как это произойдет, ему станет все равно, используете вы его пароль, или нет.


Глава 10. Что делать, когда вы внутри

Остап вдруг опечалился. Стало ему немного скучно, как Роальлу Амундсену, когда он, пронесясь в дирижабле "Норге” над Северным полюсом, к которому пробирался всю жизнь, без воодушевления сказал своим спутникам: *Ну, вот мы и прилетели”. Тайна раскрыта, цель достигнута, делать больше нечего, и надо менять профессию.

И. Ильф., Е. Петров. Золотой теленок.

Кажется, все получилось. Вы вошли в систему, вы внутри. Замечательно! Оглядитесь вокруг! Конечно же, именно этим вы и займетесь, когда проникнете в систему и мысленно похлопаете себя по плечу. Но что дальше? Чтобы ответить на этот вопрос, мы должны еще раз обдумать наши цели и намерения.

вернемся к хакерским мотивациям

Мотивами настоящего хакера являются его желание учиться, познавать, и применять свои хитрости с умом и безопасно.

Остальные, также использующие хакерские уловки, могут делать это или потому, что им хочется научиться секретам своего конкурента; или потому, что они хотят узнать, почему им постоянно недоплачивают; либо для того, чтобы с умом перехитрить компанию или частное лицо, которые что-то задолжали им, и таким образом осуществить свою месть.

Итак, что мы понимаем пол словом “хакер”? Свободомыслящего компьютерного энтузиаста, затем — промышленного шпиона, политико-промышленного шпиона, кракера-мстителя и, наконец, хакера по найму. Все вышеупомянутые взломщики при совершении взлома в основном добиваются получения низкого уровня доступа. Так происходит потому, что бюджеты с низкой степенью зашиты превалируют, а многие хакерские хитрости рассчитаны на наивных пользователей, которым обычно и принадлежат бюджета низкого уровня.

Хакерам по найму и хакерам-шпионам приходится ориентироваться на конкретные компьютеры, а порой и на конкретных людей. Они либо ищут определенную комбинацию имя, пароль, либо добиваются любого доступа с уровнем, достаточно высоким для получения тайного доступа в бюджет их “мишени”.

Вандалы и хакеры-мстители, само собой, стремятся к получению более высокого уровня доступа, чем тот, который им удалось получить при взломе, но при отсутствии достаточной сноровки они, скорее всего, изберут тактику внезапной стремительной атаки с последующим отступлением.

Это означает, что их вполне устроит взлом под любым паролем и причинение возможно большего вреда; после этого они ретируются, отправив по электронной почте ядовитое послание. Они могут атаковать снова и снова, до тех пор, пока их не арестуют, либо выставят из системы навсегда. Такие “хакеры”, скорее всего, удовлетворятся добытым низким уровнем доступа, чтобы делать свое дело. Но уж если они обладают определенными навыками, или компьютерным “ноу-хау” —тогда берегись!

Настоящий хакер необязательно доводит свой взлом до самого конца. Ему или ей может показаться, что не стоит расходовать свои силы, чтобы повысить свой уровень системного доступа. Это вовсе не сдача своих позиций, а всего лишь практичный взгляд на веши. Если искомая информация незначительна, или ее можно добыть и другим способом, незачем тратить время на ее получение. Хакер может также не настолько хорошо знать данный компьютер, или работающих на нем пользователей, или операционную систему, чтобы чувствовать себя способным достичь наивысшего уровня доступа. Это естественное и разумное чувство; если хакер сознает, что он в чем-то не дотягивает, он вполне может остановиться, чтобы подзубрить то, в чем пока несведущ. Если происходит нечто подобное, то, возможно, хакеру достаточно лишь провести дополнительные исследования, чтобы снова напасть на след, ведущий к статусу привилегированного пользователя. Вот что сказал об этом хакер по прозвищу “Умник”: “Я знаю, что компьютер от меня никуда не денется. Мне нравится взламывать, но и проводить исследования я тоже не прочь. Иногда я чувствую, что исследования, которые могут помочь мне войти в бюджет — работу с книгами, или социальную инженерию, — лучше отложить на потом, а сейчас пора заняться НАСТОЯЩИМИ исследованиями компьютера”.

Войдя в систему, хакер получает возможность не только повышать свой системный статус. Он может также:

— Читать доступные документы и запускать программы.

— Загружать файлы.

—Довести до сведения системного администратора данные о наличии изъянов в обеспечении безопасности.

— Изучать коммуникационно-вычислительное оборудование.

— Проверить, не соединен ли данный компьютер с другими.

— Покидая систему, каким-либо образом прикрыть свое отступление.

— А еще можно просто выйти из системы и никогда больше в нее не возвращаться.

Если вы приняли решение раздобыть какие-либо данные, которые, по вашему мнению, могут обладать определенной ценностью, вы можете захотеть продать эти данные, а на вырученные деньги сделать очередное компьютерное приобретение. Я настоятельно рекомендую никогда не поступать подобным образом. Профессия шпиона всегда сопряжена с серьезной опасностью. Вдобавок такие действия способствуют падению имиджа хакеров в глазах общественности, и в отдаленном будущем могут повлечь за собой весьма неприятные последствия для хакеров вообще, а в ближайшем будущем —для вас лично (если вас поймают).

Хотя большинство законников и офицеров безопасности со мной не согласится, я уверен в том, что простой просмотр файлов системы, без вмешательства в процесс ее работы, вряд ли может кому бы то ни было повредить. Во всяком случае, чтение личных данных — не большее преступление, чем сам взлом. Вам следует установить для себя определенный “кодекс чести”, и я искренне надеюсь, что он будет основан на хакерском кодексе чести, о котором идет речь и в начале, и в конце этой книги.

Немедленный выход из системы с тем, чтобы никогда в нее не возвращаться, — поступок, характеризующий сумасшедших хакеров-фанатиков. Я не могу понять, как можно морально оправдывать сам взлом системы, в то же время открещиваясь от входа в нее. Мне кажется, что хакеры, которые отсоединяются от системы, не входя с ней во взаимодействие, поступают так либо потому, что для них имеет значение лишь сам факт взлома, либо потому, что они панически боятся всего нового.

Все другие возможности, о которых я упомянул, — повышение статуса, помошь системным операторам, изучение — предполагают различные степени знакомства со взломанной системой. Давайте поговорим о том, где вы оказались, и чем вам следует заняться, войдя во взломанную систему.

Начнем с того, что взломанный вами бюджет может являться бюджетом отдельного пользователя, групповым, корневым, или “специальным” бюджетом.

Если вы вошли в главный (корневой) бюджет — примите мои поздравления! Теперь вы можете делать все, что захотите. Это бюджет системного администратора, или одного из системных администраторов (его называют также бюджетом аватара, божественным бюджетом, администраторским бюджетом, бюджетом привилегированного пользователя, бюджетом полубога, бюджетом “сисопа” и т. д.)

“Групповой бюджет” принадлежит сразу многим людям. Он может вводиться, например, в отделе, где каждый из сотрудников входит в систему с помощью одной и той же комбинации имя, пароль. Иногда определенные пользователи имеют внутри него отдельный собственный бюджет. Так, многие компании устанавливают ограниченные бюджеты для секретарей, временных сотрудников и т. п. Групповые бюджеты бытуют и там, где доступ к терминалам имеют несколько человек, которые обладают различными уровнями защищенности. В данном случае изучать базу данных могут все пользователи, но вносят в нее изменения только те, кто входит под определенным паролем.

“Специальные бюджеты” включают в себя гостевые или демонстрационные бюджеты, которые дают пользователю возможность сделать краткий обзор, прежде чем воспользоваться услугами системы. Это могут быть и проверочные бюджеты, установленные системными программистами. Специальные бюджегы могут также, в учебных и других целях, давать доступ прямо к программе, минуя приглашение операционной системы. Если вы решили взломать специальный бюджет, вам придется нелегально выходить из него в операционную систему, чтобы повысить свой уровень доступа. В любом случае, прежде чем действовать, вы должны выяснить, какой у вас доступ, какими правами вы обладаете, и каким образом лучше их использовать. Возможно, вам понадобится специальная информация о машине и ее программном обеспечении. Но есть одна малюсенькая штуковина, которую вы должны знать назубок. Я уже дважды упоминал о ней — это операционная система.

операционная система

Забудьте все, что вы знаете о компьютерах, и давайте начнем с самого начала.

Допустим, у вас есть компьютер, предназначенный только для одной функции. Например, на нем можно играть в игру. Когда вы включаете такой одноцелевой компьютер, игра автоматически запускается, а больше этот компьютер делать ничего не может.

Теперь давайте дадим этому компьютеру еще одну функцию. Пусть на нашем компьютере теперь можно будет не только играть, но и использовать текстовый процессор. Таким образом, мы будем иметь двухзадачный компьютер.

Что произойдет при включении такого компьютера? Может быть, запустится игра? Да нет — а вдруг мы включили его, чтобы поработать с текстовым процессором? Как видите, теперь нам приходится делать выбор. При включении компьютера потребуется каким-то образом сообщить компьютеру, что нам нужно — игра или текстовый процессор. Как же дать компьютеру знать, что именно нам необходимо?

Конечно, можно сделать два разных переключателя — левый для запуска игры, а правый — для текстового процессора. Идея неплоха, но только на время. Вдруг мы захотим добавить третью функцию? Четвертую? Нельзя же все время добавлять все новые переключатели?

Вместо добавления аппаратных переключателей я добавляю третью программу — программный переключатель. Такая программа называется операционной системой (ОС) и автоматически запускается при включении компьютера.

Операционная система — это программа, которая и позволяет сделать выбор между игрой и текстовым процессором. Например, при запуске она будет выдавать на экран окно: “Какая программа?”, на которое следует ответить: “Игра”, или “Текстовый процессор”.

Как вам известно, практически то же самое и происходит в реальных ОС. Когда компьютеры только зарождались, и могли выполнять только запуск считанного количества программ, управляющее программное обеспечение называлось “монитором”. Затем, когда компьютеры усложнились, понадобилось управлять множеством пользователей, большим количеством периферийных устройств, безопасностью и хитросплетением программных функций, монитор превратился во всеобъемлющую программу, которая могла делать намного больше, чем просто давать пользователю возможность выбора между несколькими программами. Таким образом, сейчас для обозначения этой сложной программы используется термин “операционная система”.

ОС управляют работой всего компьютера: контролируют распределение ресурсов, использование памяти, запуск программ. Когда вы разберетесь в этой абсолютной программе, то поймете, что представляет собой управление компьютером.

Вот некоторые из операционных систем, с которыми вы, вероятно, столкнетесь: UNIX, MS-DOS или PC-DOS (на IBM-совместимых), PRIMOS, RSTS (на PDP-11) и VMS. В последнее время вместе с компьютерами нового поколения все большее распространение получили Windows (Windows 3.11 или Windows 95) — капризные и “навороченные” графические оболочки, которые, тем не менее, дают знающему человеку почти неограниченный простор для всевозможных забав.

Вам необходимо разбираться в ОС, поскольку:

1. Если вы не будете знать команд и синтаксиса, вы не сможете заставить компьютер работать на себя.

Когда вы разберетесь в ОС, то сможете обнаружить ее недостатки, а значит, прорехи в компьютерной защите.

Вам необходимо ознакомиться с ограничениями ОС.

4. Разобравшись в ОС, вы узнаете, каким образом компьютерные менеджеры станут вас ловить, выслеживать и не давать вернуться обратно.

Из этого следует, что, если вы хотите стать НАСТОЯЩИМ ХАКЕРОМ, вы должны кое-что знать о компьютерах. Если вы хотите управлять компьютером, вы должны уметь приручать системное программное обеспечение, а в первую очередь — операционную систему.

Конечно, можно обходиться и социальными методами, время от времени добавляя чуточку программирования то тут, то там; однако нельзя обойти тот факт, что настоящее хакерство предполагает настоящие знания. Я имею в виду знания, полученные САМОСТОЯТЕЛЬНО. Так что вам придется засесть за учебу.

Вас это пугает? Тогда, возможно, вы не совсем понимаете, что такое быть настоящим хакером.

Теоретически возможно взломать любую компьютерную систему. И хороший хакер способен взломать большинство систем. Еще более хороший хакер может взломать их все. А самый лучший хакер может не только проникнуть в любой компьютер, но, оказавшись внутри, еще и сделает кое-что для того, чтобы взлом не оказался напрасным. Одно дело — просто проникнуть в базу данных, и другое — суметь так изменить записи в этой базе, чтобы вас не поймали за руку.

Чтобы стать самым лучшим хакером, необходимо знать основные команды ОС — как работать с файлами, посылать и получать почту и т. д. Хакер также должен знать малоизвестные команды, а также файлы, программы и директории, обычно встречающиеся в машинах под управлением данной ОС, изучить руководства по ОС и ее язык; знать, кто и как использует ОС, и разбираться в сообщениях об ошибках.

Но мы еще не добрались до самого сложного. Видите ли, все вышесказанное является лишь надводной частью айсберга. Ведь вся эта информация является вполне доступной и ее можно найти в справочниках и руководствах. Хакеру же необходимо знать секретную часть ОС, которой нет в руководствах, а если и есть, то она описывается настолько техническим и туманным языком, что понять ее способны лишь немногие. Списки “основных ве-шей, которые необходимо знать хакеру” посвящены тому, что такое ОС и что она делает, но хакер — чтобы успешно входить в любую систему, которая ему или ей понравится, и уметь ею пользоваться — должен знать, КАК она работает, и почему она работает именно так.

Операционные системы настолько огромны, что просто невозможно толком проверить их, дабы ликвидировать все малейшие дефекты. Порой компьютерные менеджеры изменяют ОС, включая в них свойства или функции, которые им понравятся, и тем самым создают лазейки в системной зашите. Иногда мульти программисты, работающие над различными частями ОС, даже не советуются между собой по жизненно важным аспектам, что в конечном итоге может привести к системному конфликту, когда эти программные блоки соединяются друг с другом.

Случайный пользователь не помнит о возможных нарушениях компьютерной зашиты. Хакер тоже может не помнить о них; но, если он обладает фундаментальными знаниями ОС, которая лежит в основе всех этих нарушений, то сможет, подумав, обнаружить лазейки и использовать их. В данной книге я не собираюсь углубляться в изучение технических аспектов каждой операционной системы, да настоящим хакерам это и не нужно. Найдите любую ОС, с которой сможете ознакомиться. Изучите основные команды и узнайте, как они запрограммированы. Вычислите способы, с помощью которых можно сымитировать команду, не набирая ее непосредственно в ответ на приглашение ОС. Что происходит с памятью при использовании команды? Можно ли изменить память? Вот такие веши важны для хакера, который хочет, чтобы его заветные мечты стали реальностью.

В оставшейся части этой главы приведены примеры подобных технически ориентированных ха-керских методов. Причина проста и неоспорима:

ничто хорошее в этой жизни не дается даром. Вам придется немало поработать, чтобы вершить великие дела, попав в систему. Конечно, никто не мешает просто изучать определенные веши, только когда приспичит, — например, какой-нибудь командный язык, или метод работы прикладной программы. Но, не обладая знаниями об основных принципах работы ОС, вы станете совершать свои взломы вслепую, и все особенности и дефекты системы пройдут мимо вашего внимания, как и любого обычного пользователя.

А теперь давайте вернемся к началу главы: что же все-таки делать после того, как вы окажетесь внутри?

оглядитесь ВОКРУГ

Что можно обнаружить, взломав систему или сеть? Да что угодно!

Там могут быть файлы для чтения, программы, которые можно запустить, пути соединения одного компьютера с другими, или одной сети с другими сетями.

Поищите резервные файлы или файлы с автоматическим сохранением через определенный промежуток времени. Некоторые текстовые редакторы оставляют подобные файлы, которые может прочесть каждый, кто на них наткнется, и, если системный администратор недавно редактировал с помощью такого редактора файл, содержащий ценную информацию, например, файл с паролями, значит, вам повезло. Электронная почта тоже не всегда уничтожается автоматически, а скапливается в файлах на диске (возможно, спрятанных). Уничтоженные недавно файлы порой могут не уничтожаться немедленно, а становиться спрятанными, или переноситься в специальную директорию.

Вы можете обнаружить журналы регистрации. При загрузке неопытные пользователи часто набирают пароли в окне приглашения к вводу имени, и в журналах встречаются сообщения о подобных ошибках. Например, если Джордж Вашингтон пытается войти в свой бюджет в UNIX, используя свой пароль “cherrytree”, но набирает его слишком поспешно, происходит следующее:

WashingtonUs [Enter] ername:cherrytree [Enter] Password:

Джордж соображает, что поторопился. Он напечатал свое имя еще до того, как появилось входное приглашение, и его пароль, отнюдь не в виде звездочек, появился в строке пользовательского имени. Он несколько раз нажимает [Enter], чтобы очистить экран, но ошибка-то уже сделана. Где-то в административных директориях появился регистрационный файл следующего содержания:

Unsuccessful login of user cherrytree @ Tue, Mar 24,1992, 14:16:03

Теперь вам остается только перебрать различных пользователей системы, пока вы не найдете того, кому принадлежит этот пароль.

Журналы системных операторов иногда содержат также записи отосланных и полученных файлов, ошибки, явившиеся результатом ввода несанкционированных команд, новых бюджетов или очередных пользователей, получивших статус привилегированного пользователя.

Если говорить о безопасности, первое, что вы должны сделать, загрузившись в чей-либо бюджет, — сразу же постараться узнать, кому он принадлежит (если вы еще не знаете этого). При загрузке вам, скорее всего, будет выдано сообщение о том, когда произошло последнее обращение к бюджету, и, возможно, данные о том, откуда пользователь устанавливал связь.

Если легальный пользователь, бюджет которого вы взломали, только что загружался сам, у вас могут возникнуть проблемы. Заметьте, в какое время дня пользователь входил в бюджет, и сами постарайтесь входить в это же время. Постарайтесь войти в бюджет одновременно с двух разных компьютеров — не появится ли на втором компьютере сообщение об ошибке. Можете ли вы распознать присутствие в бюджете вашего “конкурента”? Вам необходимо узнать обо воем этом, поскольку вам необходимо иметь возможность использовать бюджет, не вызывая подозрений со стороны его владельца.

Например, произошло так, что вы загрузились в бюджет, а в тоже время легальный пользователь, пытаясь сделать то же самое, получает сообщение:

“Пользователь такой-то уже установил связь через вход 11 б”. Вы не сможете узнать, что это произошло, но вы можете подготовиться к такому случаю. Пошлите настоящему пользователю сообщение якобы от системного менеджера, и оставьте не прочтенным. Когда настоящий владелец бюджета войдет в систему, его будет ждать нечто вроде:

Message #01

From 1513 SuperUser

То Al-l.USERS@calli.poo.mil

В подразделе группы С системы локальной сети произошла техническая неполадка, что привело к проблемам с работой нескольких из наших схем соединительных портов. Если во время загрузки вы получите сообщение о том, что вы уже вошли в систему, просим вас повторить свой вызов через несколько минут.

Мы приносим свои извинения по поводу возникших проблем и постараемся устранить неисправность как можно скорее, но наладка займет некоторое время. Нам пришлось выбирать между временными неудобствами и полным выключением системы. Мы надеемся, вы согласитесь, что лучше иметь систему с временными недостатками, чем не иметь системы вообще.

Мы ожидаем, что проблема будет решена к 3 марта. Спасибо за сотрудничество.

Пользователи часто хранят в своей директории личные ретроспективные журналы регистрации. Это могут быть ретроспективные отчеты о вводе команд, чтении новостей из определенных групп, передаче или уничтожении файлов. Из них вы сможете узнать, когда и как пользователь работает в системе, а также уровень его пользовательской компетентности.

Если взломанный вами бюджет используется нечасто, можете особенно не опасаться его настоящего владельца — разве что системный менеджер заподозрит неладное, заметив внезапно повысившуюся активность загрузки в бюджет, который никогда не отличался “посещаемостью”.

Но, с другой стороны, если обладатель бюджета работает в нем, как говорится, днем и ночью, вам следует опасаться его больше, чем системного оператора, который вряд ли распознает ваши сеансы входа среди множества других.

какие команды следует искать и использовать

Большинство ОС снабжены обширной помощью онлайн. В UNIX, чтобы посмотреть страницу помощи для определенной команды, следует набрать “man” (имя команды). Набрав “apropos” (слово), вы сможете просмотреть список команд, связанных с тем словом, которое вы зададите. Так, “apropos password” перечислит вам все команды, программы и переменные, которые имеют хоть какое-то отношение к паролям. А с помощью “man” (имя команды) вы сможете узнать, что означает каждая из этих команд.

В машинах TOPS можно набрать “help” или “help commandname” для получения информации онлайн.

Команды процесса сообщают о том, что происходит в системе и кто в ней работает. В UNIX команда “ps —

f” позволяет узнать, как работают на компьютере другие пользователи. Используя эти команды, вы поймете, какие из опций вам доступны. Вы также сможете выяснить, какие пользователи обладают доступом к другим компьютерам, если они соединялись с этими компьютерами с того же компьютера, за которым сидите вы. Если вам очень повезет, вы можете обнаружить в списке процессов шифровальный ключ, который может находиться там непродолжительное время перед тем, как шифровальная программа уберег его оттуда. Если некто набрал что-то вроде “crypt key < filename”, то вся команда, в том числе и ключ, появится в листинге. К сожалению, шифровальная программа стирает ключ из листинга, когда ключ задействуегся, но на непродолжительный период ключ становится общедоступен, и его может увидеть кто угодно. Такие случаи вам поможет обнаружить программа-“даемон” (см. глоссарий).

Соединяться с другими компьютерами позволяет программа “Telnet”. Я уже упоминал, что взломанный вами бюджет, скорее всего, является бюджетом низкого уровня доступа. У хакеров есть причина заниматься сначала бюджетами обычных пользователей:

им необходимо безопасное место, откуда можно совершать НАСТОЯЩИЕ взломы. Находясь в бюджете с низким уровнем, вы сможете делать все то, что никогда не стали бы делать, находясь в своем собственном бюджете, например, соединиться с помошыо “Telnet” с компьютерами Пентагона и начать атаку методом перебора. В UNIX имеется также команда “cu” (Call Up), которая дает возможность пользователю вызвать определенный телефонный номер.

Вызов одного компьютера с другого позволяет хакеру избежать выслеживания. Это также хорошее практическое решение проблемы связи с определенным компьютером, так как некоторые компьютеры можно вызвать только из других сетей.

протокол передачи Файлов (FTP)

FTP — это программа, которая позволяет копировать файлы с одного компьютера на другой (соединенный с ним обычно посредством Интернет), и наоборот. Непосредственным пользователям BITNET приходится вместо FTP использовать для передачи файлов электронную почту.

Чтобы запустить программу, следует набрать “ftp”; затем можно ввести адрес любого компьютера и попытаться с ним связаться. У вас запросят имя пользователя и пароль. Зачастую на компьютерах предлагаются также анонимные FTP-директории: для получения доступа к текстовым файлам и программам, которые сделал доступными местный администратор, можно загружаться под именем “anonymous”.

Входящая директория в анонимных FTP, как правило, установлена с разрешением на запись и использование, но не на чтение. Пользователи могут загружать файлы, которые они хотят использовать совместно с другими пользователями, без ведома последних. Системный оператор определяет, какие файлы можно сделать общедоступными.

Распространенный недостаток анонимных FTP состоит в том, что в их бюджете часто размешаются две вспомогательные директории “etc.” и “bin”. Если они не защищены от записи, любой пользователь имеет возможность загрузить свои собственные враждебные версии системных программ и пакетов.

игры

На взломанном вами компьютере могут оказаться Xtrek иди Empire, и любые другие многопользовательские игры для режима онлайн, особенно, если компьютер стоит в колледже. Так как игры являются многопользовательскими, для входа в них необходим пароль, но такие пароли не столь уж секретны, и часто хранятся в обычных текстовых файлах. Просмотрите эти файлы — пользователи могут применять одни и те же пароли везде, где у них имеется доступ.

сеть пользователей (USENET)

USENET представляет собой то же самое по отношению к локальным BBS, что и Тадж-Махал по отношению к муравейникам.

USENET — это BBS Интернет, которая управляет тысячами конференций. USENET — не просто “компьютерная” доска объявлений. В ней есть разделы, в которых можно разговаривать о программном и аппаратном обеспечении, вирусах, хакерах, индивидуальных операционных системах, принтерах, и об электронных таблицах, и об этике, и ... дополните список сами. Каждая область называется группой новостей (newsgroup) или конференцией. Существуют конференции, посвященные музыке, автомобилям, сексу, преступлениям, парашютизму, книгам, телевидению и многому другому — с ума сойдешь, пока перечислишь все эти темы.

Некоторые конференции подвергаются специальному цензурированию. Имеется в виду, что некая контролирующая организация просматривает их и решает, каким из них дать экранное время. Большинство групп не просматривается таким образом, и является общедоступными.

Получить доступ в USENET можно, запустив такие программы как “readnews”, “news” или “nn”. Вы сможете прочесть посланные кем-то сообщения, или написать свое собственное. Каждое сообщение посылается на все узлы связи, так что, вы, задав какой-либо вопрос, выносите его на громадный международный форум, и сможете выбрать подходящий ответ.

КАК стать привелигерованным пользователем

Проникновение в систему может стать бесполезным, если вы окажетесь в пустой корневой директории с таким низким уровнем доступа, что нельзя сделать ничего интересненького. Если вы взломали бюджет низкого уровня, принадлежащий, например, секретарю, вводящему данные, вы не сможете особенно развернуться, и вам захочется, по возможности, повысить свой уровень доступа. Это можно осуществить с помощью исследований изнутри, мистификации, программистских уловок, либо социальной инженерии.

Завершив свои исследования” осмотрите систему, в которую только что проникли, и выясните, какие опции доступны для вас. Прочтите все файлы, запустите все программы. Большинство технических взломов совершаются благодаря ошибкам в солидном, казалось бы, программном обеспечении. Большинство таких программ каким- либо образом связано с бюджетами других пользователей. Программы электронной почты и “бесед” доступны, равно как и текстовые редакторы. Если вы найдете любой язык программирования, вы должны быть на седьмом небе, поскольку существуют сотни различных программистских уловок, с помощью которых можно получить более высокий уровень. Давайте начнем с мистификации.

МИСТИФИКАЦИЯ

Мистификация обычно заключается в том, что вы посылаете электронную почту таким образом, что кажется, будто ее послал кто-то другой. Этим термином обозначают также любое действие хакера, с помощью которого он выдает себя за кого-то другого. Но давайте сперва остановимся на первом, более распространенном, значении, и рассмотрим некоторые способы, посредством которых мистифицированная электронная почта может услужить имеющему низкий уровень доступа хакеру добиться чего-то большего.

Один из типичных примеров мистификации — послание якобы от системного администратора. Susie User {Пользователь Сюзи), весьма влиятельное лицо в системе, занимается своими обычными делами в режиме онлайн. Она проверяет свой почтовый ящик и с удивлением обнаруживает там письмо от системного администратора. В письме говорится о том, что ввиду наличия прорех в компьютерной безопасности пароли пользователей будут теперь изменяться каждые шесть недель: “Ваш новый пароль D4YIL”, — написано в полученном Сюзи послании. — “Вы можете изменить его сами с помощью команды “SET_PASS”. He забудьте его! Не раскрывайте его никому! Компьютерная безопасность — очень важный аспект, которым нельзя пренебрегать!”

Через несколько секунд вы замечаете, что Сюзи набрала команду “SET_PASS”, а еще немного погодя загружаетесь под ее именем, получая, таким образом, все привилегии ее более высокого уровня. И это срабатывает всегда! Но вся хитрость в том, что необходимо знать, как именно следует проделать мистификацию.

Прежде чем вы сможете послать мистифицированную электронную почту, вам следует понять, каким образом это возможно. Итак, если вы когда-либо пользовались любой из программ электронной почты, на мэйнфрэйме, или же на локальной BBS, то вы знаете, что, чтобы послать электронное письмо, пользователь, как правило, вводит три порции информации: пункт назначения, тему и текст письма. Некоторые “почтовые” программы допускают еще большее усложнение, например, включение других текстовых файлов или программ, уведомление о получении, и т. д., но давайте остановимся на наиболее примитивном виде программ электронной почты, так как они используются чаше всего.

Когда вы посылаете электронное письмо другому пользователю, компьютер автоматически помешает заголовок в начало письма, чтобы идентифицировать письмо как пришедшее от вас. Для мистификации вам понадобится изменить этот заголовок таким образом, чтобы письмо казалось присланным одним из тех, кто отвечает за систему.

Электронную почту обычно посылают, запуская специальную программу. Программа включает в себя текстовый редактор и устройство для отправки почты другим пользователям. Но во многих случаях для отправки почты можно и не использовать специальную программу. Обычно существует основная команда процессора, позволяющая послать текст или файл в директорию файлов другого пользователя. То же самое делает и программа электронной почты: посылает текст вашего сообщения в специальный файл под названием MAIL.TXT или что-то в этом духе, и когда пользователь Сюзи запускает свою программу электронной почты, она показывает содержание этого файла.

Вам не составит труда открыть текстовый файл, напечатать заголовок, похожий на заголовки посланий системного администратора и добавить в коней файла свой собственный текст. Затем с помощью команды “send file” поместите этот файл в директорию пользователя с более высоким уровнем доступа, чем ваш.

Иногда ОС сама выполняет подобные действия. Так, один из протоколов Интернет предполагает участие двух компьютеров в передаче почты, для составления заголовков писем. Чтобы мистифицировать Интернет, можно соединиться с главным компьютером через порт 25, который отвечает за доставку электронной почты. Обычно таким путем соединяются только два компьютера; на месте могут присутствовать средства зашиты, но, если таковых не имеется, вы можете сыграть роль компьютера, посылая команды для генерации электронного сообщения. Они включают в себя “mail from” и “rcpt”, которые устанавливают, кем являются отправитель и получатель. Чтобы получше разобраться в этом, используйте “help”.

Многие многопользовательские системы дают пользователям возможность общаться друг с другом с помощью команд TALK, WRITE и т. п. Когда вы набираете команду TALK, на экране реципиента появляется сообщение о том, что вы хотите с ним побеседовать. Если другой пользователь разделяет ваше желание, он тоже набирает команду TALK. После этого все, что вы будете печатать у себя на экране, станет появляться на экране вашего собеседника, и наоборот. С помошыо команды TALK можно проделать множество трюков. Одним из популярных трюков является передача с помощью TALK сообщения типа:

“Сбой в системе. Прошу выключить ваш терминал, не прерывая связи с системой, для предотвращения дальнейших нарушений. Системный администратор” на экран другого пользователя. Пока его терминал будет отключен, вы сможете беспрепятственно копаться в его бюджете.

Как и в случае с мистификацией электронной почты, с помощью TALK можно помешать текст на экран другого пользователя. Вам следует обратиться к исходному коду программы TALK, узнать, каким образом она посылает текст на другой экран, и использовать те же команды. Такие маневры в обход средств зашиты являются неотъемлемым свойством команды TALK. Если вы используете настоящую команду TALK, чтобы послать приведенное в качестве примера сообщение об ошибке, получатель увидит, что это ВЫ, а вовсе не системный администратор, послали это сообщение. Вам следует эмулировать заголовок TALK, в котором сообщается имя пользователя, пославшего текст. Вам придется также спуститься к основным операторам “send text”, так как вам совсем не нужно, чтобы пользователь использовал опцию отказа от общения с вами.

Известно, что мистификацию можно достаточно легко применять в большинстве систем — достаточно войти в режим онлайн и разобраться в исходных программах и руководствах. Еще одна хитрость — послать с помощью TALK сообщение, которое сможет понять “умный” терминал. При использовании TALK вы не вводите слова в ответ на приглашение ОС — ОС просто помешает то, что вы набираете, на экран удаленного терминала. Один из способов обойти это основан на использовании удаленного аппаратного обеспечения. Некоторые “умные” терминалы обладают управляющей последовательностью Send или Enter, которая говорит терминалу, что необходимо послать текущую строку в систему так, будто пользователь ввел ее с клавиатуры. Можно использовать TALK, чтобы послать сообщение, содержащее подходящую управляющую последовательность для выполнения разных гнусностей, вроде отправки к вам конфиденциальных документов и т. п.

Хакер может использовать в своих целях не только электронную почту и команду TALK, но и любую другую команду, которая позволяет взаимодействовать с другим терминалом. Если вам попадется команда, дозволяющая такое взаимодействие, изучите ее внимательно, чтобы посмотреть, как можно ее применить.

Просмотрите также программы — нельзя ли с их помощью связаться с другими директориями на вашей собственной машине. Текстовый редактор GNU-EMACS, используемый в UNIX, позволяет переслать файл, с которым вы работаете, в директорию другого пользователя. Если вы назвали свой файл o.loginn(2), то, когда бы ни загрузился тот пользователь, будет запускаться этот резервный файл. Если этот файл включает в себя передачу по электронной почте в ваш бюджет секретных данных того пользователя — тем лучше для вас.

шифрование и дешифровка

Возвращаясь к старым уловкам: атака с помощью перебора может дать вам возможность дешифровать файлы с паролями, когда и как вам будет угодно. Даже если у вас бюджет с низким уровнем доступа, вы сможете скопировать зашифрованный файл с взломанной вами машины на более безопасный носитель. Во всяком случае, вам удастся хотя бы просмотреть содержание пусть даже закодированного файла с паролями.

После этого откомпилируйте копию зашифрованной программы, изменив ее таким образом, чтобы она читалась в терминах специально подготовленного словаря, используйте словарь в качестве ключа, а результат распечатайте. Листинги исходных программ UNIX доступны для любого вида ОС. Даже если вы не можете найти дешифратор, который использовался компьютером для шифрования скопированного вами файла, вы всегда можете заглянуть в руководство, найти там алгоритм искомого шифра, и самостоятельно написать по нему программу. Метод перебора в случае с ключами к зашифрованным файлам с паролями действует гораздо эффективнее, чем атака самих паролей для входа в систему. Вскоре вы наверняка найдете ключ для расшифровки, и станете обладателем пароля привилегированного пользователя!

Атака с помощью перебора не всегда является необходимостью. Говорят о существовании известной инверсии шифровального алгоритма, использующегося в некоторых ОС, включая старые версии VMS. К сожалению, сам я не знаю, в чем заключается данный метод инверсии, но я знаю, что существуют способы алгоритмического обратного преобразования команды “crypt” в UNIX. Эта команда использует шифровальный алгоритм World War II Enigma, который был превосходен для своего времени, но не представляет собой загадки для современных суперкомпьютеров. Конечно, для расшифровки вам все же потребуется какое-то время, но она не затруднит ваш компьютер, если у него достаточно “лошадиных сил”.

Впрочем, команда шифрования не очень широко используется из-за своей общеизвестной уязвимости. В основном “crypt” избегают по сентиментальным причинам. Шифр, наиболее часто использующийся для кодирования паролей, является версией государственного стандарта шифрования данных (Data Encryption Standart — DES). Вариант DES в UNIX не подходит для атаки с помощью перебора из-за невероятно сложных шифровальных ключей. Каким же образом версия в UNIX защищена от атак методом перебора?

Как известно, файлы паролей в UNIX доступны для чтения, копирования и печати, но сами пароли хранятся в зашифрованной форме. Однако это не совсем так: на самом деле файл паролей ВООБЩЕ не содержит никаких паролей. Когда новый пользователь входит в систему и вводит пароль, UNIX использует первые восемь символов этого пароля в качестве шифровального ключа для кодирования некоей константы (например, большого случайного числа).

Еще одна причина, по которой DES был избран для шифрования паролей, заключается в следующем: когда такой алгоритм используется в программном варианте, он действует медленно. А значит, атака с помощью метода перебора займет больше времени.

Говоря об этой теме, необходимо заметить, что стандарт шифрования данных может быть и не настолько безопасным, как некогда считалось. Основой DES стала система безопасности под названием “Аю-иифер”, разработанная IBM в 1973 году для Национального бюро стандартов. Прежде чем DES был принят в качестве официального (стандартного) шифра США, сверхсекретное Агентство по национальной безопасности (NSA) вмешалось в это дело, понизив сложность шифровального алгоритма и скрыв основные аспекты его устройства. Это выглядело весьма подозрительно! Зачем бы NSA объявлять код безопасным, в то же время делая его менее безопасным? Критики предупреждали, что в систему, возможно, была встроена лазейка.

В начале 1992 года два израильских ученых объявили, что они нашли способ победить систему. Если содержание зашифрованного сообщения кому-либо известно, с помощью определенных математических приемов можно вычислить ключ, использованный для шифровки сообщения. Затем не составит труда прочесть тексты, зашифрованные с помощью того же ключа.

Как бы то ни было, со времен семидесятых придумано уже немало гораздо лучших шифров.

В некоторых системах силовая атака на зашифрованные файлы затруднена тем, что шифровальный ключ, применяемый пользователями, шифрует не сам текст, а некую случайную последовательность символов, а эти символы, в свою очередь, зашифровывают текст. Чтобы стать хакером, не обязательно быть слишком уж проницательным, достаточно просто обладать умом. Но для того, чтобы взламывать алгоритмы шифровки данных, необходимо быть не только умным и проницательным, но еще и разбираться в математике. К счастью для тех, кто не может похвастаться калькулятором вместо мозгов, существует много других методов для прочтения зашифрованных файлов (вспомните хотя бы прибор благословенного Ван Эйка).

бит за битом

Допустим, вы вошли в какой-нибудь незначительный бюджет, где нет доступа ни к чему интересному. Допустим также, что в данной системе вы можете прочесть файл с паролями, но не изменить его.

Например, пароль вашего бюджета в этом файле закодирован в виде “fg(kk3j2.”. Если у вас есть возможность загрузить файл паролей в текстовый редактор, вы сможете сменить зашифрованный пароль системного администратора на ваш собственный; но сохранить внесенные изменения вам не удастся, если у вас нет статуса привилегированного пользователя. Но так ли это?

Компьютерная зашита системы порой осуществляет проверку достоверности только на самых высоких уровнях защищенности. Пользователь, не обладающий определенным уровнем доступа (а следовательно и защищенности) не может использовать команды высокого уровня для уничтожения, перемещения, использования и изменения файлов; к командам же машинного уровня, скажем для перемещения головки чтения,записи в определенное положение, это не относится. Если бы так происходило со всей доступной областью памяти, каждый файл можно было бы полностью считать или переписать побитно. Если у вас имеется доступ к программному обеспечению или к дисковым носителям, вы сможете изменить расположение хранящихся личных данных, поменяв зашифрованный пароль системного администратора на свой.

С другой стороны, вы можете обнаружить, что компьютерная зашита не разрешает использование даже инструкций низкого уровня. Но не сдавайтесь слишком рано! Область памяти может быть, по разным причинам, — из-за забывчивости, ошибок, неумения или непрактичности, — только частично за-шишена таким образом. Если это так, вам не удастся изменить файл паролей, но, вероятно, удастся переместить его в директорию другого пользователя, или изменить уже находящиеся в ней файлы. А это даст вам возможность широкого применения “троянских коней” и лазеек.

Если зашита отвергает любые попытки получения нелегального доступа, возможно, вам удастся заставить привилегированного пользователя поработать за вас. Напишите простую программу, например, игру, и введите в нее скрытые инструкции по изменению паролей. Затем откомпилируйте ее, сохраните, сделав доступной только для привилегированных пользователей, и поместите в общественную директорию. В конце концов какой-нибудь привилегированный пользователь наткнется на нее и запустит, таким образом задействовав те части вашей программы, которые, запусти вы их самостоятельно, привели бы к сообщениям об ошибках и, возможно, дополнительным отметкам в журнале регистрации.

применение программ

Большинство программ, применяемых хакерами, являются разновидностями “троянских коней”. А классический “троянский конь” использует ошибки других для достижения своей цели. Чаше всего это означает эксплуатацию врожденных недостатков РАТН-команд.

Большинство современных ОС позволяет вам организовывать свои файлы путем использования директорий и поддиректорий. Таким образом, поиск нужного файла облегчается, но зато для перехода из одной директории в другую приходится набирать длинные путевые имена.

Решение заключается в использовании команд PATH. Команда PATH говорит ОС: “Если ты не найдешь этот файл в текущей директории, посмотри вон там... А потом — там... И еще вон там.” Другими словами, вы определяете путь, по которому будет следовать ОС в поисках файлов. Таким образом, для получения доступа к этому файлу вам не нужно находиться в той директории, где он содержится.

Команды PATH обычно помещаются в ВАТ-файлы, которые запускаются при загрузке. Они особенно часто используются на больших машинах, которые содержат множество файлов и кучи директорий. В подобных случаях, особенно, если пользователь является обслуживающим оператором и ему нужен неограниченный доступ, очень много директорий может определяться с помощью PATH.

Пути поиска очень важны для хакеров, особенно, если поиск ведется по всем директориям системы.

Для начала хакер переписывает часто используемую программу, вставляя в нее “троянского коня”. Затем он помешает программу в директорию, которая предположительно находится на пути привилегированного пользователя. Привилегированный пользователь или программа (типа сценария заполнения “пустой” экспертной системы) могут случайно запустить, скажем, вашу программу установки даты вместо “официальной” версии, хранящейся в директории ОС. Если так случится, ваша спрятанная программа сделает свое дело.

“Троянские кони” могут делать многие веши — собирать пароли, создавать ложные приглашения к входу в систему, лишать файлы зашиты от чтения,записи, либо создавать впечатление фатального сбоя системы (а когда пользователь выключит свой терминал и уйдет, вы сможете набрать секретный управляющий код, который позволит “троянскому коню” снова “вломиться” в бюджет этого пользователя). “Троянские кони”, безусловно, составляют значительную часть хакерского арсенала, но существует и другой способ повышения уровня доступа с помощью программ — использование компьютерных вирусов.

ВИРУСЫ

Вирус возник путем скрещивания трех видов программ: “троянского коня”, червя и логической бомбы.

Логическая бомба — это небольшая программа, спрятанная внутри большей программы. Обычно она представляет собой не более чем высказывание IF THEN (ЕСЛИ ТО). ЕСЛИ что-то верно, ТО надо сделать нечто. Что обычно представляет собой ТО, можно догадаться, исходя из самого названия — логическая бомба.

Классический пример логической бомбы был использован, когда один системный программист был уволен за неверно выполненную работу. Через несколько дней после его ухода главы фирмы получают от программиста послание: “Заплатите мне Х долларов до 31-го июля, и я сообщу вам, как спасти ваши программы и записи от полного уничтожения”. Он инсталлировал логическую бомбу, которая взорвется в определенный день.

У программы-червя есть лишь одна цель: саморазмножение. Он осматривается вокруг, и копирует себя, где только может, причем каждая новая копия продолжает заниматься тем же самым. Через некоторое время после начала работы такой программы компьютер или сеть оказываются буквально забиты сотнями или даже тысячами неудержимо размножающихся программ.

Вирус выполняет функции обеих вышеописанных программ. Программа (спрятанная, подобно “троянскому коню”, внутри прикладной программы) саморазмножается, пока возможно, а затем взрывается (как логическая бомба).

Логические бомбы опасны, но, по крайней мере, известно, чего от них ждать. Вирусы же и черви, в отличие от логических бомб, не только опасны, но и непредсказуемы. Я убежден, что настоящий хакер никогда не создаст червя, поскольку они слишком деструктивны и бессмысленны. Но он может воспользоваться вирусом, при условии, что вирус не причинит вреда системе, самоуничтожаясь по мере своего продвижения, и ни разу не появится на одном и том же месте дважды.

Вирус может пересылать пароли с помощью электронной почты по определенному адресу, с помощью метода перебора в конце концов проникать в системы и т. п. Существует много путей применения вирусов, но их трудно использовать безопасно.

Ходили слухи об одном микрокомпьютерном вирусе, который, если бы он действительно существовал, согрел бы сердце каждого хакера. Он назывался AT&Tack Virus. Скопировав себя на компьютер, он сразу же пытался найти Hayes-модем или совместимый. Если таковой существовал, вирус выключал динамик модема и соединялся с заранее запрограммированным номером. После этого, естественно, любой, кто находился по вызванному им номеру, получал удаленный доступ к вашему компьютеру.

Лично мне кажется, что это не более, чем слух. Разумеется, на данный момент ни одна из коммерчески доступных программ обнаружения вирусов не содержит никаких упоминаний о AT&Tack Virus. Но мне кажется, что такая штука лучше работала бы в качестве “троянского коня”, размешенного в графической программе, нежели в качестве вируса.

Одним из достоинств “троянских лошадок” и вирусов является конструирование каналов для сбора данных и пересылки их к вам в удобочитаемой форме. Допустим, вирус присоединяется к программе загрузки и собирает пароли. Нет смысла отправлять этот вирус гулять по всему свету, не питая надежд заполучить в свои руки те пароли, которые он соберет. Как я уже упоминал, вирус может периодически пересылать вам пароли с помощью электронной почты (но только не в ваш легальный бюджет!).

Можно также шифровать почту перед отправкой. Проблема с шифрованием состоит в том, что вам понадобится ключ. Любой, кто обнаружит ваш вирус или “троянского коня”, легко сможет вычислить ваш ключ и понять, что за почту пересылает вирус (или какие временные файлы создает “троянский конь”). Значит, вам придется зашифровать этот ключ... а для этого нужен еще один ключ... а его тоже надо как-то обезопасить... значит, еще один ключ... И так — до бесконечности. Но давайте разберемся в ситуации.

Если вы собираетесь так или иначе прибегать к кодированию, будет проще заставить ваш вирус или “троянского коня” посылать зашифрованные данные в какую-либо большую, не подвергающуюся цензуре конференцию. Недостаток: вам придется мистифицировать почту, иначе кто-либо заметит, что пользователь (который, сам того не зная, приводит в действие ваш вирус) посылает слишком много “мусора”.

Вы можете также подгрузить зашифрованный файл во входную директорию какого-нибудь анонимного FTP. Убедитесь, что компьютерная зашита позволит вам затем выгрузить файлы из этой директории, поскольку зачастую она не разрешает это делать.

Для пересылки коротких сообщений (например, одного пароля) ваша программа-обманка может временно переименовать какой-либо файл с очень низкой степенью зашиты (атрибуты которого способен изменить кто угодно) в это сообщение. Ваш “троянский конь”,вирус будет входить в директорию, маскируясь под различных пользователей сети, и пытаться переименовать файл в данное сообщение. Ваш “троянский конь”,вирус не должен оставлять сообщение об ошибке. (Вы можете “вживить” блок постоянного наблюдения, который в виде фоновой задачи будете следить за состоянием этого файла; как изменится имя файла, фоновый процесс сохранит новое имя, а после вернет файлу его первоначальное имя.

Другие короткие сообщения можно пересылать по битам. Например, если файл Х находится в определенной директории, ваша программа посылает вам цифру 1, а если директория пуста — цифру О. Фоновая задача в то же время следит за появлением и исчезновением из вашей директории этого файла. Когда соберется необходимое количество нулей и единиц (восемь для ASCII-кодов), программа переводит их в символы сообщения. Например, 01000001 — это заглавная “А”. 01000010 — “В”, и т. д. Чтобы послать восьмизначный пароль, вашему вирусу или “троянскому коню” потребуется 64 уничтожения и восстановления файла X. Биты будут пересылаться по одному, тогда, когда спрятанная программа сможет делать это незаметно.

КАК выбраться ИЗ заточения на волю

Допустим, вы совершили взлом, но единственный доступ, который вы обнаружили, это доступ к двум-трем командам или неинтересному информационному блоку. В этом случае вам придется думать, как выбраться из этой программы-тюрьмы и вернуться на уровень операционной системы. Если прежде вы серьезно занимались программированием, ваша задача облегчится.

Программист знает типы лазеек и ошибок, а также способы их обнаружения. Если он завязнет в бюджете, который запускает информационную программу, то использует все, даже самые неожиданные, способы в поисках вещей, от которых человек, создавший эту программу, не додумался защититься, в надежде получить сообщение об ошибке и вырваться к приглашению ОС.

Вот что можно попробовать.

Вводить неверные, неподходящие или слишком длинные ответы на приглашения; особенно подойдут буквенные ответы вместо требуемых числовых. Или, если вас просят ввести число, которое будет анализироваться функцией, попробуйте ввести слишком маленькое или несуразно большое. Попытайтесь вводить ответы с прерыванием, типа Ctrl-Z, Ctrl-C или даже Ctrl-P. Постарайтесь использовать команду “Find” для поиска вне доступных ресурсов. Посмотрите, нельзя ли установить программы для несуществующего аппаратного обеспечения или объема памяти.

Если в ловушке имеется нечто вроде текстового редактора, например, программы для пересылки почты системным операторам, попробуйте создать резервный файл и послать ваше сообщение в качестве команды на выполнение. Можно также попробовать создавать несоразмерно большие сообщения. Если в редакторе имеются специальные функции проверки текста, напишите громадный абзац, поместите в буфер и скопируйте под первый. Затем проделайте то же самое с двумя абзацами, и т. д., до тех пор, пока программа либо не даст сбой, либо не разрешит вам продолжать. Если это письмо, посмотрите, что получится, если вы попытаетесь сохранить или послать все сообщение целиком.

Вы можете оказаться в программе, похожей на обычную ОС или управляющую программу, в которой меню со списком опций либо недоступно, либо вызывается с помощью команды HELP. Вам выдается приглашение к вводу команды. К некоторым прикладным командам добавляется имя файла, с которым вы собираетесь работать (например, для редактирования файла с помощью текстового процессора:

“WORD_PROC STORY.DOC”). Если система работает в режиме онлайн, попробуйте ввести таким образом слишком много данных (“WORD_PROC STORY.DOC FILE.ONE FILE.TWO...”) или неподходящие данные. Например:

WORD_PROC WORD.PROC WORD_PROC \directoryname WORD_PROC nonexistent-filename WORD_PROC ,etc,date, [или другая команда].

Тактика “неподходящих данных” с успехом применялась до последнего времени. Можно прибегнуть также к переполнению стека команд, т. е. размещению множества команд в одну линию. Команды могут быть разделены пробелами, скобками, слешами, или другими знаками пунктуации. Синтаксический анализатор может оказаться не в состоянии интерпретировать слишком большое количество команд. Если строчный редактор не разрешит вам вводить столько строк, попробуйте с помощью программирования создать впечатление, что большой стек команд послан прямо с клавиатуры.

Если в вашем распоряжении имеется язык программирования или компилятор, попробуйте поставить какие-либо величины на места, вовсе для этого не предназначенные. Возможно, вам удастся откомпилировать программу в специальные области памяти, записав ее поверх машинной программы, которая препятствует вашему продвижению вперед, или заставить программу переместиться в новое положение, где можно будет прибегнуть к дополнительным инструкциям.

Наконец, попробуйте загрузить программу в редактор электронной почты, или любой другой, или программу-доктор, и изменить ее так, чтобы она разрушалась при запуске.

Дефекты наиболее часто встречаются в следующих видах программного обеспечения:

• Новое ПО (программное обеспечение) — одна из первых версий, или прошедшая Бета-проверку и т. п.

• Программы, по каким-то причинам финансового или рекламного порядка “слепленные” на скорую руку.

• Программы, годами остававшиеся неизменными, несмотря на изменения аппаратного обеспечения и пр.

• Обновляющееся ПО.

• ПО, не обладающее коммерческой ценностью.

Путешествуя по сетям, выберите время, чтобы остановиться и прочесть заметки о новых версиях старого программного обеспечения. В них часто сообщается об исправленных дефектах старых версий. К тому времени, как вы об этом прочтете, еще далеко не все успеют поменять свои старые версии программ на новые.

возвращение к месту действия

Предусмотрительный хакер всегда обеспечит себя лазейкой, чтобы в дальнейшем, если понадобится, беспрепятственно войти снова. Обычно это делается с помощью установки фиктивного бюджета для использования в успешных взломах. В конце концов, нет никакой гарантии, что бюджет, который вы использовали при первом взломе, сохранится к тому времени, как вы загрузитесь снова, или что пароль или другая важная входная информация не изменится, закрыв вам доступ. Если вы получили доступ не с помощью пароля, а какими-то командными или техническими средствами, вам тем более понадобится такой потайной вход, чтобы заново не возиться со всей этой ерундой.

Во многих ОС можно запускать программы даже после того, как пользователь вышел из системы. Иногда можно установить программу на начало работы в определенное время. Написание подходящей программы и ее запуск с помощью одной из этих команд поможет вам, если вы захотите вернуться к месту своего действия.

задание выполнено... но не совсем!

Эй! Взгляните-ка, что у вас получилось! Итак, вы провели исследования, нашли нужный компьютер, взломали его, и теперь разгуливаете внутри. Это четыре составляющих хакерской деятельности. Это и означает — быть хакером.

Первые четыре составляющих выполняются по порядку, одна за другой. Но вот последняя часть на самом деле вовсе не последняя. О ее выполнении следует заботиться с самого начала и до конца, ни на секунду не забывая о ней.

Ведь то, чем вы занимаетесь, — ХАКЕРСТВО, а это, как вам известно, вещь незаконная. Значит, вы должны подумать о собственной безопасности.

Давайте теперь рассмотрим, что же такое хакерство, которое считается незаконным в нашем обществе, как можно заниматься хакерством, не попадаясь при этом в лапы закона, а в заключение мы подведем итоги и поговорим о вашем будущем в качестве хакера.


Глава 11. Kак не попасть в лапы закона

Козлевичу не везло. Его ловили и тогда, когда он применял излюбленные им технические средства, и тогда, когда он обходился без них. Его ловили на вокзалах, пристанях, на пароходах и в гостиницах. В вагонах его тоже ловили. Его ловили даже тогда, когда он в полном отчаянии начинал хватать чужую собственность по предварительному сговору с другим лицами.

И. Ильф, Е. Петров. Золотой теленок.

Хакерство — это здорово. Черт возьми, да это просто потрясающе! Но вместе с тем хакерство — нелегальное, порой аморальное и обычно наказуемое занятие. Даже если вы не сделали ничего плохого, для судей вам придется подыскать достаточно веское обоснование своим действиям. Самое малое, что может произойти, это заделка прорех в компьютерной безопасности, которые вы использовали для взлома. Более серьезные наказания могут варьироваться от штрафов и вплоть до тюрьмы. Неофициальные наказания могут заключаться в разрушении вашего оборудования и невозможности устроиться на работу, имеющую отношение к технике. Занимаясь своим делом, предусмотрительный хакер преследует две цели:

1. Не попасться. 2. Если попался, постараться не усугублять дела.

В этой главе рассказывается о стратегиях, с подошью которых можно следовать этим правилам. Хакерство предполагает не только технические знания, но и особый склад ума. И часть этого ума должна быть отдана знаниям о том, как обеспечить собственную безопасность, иначе оставшаяся часть будет тратиться зря. Приведенные здесь стратегии следует не только знать и применять, но и уметь приспосабливать их к новым ситуациям. Не забывайте, сколько компьютерных преступников отправились в тюрьму. Правда, некоторые из них умудрялись заниматься хакерством и там. Некоторые даже научились хакерству в тюрьме. Но если вы все же не стремитесь туда попасть, везде и повсюду помните приведенные ниже советы.

в процессе исследований

На вашей территории проживания могут действовать местные законы, запрещающие машинам или людям постоянно набирать номера и отключаться сразу после набора (так поступает, например, программа автонабора, когда ищет входные наборы). Если вы делаете звонки самостоятельно, лучше говорить тому, кто поднимет трубку: “Извините, я ошибся номером”, нежели просто бросать трубку. Помните правило: чем больше людей вы разозлите, тем больше вероятность, что вас начнут преследовать и, в конце концов, накажут.

при ЗАНЯТИЯХ СОЦИАЛЬНОЙ инженерией

Социальная инженерия, а еще чаше обратная социальная инженерия, предполагает контакт с зарегистрированным пользователем по телефону или посредством электронной почты. Это рискованно, так как при этом вы даете свой адрес или телефонный номер людям, которых собираетесь обмануть. Для решения данной проблемы хакеры разработали несколько оригинальных методов.

Однажды я вышел на небольшое предприятие, которое закрывалось на несколько недель. Проведя некоторые исследования и свершив несколько взломов, мне удалось найти программу, которая оставляла сообщения на их автоответчике. С ее помощью я смог входить в контакт с людьми, не сообщая им, кто я такой. Я поместил телефонную рекламу компьютерной сети, приглашавшую людей звонить и оставлять свои имена и данные. Я мог в любое время вызвать компьютер, набрать заветный код и прослушать эти сообщения. Когда предприятие вновь открылось, я позвонил им, сказав, что я из телефонной компании, и сообщил владельцу, что несколько линий пересеклись, из-за чего к ним иногда могут проходить непонятные звонки.

Некоторые хакеры просто переводят телефонные автоматы в резидентное состояние и работают с них. Для занятий социальной инженерией по почте можно арендовать личный почтовый яшик. Один хакер нашел более простое решение. Он заметил, что почтовый яшик в колледже, находящийся прямо под его ящиком, всегда пустует и, по-видимому, никому не принадлежит. Он долгое время пользовался им, с помощью нехитрого приспособления опуская туда свою секретную корреспонденцию (позднее я показал ему, как открывать эти ящики).

использование: телефона

Если хотите сохранить что-то в секрете, не говорите об этом по телефону. Нельсон Рокфеллер

Если вы новичок, у вас может не возникнуть никаких затруднений с вызовом удаленных компьютеров из собственного дома. Но однажды вы можете оказаться в ситуации, когда не будете точно знать, не прослушивают ли ваш телефон и не следят ли за тем, как вы используете компьютер. Значит, если вы уже вышли из хакерского “детства”, вам не следует делать незаконных вызовов из своего дома и вообще с любого телефона, по которому вас могут выследить.

Неприятности могут произойти, даже если вы действительно новичок. Представьте себе, что вы стали членом TECHRIME-USA BBS как раз тогда, когда ФБР собирается начать акцию против системных операторов, использующих свои доски объявлений в нелегальных целях! Вам совсем не захочется быть втянутым в это, особенно, если вы не делали ничего противозаконного. Даже намек на полуправдивые слухи, циркулирующие по каналам технического андеграунда, может заставить телефонные компании начать следить за проходящими по их линиям модемными сообщениями и записывать их. Это может проделываться автоматически с помощью детекторов, которые прослушивают тоны модемов и передают их на записывающее устройство. В любом случае надо учитывать следующее: 1. Технология, позволяющая делать такие веши, существует, и 2. Известно, что прослушиваются очень многие телефоны. Итак, если вам необходимо общаться с известными компьютерными преступниками, или с доказанными хакерами, соблюдайте крайнюю осторожность.

Делать телефонные вызовы можно не из дома, но откуда-либо еще. Возможно, придется раскошелиться на портативный лап топ. Сделав это, купите к нему также акустический соединитель и внешний модем. Все это обойдется вам в одну-две тысячи долларов — гораздо меньше, чем потребует с вас адвокат, если вы попадетесь. Акустический соединитель необходим, так как не везде имеются телефонные розетки. Во внешний модем вы будете вставлять соединитель. Многие лап топы уже снабжены модемами, но это внутренние модемы, которые нельзя подсоединить к телефону.

Итак, вы обзавелись оборудованием. Куда бы его ^ поместить? Существует много возможностей. Ночью и на уик-энд бывает можно проникнуть в здание какого-нибудь большого офиса и, если дверь не заперта, устроиться в одной из смежных комнат. Два года назад летом, прогуливаясь в центре своего города около девяти вечера, я заметил, что окна всех учреждений открыты — и это вечером! Днем стояла жара, и, вероятно, их таким образом проветривали. Будь я в соответствующем настроении, я мог бы беспрепятственно проникнуть в любое здание и подключить свой портативный компьютер к телефону, находясь всего в нескольких сотнях метров от полицейского участка.

Если у вас водятся деньги, или вам удалось взломать какой-нибудь счет, вы можете заниматься хакерством в гостинице или мотеле. Денежные проблемы беспокоят хакеров и по другой причине. Телефонные счета растут, как на дрожжах, поэтому многие хакеры являются также и фриками. Фрик — это человек, занимающийся взломами телефонных сетей. Одним из основных аспектов этого занятия является создание тональных кодов, которые заставляют телефонную систему выполнять специальные функции, такие, как бесплатные звонки на дальние расстояния. Фрикерство, разумеется, представляет собой обширную область для хакерских исследований, и с телефонными системами — а особенно с компьютерами, обслуживающими эти системы, — должен быть близко знаком каждый хакер. Многие хакеры считают, что любое другое хакерство, нежели взлом таких компьютеров, — это детские игры. В чем-то они правы.

Телефонные компьютерные сети — это невероятно большие, распространенные, замечательные массивы хитроумных функций, громадных баз данных, технических операций и прочих чудес, на фоне которых бледнеет все прочее хакерство. Покинув ваш дом, телефонный сигнал отправляется на местную АТС, которая управляет всеми телефонами вашего района. Каждая АТС управляется собственным компьютером. Такие компьютеры и являются потенциальными целями взломщиков телефонных компаний; если вы получите доступ к компьютеру, у вас будет доступ ко всем телефонам, которыми он управляет. Вы сможете включать и выключать телефоны, перенаправлять вызовы, изменять номера. Не будь вы хакером, вы могли бы устроить таким образом немалый переполох.

Существуют также коммутируемые сети, которые соединяют между собой компьютеры, управляющие коммутаторами. Из них можно проникнуть в региональные системы типа COSMOS (одной из функций которой является создание и уничтожение телефонных номеров). Когда вы поближе познакомитесь с особенностями этих телефонных компьютеров, вы можете использовать их для собственной зашиты. Например, вы не хотите делать хакерские телефонные звонки из собственного дома. Вы можете соединиться с компьютером вашей местной АТС, взять телефонные номера нескольких автоматов и сделать их бесплатными. Затем вы можете взламывать из этих автоматов хоть целый мир.

Вы можете также использовать региональную обслуживающую систему, чтобы временно изменить ваш настоящий номер телефона на номер, допустим, близлежащей церкви. Если ваши звонки и отследят, слежка отправится по ложному пути. Должен заметить, что вызов удаленных компьютеров — не такая безопасная вещь, как может показаться. Иногда соединение с помощью телефона или компьютера дает ложное чувство защищенности, особенно, если вы уже достигли успехов в хакерстве и фрикерстве и утратили чувство бдительности. Не допускайте подобного. Всегда следуйте правилам безопасности. Не приобретайте никаких привычек. Делайте звонки всегда из разных мест и в разное время дня. Когда лучше всего делать вызовы? Каждый хакер ответит на этот вопрос по-разному. Поздний вечер хорош тем, что системные администраторы, скорее всего, уже дома — но то же самое можно сказать и про большинство полноправных пользователей, и вы со своим звонком будете выделяться, как клоун на похоронах. Можно попытаться также звонить в самый разгар рабочего времени, в середине утра и после обеда, но в это время мэйнфрэймы работают медленнее всего, вашу деятельность нетрудно будет заметить, да и бюджет, который вы взломали, может быть занят. Наилучшего времени для вызовов не существует — вам могут помочь разве что исследования организации устройства компьютерной зашиты конкретного предприятия. Замечайте время, в течение которого вы были соединены с машиной по телефону. Если это местный звонок, сигнал идет мгновенно, и чуть дольше — если вы звоните издалека. Но не стоит висеть по полдня на одной и той же линии. Лучше сделать несколько вызовов с разных телефонных номеров на разные номера доступа. Если на избранном вами объекте имеется несколько коммутируемых линий, следует время от времени бессистемно пользоваться каждой из них.

советы по лап топам

Если вы делаете вызов бог знает откуда со своего портативного лап топа, я могу предложить вам несколько полезных советов. Если вы находитесь в незнакомом месте, например, в офисе, отеле, аудитории после уроков и т. п., ваш лап топ является неоспоримой ценностью — до тех пор, пока он работает. Никогда не подключайте ваш модем к незнакомому телефону. Сначала убедитесь, что не сожжете таким образом ваше оборудование. Многие конторы устанавливают свои собственные электронные телефонные системы, или РВХ (private branch exchange) — частные телефонные станции, для выполнения специальных функций, таких как переговоры внутри здания, либо чтобы не дать определенным телефонам делать телефонные звонки на дальние расстояния. По проводам некоторых РВХ течет ток, достаточный, чтобы повредить ваш хрупкий модем. Чтобы проверить безопасность линии, сначала попробуйте подсоединить к ней обычный дешевый телефон. Если он заработает, то и модем тоже будет работать. Телефоны, объединенные в РВХ, могут не работать с вашим модемом из-за специальных звуковых или цифровых кодов, используемых в локальных процедурах маршрутизации. Если на вашем проверочном телефоне имеется сигнал в линии, но модем не работает, значит, данная РВХ неисправна. Для устранения этой проблемы вы можете включить модем в телефонную розетку, а комнатный телефон (не тот, что взяли для проверки!) — к модему (для этого вам может понадобиться специальный двойной порт). Чтобы использовать модем, вы делаете звонок с комнатного телефона, а затем, услышав звонок удаленного компьютера, включите модем и подсоединяйтесь.

Вы можете приобрести устройства для обработки сигналов, проходящих между телефоном и модемом. Такое устройство приспосабливает обычные сигналы модема к цифровым системам вроде РВХ. Для вас это будет более приемлемым, особенно если вам часто приходится сталкиваться с РВХ. Иногда попадаются такие места, где есть телефон, но нет розетки для вашего модема. В этом случае надо отвинтить рупор микрофона телефона и с помощью кабеля с присоединенными “крокодильчиками” соединить красные и зеленые провода вашего модема с двумя серебристыми контактами микрофона телефонной трубки. Это может повлечь за собой возникновение слабого сигнала, поэтому, если в вашем распоряжении есть настоящий телефонный аппарат (а не одна трубка), снимите с него корпус и соедините красные, зеленые провода модема с красными, зелеными проводами телефонного преобразователя. Чтобы позвонить, вам придется придерживать рычаг телефона.

ваше походное снаряжение

Прежде чем выхолить на большую дорогу, не забудьте прихватить с собой следующие предметы: лап топ, иди другой портативный компьютер. Обязательно модем. Лучше два: внутренний и внешний, с чашечками акустического соединителя. Один небольшой, дешевый, надежный телефонный аппарат для проверки напряжения на линии. Можно использовать готовый тестер, но телефон удобнее использовать, например, в мотелях, где акустический соединитель может не подойти к местному телефону. Телефонный шнур с модульным зажимом на одном конце и зажимами- "крокодилами” на другом. Ножницы для обрезки проводов, отвертки и набор шнуров с портами разного размера.

ХОДЬБА на ЦЫПОЧКАХ

Большинство менеджеров смотрят даже на самых честных, избегающих разрушений хакеров как на дьявольское отродье. Поэтому, если вас застали за взломом чужих компьютеров, ждите неприятностей. Даже если ваш взлом не принес никому вреда, вас все равно, скорее всего, накажут. Я читал статьи о том, что компьютерные преступления ежегодно уносят, по крайней мере, от 3 до 5 биллионов долларов. Другие же источники приводят данные до ста биллионов. Лично мне даже три биллиона кажутся несколько завышенной, для пущей убедительности, суммой. Но правительство и владельцы предприятий считают иначе. Они понимают, что большинство компьютерных преступлений остаются нераскрытыми, и реальные убытки могут оказаться гораздо больше официальной суммы. Даже если все эти биллионы долларов — не более, чем выдумки, государство и промышленники в них верят, и полны решимости наказывать всякого, кто отнимает у них такие деньги.

Давайте теперь рассмотрим случай, произошедший с BBS Гринвудской “Pretty Theft” ( “Вороватая милашка”)—так звали одну женшину-хакера, с которой я время от времени обшался. Однажды она послала мне на BBS сообщение, в котором спрашивала, не знаю ли я, как проникнуть в компьютеры одного госпиталя неподалеку от меня. Я был в недоумении — задача была проше простого, и взлом данной системы можно назвать одним из моих первых успехов. При загрузке в эту систему появлялось следующее сообщение (все имена и номера, разумеется, изменены):

Добро пожаловать в GFH-NET! 300-2400 бод (123)45&-7890 GREENWOOD FAMILY HOSPITAL GFH-NET обслуживается Роджером Корнуоллом и Гарольдом Липником. Если у вас возникнут вопросы или комментарии, напишите им по электронной почте!!! Ваше имя? Введите имя и фамилию:

Ваш пароль? Если у вас нет пароля, нажмите “RETURN” после ввода:

Через несколько месяцев после того, как я активно занялся хакерством, я сидел за компьютером и одновременно смотрел выпуск вечерних новостей. В новостях я увидел репортаж об одном из членов правительства, который сломал руку и был вертолетом отправлен в больницу. Тогда я подумал: “Эге, ведь в больницах наверняка есть компьютеры, верно? Так почему бы мне не взломать такой компьютер!” Итак, я раздобыл якобы закрытый номер доступа в сеть Гринвудской семейной больницы, и в ответ на вызов получил такой вот гостеприимный экран. Догадываетесь, что я сделал вслед за этим? Нетрудно догадаться — я, конечно же, ввел в качестве имени имя Роджера Корнуолла. К сожалению, у настоящего Роджера Корнуолла имелся какой-то пароль; а нажав “RETURN”, я просто получил сообщение об ошибке. Тогда я попробовал имя Гарольд Липник. Тот же результат. Я достал телефонную книгу, нашел телефонный номер Гринвудской семейной больницы и позвонил. Женский голос сказал: — Гринвуд. Чем я могу вам помочь? — Извините, — сказал я, — нельзя ли пригласить Тома? — Кого? — М-м... Есть у вас один парень, я с ним уже говорил... Супервизор, или что-то в этом роде... — Вы имеете в виду Аи Брауна? — спросила она. — Ну да, вот именно. (Не знаю, почему я решил, что его зовут Том.) А он на месте? — Нет. Ли ушел в пять. — Понятно, спасибо. — Пока.

Я вернулся к своему компьютеру, снова вызвал GFH-NET и попробовал ввести в качестве имени “Ли Браун”. Но мне опять не повезло. Впрочем, сделав еще несколько телефонных звонков по разным телефонам данной больницы, приведенным в книге, я вышел-таки на парня, не имевшего пароля. GFH-NET, как выяснилось, не представляла собой ничего особенного. Она не имела ничего обшего с больничными счетами, записями о пациентах и т. п. Это была обычная медицинская BBS. Насколько мне удалось понять, данная система была создана для того, чтобы студенты-медики могли обсуждать различные проблемы с врачами. Никакой передачи файлов или чего-нибудь в этом роде; самая простая система сообщений. Она оказалась неинтересной, но зато было интересно в нее проникать.

На следующий день я просматривал телефонные номера врачей на желтых страницах, и нашел восемь номеров врачей Гринвудской больницы. Из них трое не имели пароля. Таким образом, я был несколько озадачен тем, что у Вороватой Милашки возникли затруднения с этим взломом. Я вызвал BBS Гринвудской больницы, в первый раз за несколько лет, и, к своему удивлению, наткнулся на такой вот угрожающий экран:

ДАННАЯ СИСТЕМА ПРЕДНАЗНАЧЕНА ТОЛЬКО ААЯ САНКЦИОНИРОВАННЫХ ПОЛЬЗОВАТЕЛЕЙ! ЕСЛИ ВЫ НЕ ЯВЛЯЕТЕСЬ ТАКОВЫМ, ВАМ СЛЕДУЕТ НЕЗАМЕДЛИТЕЛЬНО ОТКЛЮЧИТЬСЯ!

Всю полезную информацию как ветром сдуло! Осталась только это грозное предупреждение и бесполезное приглашение к вводу пароля. Я попытался войти под теми же именами, которыми пользовался когда-то, и обнаружил, что все они обзавелись паролями. Затем я попытался прибегнуть к социальной инженерии, но все те, с кем я разговаривал, словно воды в рот набрали. (Впоследствии мне удалось проникнуть в настоящую больничную систему с помощью нескольких милых секретарш из административного отдела.) Я отправил Вороватой Милашке ответное письмо по электронной почте, в котором спрашивал, что же там произошло. На следующий день я получил ответ

В прошлом месяце мой друг лежал в больнице, и мне захотелось взглянуть, не удастся ли изменить его счет. Я помнила, что года два тому назад плавал мне этот номер, я посмотрела в блокнот и, к своему удивлению, обнаружила, что номер по-прежнему там. Я знала, как зовут лечащего врача моего приятеля, а навещая его в больнице, я узнала еще больше из справочной системы и объявлений на стенах. Затем я пыталась войти в систему, используя все эти имена, но в это время появимся системный оператор и вышвырнул меня. И каждый раз, когда я хотела продолжить свои попытки, происходило то же самое. Но на следующее утро, около восьми часов, мне наконец удалось проникнуть в систему. Один из врачей, имя которого я использовала, вводил вместо пароля собственное имя. Ты, наверно, догадываешься, что изменить счет моего друга мне не удалось, и больше вообще ничего не удалось...после того, как я ввела имя и пароль, система просто зависла. Вечером я попыталась еще раз, и вместо запроса имени на экране появилось следующее сообщение:

БОЛЬШАЯ ЧАСТЬ ВАЖНЫХ ФАЙЛОВ БЫЛА УНИЧТОЖЕНА КЕМ-ТО ИЛИ ЧЕМ-ТО. СИСТЕМА ВРЕМЕННО ПРЕКРАЩАЕТ СВОЮ РАБОТУ— РОАЖЕР.

Через неделю я попыталась проникнуть в систему еще раз, но безуспешно. Мне кажется, системный оператор решил, что я или кто-то еще уничтожил файлы, хотя на самом деле я этого не делала. Несколько дней назад я позвонила еще раз, просто так, и увидела — ну, ты знаешь, что. Как видно, они поумнели!

Да, Милашка была права. Они действительно поумнели и усилили свою защиту. Вот почему хакерам не следует открыто подходить к системе или привлекать внимание каким-либо другим способом. На самом деле существует только один случай, когда следует обнаруживать себя системному оператору, и только тогда, когда вы уже изучили всю систему и больше никогда не собираетесь в нее возвращаться. Кое в чем Рожер и Гарольд действительно поумнели, а кое в чем нет. Я проявил некоторое упорство и снова взломал GFH-NET. Как выяснилось, я и сам малость поумнел: медицинские беседы между докторами и студентами показались мне гораздо более понятными, чем каких-то два года назад. А может, это студенты поглупели? Я увидел также старое объявление одного из системных операторов. Он рассказывал то, что ему было известно о случившемся инциденте с системой (а известно ему было немного.) Речь в основном шла о том, что определенные файлы были уничтожены, а многие объявления заменены натуралистическими описаниями особенностей женской анатомии. Автор, похоже, считал, что файлы могли быть стерты или каким-то недоумком-оператором, либо хакером-злоумышленником. После некоторых исследований я обнаружил, что, хотя Данная опция и не присутствует в меню, нажатие клавиши “F” отправляет прямо в несуществующую систему передачи файлов. Подумав несколько минут, я ясно увидел, каким образом можно было подгрузить программу уничтожения любых файлов корневой директории после перезагрузки системы. На следующий день я послал системным операторам больницы длинное письмо, в котором подробно объяснял, каким образом можно устранить данную проблему, и как ликвидировать другие прорехи в защите. Подписался я так: “Искренне ваша, полай Ваниа Хакер”. Затем я снова вызвал BBS и загрузил им свое послание. Вскоре после этого я получил сообщение от Милашки: “В больнице появился новый экран загрузки. Там написано: “СПАСИБО, ПОЛАЙ! — Р.К. и Г.Л.” Я был совершенно счастлив.

Уроки, полученные в больнице

Вы уже знаете, что системные операторы не жаждут приветствовать вас в своей системе. Поэтому-то вы и совершаете взлом. Но если вы обнаружите свое присутствие, у вас, естественно, возникнут осложнения.

Системные операторы GFH-NET чуть с ума не посходили, когда поняли, что их компьютеры взломаны, и сделали так, что проникнуть в систему стало намного труднее. В случаях с такими маленькими BBS не имеет большого значения, проникнете вы в них, или нет, но если вы имеете дело с чем-то вроде правительственной организации, дополнительные сложности вам вовсе ни к чему.

Если вы каким-то образом обнаруживаете свое присутствие — например, вводя в качестве пароля подряд все слова из словаря, и каждый раз получая сообщение “НЕПРАВИЛЬНО ВВЕДЕНЫ ВХОДНЫЕ ДАННЫЕ”, — системные операторы, как минимум, обеспокоятся. Это означает, что вам уже не удастся получить никакой информации по телефону, а также возможно изменение паролей всех легальных пользователей либо чистка неиспользуемых бюджетов, которая, впрочем, может облегчить вход. С другой стороны, если вы испытываете теплые чувства по отношению к той или иной системе, и не хотите, чтобы ей был причинен вред (и вас мало беспокоит то, что вы можете в нее никогда больше не вернуться), вы можете принять решение известить операторов обо всех маленьких недостатках, которые вы обнаружили в их замечательной системе. Во многих случаях вам просто не поверят. Они могут даже не потрудиться проверить ваши сообщения, либо потому, что уверены в собственной непогрешимости, либо потому, что примут вашу информацию за какую-то уловку, да бог знает, почему еще. Но если они действительно поверят вам и примут ваши советы, они будут весьма благодарны и, если вы попросите, наградят вас доступом невысокого уровня или сообщат какие-нибудь интересные сведения. Скажите им, что вы будете их неофициальным “советником по безопасности”. Некоторые из них с радостью примут ваше предложение, хотя остальные предпочтут больше не иметь с вами дела.

Зашита BBS

Этот раздел посвящен двум предметам безопасного использования BBS хакерами: хакер-пользователь и хакер — системный оператор. Эти две ипостаси тесно взаимосвязаны, поскольку системные операторы одной BBS могут в то же время являться пользователями других. Вы должны применять эти меры предосторожности на всех BBS, которые вы используете и запускаете, и не стоит. связываться с системами, которые не обеспечивают высокой степени хакерской безопасности.

Не помешайте сообщений, содержащих сведения о нелегальной деятельности на BBS, в безопасности которых вы не уверены полностью. Не следует также расписывать свои хакерские достижения в своей личной электронной переписке. Если вы всерьез увлечены электронными системами объявлений, постарайтесь всеми силами подружиться с “неблагонадежными” системами, если не хотите портить себе перспективу вашего дальнейшего существования в компьютерном мире. Но всегда следует убедиться, что ваши сообщения на этих досках никак не втянут вас ни во что криминальное. Поймите меня правильно. Я вовсе не утверждаю, что размещение хакерских сообщений на хакерских BBS гарантирует вам безопасность — это совсем не так. Если вы начали делиться информацией с другими хакерами на хакерской BBS, вам лучше убедиться, что системный оператор соблюдает следующие меры предосторожности: ложный фасад, спрятанные полдоски, полная двойная анонимность, шифровка и проверка намерений. Самым главным аспектом любой хакерской группы, клуба или BBS является секретность. Настоящая хакерская BBS не станет давать рекламу, поскольку не нуждается в новых членах. Хакерская BBS снаружи может казаться очень домашней, этакой семейной BBS, но стоит набрать кодовое слово, не указанное в меню, ввести один-два пароля — и вот вы вошли в секретную область. Хакерская BBS должна также заботиться о своей безопасности, разрешая вход в секретные разделы только определенным пользователям, чтобы не дать несанкционированным хакерам-пользователям или псевдо хакерам взломать ваше место сбора. Любая хакерская BBS, пренебрегающая этими простыми правилами, необходимыми, чтобы казаться легальной, является несерьезной, опасной, и с ней не следует иметь дела. Многие BBS делают еще большие с глупости — я встречал такие системы, для получения доступа в секретные разделы которых достаточно было набрать в качестве пароля слова вроде “DEATH” (“СМЕРТЬ”) или даже “PASSWORD” (“ПАРОЛЬ”). Нечего и говорить, что информация, которую можно найти на таких досках, не обладает высокой ценностью, и обычно состоит из взаимной перебранки между пользователями. Ни один новый пользователь не должен быть до-пушен на хакерскую BBS до тех пор, пока один или несколько действительных пользователей не смогут подтвердить, что он не из полиции, что он будет соблюдать принятые в данном сообществе нормы поведения, располагает полезной информацией и умеет держать язык за зубами.

В качестве системного оператора вы можете получить удовольствие, составляя список правил, определяющих процедуру приема на BBS новых членов. Помните о том, что, пока новый человек не будет принят на BBS, он не должен даже знать о ее существовании. Это позволит вам избежать встречи с полицейскими и сделать секреты системы доступными только для самых лучших хакеров. Как только новый человек будет принят, частная информация о нем должна быть стерта из памяти компьютера.

Вообще, поразмыслите о тех BBS, членом которых вы являетесь на данный момент. Нет ли среди них таких, которые могут накрыть во время полицейской облавы? Лаже если ни вы сами, ни остальные члены системы не совершают никаких нелегальных действий в данной системе, федеральным агентам на это наплевать. Если вы не хотите оказаться замешанным в деле о компьютерном преступлении, даже незначительном, попросите оператора подпольной BBS, членом которой вы являетесь, заменить вашу личную информацию — имя, адрес, телефон, — на ложную. Если вы решили распрощаться с какой-либо BBS, обязательно информируйте оператора о том, что вы хотите, чтобы ваша информация была уничтожена. (Одна из вполне законных — с точки зрения хакера, конечно, — причин для взлома BBS — именно желание убедиться, что такая информация была изменена или уничтожена.) Обязательно проделывайте все эти веши, поскольку блюстители порядка обожают заставать хакеров врасплох. В случае, если представитель закона не сомневается в том, что конкретный хакер пользовался конкретной хакерской BBS, он может и сам совершить взлом, чтобы добраться до настоящего имени этого хакера. Так или иначе, убедитесь в том, что ваши настоящие данные никогда не всплывут в мутной водице.

Прежде чем мы продолжим разговор о том, что следует делать, будучи системным оператором хакерской BBS, я хотел бы привести наглядный пример того, что случается с хакерами, которые НЕ следуют приведенным выше советам. В 1986 году в Детройте появилась BBS с простым, но высокопарным названием — “The ВоагсЬ(игра слов —доска или министерство, совет и т. п.) Аоска использовала компьютер НР2000, и влекла к себе хакеров и кракеров (а также тех, кто только хотел стать таковыми) отовсюду, 20-го августа при загрузке в систему на экране появлялось следующее сообщение:

Добро пожаловать на “осиную” BBS команды (1-ТЕАМ) МАЙКА ВЕНЛААНЛА! (Компьютерное обеспечение — BOARDSCAN) 66 мегабайт 300,1200 бод — 24 часа. V нас есть (3) линии — и ни одной занятой. 313-ХХХ—ХХХХ

Если в тот день вы вызывали систему и читали новые сообщения, вас могло удивить такое сообщение:

Лоска объявлений:

Общая информация и BBS Сообщение: 41 Заголовок: ВАС НАДУЛИ!!!

Кому: ВСЕМ

От кого: ГЛАВНЫЙ ТЕХНИК Отправлено: 8,20,86 @ 12.08 часов

Приветствуем:

Вы находитесь на THE BOARD, “осиной” BBS, оператор МАЙК ВЕНАЛАНА из команды WDIV-TV. Цель:

продемонстрировать и задокументировать существование криминальной и потенциально противозаконной деятельности хакеров и телефонных мошенников, или так называемого “хакерского сообщества”.

Благодарим вас за сотрудничество. В течение последних полутора месяцев мы получили от вас информацию всех видов, которая обнаруживает ваше участие в подделке кредитных карточек, телефонных счетов, вандализме и, возможно, в насильственном проникновении в государственные компьютеры либо компьютеры общественной безопасности. Самое главное, теперь у нас есть ваши объявления, ваши электронные адреса, и — что важнее всего — ваши НАСТОЯЩИЕ имена и адреса. Что мы собираемся со всем этим делать? Не уходите с канала News 4. Я планирую специальные серии докладов о наших экспериментах с THE BOARD, которую посещали пользователи от побережья до побережья, а также пользователи Канады в возрасте от 12 до 48 лет. Наши постоянные пользователи знали меня как ГЛАВНОГО ТЕХНИКА, не считая других ID. Ажон Максфилд из Boardscan

являлся нашим консультантом и обеспечил нам НР2000, который поддерживал это “осиное гнездо”. С помошью ретрансляции звонков и других современных средств, которые стали возможными благодаря телефонной технологии, данная BBS взаимодействовала с удаленными пользователями, находясь непосредственно здесь, в Детройте. Когда будут готовы наши доклады? Через несколько недель мы собираемся непосредственно вступить в контакт с многими из вас, подключив полицию и агентов по безопасности из компаний по производству кредитных карточек и из телефонных служб. Докладов будет чертовски много. Спасибо за помошь. И не затрудняйте себя излишним беспокойством. Помните — у нас есть ВАШИ настоящие имена.

Майк Вендланд The ,-team WDIV, Detroit, Ml.

Доска объявлений:

Основная информация и BBS Сообщение: 42 Заголовок: BOARDSCAN Кому: ВСЕМ

От кого: КОСИАЬШИК Отправлено: 8,20,86 @ 3.31 часа

Это Джон Максфилд из Boardscan (1). Приветствую! Просьба отправлять все бомбы Майку Вендлан-ду из WDIV, Detroit. Эта доска — его идея. КОСИАЬШИК (он же Cable Pair)

Нужны ли здесь какие-либо комментарии? Теперь вы видите, что люди, которые охотятся за хакерами — то есть, за ВАМИ, — отнюдь не просто тупые копы. Максфилд знал достаточно, чтобы придумать прозвища “k001 ”, типа Косильшика (The Reaper) и Cable Pair. Пароль для новых пользователей, желающих попасть в систему, был HEL-N555,Elite,3 — неплохой пароль, если принять во внимание его происхождение. Макс-филды разбираются в хакерстве не хуже, чем мы с вами. Они знают нашу культуру, жаргон и способ мышления. Последнее причиняет особенно много неприятностей, а значит, вам следует обладать своим собственным стилем мышления. Вы не станете хакером высшего класса, пока не научитесь полностью использовать свой здравый смысл. Помните об этом, вызывая BBS. У нас есть право запускать свои собственные BBS и обмениваться информацией с их помошью. Но информацию с хакерской доски вы вряд ли стали бы показывать своей матушке. Заявления типа “На данной BBS запрошены любые противозаконные дискуссии...” бесполезны, но они могут послужить дополнением к следующему утверждению: многие традиционные законы против хакерства говорят о “намеренном причинении вреда”. Можно ли доказать, что хакер или кракер умышленно повредил компьютер? Если вы основали хакерскую BBS или клуб, вы должны убедиться в честности намерений ее участников. Пусть они подпишут соглашение о том, что они никогда не нанесут умышленного вреда чужому компьютеру или его содержимому, что обмен информацией, которая появляется на BBS, имеет под собой исключительно познавательную цель, что никакие обсуждения нелегальной деятельности не станут преследоваться и т. д. Таким образом члены BBS будут следовать вашему своду правил “хакерского кодекса чести”, который может появляться на экране во время прохождения процедуры загрузки. Такое соглашение, возможно, и не убережет вас от столкновения с законом, но позволит вам достичь двух целей: нарушившие соглашение члены BBS будут исключаться; а судьи, благодаря ему, возможно, поверят, что ваша BBS — всего-навсего невинный кружок для людей, которых объединяет общее хобби. Системным операторам стоит заставить участников своей BBS подписать такое соглашение еще и затем, чтобы в случае рейда блюстителей закона пользователи могли на законном основании потребовать вернуть им деньги за разрушенное оборудование, потерянное время, ложные аресты, причиненное беспокойство и т. п.

Электронную почту следует всегда держать под рукой, чтобы можно было истолковать в свою пользу Акт о неприкосновенности электронных коммуникаций. Данный акт предусматривает арест каждого служителя закона, который прочтет электронную почту, являющуюся частной в течение 180 дней. Подобное же, впрочем, ждет каждого пользователя, хранящего свою почту на вашей BBS. Итак, если ваши веселые хакеры подпишут такое соглашение и у каждого пользователя будет храниться образец электронной почты (которая может обновляться каждые 180 дней), вам следует продемонстрировать все это вторгшимся на вашу территорию полицейским. Можно сделать для них специальное сообщение о том, что, в соответствии с законом, некоторые хранящиеся в данной системе материалы и электронная почта, а также сама система и компьютер, на котором она расположена, по закону являются неприкосновенной частной собственностью. Как системный оператор, можете попросить их довести до вашего сведения любую информацию о незаконной деятельности в рамках системы, если таковая будет обнаружена, поскольку вы “не потерпите подобного на своей BBS”.

Джон Максфилд, консультант по компьютерной безопасности, просматривает BBS в поисках свидетельств хакерской деятельности, а обнаружив их, информирует об этом компанию, подвергшуюся взлому. Вы сами знаете, как хрупка бывает компьютерная безопасность. Размещая сообщения или посылая электронную почту на BBS, вы словно открываете ее всему миру. Не позволяйте таким вот охотникам на хакеров копаться в ваших личных делах.

Другие меры по обеспечению безопасности в режиме онлайн

Если вы станете следовать какой-либо определенной схеме, вам станет проще жить, но зато другим будет легче найти то, что вы хотели бы спрятать, и заметить вас, когда вы предпочли бы остаться незамеченным. Один работник нефтяной компании попросил системного менеджера каждый раз до начала компьютерного сеанса устанавливать для него временные резервные записи, чтобы он мог прочесть их перед тем, как приступить к работе. Менеджер сразу заподозрил, что этот человек ищет резервные данные, которые сохраняли до него на этих лентах другие сотрудники. Этого промышленного шпиона, как и многих других, поймали из-за того, что он действовал в рамках определенных установок. Преступники, в том числе и хакеры, любят создавать планы своих действий. Но любой придуманный вам план должен содержать в себе элементы случайности. Не позволяйте себе всегда делать вызовы удаленного компьютера в одной то же время, использовать одни и те же рабочие станции или телефоны, поскольку в один прекрасный день, придя на излюбленное вами место, вы можете обнаружить, что некто поджидает вас там с парой наручников.

Однажды мне в руки попал список номеров социальной безопасности: это был первый урок в компьютерном классе, и профессор попросил студентам сделать для него список с их именами и номерами, чтобы затем создать их компьютерные бюджеты. Я подождал, пока бюджегы будут созданы, но не стал перебирать все подряд. Вместо этого я вводил новое имя через каждые несколько часов чтобы создать впечатление, что это разные люди входят в систему под своими именами. После первой загрузки система попросила меня сменить мой пароль. После этого мне удалось использовать команду изменения паролей операционной системы, чтобы настоящий пользователь смог войти в нее, введя свой номер социальной безопасности. Но в каждой из пользовательских директорий я оставил спрятанную программу, дабы позднее использовать ее для удаленного просмотра файлов и игр. Если вы попадете в ситуацию, когда будете не в состоянии сменить измененный вами пароль обратно на пароль легального пользователя, попытайтесь снова ввести пароль, подобный номеру социальной безопасности — например, 123-45-6780 вместо 123-45-6789, словно вводивший пароль ошибся клавишей. Переходя от одного взломанного бюджета к следующему, важно изменить также свой образ действия. Как вам известно, оказавшись в системе, следует постараться создать новый бюджет для себя. Но всегда используйте разное имя и пароль, причем вводимые данные должны иметь как можно меньше отношения к реальным данным о вашей персоне.

Журналы регистрации (Log-файлы)

Вам не составит труда заставить производителей продукции по компьютерной защите послать вам по электронной почте всю информацию об их товарах. Аля меня имеет значение, в основном, такое программное обеспечение, которое незаметно следит за тем, что происходит в системе, проверяет ресурсы системы на предмет неправильного и беспорядочного использования и ведет журнал регистрации на диске или в распечатках. Сотрудник компании может заглянуть в журнал и сказать себе: “Ого! М-р Полтри каждый раз входит в систему в три часа ночи. Странно... Надо бы поговорить с ним...” Внезапно вы оказываетесь в опасной ситуации, даже не зная об этом.

Производя исследования конкретного компьютера, который вы собираетесь взломать, вы узнаете, какие из программ компьютерной зашиты используются в данном случае (можно узнать об этом у системных операторов, прикинувшись консультантом по компьютерам, или зайти в библиотеку компании и заглянуть в справочник). Закажите у производителя программ по защите образцы его продукции, чтобы “знать своего врага в лицо”. Журналы регистрации могут предупреждать администраторов обо всех ваших привычках. Даже если вы не собираетесь обзаводиться привычками, вы, возможно, станете причиной каких-либо проблем, что также будет отражено в журнале регистрации. Если вы не собираетесь немедленно покидать взломанный компьютер, а, например, хотите выходить из него в сеть, вы должны обнаружить следящую программу компьютерной зашиты и

обезвредить ее. Не стоит разрушать такую программу, просто перепрограммируйте ее так, чтобы она оставляла без внимания ваш вход в систему. Иди выясните, каким образом она ведет запись происходящего и посмотрите нельзя ли уничтожить записи вашей деятельности. Если вы сможете это сделать — прекрасно, значит, вам, скорее всего, достался корневой доступ. Если вы в течение некоторого времени загружались одним и тем же образом, вам надо изменить соответствующие записи, чтобы создать впечатление случайности при прохождении входных процедур. Возможно, вам также удастся использовать команду установки времени или даты, чтобы в свою очередь следить за следящей программой.

ВНИМАНИЕ!

Очень многие хакеры, пытаясь осторожно отредактировать записи следящей программы со своими действиями, обнаруживали к своему ужасу, что уничтожили больше, чем требовалось. Другие пытались оказать помощь, очищая грязную программу и т. п., что приводило к различным несчастьям. Всегда создавайте резервные копии, особенно на компьютерах, которые принадлежат не вам. Если вам необходимо изменить чужой файл, изменяйте его копию. Затем убедитесь, что сделали все правильно, и только после этого уничтожайте оригинал и переименовывайте копию.

Одни из простейших задач, которую выполняют большинство следящих программ и многие средства зашиты ОС — запись неудачных попыток входа в систему. Аля того, чтобы узнать, каким образом избранный вами компьютер реагирует на неправильные входные данные, вам опять же понадобятся исследования. Некоторые программы позволяют сделать три-четыре попытки ввода комбинации имя, пароль, после чего перезагружаются, сохраняя последнюю попытку. В этом случае вместо ввода последнего пароля лучше нажать Control-C или что-то другое, позволяющее вернуться к предыдущему уровню взаимодействия.

Следящие программы могут стать досадной помехой при такой большой работе, как атака с помощью грубой силы. Если получится, попробуйте написать программу для перебора паролей так, чтобы обмануть журнал регистрации. Можно обратиться прямо к аппаратному обеспечению, или, в зависимости от того, какие веши записывает журнал, переименовать могущие показаться подозрительными команды.

Распечатанные журналы являются большой проблемой. Можно попытаться изменить записи на ленте или диске, но что если программа зашиты одновременно делает распечатку происходящего? Тут-то ничего уже не исправишь. Не допускайте ошибок. Ограничьте подозрительную деятельность до тех пор, пока не сможете вывести из строя принтер. Возможно, вам удастся запрограммировать принтер на печать несуществующим шрифтом, или если принтер цветной, на печать таким цветом, которого нет на ленте или картридже. Конечно, если вы действуете по телефонной линии, вам неизвестно, какое оборудование используется. Впрочем, существует еще возможность заставить компьютер выводить данные на другой, несуществующий принтер. Иногда удается даже заставить компьютер думать, что он выводит данные на принтер, в то время как они идут через его модем — в таком случае, вы будете получать репортажи о своей собственной деятельности.

Более неприятная разновидность журналов регистрации ведет запись: кто из пользователей что сделал, когда и почему. В некоторых компаниях сотрудники заносят в журнал все телефонные звонки, а каждый месяц сравнивают сделанные записи с телефонными счетами. Если вы проникнете в офис и станете делать удаленные вызовы, вас легко обнаружат. Лаже если вы занимаетесь этим дома, или в телефонной будке, журнал может вас засечь. Компании могут заносить в журнал приход и уход сотрудников и то, как используется оборудование. В этом случае нельзя допустить ни малейшей ошибки.

“в людях” и на местности

Занятия хакерством на людях — взлом общественных компьютеров или терминалов, социальная инженерия, даже исследования в библиотеке, и т. п., — гораздо опаснее, нежели занятия хакерством у себя дома. В этом случае появляется дополнительная опасность того, что вас узнают или арестуют.

Выбирая место для “публичного” хакерства, используйте проверенные взломшические уловки. Когда взломщик входит в дом, он прежде всего находит все выходы. Не садитесь за компьютер, от которого можно убежать только в одном направлении. Взломщик всегда рад любому кусту, за которым можно спрятаться; постарайтесь выбрать компьютер, который был бы каким-то образом “спрятан”, если за спиной у вас будет стена, а впереди — что-то еще, никто не сможет заглянуть вам через плечо.

Никогда не позволяйте себе забыть, где вы находитесь, увлекшись работой. Ведь именно это и происходит с обычными пользователями, когда вы занимаетесь “подглядыванием через плечо”. Хакер должен думать о безопасности больше, чем легальный пользователь. Приготовьте правдоподобную историю на случай, если вас заметят. Одевайтесь соответственно случаю, и всегда в чистую одежду. Наконец, помните, что в компьютерном зале почти всегда найдется хотя бы один хакер или кракер. Опасайтесь “подглядывателей” и прочих хитрецов. Сидя за общественным компьютером, я всегда несколько раз нажимаю клавишу “Break” перед окончательной загрузкой, на случай, если кто-то установил поддельную программу-ловушку. При выходе тоже соблюдайте осторожность. Некоторые терминалы снабжены буфером экрана. Этот буфер после выхода из системы часто не очищается сразу, и вы можете со спокойной душой выйти из-за компьютера, оставив на нем запись всех проделанных вами действий.

связь с компъютером прервана: минмизация потерь

Но что, если все эти советы вам не помогут, и вас все-таки поймают? Стоит подготовиться к такому повороту событий, чтобы блюстители закона не могли найти, в чем бы вас обвинить.

сопровождение вашего компьютера

Следует регулярно просматривать файлы, хранящиеся на вашем компьютере, и уничтожать те, которые вы незаконно присвоили. Не просто стирайте их: записывайте на их место тексты, состоящие из единственного повторяющегося символа, шифруйте самыми сложными ключами, и только затем стирайте. Можно использовать программу “Wipefile”. Тогда компьютерным копам не к чему будет придраться. Помните, что иногда куски файлов теряются, или отрываются от основной части, или дублируются где-нибудь на диске. Регулярно ишите таких “сироток” и стирайте их, если они содержат что-то нелегальное. Аюбой файл, который вы не можете просто уничтожить, надо шифровать и, в идеале, скрывать под не вызывающим подозрений именем.

На вашем компьютере могут быть и другие веши, которые можно использовать в качестве обвинения против вас: терминальные программы, автонаборы, базы данных с номерами модемов и кодов доступа, списки номеров BBS и т. п. Чтобы сделать их безопасными, наряду с программными “замками” на своем компьютере я использую замки физические.

Прежде чем начать работу, мои компьютеры проверяют, был ли набран на клавиатуре определенный ключ. Если компьютер загружается, не обнаружив ключа, он знает: что-то не так. Тогда он вызывает подпрограмму времени и даты, которая показывает правильное время и дату, тем самым давая мне возможность откорректировать их. Я должен ввести определенные время и дату, в противном же случае компьютер выдаст сообщение “ИДЕТ ЗАГРУЗКА МЕНЮ” и перенесет директорию, в которой я храню все свои безобразия. Там тоже будет открытое меню, но в него никто не сможет войти или выйти из него, не введя правильный пароль. К счастью, мои компьютеры ни разу не конфисковали. Если это произойдет, мне жаль того простака, которому придется продираться сквозь насаженные мною дебри; все мои системы настроены на уничтожение незаконного содержимого в определенных ситуациях. Даже если он подготовится к этому, он не сможет узнать, как это предотвратить!

Как хранить остальные матерьялы

Если у служителя закона имеется ордер на ваш арест, он сможет совершенно легально забрать все ваши компьютеры, периферийное оборудование, чистые дискеты и аудиокассеты, коммерческое программное обеспечение и документацию, распечатки, телефоны и т. п. — любое электронное оборудование, равно как и любые бумаги, подтверждающие, что вы являетесь владельцем этого оборудования, книги, журналы — все, что угодно. Именно так и происходит во время полицейских рейдов. Вдобавок, если преступления, в которых вы подозреваетесь, связаны с конкретным местом или человеком, у вас заберут любые свидетельства того, что существует связь между этим местом, или личностью, и совершенным преступлением. Ордера на арест пишутся специально для того, чтобы узаконить захват такого количества предметов, и будьте уверены — они возьмут все, что захотят. И не рассчитывайте, что вам хоть что-то вернут. Именно поэтому вначале я упоминал, что хакеру необязательно иметь собственный компьютер.

Печально, но факт — вам лучше всего прятать свое имущество, когда вы не находитесь дома или не пользуетесь им. Распечатки и заметки лучше хранить в папках с названиями типа “Школьные сочинения”, написанными крупными буквами, — тогда они, может быть, и не привлекут внимания. Весьма распространен миф о том, что компьютерные распечатки якобы не могут использоваться на суде в качестве вещественного доказательства, т. к. их легко подделать. На самом деле распечатки являются таким же доказательством, как и любые другие записи, если удастся доказать, что они были сделаны во время подготовки или совершения незаконных действий. Распечатки, сделанные позднее, и не вами, доказательством не являются. Но, с другой стороны, если в памяти вашего компьютера хранятся свидетельства ваших незаконных действий, блюстители закона найдут способ представить их суду в качестве доказательства. (Правда, они настолько любят разбивать конфискованные компьютеры, что вам, право же, не о чем беспокоиться!)

Пряча свое имущество, важно сделать так, чтобы оно выглядело как нечто, не имеющее отношения к компьютерам или электронике. Офицеры полиции умудряются получать такие ордера, которые разрешают им забирать все, что имеет хотя бы отдаленное отношение к электричеству. Например, незаконная информация подпольно распространяется на аудиокасоетах. Конечно, мы поместим подобную информацию на купленные в магазине кассеты с надписями вроде “Битлз”, но копы знают об этом, и захотят забрать все наши записи, включая и те, которые выглядят совсем невинно.

Хакеры обмениваются информацией и хранят записи на дискетах. Значит, если у вас есть коробка подобных дискет, вы не можете просто наклеить на них этикетки с названиями игр — вас все равно заподозрят. К тому же, полиция вряд ли станет разбираться с надписями на дискетах. Значит, вам придется спрятать сами дискеты, способом, не имеющим отношения к технике. То же самое относится и к прочему электронному оборудованию. Так, я храню свои резервные дискеты в коробке из-под крекеров — при этом я не являюсь параноиком. Мой лаптоп хранится в большой коробке из-под хлопьев на верхней полке чулана. Мне так спокойнее. Вы уже знаете, что компании и предприятия могут оставлять ценную информацию в мусорных баках. Вам необходимо осознать, что и ваш мусор может так же пригодиться тому, кто хочет обвинить вас в компьютерном преступлении. Все подобные отходы следует сначала подвергать необратимому разрушению, а затем уносить подальше от дома. Распечатки намачивайте, и лишь затем разрывайте. Содержимое дискет шифруйте, потом уничтожайте. Дискеты размагничивайте сильным магнитом, потом крошите на куски. Это не сумасшествие — методы восстановления уничтоженной электронным способом информации существуют. После все это можно выбросить в общественный мусорный контейнер. Я не шучу! Следуйте этим советам — и на вас не навесят ярлык “похитителя промышленных секретов”!

заключение: КАК сделать чтобы вас поймали

На этот раз я хотел бы предложить вам список методов, которые НЕ НАДО использовать, иначе у вас

будут неприятности. Вот пять способов, с помощью которых можно схватить хакера за руку: 1. С помощью слежки или техническими средствами. 2. С помощью доносчика. 3. Объединив против него несколько агентств. 4. По его ошибке, или 5. Узнав его.

Вас могут поймать, выследив по телефонным линиям или другими техническими средствами, вроде журналов регистрации. Так что не оставляйте за собой следов. Все время меняйте компьютеры и телефоны, с которых вы делаете удаленные вызовы. На вас могут донести. Будьте осторожны, общаясь с другими хакерами. Не рассказывайте всем подряд о своих достижениях. Прежде всего, обращайтесь с людьми, с которыми ведете разговоры о хакерстве или вместе занимаетесь хакерством, так, как вам хотелось бы, чтобы они обращались с вами. Если на вас станут охотиться сразу много агентств, вас непременно поймают. Не крадите, не разрушайте, не занимайтесь вандализмом. У хакеров и так неважная репутация, в основном, потому, что большинство пытающихся практиковать хакерство — это прыщавые псевдоанархисты старшего школьного возраста. Если вы соблюдаете хакерскую этику, на вас не станут устраивать травлю. Вас могут поймать из-за вашей собственной ошибки. Ошибкой является несоблюдение нижеследующих предосторожностей.

Всегда подумайте, прежде чем действовать. Не раскрывайте никаких сведений о себе. Не забывайте уничтожать, а не стирать, резервные файлы; это особенно касается временных файлов, которые создаются без вашего участия, автоматически. Если вы будете осторожны, вам удастся практически полностью избежать ошибок. Но даже самый осторожный хакерможет попасться, веруя в стопроцентный успех своего плана действий, тогда как на деле в нем куча недостатков. Например, в 1974 году преступник в Токио пытался использовать одно из основных свойств электронной передачи данных — задержку, которая происходит в то время, когда данные идут по кабелям или телефонным линиям. Преступник открыл банковский счет, использовав фальшивое имя Кобаяши, и начал потихоньку перетягивать небольшие суммы из банкоматов, разбросанных по всей Японии. Каждый раз, перетащив немного денег, он звонил в банк, чтобы узнать текущее состояние своего счета. Таким образом ему удалось выяснить, что центральному компьютеру банка требуется двадцать минут, чтобы зарегистрировать отток денег с удаленной машины. Позднее Кобаяши решил воспользоваться этой информацией. Он перевел на свой счет 5 миллионов йен, рассчитав, что у него в запасе будет двадцать минут, чтобы унести ноги, пока служащие банка станут ожидать, когда главный компьютер получит информацию о том, с какого автомата была снята такая сумма. План провалился — Кобаяши не подумал, что программисты банка смогу перепрограммировать центральный компьютер для немедленной идентификации использованной преступником машины. Грабитель не успел снять со счета свои деньги, как его схватили.

Просматривайте свои планы на случай неожиданных поворотов, и помните, что по ту сторону линии могут быть люди, стремящиеся вас схватить. И, наконец, вас могут узнать. Постарайтесь не выделяться среди массы людей. Самый надежный способ никогда не попасться — никогда не начинать заниматься хакерством. Тогда все, что вы сможете делать с компьютером, — это заниматься делами, решать задачки и иногда играть. Но, занявшись хакерством, вы приобретете целый мир. Вот и все. Желаю всем нам еще много мирных счастливых взломов!


Глава 12. Ваше будущее в качестве хакера

— И что это за профессия такая, прости господи! Сын лейтенанта Шмидта, Ну, год еще, ну, два. А дальше что? Дальше ваши рыжие кудри примелькаются, и вас просто начнут бить.

— Так что же делать! — забеспокоился Балаганов.

— Надо мыслить, — сурово ответил Остап.

И. Ильф, Е. Петров. Золотой теленок

Многие хакеры и не хакеры излагают свои версии “хакерской этики”, и почти все версии похожи друг на друга. Но часто крутые ребята-хакеры сначала следуют принципам, моральным установкам — Кодексу чести, — а затем их уводит в сторону. Им начинает казаться, что, зная закон, они получают право его нарушать: “Мы не действуем вслепую”. Так поступают крутые ребята — они знают, что они крутые, забывая при этом, что порой даже самые крутые хакеры на поверку оказываются полными тупицами.

Я хочу изложить вам свою собственную версию хакерского Кодекса чести. Это список моих убеждений, относящихся к миру компьютеров. Возможно, у вас совсем другие убеждения, но это не страшно — хакеры люди независимые. Впрочем, я хочу, чтобы вы поняли, почему так важно сформулировать кодекс чести и следовать ему. Это может уберечь вас от неприятностей. Я не хочу сказать, что, если вас поймают, суд обратит внимание на то, что вы вели себя в соответствии со своими принципами, особенно если эти принципы включают в себя незаконную деятельность. Я имею в виду, что мне хотелось бы верить в следующее: если вы сформулировали свой моральный кодекс, и если все хакеры из вашего круга подпишут заверения в своей верности этому кодексу, то, быть может, судья или присяжные скажут себе: “Господи, да ведь он не собирался причинять никакого вреда”. Вы, возможно, помните наш разговор об умышленном причинении вреда. Хотелось бы думать, что суд обратит на это внимание, хотя в действительности люди редко пытаются посмотреть на веши с чужой точки зрения. По крайней мере, обладая кодексом чести, вы сможете избавиться от нежелательных людей, и участники вашей группы будут счастливы и в безопасности. Но еще более важно то, что в подобном кодексе, которому вы следуете, присутствует какая-то необъяснимая скрытая ценность. Вам кажется, что я читаю вам проповеди? Ну что ж, я не стану спорить. Вот мой Кодекс Чести Хакера. Здесь мои принципы, касающиеся компьютеров и хакерства, которым я стараюсь следовать.

мой кодекс: чести

Компьютеры дали возможность каждому получать огромные количества информации быстрее и дешевле, чем когда-либо прежде. Свободное распространение информации является благом, но лишь постольку, поскольку не ущемляет прав человека. Существует два вида прав человека—права отдельной личности и права человечества в целом. Человечество должно иметь возможность виртуального доступа к любой информации, и эта информация должна использоваться в моральных целях.

Люди должны знать то, что они хотят знать, и нельзя скрывать от них информацию. Новые идеи должны публиковаться и обсуждаться. Знания должны доходить до людей. Технологии должны использоваться на благо людей, но не ради наживы и не в политических целях. Каждый человек должен иметь право на то, чтобы связанная с ним информация не использовалась во вред ему. Люди должны иметь право знать, если их личная информация внесена в базу данных, знать о том, кому и когда она отдается или продается. Они должны иметь право следить за тем, каким образом используется эта информация. Человек должен иметь право проверять информацию о самом себе, если она занесена в компьютерный файл или базу данных, и в этом ему не должны чиниться препятствия. Он должен иметь право беспрепятственно исправлять неточности в этих данных, и убирать оскорбительную для себя информацию. Аюди должны иметь гарантию, что те, кто создает и обслуживает базы данных, будут своевременно предоставлять им эти права.

Так должно быть, и в некоторых ситуациях эти права действительно имеют силу. Но большинство этих прав почти единодушно игнорируется. Значит, взломы необходимы.

Хакерство позволяет использовать компьютеры в соответствии с вышеперечисленными идеалами. Хакеры обладают идеалами относительно всех людей и всего человечества в целом, и у меня есть набор таких идеалов, которые лично я использую. Вот главные из них:

• Никогда и никаким образом не наноси вред ни компьютеру, ни программному обеспечению, ни системе, ни человеку, ничего не изменяй и не уничтожай.

• Если вред все же был нанесен, сделай все, что в твоих силах, чтобы исправить содеянное, и предотвратить подобное в будущем.

• Не позволяй ни себе, ни другим откровенно наживаться на взломах.

• Сообщай компьютерным менеджерам о наличии прорех в защите их компьютеров.

• Учи других, если тебя просят об этом, делись знаниями, если тебе есть чем делиться. Это не необходимость, но простая вежливость.

• Помни о своей уязвимости во всем, что касается компьютеров, включая секреты, которые тебе удалось узнать с помощью взломов.

• Будь осторожен. Проявляй настойчивость, но не делай глупостей и не рискуй понапрасну.

Я не хочу сказать, что следование этим принципам делает мои занятия хакерством моральными или правомочными. Но я также не считаю, что мое хакерство аморально. И я не стану выслушивать ничьих возражений по этому поводу. Мы-то знаем, что законно, а что — нет. Я собираюсь заниматься хакерством вне зависимости от того, насколько моральным я его считаю. И если у вас возникнет вопрос типа “Неужели вы действительно думаете, что этот ваш кодекс чести может оправдать что-нибудь вроде „вынюхивания"?”, значит, у вас в крови нет хакерства.

комбинирование принципов

В данной книге я попытался предложить основные указания по различным темам, которые подготовят вас к любой, связанной с компьютерами, ситуации, в которой вы можете оказаться.

Когда речь заходит о понятии “хакерства”, невозможно говорить о какой-то определенной последовательности шагов, которые следует предпринимать для достижения своих целей. Надо, скорее, выбрать основные идеи, дополнять их по мере необходимости, и взламывать до тех пор, пока что-то не выйдет. Зная, что вас ожидает, вы будете знать, как реагировать на очередное изменение, — и ваши хакерские способности только увеличатся. Я хочу рассказать вам еще одну, последнюю, историю. Она демонстрирует многое из того, о чем вы прочли в книге: исследования, копание в мусоре, подглядывание через плечо, упорство и логические рассуждения, программистские методы и методы грубой силы, общие знания о компьютерах, простую и обратную социальную инженерию, анализ экранов и модели систем. Эта история показывает, как все это вместе работает на конечный результат — удачный взлом.

“команда тигров” в моем лице

Недавно мне представилась возможность показать себя в хакерстве, взламывая только что установленную компьютерную систему специализированной библиотеки. Директор библиотеки был в курсе дела, поскольку они недавно обратились к этой новой системе, которая, в отличие от предыдущих, давала возможность получения коммутируемого доступа с внешних линий. Директор захотел узнать, возможно ли, находясь в режиме поиска, проникнуть в запретные зоны, имеющие дело с штрафами за просроченные книги, именами и адресами клиентов и можно ли вообще выйти из библиотечной программы в ОС? И многое-многое другое. Я сообщил ему, что буду счастлив разобраться с этой проблемой. Он предложил дать мне один из номеров для соединения с системой, но я отказался. Ведь я — хакер! (На самом деле я просто хотел произвести на него впечатление — я уже знал этот номер, когда он демонстрировал мне работу общедоступной части системы.)

Я вызвал систему из дома и изучил ее вдоль и поперек. Это была система, работавшая по командам. На экране я смог выбрать функцию, вводя такие команды, как CAT для поиска библиотечного каталога, и HOL, чтобы помечать пункты. Правильно завершать сеанс работы следовало с помошыо команды END. Я попробовал вводить другие, не указанные, команды. Очень часто бывает так, что часть системы является открытой, а часть —• секретной. Почти всегда общедоступная часть располагает по крайней мере одной секретной командой для входа в закрытую часть. Итак, я использовал множество ключевых слов: EXIT, BYE, LATER и т. д. Я видел, что некоторые из них используются в действующих прикладных программах. Так, команда LEAVE открывала доступ в специальную область для кураторов и сотрудников музея. Но ни одна из испробованных мною команд не сработала. Так как система была новой и не устоявшейся, я не сомневался, что в ней должна быть куча ошибок, которые я смогу обнаружить. В разговоре с директором он упомянул о том, что определенные функциональные клавиши на терминалах еще не установлены, и их нажатие означает провал в непонятную программную оболочку. Ага! Вот это-то мне и надо! Но, если вы вызываете систему по телефонной линии, вы не сможете добраться до функциональных клавиш. Я думал, что, возможно, функциональные клавиши являлись макросами команд, которые пользователь так или иначе должен вводить вручную, но я не знал этих команд.

Под покровом ночи я извлекал содержимое находящихся возле здания мусорных контейнеров в поисках полезной информации, и наконец нашел кое-что — ужасно изорванную брошюрку — документацию по интересующей меня системе. Лома я увидел, что среди перечисленных в карточке вешей были и имена команд, присвоенных функциональным клавишам. Одну-две из них можно было прочесть, остальные же прочесть не удалось. Но и двух было достаточно. Мне сразу стало ясно, что я исходил из неверных предпосылок — не ВСЕ команды представляли собой стандартные слова английского языка или аббревиатуры. Присутствовали и двузначные команды, и точечные. Вводя точечную команду, вы набираете сперва точку, а вслед за ней — буквенно-иифровую команду. Они часто используются в прикладных программах, когда непосредственный ввод буквенно-цифровой команды может быть истолкован как ввод данных. В программах часто используется точка перед командами, поскольку точка — простой, неприметный символ, который очень просто набрать. Но иногда в “точечных” командах используются и другие символы — слеш, апостроф и т. п. Из карточки я узнал, нажатие клавиши F1 соответствует команде .QUIT, a F2 — команде .HELP. Это показалось многообещающим — .QUIT могла давать доступ к закрытым областям, а помощи, скорее всего, вообще пока нет, так как система только что установлена. Возможно, эта функция

и ведет к остановке системы. Я вызывал компьютер по внешней линии, а через модем нажатие функциональных клавиш передать невозможно; так что мне оставалось надеяться на .QUIT и .HELP. Конечно, я уже пытался их вводить, но без точки. Может быть, теперь... Нет! Ничего! Команда .QUIT просто отсоединила меня от компьютера. В ответ на .HELP экран очистился, и на нем появилось следующее:

*EOF\txt\hlp\helpOOO* Я предположил, что это означало End Of File helpOOO в директории \txt\hlp, то есть файл существовал, но был пустым. Я тут же обрадовался — теперь я знаю о директориях текстовых файлов и файлов помощи. И я заметил еще кое-что:

каждый раз при смене экрана вверху появлялось нечто вроде:

*** J. Smith Co Special Library On-Line ***

(000)U,SYSv55.6 Три цифры в скобках изменялись в соответствии с тем, какую часть программы я использовал. Три нуля, возможно, означали открытый экран, где я пытался набирать не указанные в списке команды. Если я наберу команду .HELP вместе с номером экрана, допустим, (013), значит, решил я, система начнет искать файл “\txt\hlp\help013”. Так и случилось. Аля ввода эта система использовала, в том числе, и команды, сопровождающиеся номером. Мне стало интересно, подходит ли такой формат и для команд помощи. Я попробовал ввести “HELP99999”, надеясь, что такое большое число система просто не проглотит — ведь, такого экрана просто не может быть. В ответ я получил сообщение о неверной команде. Я попробовал другие варианты, но они тоже не сработали. Наконец, я снова набрал “HELP99999”, и на этот раз команда подействовала! Наверно, в первый раз я сделал ошибку. Теперь система полетела, и я оказался в отладочной среде программы. Это было нечто вроде мини-системы для редактирования текстовых и командных файлов. Я не нашел в ней ничего ценного, кроме копирайта с первыми буквами названия компании, выпустившей программу. Я просмотрел несколько каталогов компаний по производству программного обеспечения, пытаясь расшифровать аббревиатуру, и наконец мне это удалось. Позвонив туда, я выяснил, что именно они написали интересующую меня программу. Я попросил прислать мне запасную документацию к пакету. Конечно, сказали они, просто вышлите нам серийный номер своей программы, и они вышлют мне книгу за соответствующую плату. Я попытался схитрить, но не тут-то было: секретарша сообщила, что серийный номер можно найти на ярлыке инсталляционных дискет. “У меня сейчас нет дискет... Я звоню из машины. Я уверен, что высылал свою карточку, может, вы проверите? Меня зовут Ажонатан Смит из ...” Я молил бога, чтобы настоящий J. Smith посылал им свою карточку. Но — нет. Мне пришлось сказать, что я перезвоню на следующий день. Я решил, что в библиотеке компании должна быть эта документация, но не мог же я там появиться и попросить директора дать мне ее на время. Я должен был действовать как независимый хакер. Пришло время серьезно заняться социальной инженерией. Директор для этой цели не годится — он знает мой голос. Все, что мне было надо, — это серийный номер. Я позвонил секретарше библиотеки и сказал, что я — программист из компании, которая установила им новую компьютерную систему, и хотел бы знать, нет ли у них восьмой версии программы? Этого она, конечно, не знала, но я вежливо объяснил, что ей нужно просто найти несколько дискет с приклеенными на них ярлычками... Найдя их в директорском офисе, она сообщила мне серийный номер. Одной из его цифр оказалась восьмерка, и я сказал ей, что все верно, и я просто хотел убедиться, что компания поставила им самую новую версию, и как только появится девятая версия, мы пошлем ее им.

Я больше суток разбирался в отладочной документации. Я обнаружил, как можно обойти программное окружение и как — самое главное! — выйти из него. Выйдя из отладки, я оказался перед приглашением к загрузке. Нажав в ответ “circ” и “JSC” — J. Smith Co. — я вошел внутрь. Разумеется, здесь я привожу вымышленное имя. После ввода верного пароля я оказался на втором уровне зашиты — circ,JSC была общая входная комбинация, известная любому легальному пользователю. Я знал, что означает “ваш личный девятизначный код”. Номер социальной безопасности! Я знал, где родился и вырос директор, так что первые три цифры у меня были. Я написал программу для перебора последних шести цифр, и вскоре нашел верную комбинацию. Мне выдали сообщение: “Добрый вечер, Ажейн Торнбакл! Пожалуйста, введите ваш личный пароль”. Директора звали иначе. Теперь мне был нужен пароль Ажейн. Я снова попробовал метод грубой силы, но безрезультатно. Я не знал, кто такая Ажейн Торнбакл, но у меня была извлеченная из мусора пачка рекламных проспектов компании. А вот и ответ: Торнбакл оказалась сотрудницей отдела службы управления информацией — то есть программистом. Вычислить ее пароль мне так и не удалось; продолжив перебирать номера социальной безопасности, я опять вышел на номер директора библиотеки. Итак, чего я достиг? Программная оболочка — вещь интересная, и я научился с ее помощью как угодно редактировать файлы и т. п. Я сумел использовать одну из отладочных команд поиска для обнаружения слова “circ” в файлах системы. В одном из них среди абракадабры я обнаружил слово “minicirc”, а затем “circ”. Я попытался расшифровать абракадабру, идущую после “circ”, думая, что это зашифрованное “JSC”, и надеясь таким образом найти ключ к абракадабре после “minicirc”. Безрезультатно. Вернувшись к входному приглашению, я попытался использовать “minicirc” с различными паролями. Проблема была в том, что я не знал, что такое “mini”. Я подумал, что это может быть модель программы или руководство. Наконец, я нашел верный пароль — T.CIRC1. Он-то и привел меня к заветному сообщению: “Пожалуйста, введите вам личный девятизначный идентификационный код”. Через несколько секунд я нашел нужный номер, и экран очистился. “Доброе утро, Новый Пользователь!” — появились на нем слова. — “Пожалуйста, введите ваш личный пароль”. Я надеялся, что это — последний уровень зашиты. И точно: через несколько мгновений мне удалось войти, использовав пароль “TRAIN”. Я гордился собой — я взломал-таки закрытую часть системы. Но приключения еще не закончились — ведь “minicirc” была всего лишь учебной моделью настоящей системы. Ее можно было использовать для проверки книг для выдачи посетителям, регистрации новых посетителей, поиска в базах данных и т. д. Но в базе данных содержались только вымышленные имена и адреса. Многие другие свойства системы были бесполезны, но мне помогло само их наличие.

Там была электронная лоска объявлений, на которой инсталлировавшие программу оставили несколько стандартных сообшений-приветствий. Прочитав их, я узнал немало полезного. Каждое сообщение открывалось списком пославших его, и тех, кому оно предназначалось. Я заключил, что можно посылать сообщения из “minicirc” в “circ”, и наоборот. Во-вторых, там оказались сообщения, предназначавшиеся одному пользователю, но по ошибке посланные всем. С помошью текстового редактора я написал письмо и лично послал его. Затем вышел, перезвонил и снова оказался в программной оболочке. Использовав редакторы отладчика, я нашел написанное мною письмо, и изменил его содержание, адресовав его директору библиотеки. Свое имя, под которым хранился файл, — “Новый Пользователь” — я изменил на фиктивное имя представителя компании, произведшей программное обеспечение. В послании содержалась просьба к директору позвонить этому представителю для разговора насчет новой, девятой, версии — обратная инженерия! Телефонный номер, который я дал директору, принадлежал одному моему другу, которому я кратко объяснил, как действовать в случае, если директор позвонит. На всякий случай мы установили автоответчик. Когда директор позвонил, мой друг немного рассказал о новых разработках, а затем задал несколько технических вопросов о способе, с помошью которого в библиотеке была инсталлирована программа. Директор не знал этого, но сказал, что может посмотреть у себя на терминале, загрузившись в систему... “Отлично”, — сказал мой друг. — “Делайте все то же, что обычно. Circ. JSC. Так, номер... Кстати, вы используете все тот же личный пароль?” “Ну да, „Firebird". Ну вот, я загрузился...” Итак, последний шаг оказался самым легким.

Для завершения проекта мы стали думать, что же можно сделать, используя директорский системный доступ. Оказалось, что сделать можно многое. Покинув данный уровень, мы вышли на сетевой сервер, а оттуда загрузились в один из главных компьютеров, используя имя и пароль директора. Под конец, для подтверждения своего успеха, я использовал редактор интерактивного отладчика и изменил программу так, чтобы вместо пояснений к командам она выдавала на экран непристойную шутку. Затем я оставил файл в директории директора библиотеки, в котором объяснил, каким образом был совершен взлом.

комбинирование принципов

Если вы хотите быть по-настояшему удачливым хакером, вы должны стать “хакером на все руки”. Недостаточно хорошо владеть методами социальной инженерии, или быть гением-программистом, и т. д. Вы должны обладать всеми этими навыками в совокупности с богатым воображением и установкой на конкретные цели. Плюс этика. Я действительно считаю, что хакерство без этики не ведет ни к чему хорошему — если вы будете причинять неприятности другим, то неприятности вскоре начнутся и у вас. Присутствовала ли этика в описанном мною взломе? Конечно — ведь я просто переименовал экранный файл, а неприличную шутку поместил в другой, под прежним именем. Позднее мы вместе с директором и программистами компании вместе обсудили план действий по заделыванию дыр в защите системы.

мысли в заключение

Спросите мудреца о цели существования вселенной, или еще что-нибудь в том же духе — и он ответит:

— Этого нельзя выразить словами. Я знаю ответ, я его чувствую, но неописуемое словами не опишешь. “Ну и чушь!” — подумаете вы. Конечно. Но вместе с тем это правда. Мудрец действительно верит в то, что знает обо всех тайнах вселенной, но вы этого не поймете, пока сами не почувствуете то же самое. Вот ваш проводник в мире хакерства, лежащем за пределами этой книги. Из книги вы узнали идеи, методы и факты, которые позволят вам начать заниматься хакерст-вом, сводя к минимуму возможность совершения ошибок. Но это еще не все. Это хобби (игра? профессия?) требует, как и любое хобби, времени, сил, практики и еще, и еще, до тех пор, пока у вас все не начнет получаться так, как вы хотите.

несколько советов обеспокоенным администраторам

Если же вы прочли эту книгу с точки зрения соблюдения закона и обеспечения компьютерной безопасности — что ж, теперь вы знаете множество способов взлома самых “непробиваемых” систем. Вы, наверное, уже составили список мер, которые примете против описанных мною методов. Объясните вашим пользователям, что никогда нельзя открывать никакую конфиденциальную информацию по телефону, по почте или в режиме онлайн. В ответ на просьбу открыть пароль следует отвечать просто: “в этом я не смогу вам помочь”. Нельзя раскрывать имена или телефонные номера, адреса электронной почты иди физические адреса. Если человек спрашивает такие веши, он, скорее всего, является хакером.

Установите правила, по которым легальные пользователи задавали бы вопросы любому подозрительному типу, шатающемуся по офисам. Но не стоит и слишком давить на пользователей проблемами безопасности. Если вы проявите излишнюю бдительность — например, поменяете все пароли, — пользователи могут вас не понять. Объясните им, что они потеряют, если компьютерная безопасность будет нарушена. Убедите их, что это важно для всех сотрудников организации. Чтобы убедиться в нерушимости зашиты на все 100%, возьмите за правило регулярную проверку и очистку компьютеров. Найдите и залатайте дыры в защите вашей системы. Уберите все отладочные опции, которые могут быть причиной появления таких дыр. Если вы увольняете сотрудника, немедленно сотрите его доступ и поменяйте код всех остальных. Существует специальная литература о мерах по компьютерной безопасности, которые должен предпринять администратор. Прочтите ее. Немного хорошей работы — и ваш труд не пропадет зря.

несколько советов обеспокоенным хакерам

Вы прочли всю книгу, и все еще сомневаетесь в успехе? Я гарантирую вам — если вы прилежно обучаетесь хакерству, вы станете настоящим мастером этого искусства. Лаже если вам пока не удалось совершить ни единого взлома, вы все же можете считать себя настоящим хакером — ведь у вас благородные намерения, вы соблюдаете правила хакерской безопасности, вы не станете вредить системе, которую взломаете, и вы стремитесь наслаждаться жизнью во всей ее полноте. А все это и есть хакерство. Поздравляю вас и желаю удачи: теперь вы знаете все Секреты Супер-Хакера! То есть ваши секреты.


"ОСНОВЫ ХАКЕРСТВА"

Основы

Глава 2 Исследования перед взломом

Глава 3. Пароли и контроль над доступом

Глава 4. Социальная инженерия

Глава 5. Компьютеры общественного доступа

Глава 6. Хакерство на местности

Глава 7 Хакерство на дому

Глава 8. Электронные доски объявлений

Глава 9. Что греховно, а что нет

Глава 10. Что делать, когда вы внутри

Глава 11. Kак не попасть в лапы закона

Глава 12. Ваше будущее в качестве хакера

Глоссарий


Глоссарий

acoustic coupler (акустический соединитель) — прибор, состоящий из двух чашечек на основании, в которые вставляется микротелефонная трубка. Акустический соединитель соединяется с модемом, который посылает свои сигналы прямо на микрофон телефонной трубки, а принимает сигналы с телефона. Полезен для “хакерства на ходу”.

amplifier (усилитель) — прибор для увеличения амплитуды сигнала без изменения его свойств.

analog signal (аналоговый сигнал) — выходной сигнал, который изменяется пропорционально изменениям входного сигнала.

anonymous FTP (анонимный протокол передачи файлов FTP) — возможность переноса файлов с удаленного компьютера, соединенного с Интернет, без обладания бюджетом на удаленном компьютере. Вместо имени пользователь вводит: “anonymous”, а вместо пароля — обычно адрес электронной почты.

asynchronous (асинхронный) — название множественных программ или процессов, которые перекрывают друг друга в использовании и, возможно, в памяти. Асинхронная атака на систему заключается в том, что одна программа пытается изменить те параметры, которые другая программа проверила на достоверность с положительным результатом, но еще не использовала.

avatar (аватар) — альтернативное наименование для привилегированного пользователя системы (обычно UNIX). В индийской мифологии аватар — инкарнация бога.

backbone site (магистральный узел) — ключевой узел USENET и электронной почты, обрабатывающий большое количество поточной информации. Получает и посылает на другие узлы новости и сообщения.

back door — см. Trapdoor baud (бод) — единица скорости передачи информации, импульс, секунду, причем импульсы равны по амплитуде. Один бод равняется одному биту в секунду.

BITNET — сеть, состоящая из миникомпыотеров или мэйн-фрэймов. В ITN ЕТ объединяет множество учебных заведений. Дает возможность посылать электронную почту и передавать файлы, но не позволяет осуществлять удаленный вход.

BBS — Bulletin Board System (Электронная доска объявлений) — компьютер, установленный на прием вызовов с модема. Пользователи устанавливают с ним связь и получают доступ к различным услугам, включая электронную почту, обмен сообщениями, игры и т. д.

boffin (боффин) — термин, использовавшийся во времена второй мировой войны для обозначения людей, подобных хакерам, которые стремились понять, как устроен этот мир, и использовали свои знания на благо этого мира.

buffer overflow (переполнение буфера) — переполнение происходит, когда в буфер поступает избыточное количество новых данных. Причин может быть две: буфер недостаточно велик, чтобы вместить все данные, которые необходимо, до начала обработки этих данных; либо несоответствие между приемом и обработкой данных.

С (Си) — язык программирования, с которым, равно как и Си++, должен быть знаком каждый хакер. На Си написана UNIX.

chat (беседа)—беседа с другом в режиме онлайн.

CCTV — внутренние системы телевизионного наблюдения.

СЮ (Chief Information Officer) — главный офицер службы информации.

console (консоль) — операторский терминал на мэйнфрэй-ме, с помощью которого оператор управляет системой.

console РВХ — настольный коммутатор.

covert channel (“плохой канал” ) — канал, не предназначенный для передачи информации, по которому все же можно нелегально получить секретную информацию о системе.

cracker (кракер) — хакер, плохо относящийся к компьютерам, которые взламывает.

cty — консоль tty (также ctty).

daemon (Disk And Execution Monitor) — “даемон”, программа, которая не запускается пользователем или программой пользователя, но дожидается определенных условий, после чего запускается сама.

demodulation(дeмQдyляuия) — процесс перевода аналогового сигнала в цифровой.

demon — “демон”; то же, что даемон, но может вызываться пользователем.

DES (Data Encryption Standard) — стандарт шифровки данных.

detector — детектор, электрическая схема, используемая для изъятия модуляции из несущего сигнала.

dual-tone multifrequensy dialing — двухтональный многочастотный набор, метод коммутации с использованием пары тонов, высокого и низкого. Используется в кнопочных телефонах.

dumb terminal — “глупый” терминал, устройство, предназначенное только ввода в компьютер и вывода из него. Ср. “интеллектуальный” терминал.

duplex — дуплексный канал, позволяет одновременную связь в двух направлениях.

EDP (Electronic Data Processing) — электронная обработка данных.

e-mail — сокр., электронная почта.

firewall mashme — машина, оснащенная различными защитными свойствами. Используется в качестве шлюза для зашиты главных компьютеров.

FTP (File Transfer Protocol) — протокол передачи файлов. Набор протоколов, с помощью которых можно передавать файлы с одного компьютера на другой.

group accounts — групповые бюджегы, бюджета группового доступа. Компьютерная директория иди бюджет, защищенный паролями, принадлежащими группе пользователей.

hacker — прочтите эту книгу и вынесите собственное суждение о значении этого термина!

handshaking (квитирование, подтверждение связи) — процесс, в результате которого два независимых друг от друга устройства аппаратного обеспечения координируют свои сигналы и получают возможность работать совместно.

intelligent terminal — интеллектуальный терминал.

interoffice telephone (внутренний телефон) — телефон, которому нельзя позвонить во “внешний мир”.

iron box — ловушка для неосторожных хакеров.

LAN — локальная вычислительная сеть.

letterbomb (текстовая бомба) — фрагмент электронной почты, содержащий “живые” данные с целью нанесения вреда системе-реиипиенту.

limited-use passwords (ограниченное использование паролей) — система паролей, содержащая как обычные пароли, так и пароли однократного применения.

line (линия) — провода, соединяющие телефон с центральной станцией.

Listserv — программа, посылающая файлы и почту с одного компьютера на другие.

live data (“Живые данные”) — информация в файле, которая, при определенных обстоятельствах, может быть интерпретирована как инструкции компьютеру.

log (журнал) — запись работы компьютера.

login (вход, начало сеанса связи) — получение доступа к компьютеру после ввода имени и пароля.

logic bomb (логическая бомба) — программа, внедренная в прикладную программу; запускается при определенных условиях.

macro (макрос) — ключевая строка или короткое имя, использующаяся для ссылки на более обширный текст.

modulation (модуляция) — перевод цифрового сигнала в аналоговый.

modem — модулятор,демодулятор.

multiplexing (мультиплексирование) — Использование различных модуляционных частот для одновременной передачи нескольких сигналов.

net — сокр. от network.

network (сеть) — две и более машин, соединенные вместе с целью обмена данными.

newsgroup (группа новостей) — раздел USENET, посвященный определенной теме.

поое(узел) — самостоятельная машина, соединенная с другими сетью.

once-only code (код однократного применения) — пароль, который можно использовать только для однократного доступа.

operating system (операционная система, ОС) — управляющая программа, которая следит за интерфейсом системы с пользователем и периферией.

PAD — пакет ассемблер,диассемблер.

РАВХ (Private Automatic Branch exchange) — закрытый автоматический обмен. PAX с возможностями внешнего соединения.

packet assembler,diassembler (ассемблер,диассемблер пакетов) — один из узловых компьютеров сети общественных данных.

packet switching (коммутирование пакетов) — метод передачи данных, при котором каждое сообщение перед отправлением разбивается на пакеты.

parser (анализатор) — программа, считывающая введенный текст и анализирующая его значение.

passive computing (пассивное электронное считывание данных) — тайное наблюдение за компьютерным экраном, например, с помощью прибора Ван Эйка.

PAX (Private Automatic Exchange) — закрытый автоматический обмен. Сеть телефонов, не соединенных с внешними линиями.

РВХ — сеть телефонов, каждый из которых оснащен собственными средствами коммутации.

PDN (Public Data Network) — сеть общественных данных.

phreak (фрик) — человек, взламывающий телефонные системы

piggybacking — проникновение в закрытое здание, следуя по пятам за тем, кто имеет право туда войти.

plaintext (шифровка) — зашифрованный файл или сообщение.

PLE (Public Local Exchange) — локальный общественный обмен. Локальная телефонная сеть в отдельном здании и,или офисе, управляемая снаружи телефонной компанией.

post — опубликование письма, статьи, рассказа и т. д. путем его пересылки в область сообщений.

BBS,PPN (Project-Programmer Number) — применяется для обрашения к ID пользователя.

pps (pulses for second) — импульсы в секунду.

premises wiring — провода внутри здания для соединения телефонов с телефонными линиями компании.

PRIMOS — ОС для компьютеров PRIME.

process (прогон) — программа, которую компьютер “прогоняет” в данный момент.

process command (команда процесса) — команда ОС для распечатки всех активных процессов.

protocol (протокол) — набор правил, используемых программным обеспечением для взаимодействия с аппаратным обеспечением.

public data netwoik (сел” передачи данных общего пользования) — сеть типа Telnet, использующая коммутирование пакетов для соединения компьютеров.

pulse (импульс) — моментальное протекание тока, характеризующееся резким подъемом и падением.

pulse frequensy (частота импульсов) — число импульсов в секунду.

receive only telephone (телефон только для приема звон' ков) — телефон, который может только принимать, но не производить звонки.

reverse social engineering (обратная социальная инженерия) — тактика, при которой системный пользователь обращается к хакеру за советом.

root (корневой бюджет) — бюджет привилегированного пользователя, занимающий главенствующее положение.

salami technique (техника “салями”) — метод для краж больших сумм в течение длительного промежутка времени.

scavenging (копание в мусоре) — проверка мусорных контейнеров в поисках информации.

script (сценарий) — командный файл, автоматически запускающийся после квитирования коммуникационным программным обеспечением вызывающего.

security through obscurity (безопасность посредством неясности) — обеспечение безопасности системы путем ее маскировки.

serial (побитная передача) — прохождение информации побито в последовательном порядке.

shoulder surfing — подглядывание через плечо пользователя за тем, что набирает пользователь на клавиатуре и что появляется на экране.

simplex (симплекс) — однонаправленные коммуникации.

simulation (модель программы) — программа, устанавливаемая хакером, имитирующая открытую часть системы.

smart terminal (“умный”, он же интеллектуальный терминал) — терминал, обладающий памятью, командами для редактирования, графикой и т. д., в отличие от “глупого” терминала.

social engineering (социальная инженерия) — использование обмана, мошенничества, своего актерского мастерства и владения словом для выманивания у легального пользователя системных секретов.

stand-alone (автономный) — термин для обозначения компьютера или компьютерной системы, которая функционирует без дополнительного оборудования.

superzap •— использование специальной отладки или компьютерного сопровождения для модификации данных.

ТАР (Technological Assistance Program) — программа технической ПОМОЩИ.

temet — набор протоколов, используемых для получения доступа к одной машине через другую.

tiger team (“команда тигров”) — хакер или группа хакеров, нанятых организацией для проверки безопасности ее компьютерной системы.

tone generator (генератор тонов) — прибор для генерации тонов, необходимых для задействования телефона; состоит из акустического соединителя и телефонной клавиатуры.

trapdoor (лазейка) — недокументированный способ получения доступа в компьютерную систему.

tracking (выслеживание) — использование системных журналов и т. п. для выслеживания хакеров.

trashing — см. scavenging Trojan horse (“троянский конь”) — программный кусок “с секретом”, спрятанный внутри прикладной программы.

trusted hosts (проверенные главные компьютеры) — в некоторых приложениях UNIX, список других компьютеров и пользователей, которым не требуется пароль для входа.

TSR program(Terminate and Stay Resident) — загружается в память и остается там после загрузки других программ, собирая информацию.

UNIX — ОС, созданная Кеном Томпсоном и Аеннисом Ри-чи из Computer Research Group.

USENET — обмен сообщениями на базе Интернет.

vandal (вандал) — кракер, уничтожающий файлы, разрушающий системы и т. п.

VMB (Voice Mail Box) — компьютеризированный автоответчик, который сохраняет приходящие сообщения в цифровой форме, на диске.

VMS (Virtyal Memory System) — система виртуальной памяти; ОС, используемая на миникомпьютерах VAX.

WAN (Wide Area Network) — сеть широкого распространения. Сеть, которая соединяет между собой машины, находящиеся очень далеко друг от друга, обычно с помощью телефонных линий.

WATS (Wide Area Telecommunications Service) — телекоммуникационная служба широкого распространения. Позволяет делать удаленные вызовы внутри определенного географического региона, в т. ч. международные.

worm (“червь”) — программа, целью которой является бесконечное саморазмножение — пока хватает места на диске.


Основы

— Скажите, а вы-то сами помните восстание на броненосце “Очаков”?

— Смутно, смутно, — ответил посетитель. — В то героическое время я был еще крайне мал. Я был дитя.

— Простите, а как ваше имя?

— Николай... Николаи Шмидт.

—А по батюшке?

“Ах, как нехорошо!”— подумал посетитель, который и сам не знал имени своего отца.

—Аа-а, — протянул он, уклоняясь от прямого ответа, — теперь многие не знают имен героев. Угар нэпа. Нет того энтузиаста.

Председателю показалось позорным, что он забыл имя очаковскою героя. •Действительно, —думал он, глядя на воодушевленное лицо героя, — глохнешь тут за работой. Великие вехи забываешь”.

И. Ильф, Е. Петров. Золотой теленок

Существует два способа написать книгу о компьютерных взломах.

Можно написать энциклопедию всех известных систем, их номеров доступа, паролей, лазеек и способов повышения уровня доступа. Это неплохой способ, если забыть о том, что ко времени выхода такого издания большая часть ее содержания станет устаревшей. И уж, конечно, напечатанные в книге пароли можно будет считать недействительными. Такой подход лучше оставить для периодики, некоторые печатные и электронные издания пытаются этим заниматься.

Второй путь — написать книгу, которая являлась бы энциклопедией методов взлома систем. Это решит проблему распространения постоянно меняющейся информации, читатели же смогут следовать описанным в ней алгоритмам, добавляя немного собственного воображения и не боясь оказаться в какой-либо совершенно новой, не указанной в книге ситуации. Именно таким способом и написана эта книга.

Я старался построить данную книгу в логичной последовательности и сделать ее понятной, но порой мне приходилось нарушать плавное течение повествования, возвращаясь к уже сказанному в предыдущих разделах.

Если вам встретится незнакомый термин или ситуация — забудьте об этом. Скоро вы обретете опыт. Можете заглянуть в глоссарий, возможно, там содержится ответ на ваш вопрос.

Компьютерные взломы связаны с громадным количеством информации. Готовя книгу к печати, мне приходилось решать, стоит ли углубляться в подробности в том или ином разделе, или открывать некоторые тайные уловки. Кое-что мне пришлось опустить. На самом деле важно не написание книги, а прочтение ее и претворение в жизнь новых идей. Хакерство — это не чтение, а действие, это работа, работа для себя и над собой. Я рад, если мне удалось указать вам верное направление, но я не смогу быть проводником на вашем пути.

Я хотел бы поблагодарить Р. С. и Аж. за критику отдельных разделов моей книги, сотрудников Loompanics за понимание того, что наша конституция дает прессе право на свободу, а также многих хакеров за внесенные ими ценные предложения.

ЗАМЕЧАНИЯ

В данной книге описаны различные методы взлома компьютерных систем.

Легко сказать — взлома. В наши дни люди больше обеспокоены проблемой компьютерной безопасности, чем раньше. Но, несмотря на это, в защитной броне любой системы существует немало прорех. Системные администраторы могут бесконечно усиливать зашиту, но способ обойти ее все равно найдется. Запомните первое правило хакерства: то, до чего додумался один человек, додумается и другой, что один скрыл — другой раскроет. Люди в большинстве своем мыслят и действуют одинаково, и хакеры должны использовать это единомыслие.

Что же такое хакер? (Если вы не согласитесь с данным определением, можете закрыть эту книгу.)

Хакер — это человек, который чем-то увлечен, будь то компьютеры, написание книг, природа или спорт. Это человек, который, благодаря этой своей увлеченности, испытывает любопытство ко всему, связанному с его увлечением. Если хакер любит компьютеры, то будет стараться узнать как можно больше о компьютерах, а также о том, как ими пользуются другие люди. Хакеры уважают предмет своего увлечения. Для компьютерного хакера это означает уважение к компьютерам, которые предоставляют людям возможность входить в контакт друг с другом и получать информацию со всего мира, а это в свою очередь означает, что он уважает других людей и не допустит умышленного использования своих знаний о компьютерах в целях развлекательных или разрушительных. Серьезный компьютерный взломщик просто хочет знать обо всем, что делается в мире, особенно в мире компьютеров. Настоящий Компьютерный Взломщик — это компьютерный энтузиаст, и, что более важно, вселенский энтузиаст. Я надеюсь, что вы будете энтузиастами.

Итак, вы готовы познавать?

ОБОРУДОВАНИЕ

Для того, чтобы стать удачливым компьютерным взломщиком, вам потребуется один прибор — ваши мозги. Вам не нужен даже компьютер. Более того, иногда бывает лучше вообще не иметь компьютера, как вы увидите в дальнейшем. Впрочем, для начала вам все же потребуется компьютер, модем и телефонная линия для связи с внешним миром.

Компьютер может быть каким угодно. Гораздо важнее, какой у вас модем и коммуникационное программное обеспечение.

Хакерство — хобби, не требующее большого количества снаряжения; но если вам приходится что-то покупать, покупайте самое лучшее из того, что вы сможете себе позволить. Это не означает, что вы должны приобретать то, что вам предлагают продавцы или специальные журналы. Выбирайте то, что вам больше всего подойдет. Уверен, вы захотите, чтобы ваш модем был быстрым. Когда я приобрел свой первый модем, то считал 140-бодный модем просто копушей. Теперь я смотрю на 300-бодный и не понимаю, как я мог управляться с этой каракатицей.

Какой бы скоростью ни обладал ваш модем, он всегда будет работать несколько медленнее, чем вы ожидали. Из-за помех на линии модем бывает вынужден перепосылать данные снова и снова, пока не передаст или не примет их в неискаженном варианте. Модемы могут работать вполовину указанной скорости, и, если у них плохое настроение, и того медленнее. При передаче на дальние расстояния или если удаленные компьютеры слишком загружены, или при доступе к одному компьютеру через несколько других — чтобы вас труднее было выследить — скорость снижается еще больше.

Итак, если вы хотите получать удовольствие от своих занятий — покупайте высокоскоростной модем.

коммуникационное программное обеспечение

Бывает трудно найти действительно подходящую коммуникационную программу, но именно от нее, в совокупности с подходящим модемом, и зависит, принесет ли вам радость ваша работа в режиме он-лайн или только разочарует вас.

Существует много видов терминальных программ. Если какой-то пакет приложен к вашему модему, это еще не значит, что он вас устроит. Хорошая программа должна обладать нижеперечисленными свойствами и все они для хакера необходимы или хотя бы желательны.

Программа должна эммулировать достаточно большое количество разных терминалов, таких, например, как ANSI, VT52, VT100 и т. д. Неплохо, если программа располагает адресной таблицей — возможностью переводить входящие и выходящие символы в другие символы. Программа должна быть в состоянии посылать и принимать файлы, используя Xmodem, Ymodem, Zmodem и Kermit протоколы. Удостоверьтесь, что ваша терминальная программа располагает, по меньшей мере, этими четырьмя протоколами. Программа должна позволять управлять модемом используя "АТ"-команды. Вам также понадобится возможность обращаться к вашей операционной системе во время поддержания связи, т. к. иногда в процессе работы онлайн бывает нужно запустить другую программу. Программа должна включать в себя телефонную книжку, позволяющую хранить множество номеров, имен и комментариев. У вас должна быть возможность хранить более чем десятизначные телефонные номера, а также программа должна обеспечивать возможность написания сценариев соединения. Полезно также иметь автонабор, который сможет периодически перенабирать занятые телефонные номера. Наконец, программа должна быть простой и приятной в обращении. Если вы не можете найти одну программу, отвечающую всем вашим требованиям, имейте под рукой несколько, для выполнения различных функций. Я рекомендую коммуникационную программу PC Tools Desktop. Она не обладает многими из вышеперечисленных свойств, но весьма удобна в обращении. ProComm Plus для IBM и Macintosh, коммуникационная программа Lotus 1 -2-3 — огромный пакет, обладающий всеми мыслимыми свойствами. Хорошая общедоступная программа для IBM — Qmodem. И последнее, что необходимо хакеру. Ваша терминальная программа должна обладать возможностью сбора данных. Это значит, что, когда информация проходит через ваш модем и появляется на экране, вы можете сбросить ее в файл на диске.

Функция сбора данных должна быть включена всегда, когда вы используете свой модем. Когда я вхожу в какую-либо систему, мне нравится иссследовать все имеющиеся там текстовые файлы, но, разумеется, я не читаю их в режиме онлайн. Вместо этого я включаю сбор данных, сохраняю все эти сотни страниц текста в отдельных файлах, а затем, отключившись от линии, сортирую собранные данные. Иногда бывает проше забрать эти файлы без просмотра.

Сбор данных удобен также для записи текста, который пробегает по экрану так быстро, что вы не успеваете его прочесть. А иногда текст вообще немедленно стирается сразу же после ввода. К тому же приятно иметь документированное свидетельство своей хакерской деятельности, которое можно использовать для справок и исследований.

Однажды я вызвал электронную доску объявлений (BBS) местной компании, созданную в рекламных целях. Модемы соединились, я несколько раз нажал ввод, на экране появились обычные случайные символы, и я стал ждать появления приглашения. Приглашение к загрузке несколько запоздало, чему я удивился, но все казалось обычным, и я приступил к работе.

Позднее я рассматривал распечатки, сделанные во время взлома, и повнимательнее взглянул на обычный загрузочный "мусор". Среди мешанины символов я увидел следующее: "d-b". А на следующей строке, между двумя плюсами, — "уе!" Получилось: "d-Ьуе". То есть, я обнаружил вторую половину слова "good-bye!". Я знал, что это означает прощание после выхода из системы. Другими словами, я вызвал систему непосредственно после того, как кто-то другой из нее вышел, и я поймал остаток его прощания. Значит, у того компьютера было что-то не в порядке с разьединениями. Это означало ошибку, которую можно было использовать. Я снова вошел в систему и открыл журнал пользователей, чтобы найти запись своей последней загрузки. Предыдущий пользователь являлся легальным пользователем системы, и его выход из системы записался как мой вход.

Затем, используя данную лазейку, мне удалось притвориться системным оператором: я вызывал систему сразу же после того, как настояший оператор заканчивал очередную проверку сопровождения. Я написал ему письмо, объяснявшее, в чем дело, и, спустя несколько дней, ошибку устранили.

Итак, вам следует быть готовыми ко всяким странностям и уметь анализировать их. Может случиться и такая неожиданная ситуация, когда системный оператор начинает проверку сопровождения системы у вас на глазах. Со мной такое случалось два раза на одной и той же неделе.

Однажды, когда я еще учился в старших классах, я заболел и остался дома, занимаясь вызовом BBS. В первый день я как раз подключился к системе и собрался посмотреть свою электронную почту, когда меня прервал системный оператор, которому срочно понадобилось кое-что сделать. Он вошел во внутренние экраны программы BBS, затем вышел на жесткий диск и снова вернулся. Я не успел проследить за его действиями, но позднее, выйдя из системы, я просмотрел файл, в который смог занести это событие, и проанализировал его. Это помогло мне не совершить никакого взлома, но я получил новые сведения о том, как работает программа на BBS.

Через несколько дней я находился в другой системе. Теперь уже этот оператор опаздывал на встречу, но перед этим ему потребовалось сделать какие-то перестановки. На этот раз я сумел понять, что происходит; среди прочего оператору было необходимо зарегистрировать пароль нового пользователя, возможно, оператор не понял, что я за ним наблюдаю. Я сбросил все это в текстовый файл, таким образом приобретя новый пароль.

прошлое и будущее

Читая издания о хакерстве, вы еще многое узнаете об оборудовании, программном и аппаратном обеспечении и о том, что необходимо хакерам, специализирующимся в конкретных областях. Но пока вам необходимо понять...

Читая литературу по защите данных, можно всерьез обеспокоиться. Прошли времена ошибок и лазеек в системах и времена наивных пользователей. Прошли, казалось бы, времена благоговейного страха перед хакером-одиночкой, среди ночи проникающим в секретные правительственные базы данных, и времена самих хакеров-одиночек.

Так кажется.

Но это не так! Всего несколько лет назад Роберту Моррису-младшему удалось проникнуть в систему, используя ошибки, которые никто не потрудился заметить и исправить. Кто знает, сколько еще таких ошибок ждет своего часа? Не забывайте и о глупости: существуют демонстрационные режимы, меры по безопасности, которые никто не уничтожил и не изменил.

В июле 1987 года группа членов клуба Chaos Computer Club взломала компьютерную сеть системы NASA SPAN. Эти хакеры использовали изьян в инфраструктуре VMS, по заявлению DEC Corporation, реконструированной тремя месяцами раньше. А это свыше ста VAX компьютеров с неисправной операционной системой. Члены клуба посмеивались, что для "зашиты" этой системы часто использовались примитивные пароли, подчас взятые прямо из руководства пользователя. С одной стороны мы видим суперсекретные компьютеры, опекаемые NASA, а с другой — 4000 пользователей этих компьютеров. Понятно, что 4000 человек не сохранят секрета.

В наши дни хакерство может показаться более трудным занятием, нежели раньше, но на самом деле оно не стало таким. Меры по безопасности могли стать строже, но сам пользователь ничуть не изменился в своей беспечности, равнодушии, добродушии по отношению к другим пользователям. Более опытные пользователи всегда рады помочь менее осведомленным, а те, в свою очередь, просят совета у "гуру". Значит, социальная инженерия, простая и обратная, живет и побеждает, как вы увидите далее.

Людьми всегда руководит стремление к простоте. Никто не выберет в качестве пароля нечто вроде "bWoQt 0(@vbM-34trwX51 "!

Сегодня создано немыслимое количество систем, в которых работает множество пользователей. Раньше на компьютерах работали лишь немногие, теперь же их может купить и использовать кто угодно. И далеко не все, кто этим занимается, помнят о компьютерной безопасности. Фактом является то, что большинство компьютерных систем не защищено от вторжения. Многие люди, связанные с компьютерами, понимают это, но ничего не предпринимают по этому поводу.

Причин, по которым компании не повышают уровень компьютерной безопасности, много. При этом приводятся следующие доводы:

• Усиление зашиты влечет за собой исчезновение открытости и доверия, которые мы стремимся развивать.

• Компьютерная зашита слишком неудобна.

• Усиление зашиты только привлечет любящих приключения хакеров.

• Закрывать существующие лазейки в защите слишком дорого и трудно.

• Перепрограммирование может повлечь за собой новые проблемы с безопасностью.

• У нас никогда не было проблем с безопасностью!

• Наша информация не нужна никому, кроме нас.

• Мы только что подверглись взлому; но уж теперь-то они точно не вернутся!

• А разве хакеры еще не исправились?

Все эти доводы не корректны. Последний вообще не выдерживает критики: компьютеры имеют такое большое значение в нашей жизни, что хакеры будут существовать всегда, пока существуют компьютеры.

В некоторых из этих доводов есть своя правда, во всяком случае, люди, занимающиеся компьютерами, верят в эти утверждения, так что работа для хакера всегда найдется.

компьютерные преступления

К сожалению, в нашем мире существует такая штука, как компьютерные преступления. Хакерство занимает последнее место в списке безобразий, которые люди проделывают с компьютерами, и не имеет ничего общего с обычными преступлениями, убийствами, кражами и т. п. Настоящее хакерство не оставляет жертв, и я считаю его преступлением лишь чисто условно. Возможно, оно аморально, но есть и куда худшие веши.

Компьютерные преступления делятся на семь основных категорий, так или иначе связанных с хакерством: финансовые кражи, саботаж, кражи аппаратного обеспечения, кражи программного обеспечения, кражи информации и электронный шпионаж. А седьмое "преступление" — компьютерное хакерство.

денежные кражи

Финансовые кражи происходят, когда компьютерные записи изменяются в иелях присвоения чужих денег. Часто это делается с помощью программы, направляющей деньги на конкретный банковский счет, обычно с помощью техники "салями".

"Салями" — это метод, предполагающий кражи небольших сумм в течение длительного времени в надежде, что это не будет замечено. Воры перепрограммируют банковский или какой-либо другой компьютер так, чтобы пенни поступали на липовые счета.

Например, на счете может храниться 713.14863, где 863 случайные цифры, т. к. при умножении учитываются все знаки. Обычно компьютер показывает, что у данного лица в банке 713.15 $, округляя 4 до 5. Однако, компьютер, запрограммированный с "салями" отделяет эти экстра-числа и помешает их на отдельные счета. И теперь человек имеет только 713.14 $, ну кто же заметит или пожалуется на потерю пенни.

Компьютер сам не в состоянии производить новые деньги, он может только перевести легальные деньги на нелегальный счет. Такие кражи довольно трудно обнаружить. Как только на счете у вора скапливается большая сумма, он снимает деньги со счета и, в большинстве случаев, удаляется вместе с ними< Многие воры пытались использовать эту форму ограбления банка, и многие были пойманы, но сейчас это может сделать каждый.

Выявить применение подобной техники можно так:

на компьютере создается список всех счетов с указанием, сколько раз в течение одного или нескольких дней к счету обращались. Затем любой счет, который затребывался слишком часто, проверяется, чтобы установить, сколько денег с него снималось во время каждого обращения. Если это небольшая сумма - значит кому-то повезло.

Хотя сам я не занимаюсь подобными вешами, хочу все же указать, в чем заключается ошибка таких грабителей. Вместо того, чтобы перепрограммировать компьютер для прямой передачи небольших сумм на счет, им следовало просто вычитать эти деньги и следить за тем, сколько денег соберется в области, отдельной от файлов со счетами. Затем изменяются те части программы, которые распечатывают общее количество банковских вкладов, для учета скрытой суммы, чтобы эти деньги не казались утерянными. Когда спрятанное число достигает определенной величины, только тогда его следует переводить на счет вора, причем переводящиеся суммы должны равняться случайным величинам, дабы избежать подозрений.

Такие действия предполагают наличие доступа к компьютеру. Обычно их совершают сотрудники банка, и о настоящем хакерстве здесь речь не идет. Впрочем, если такую кражу совершает сотрудник с ограниченным уровнем доступа или чужак, взлом бывает необходим.

САБОТАЖ

Компьютерный саботаж — это физическое разрушение аппаратного или программного обеспечения, либо искажение или уничтожение содержащейся в компьютере информации. Причиной саботажа может быть желание избавиться от конкурента или получить страховку. Компьютерное хакерство лишь косвенно связано с саботажем, поскольку целью большинства хакеров является сохранение компьютеров, а не разрушение. Впрочем, иногда в хакерстве присутствуют элементы саботажа. Обратная социальная инженерия использует нечто вроде саботажа, но на самом деле это всего лишь временный и легко устраняемый вывод компьютера из строя.

Компьютерные вандалы часто подвергают саботажу информацию, хранящуюся в компьютерах, сперва использовав хакерские методы получения доступа к ним. Но не стоит путать вандалов и других приверженцев саботажа данных с хакерами. Эти люди вводят ложную информацию в компьютерные системы, так или иначе повреждая базы данных.

другие виды краж

Могут включать в себя кражи аппаратного обеспечения или самого компьютера и периферии, а также воровство компьютерных разработок. Они относятся к хакерству постольку, поскольку украденный компьютер может использоваться для получения кодов доступа. В случае компьютерного пиратства хакер может тайно читать электронную почту или файлы разработчика, пытаясь украсть новые идеи.

Кражи программного обеспечения, или программное пиратство, — это нелегальное копирование программ, защищенных авторскими правами. Хакеры часто делают для себя копии программ, найденных в компьютерной системе, чтобы понять, как они работают. Что касается краж аппаратного обеспечения, здесь присутствует желание догнать конкурента в области новых разработок программ.

Кражи информации включают кражи кредитных карточек, результатов лабораторных исследований, данные о пациентах или клиентах и вообще любых данных, обладающих потенциальной ценностью. Электронным шпионажем называется продажа такой информации третьей стороне, когда хакер начинает шпионить на другую компанию или страну. В обоих случаях для краж информации, а иногда и для установления контакта со шпионским агентством используется хакерская техника.

седьмой вид преступлений

Наконец, мы подошли непосредственно к хакерству. Хакеры способны совершать любые из вышеперечисленных преступлений, но они предпочитают этого не делать. Так можно ли считать их преступниками?

Конечно, перед тем, как сделать такой выбор, хакер нелегально взламывает чужие компьютеры. Но мы не видим никакого вреда в самом акте "взлома".

Там, где имеют место другие компьютерные преступления, мотивы преступника ясны. Вполне понятно, когда человек крадет компьютер, заказывает преступление из чуства мести или из корыстных побуждений.

Но в случае "чистого" хакерства мотивы могут и не лежать на поверхности.

Традиционная причина для занятий хакерством -стремление к знаниям. Но в наши дни этим стремлением могут руководить более сильные желания, например, жажда денег. Существуют хакеры, относящиеся к своему таланту не как к хобби, а как к профессии. Насчитывается несколько причин, как моральных, так и аморальных, для занятий хакерством за деньги. Прежде чем начать разговор о том, как заниматься хакерством, давайте рассмотрим, почему им занимаются.

мотивы для занятий хакерством

Самым честным побуждением к занятиям хакерством является распространение информации. Том Форестер и Перри Моррисон в своей "Компьютерной этике" пишут, что после чернобыльской аварии хакеры Chaos Computer Club "...опубликовали большее количество информации о событиях, чем даже правительство Восточной Германии. Вся эта информация была получена путем незаконных взломов содержимого государственных компьютеров...". Конечно, это было весьма благородно и "по-нашему".

Хакеры занимаются также предотвращением компьютерных несчастий. Недавно несколько компаний по компьютерной безопасности из разных стран решили подвергнуть свою продукцию проверке. Они опубликовали телефонные номера, по которым могли бы звонить хакеры и пытаться проникнуть в систему. Конечно, это был рекламный трюк, но сама идея была неплоха, поскольку дала хакерам возможность совершения взлома из лучших побуждений.

Хакеры, которые используют свои незаконные методы для предотвращения несчастий, обладают высокой нравственностью. Обнаружив прореху в защите системы (но не воспользовавшись ею!) они предупреждают о ней системного оператора. Таким образом, они помогают нашему миру свободно и безопасно пользоваться информацией. Мы только можем надеяться, что жизненное кредо хакеров не позволит им вести себя неэтично.

К сожалению, волнующая и заманчивая природа хакерства зачастую влечет к себе нравственно неразвитых людей, питающих слабость к вандализму и чужим кредитным карточкам. Настоящие хакеры не должны иметь никакого отношения к подобной деятельности, дабы не уронить звание "Хакера".

Многие хакеры, даже лучшие из них, внесли свой вклад в создание плохой репутации хакерства, т. к. ими руководили сомнительные мотивы. Встречаются и хакеры-разрушители, и такие, которые просто не могут вовремя выйти из игры.

Существует и "хакерство по найму". Частные лица готовы платить хакерам за то, чтобы те изменили для них информацию на компьютере: счета, уровни доступа и т. п. Иногда люди хотят уничтожить информацию о самих себе, поскольку скрываются. Частные сыщики тоже могут воспользоваться услугами хакеров, чтобы найти телефонные номера, адреса и другую необходимую им частную информацию, хранящуюся в компьютерах. Сотрудники офисов нанимают хакеров, чтобы прочесть электронную почту и файлы своих коллег и конкурентов. Хакеры могут заниматься не только промышленным, но даже государственным шпионажем. Все это ЕСТЬ, и этим занимаются хакеры, которые совершают взломы за деньги.

В хакерской среде с пренебрежением относятся к "наемникам". Один раз еще можно пойти на такое, но заниматься этим постоянно — значит лишиться хакерской чести. Мне хочется думать, что все читатели этой книги, в том числе и хакеры, будут использовать свои таланты для добрых дел: обеспечения общественной осведомленности, предотвращения трагедий, а также для изучения новых технологий и открытий в целях саморазвития.